Modifies the automatic release time of a specified pay-as-you-go or spot instance. You can also use this operation to cancel the automatic release feature.
Try it now
Test
RAM authorization
|
Action |
Access level |
Resource type |
Condition key |
Dependent action |
|
ecs:ModifyInstanceAutoReleaseTime |
update |
*Instance
|
None | None |
Request parameters
|
Parameter |
Type |
Required |
Description |
Example |
| RegionId |
string |
No |
The region ID of the instance. You can call DescribeRegions to query the most recent region list. |
cn-hangzhou |
| InstanceId |
string |
Yes |
The ID of the ECS instance for which to configure automatic release. |
i-bp1env7nl3mijm2t**** |
| AutoReleaseTime |
string |
No |
The automatic release time. Specify the time in the ISO 8601 standard in the yyyy-MM-ddTHH:mm:ssZ format. The time must be in UTC.
If you do not specify the AutoReleaseTime parameter, the automatic release feature is canceled and the ECS instance is no longer automatically released. |
2018-01-01T01:02:03Z |
Response elements
|
Element |
Type |
Description |
Example |
|
object |
|||
| RequestId |
string |
The request ID. |
473469C7-AA6F-4DC5-B3DB-A3DC0DE3**** |
Examples
Success response
JSON format
{
"RequestId": "473469C7-AA6F-4DC5-B3DB-A3DC0DE3****"
}
Error codes
|
HTTP status code |
Error code |
Error message |
Description |
|---|---|---|---|
| 400 | MissingParameter | InstanceId should not be null. | The InstanceId parameter is required. |
| 400 | InvalidAutoReleaseTime.Malformed | The specified paramter autoReleaseTime is not valid. | The automatic release time parameter AutoReleaseTime is illegal. |
| 400 | UnsupportedParameter | The parameters is unsupported. | The specified parameter is invalid. |
| 500 | InternalError | The request processing has failed due to some unknown error, exception or failure. | An internal error has occurred. Try again later. |
| 403 | ChargeTypeViolation | The operation is not permitted due to charge type of the instance. | |
| 403 | InstanceLockedForSecurity | The specified operation is denied as your instance is locked for security reasons. | The instance to which the disk is attached is locked due to security reasons. |
| 404 | NoSuchResource | The specified resource is not found. | The specified resource does not exist. |
See Error Codes for a complete list.
Release notes
See Release Notes for a complete list.