All Products
Search
Document Center

Elastic Compute Service:TagResources

Last Updated:Aug 28, 2026

Creates tags and adds the tags to Elastic Block Storage (EBS) resources.

Operation description

Before you add tags to a resource, Alibaba Cloud checks the number of existing tags of the resource. If the maximum number of tags is reached, an error message is returned. For more information, see the "Tag limits" section in Limits.

Try it now

Try this API in OpenAPI Explorer, no manual signing needed. Successful calls auto-generate SDK code matching your parameters. Download it with built-in credential security for local usage.

Test

RAM authorization

The table below describes the authorization required to call this API. You can define it in a Resource Access Management (RAM) policy. The table's columns are detailed below:

  • Action: The actions can be used in the Action element of RAM permission policy statements to grant permissions to perform the operation.

  • API: The API that you can call to perform the action.

  • Access level: The predefined level of access granted for each API. Valid values: create, list, get, update, and delete.

  • Resource type: The type of the resource that supports authorization to perform the action. It indicates if the action supports resource-level permission. The specified resource must be compatible with the action. Otherwise, the policy will be ineffective.

    • For APIs with resource-level permissions, required resource types are marked with an asterisk (*). Specify the corresponding Alibaba Cloud Resource Name (ARN) in the Resource element of the policy.

    • For APIs without resource-level permissions, it is shown as All Resources. Use an asterisk (*) in the Resource element of the policy.

  • Condition key: The condition keys defined by the service. The key allows for granular control, applying to either actions alone or actions associated with specific resources. In addition to service-specific condition keys, Alibaba Cloud provides a set of common condition keys applicable across all RAM-supported services.

  • Dependent action: The dependent actions required to run the action. To complete the action, the RAM user or the RAM role must have the permissions to perform all dependent actions.

Action

Access level

Resource type

Condition key

Dependent action

ebs:TagResources

create

*DedicatedBlockStorageCluster

acs:ebs:{#regionId}:{#accountId}:dedicatedblockstoragecluster/{#DedicatedBlockStorageClusterId}

*DiskReplicaGroup

acs:ebs:{#regionId}:{#accountId}:diskreplicagroup/{#ReplicaGroupId}

*DiskReplicaPair

acs:ebs:{#regionId}:{#accountId}:diskreplicapair/{#ReplicaPairId}

*EnterpriseSnapshotPolicy

acs:ebs:{#regionId}:{#accountId}:enterprisesnapshotpolicy/{#EnterpriseSnapshotPolicyId}

*SolutionInstance

acs:ebs:{#regionId}:{#accountId}:solutioninstance/{#SolutionInstanceId}

None None

Request parameters

Parameter

Type

Required

Description

Example

ResourceId

array

Yes

The ID list of the resources. You can specify up to 50 IDs in each request.

disk-123

string

No

The ID of resource N. Valid values of N: 1 to 50.

pair-cn-c4d2t7f****

Tag

array<object>

Yes

The resource tags. You can specify up to 20 tags.

object

No

The value of tag N used for exact search of EBS resources. The tag value must be 1 to 128 characters in length. Valid values of N: 1 to 20.

Key

string

Yes

The key of tag N to add to the resource. Valid values of N: 1 to 20. The tag key cannot be an empty string. The tag key can be up to 128 characters in length and cannot contain http:// or https://. It cannot start with acs: or aliyun.

tag-key

Value

string

Yes

The value of tag N to add to the resource. Valid values of N: 1 to 20. The tag value can be an empty string. The tag value can be up to 128 characters in length and cannot start with acs: or contain http:// or https://.

tag-value

RegionId

string

Yes

The region ID of the resource. You can call the DescribeRegions operation to query the most recent region list.

cn-hangzhou

ResourceType

string

Yes

The type of the resource. Valid values:

  • dedicatedblockstoragecluster: dedicated block storage cluster

  • diskreplicapair: replication pair

  • diskreplicagroup: replication pair-consistent group

diskreplicagroup

ClientToken

string

No

The client token that is used to ensure the idempotence of the request. You can use the client to generate the value, but you must make sure that the value is unique among different requests. The ClientToken value can contain only ASCII characters and cannot exceed 64 characters in length. For more information, see How to ensure idempotence.

0c593ea1-3bea-11e9-b96b-88e9fe63****

Response elements

Element

Type

Description

Example

object

TagResponse

RequestId

string

The ID of the request. The request ID is returned regardless of whether the call is successful.

473469C7-AA6F-4DC5-B3DB-A3DC0DE3****

Examples

Success response

JSON format

{
  "RequestId": "473469C7-AA6F-4DC5-B3DB-A3DC0DE3****"
}

Error codes

HTTP status code

Error code

Error message

Description

400 InvalidParameter The parameter %s is invalid.
400 InvalidParameter.Conflict The specified parameter %s and %s are not blank at the same time.
400 InvalidParameter.Format Specified parameter format is not valid.
400 MissingParameter The input parameter %s that is mandatory for processing this request is not supplied.
400 Duplicate.TagKey The Tag.N.Key contain duplicate key.
400 NumberExceed.ResourceIds The ResourceIds parameter number is exceed , Valid : 50
400 NumberExceed.Tags NumberExceed.Tags
500 InternalError The request processing has failed due to some unknown error, exception or failure.
403 Forbidden User is not authorized to operate.
403 Forbidden.Action User is not authorized to operate this action.
403 InvalidAccountStatus.NotEnoughBalance Your account does not have enough balance.
403 LastTokenProcessing The last token request is processing.
403 NoPermission.SLR The RAM user does not have the permission to create service linked role: AliyunServiceLinkedRoleForEBS.
403 OperationDenied The operation is not allowed.
404 InvalidApi.NotFound Specified api is not found, please check your url and method.
404 InvalidResourceId.NotFound The specified ResourceIds are not found in our records.
404 InvalidResourceType.NotFound The ResourceType provided does not exist in our records.
404 MissingParameter.ResourceType The parameter - ResourceType should not be null
404 NoSuchResource The specified resource does not exist.
504 RequestTimeout The request is timeout, please try again later.

See Error Codes for a complete list.

Release notes

See Release Notes for a complete list.