Cancels the quota configured for a fileset.
Operation description
Only CPFS for Lingjun 2.7.0 and later support quota cancellation.
Before you begin
This operation applies only to CPFS for Lingjun file systems of version 2.7.0 or later.
The file system ID must start with
bmcpfs-.Before you call this operation, make sure that a quota has been configured for the target fileset by calling the SetFilesetQuota operation.
Try it now
Test
RAM authorization
|
Action |
Access level |
Resource type |
Condition key |
Dependent action |
|
nas:CancelFilesetQuota |
update |
*Fileset
|
None | None |
Request parameters
|
Parameter |
Type |
Required |
Description |
Example |
| FileSystemId |
string |
Yes |
The ID of the CPFS for Lingjun file system. The ID must start with |
bmcpfs-290w65p03ok64ya**** |
| FsetId |
string |
Yes |
Fileset ID。 |
fset-1902718ea0ae**** |
| DryRun |
boolean |
No |
Specifies whether to perform a dry run. A dry run validates the parameter validity and business constraints without actually canceling the fileset quota or incurring any charges. Valid values:
|
false |
| ClientToken |
string |
No |
The client token that is used to ensure the idempotence of the request. You can use the client to generate the token, but make sure that the token is unique among different requests. The token can contain only ASCII characters and cannot exceed 64 characters in length. For more information, see How to ensure idempotence. Note
If you do not specify this parameter, the system automatically uses the RequestId of the API request as the ClientToken. The RequestId may vary for each API request. |
123e4567-e89b-12d3-a456-42665544**** |
Response elements
|
Element |
Type |
Description |
Example |
|
object |
|||
| RequestId |
string |
The request ID. |
98696EF0-1607-4E9D-B01D-F20930B6**** |
Examples
Success response
JSON format
{
"RequestId": "98696EF0-1607-4E9D-B01D-F20930B6****\n"
}
Error codes
|
HTTP status code |
Error code |
Error message |
Description |
|---|---|---|---|
| 400 | IllegalCharacters | The parameter contains illegal characters. | The parameter contains illegal characters. |
| 400 | MissingFileSystemId | FileSystemId is mandatory for this action. | The FileSystemId parameter is not specified. |
| 400 | MissingFsetId | FsetId is mandatory for this action. | The Fileset ID parameter is not specified. |
| 400 | InvalidFilesetId.NotFound | Invalid FilesetId. | Fileset does not exist |
| 400 | InvalidFilesystemType.NotSupport | The API operation does not support the file system type. | The API operation does not support the file system type. |
| 403 | OperationDenied.DependencyViolation | The operation is denied due to dependancy violation. | The conditions for this operation are not met. |
| 403 | OperationDenied.FilesetNotSupported | The operation is not supported. | The file system does not support Fileset. |
| 404 | InvalidFileSystem.NotFound | The specified file system does not exist. | The specified file system does not exist. |
| 404 | InvalidFsetId.NotFound | The specified Fileset ID does not exist. | The specified Fileset does not exist. |
| 429 | Throttling.Api | Request was denied due to api flow control. | The request is throttled. |
See Error Codes for a complete list.
Release notes
See Release Notes for a complete list.