Error codes
|
HTTP status code |
Error code |
Error message |
Description |
Action |
| 400 | AccountNotEnableRdTrustedService | You have not enabled HBR as a trust service of resource directory. | Cloud Backup is not enabled as a trusted service in the resource directory for this account. | diagnosis |
| 403 | AccountNotHbrRdAdministrator | You are not the resource directory administrator of HBR. | You are not the resource directory administrator of Cloud Backup. | diagnosis |
| 404 | AirBackupJobNotExists | The air backup job does not exist. | The ECS Backup Essential Edition backup job does not exist. | diagnosis |
| 404 | AirBackupPlanNotExists | The air backup plan does not exist. | The ECS Backup Essential Edition backup plan does not exist. | diagnosis |
| 400 | AirInstanceAtLeastOnePlan | The air instance must have one plan. | At least one type of backup must be enabled for ECS Backup Essential Edition. | diagnosis |
| 400 | AirInstanceError | The air instance is error, does not support this operation. | The ECS Backup Essential Edition is in an abnormal state and does not support this operation. Rebind or unbind the ECS instance. | diagnosis |
| 400 | AirInstanceExpired | The air instance is expired, does not support this operation. | The ECS Backup Essential Edition has expired and does not support this operation. | diagnosis |
| 400 | AirInstanceInitializing | The air instance is in INITIALIZING. | The ECS Backup Essential Edition subscription instance is being initialized or unbound and does not support this operation. | diagnosis |
| 404 | AirInstanceNotExists | The air Instance does not exist. | The ECS Backup Essential Edition subscription instance does not exist. | diagnosis |
| 400 | ArchiveDaysTooShort | The snapshot should be in standard bucket for at least 30 days. | The backup must be retained in the standard tier for at least 30 days before it can be moved to the archive tier. | diagnosis |
| 400 | ArchiveRetentionDaysTooShort | The archive snapshot should be in archive bucket for at least 60 days. | The backup must be retained in the archive tier for at least 60 days. | diagnosis |
| 400 | ArchiveSnapshotCannotDetect | Archive snapshot cannot detect. | The backup has been moved to the archive tier and does not support virus file detection. | diagnosis |
| 400 | ArchiveSnapshotCannotGenerateReport | The archived snapshot can not generate report. | Archived backup points do not support report generation. | diagnosis |
| 403 | AssumeRoleFail | Failed to assume role. | Cross-service authorization failed. Grant Cloud Backup the permissions to access OSS and other services. | diagnosis |
| 403 | BackupAccountNotInSpecifiedRd | The backup account is not in the specified resource directory. | The account to be backed up is not in the specified resource directory. | diagnosis |
| 400 | BackupJobStillRunning | Last Backup job with same backup plan ID is not finished yet. | The previous backup job of the backup plan has not finished. A new job cannot be started. | diagnosis |
| 400 | BackupJobStillRunning | Previous backup job has not complete yet, please wait until it complete. | The preceding backup job has not been completed. Wait until the backup job is completed. | diagnosis |
| 400 | BadRequest | The request has invalid parameters. | Invalid request. Check the request parameters. | diagnosis |
| 400 | BASIC_INFO_UNCOMPLETED | Your information is incomplete. Complete your information before the operation. | Your basic user information is incomplete. Complete the basic user information. | diagnosis |
| 400 | BrowseDuplicateLoad | Backend job have already submitted. | An identical task is already running in the background. | diagnosis |
| 400 | BrowseFileError | Browse file error. | Failed to browse files. | diagnosis |
| 500 | BrowseFileError | An error occurred while browsing the backup files; please submit a ticket. | Failed to browse backup files. Submit a ticket. | diagnosis |
| 400 | BrowseTimeout | Too many files in this folder, backend job have already launched. Please wait for a while and try again. | The folder contains too many files. A background task has been submitted. Wait a moment and try again. | diagnosis |
| 400 | CannotAccessRdService | Cannot access resource directory service. | The resource directory service cannot be accessed. | diagnosis |
| 400 | CannotArchiveDetectingSnapshot | Can not archive detecting snapshot. | The backup is undergoing virus file detection and cannot be archived. Wait until the virus file detection is completed and try again. | diagnosis |
| 403 | CannotCancelFileDetectionJob | This job is in progress for virus detection and cannot be canceled. | The task is undergoing virus detection and cannot be canceled. | diagnosis |
| 400 | CannotDeleteActiveClient | The active client can not deleted. | An active client cannot be deleted. | diagnosis |
| 400 | CannotDeleteArchivedSnapshot | Can not delete archived snapshot. | A backup that has been moved to the archive tier cannot be deleted before it expires. Wait until the backup expires and Cloud Backup automatically deletes it. | diagnosis |
| 400 | CannotDeleteArchivingSnapshot | Can not delete archiving snapshot. | A backup that is being archived cannot be manually deleted. Wait until the backup expires and Cloud Backup automatically deletes it. | diagnosis |
| 400 | CannotDeleteClusterWithDataSources | Cannot delete a cluster with data sources. | A client group that has data sources cannot be deleted. | diagnosis |
| 400 | CannotDeleteDetectingSnapshot | Cannot delete detecting snapshot. | The backup is undergoing virus file detection and cannot be deleted. Wait until the detection is completed and try again. | diagnosis |
| 400 | CannotDeleteLatestOtsSnapshot | Cannot delete latest snapshot. The backup plan has enabled Keep-Latest-Snapshot. If you want to delete this snapshot, please delete the backup plan first. | The latest backup cannot be deleted because the "Retain the latest backup" setting is enabled for this backup plan. To delete this backup, delete the backup plan first. | diagnosis |
| 400 | CannotDeleteLatestSnapshot | Cannot delete latest snapshot. The backup plan has enabled Keep-Latest-Snapshot. If you want to delete this snapshot, please turn off Keep-Latest-Snapshot. | The latest backup cannot be deleted because the "Retain at least one backup version" setting is enabled for this backup plan. To delete this backup, disable the "Retain at least one backup version" setting in the backup plan first. | diagnosis |
| 400 | CannotDeletePlanWithRunningJobs | Cannot delete plan with running jobs. | A backup plan cannot be deleted while a job is running. | diagnosis |
| 400 | CannotDeleteReplicationSourceVault | Cannot delete replication source vault. | The source backup vault of a cross-region backup cannot be deleted. | diagnosis |
| 400 | CannotDeleteReplicationTargetVault | Cannot delete replication target vault. | A replication target vault that is being replicated cannot be disabled. | diagnosis |
| 400 | CannotDeleteSharedResource | Cannot delete shared resource. | A resource that is being shared cannot be deleted. | diagnosis |
| 400 | CannotDeleteUniBackupVaultWithActiveInstances | Cannot delete unibackup vault with active instances. | A database backup vault that contains active instances cannot be deleted. | diagnosis |
| 400 | CannotDeleteUniBackupVaultWithPlans | Cannot delete unibackup vault with plans. | A backup vault that contains backup plans cannot be deleted. | diagnosis |
| 400 | CannotInstallNewClientWithAegisClient | Cannot install client on this ECS because an old version of aegis backup client already installed. | The client cannot be installed on this ECS instance because a legacy aegis backup client is already installed. | diagnosis |
| 403 | CannotOperateClientInstalledByEcsOwner | Can not operate client on this ECS because it was installed by ECS owner. | You cannot perform operations on ECS clients that belong to other users. | diagnosis |
| 400 | CannotOperateClientInstalledByOthers | The client is installed by another service, can not be operated. | You cannot perform operations on clients installed by other services. | diagnosis |
| 400 | CannotOperateNewClientWithBasic | The client is used by the essential edition, please do not perform any operations on this client. | This client is used by the Essential Edition. Do not perform any operations on it to avoid affecting Essential Edition features. | diagnosis |
| 400 | CannotOperateReplicationTargetSnapshot | Can not operate replication target snapshot. | This operation cannot be performed on backup points obtained through replication. | diagnosis |
| 400 | CannotTurnOffKeepLatestSnapshot | Cannot turn off Keep latest snapshot, please set KeepLatestSnapshot to 1. | The "Retain at least one backup version" option cannot be disabled. Enable this feature. | diagnosis |
| 403 | CannotUnInstallNewClientWithAegisClient | The client is being used by the Anti-Ransomware feature of Security Center and cannot be deleted. | This backup client is being used by the anti-ransomware feature of Security Center and cannot be deleted. | diagnosis |
| 400 | CannotUpgradeClientWithRunningJobs | Cannot upgrade the client when there is an ongoing job. Try again after the job is finished. | The client cannot be upgraded because a task is in progress. Try again after the task is complete. | diagnosis |
| 400 | Client.HanaInvalidCertOrNetworkFailure | Connection to database failed, please ensure the server certificate is valid and network is reachable. | Failed to establish a database connection. Make sure that the HANA SSL certificate is valid and the client can Normal access HANA. | diagnosis |
| 400 | Client.HanaSqlError | Hana reports error when execute SQL statements. | An error occurred while executing an SQL statement on HANA. | diagnosis |
| 400 | Client.HanaSqlError | Internal HANA SQL error. | An error occurred while the client was executing a HANA SQL statement. | diagnosis |
| 400 | ClientBindsToWormVaultCannotBeDeleted | Cannot delete client bond to WORM vault. | You cannot delete clients from a locked backup vault. | diagnosis |
| 400 | ClientBindsToWormVaultCannotBeDeleted | The client is bound to a backup vault that has enabled backup lock. You cannot delete the client. | This client is associated with a backup vault that has backup lock enabled. The client cannot be deleted. | diagnosis |
| 404 | ClientNotExist | The specified client doesn't exist. | The client does not exist. Check whether the input parameters are correct. | diagnosis |
| 400 | ClientResponseTimeout | The client response timed out. | The client response timed out. | diagnosis |
| 400 | CloudAssistNotRunningOnInstance | There is no cloud assistant running on the instance. | Cloud Assistant is not running on the instance. | diagnosis |
| 400 | ClusterNameDuplicate | The cluster name already exists, please modify the cluster name and try again. | The client group name already exists. Change the client group name and try again. | diagnosis |
| 400 | ClusterNotExist | Cluster does not exist. | The client group does not exist. | diagnosis |
| 404 | CommodityCodeNotSupport | The commodity code does not support. | The commodity code is not supported. | diagnosis |
| 400 | ContainerBackupJobStillRunning | The previous backup task for this resource is still running. | The previous backup job for this resource has not finished. | diagnosis |
| 404 | ContainerClusterNotExists | The container cluster does not exist. | The container cluster does not exist. | diagnosis |
| 200 | CrossAccountBackupSlrNotExist | AliyunServiceRoleForHbrCrossAccountBackup doesn't exist, please create this role. | The AliyunServiceRoleForHbrCrossAccountBackup role does not exist. Create this service-linked role. | diagnosis |
| 400 | CrossAccountBackupSlrNotExist | AliyunServiceRoleForHbrCrossAccountBackup does not exist, please create this role. | The cross-account permission role AliyunServiceRoleForHbrCrossAccountBackup does not exist. Create this role. | diagnosis |
| 400 | CrossAccountItemAlreadyExists | The cross account item already exists. | The cross-account configuration already exists. Do not create it again. | diagnosis |
| 403 | CrossAccountItemNotExists | The cross account item not exists. | The cross-account information does not exist. | diagnosis |
| 404 | CrossAccountRoleNotExist | Cross account role doesn't exist, please check this role. | The cross-account role does not exist. Check the role configuration. | diagnosis |
| 400 | DataSourceNotExists | Data source not exist. | The data source does not exist. | diagnosis |
| 400 | DoNotHaveActivatedClient | There is not any actived client. | No activated client is available. | diagnosis |
| 409 | DuplicateRequest | Duplicate request, another request is processing. | Duplicate request. Another request is being processed. | diagnosis |
| 400 | EcsAlreadyHasClientInstalledByOthers | The ECS already has a client which managed by another service. | A disaster recovery client managed by another service already exists on the ECS instance. | diagnosis |
| 403 | EcsClientError | Failed to call ECS client. | Failed to access ECS. Log on to the Alibaba Cloud Management Console and submit a ticket. | diagnosis |
| 400 | EncryptedDiskNotSupportCopy | The instance contains encrypted disk not support replication in ecs server backup. | Encrypted cloud disks do not support cross-region replication. | diagnosis |
| 400 | ExceedMaxBytes | The bytes done exceeds 500G. | The source data volume exceeds the upper limit. | diagnosis |
| 400 | FailedToActivateUniBackupInstance | Failed to activate unibackup instance. | Failed to activate the activation data for the database backup instance. | diagnosis |
| 400 | FailedToCreateUniBackupJob | Failed to create unibackup job. | Failed to create the database backup job. | diagnosis |
| 400 | FailedToDeleteUniBackupJob | Failed to delete unibackup job. | Failed to delete the database backup job. | diagnosis |
| 400 | FailedToDescribeFileSystems | Failed to describe NAS file systems. | Failed to query the NAS file system. | diagnosis |
| 400 | FailedToGetOssBucket | Failed to get oss bucket. | Failed to retrieve the OSS bucket. | diagnosis |
| 400 | FailedToListUniBackupInstanceDetail | Failed to list unibackup instance detail. | Failed to list the database instance details. | diagnosis |
| 400 | FailedToListUniBackupResources | Failed to list unibackup resources. | Failed to expand the database instance resources. | diagnosis |
| 400 | FailedToUpdateUniBackupJob | Failed to update unibackup job. | Failed to update the database backup job. | diagnosis |
| 400 | FeatureDeprecated | The feature has been deprecated. | The feature has been deprecated. | diagnosis |
| 400 | FileDetectionNotExits | File detection not exists. | The virus file detection record does not exist. Submit a ticket. | diagnosis |
| 400 | HanaNodeNotExist | There is no hana node. | No valid HANA node was found. | diagnosis |
| 404 | HanaNotExist | The HANA cluster or instance does not exist. | The HANA cluster or instance does not exist. | diagnosis |
| 400 | HanaUsesWormVaultCannotBeDeleted | Cannot delete Hana instance in WORM vault. | You cannot delete a HANA instance from a locked backup vault. | diagnosis |
| 400 | HanaUsesWormVaultCannotBeDeleted | Hana instances that use worm vault cannot be deleted. | The HANA instance that uses a locked backup vault cannot be deleted. | diagnosis |
| 400 | HbrRoleNotExist | Aliyun HBR default role doesn't exist. | The default China Backup role for Alibaba Cloud does not exist. | diagnosis |
| 400 | ImmutablePolicyCannotBeDisabled | The immutable setting of the policy can not be disabled. | After the backup lock feature of the backup policy is enabled, it cannot be disabled. | diagnosis |
| 403 | ImmutableSnapshotCannotBeDeleted | This ECS instance backup snapshot is immutable and cannot be deleted. | The ECS full-server backup is an immutable backup and cannot be deleted. | diagnosis |
| 400 | InDebt | Use is in debt. | The user has an overdue payment. | diagnosis |
| 0 | InDebt | The user account is in debt. | Your account has an overdue payment. Top up your account immediately. | diagnosis |
| 400 | InDebtOverdue | The user is overdue. | The user has an overdue payment that has exceeded the grace period. Top up your account before using the service. | diagnosis |
| 0 | InDebtOverdue | The user account is in debt overdue. | Your account has an overdue payment that has exceeded the grace period. Top up your account immediately. | diagnosis |
| 400 | InitVaultError | Initialize vault failed. | Failed to initialize the backup vault. | diagnosis |
| 500 | InitVaultError | An error occurred while initializing the repository; please submit a ticket. | Failed to initialize the vault. Submit a ticket. | diagnosis |
| 400 | InstanceHasBeenProtected | The instance has been protected. | The instance is already protected by another method. This operation is not supported. | diagnosis |
| 400 | InstanceHasBeenProtectedByAir | The instance has been protected by air instance. | The ECS instance is already protected by another subscription instance of ECS Backup Essential Edition. | diagnosis |
| 400 | InstanceNotExists | The instance does not exist. | The instance does not exist. | diagnosis |
| 400 | InstanceNotRunning | The Ecs instance is not running. | The ECS instance is not in the Running state. | diagnosis |
| 400 | INSUFFICIENT_AVAILABLE_QUOTA | Your account balance drops below 0. Top up your account balance before you can make a purchase. | Your account balance is insufficient. Top up your account before making a purchase. | diagnosis |
| 0 | InternalError | The request processing has failed due to some unknown error. | An internal server error occurred. Log on to the Alibaba Cloud Management Console and submit a ticket. | diagnosis |
| 400 | InvalidBackupInterval | invalid backup interval, please modify your parameter | The backup interval parameter in the request is invalid. Modify the request parameters and try again. | diagnosis |
| 400 | InvalidBackupRuleRetention | The retention of BACKUP rules is invalid. If the policy has no TRANSITION rule, the retention of BACKUP rule must be -1 or 1 to 364635 days. | The retention period of the BACKUP type rule in the policy is invalid. If the policy does not contain a TRANSITION type rule, the retention period of the BACKUP type rule must be -1 or in the range of 1 to 364635 days. | diagnosis |
| 400 | InvalidDestinationPath | Invalid destination path. | The destination path is invalid. | diagnosis |
| 400 | InvalidKmsKeyStatus | The status of kms key is invalid. | The KMS key status is invalid. | diagnosis |
| 400 | InvalidOssBackupPrefix | OSS backup prefix must not start with '/'. | The OSS bucket matching prefix cannot start with a forward slash (/). | diagnosis |
| 400 | InvalidPolicyPolicyNameDuplicate | The policy name is duplicate. | The policy name is duplicated. | diagnosis |
| 400 | InvalidPolicyPolicyNameTooLong | The policy name is too long. The length should be between 1 and 64 characters. | The backup policy name is too long. The name must be 1 to 64 characters in length. | diagnosis |
| 400 | InvalidPolicyType | The policy type does not allow binding to this type of data source. Please change the policy and try again. | This policy type does not support binding to this type of data source. Change the policy and try again. | diagnosis |
| 400 | InvalidResource.Duplicate | The resource is duplicated. | Illegal resource: duplicate. | diagnosis |
| 400 | InvalidScheduleFormat | invalid schedule format, please modify your parameter | The backup policy parameter in the request is invalid. Modify the request parameters based on the API reference and try again. | diagnosis |
| 400 | InvalidScheduleForOtsIncrementalBackup | Invalid backup interval for Tablestore incremental backup, please modify the parameters. | The incremental backup time interval for Tablestore is invalid. Modify the parameter. | diagnosis |
| 400 | InvalidSourcePath | Invalid source path. | The source path is invalid. | diagnosis |
| 400 | InvalidStatusToDetect | The archiving snapshot can not do detect. | The backup is being archived and virus file detection cannot be performed. | diagnosis |
| 400 | InvalidToken | The token is invalid. | The token is invalid. | diagnosis |
| 0 | InvalidToken | Invalid client token is provided. | The token is invalid. Check the request parameters. | diagnosis |
| 400 | InventoryFilterPrefixNotEqualToBackupPrefix | OSS inventory filter prefix doesn't equal to backup prefix. | The prefix of the OSS inventory is different from the prefix of the backup job. | diagnosis |
| 400 | InventoryFilterPrefixNotEqualToBackupPrefix | Inventory filter prefix does not equal to backup prefix | The backup plan cannot be created. The filter prefix of the selected OSS inventory does not match the current source path. Modify the inventory settings or the source path. | diagnosis |
| 400 | JobCanceled | The job has been canceled. | The task has been canceled. | diagnosis |
| 404 | KmsKeyNotFound | Kms key not found. | The KMS key was not found. | diagnosis |
| 400 | KmsServiceNotEnabled | Kms service not enabled. | Key Management Service (KMS) is not activated. | diagnosis |
| 400 | LocalDiskNotSupported | Not support local disk yet. | Local cloud disks are not supported. | diagnosis |
| 400 | LocalDiskNotSupported | This instance has local disk(s) that is not supported by HBR ECS Server Backup | Instances that contain local disks do not support full-server backup. | diagnosis |
| 403 | MagpieBridgeSlrNotExist | AliyunServiceRoleForHbrMagpieBridge doesn't exist, please create this role. | The service-linked role AliyunServiceRoleForHbrMagpieBridge does not exist. Create the role first. | diagnosis |
| 404 | NasFileSystemNotExist | The NAS file system does not exsit. | The NAS file system does not exist. | diagnosis |
| 400 | NasFileSystemTypeNotSupported | The NAS file system type is not supported. | This NAS file system type is not supported. | diagnosis |
| 400 | NasServiceNotOpened | Alibaba Cloud NAS has not been activated. Go to the Alibaba Cloud NAS console to activate the product. | Apsara File Storage NAS is not activated, or your account has an overdue payment. Go to the Apsara File Storage NAS console to activate the service or top up your account. | diagnosis |
| 400 | NeedClientIdInParam | ClientId is needed in the parameter. | The ClientId parameter is missing. Check whether the input parameters are correct. | diagnosis |
| 400 | NeedTokenInParam | Token is needed in the parameter. | The Token parameter is missing. Check whether the input parameters are correct. | diagnosis |
| 400 | NeedVaultIdInParam | VaultId is needed in the parameter. | The VaultId parameter is missing. Check whether the input parameters are correct. | diagnosis |
| 400 | NoCompleteBackupRule | The policy is missing the backup rule for full backup. Add it and try again. | The policy does not contain a backup rule (RuleType=BACKUP) for full backup (BackupType=COMPLETE). Add the rule and try again. | diagnosis |
| 0 | NoPermission | User is not authorized to do this operation. | You do not have sufficient permissions. Contact your Alibaba Cloud account administrator to grant you the required permissions. | diagnosis |
| 400 | NoPermissionToCreateCrossAccountBackupSlr | No permission to create AliyunServiceRoleForHbrCrossAccountBackup | You do not have the permission to create AliyunServiceRoleForHbrCrossAccountBackup. | diagnosis |
| 403 | NoPermissionToCreateMagpieBridgeSlr | No permission to create AliyunServiceRoleForHbrMagpieBridge. | You do not have the permission to create the service-linked role AliyunServiceRoleForHbrMagpieBridge. Check your permissions. | diagnosis |
| 404 | NoSuchEcsInstance | The ECS Instance does not exist. | The ECS instance does not exist. | diagnosis |
| 403 | NotExist_ResourceGroup | The resource group does not exist. | The resource group does not exist. | diagnosis |
| 400 | ORDER.OPEND | The service is activated. | The service is already activated. | diagnosis |
| 0 | OSSAccessFail | Failed to access OSS. Log on to the Alibaba Cloud Management Console and submit a ticket. | diagnosis | |
| 404 | OssBucketNotFound | The OSS bucket is not found. | The OSS bucket was not found. | diagnosis |
| 404 | OssObjectNotExist | OSS object doesn't exist. | The OSS object that you attempted to access does not exist. Log on to the Alibaba Cloud Management Console and submit a ticket. | diagnosis |
| 400 | PERMISSION_DENIED | Permission denied: Unknown or unsupported caller type. Please ensure the request is made with a valid caller type (Partner, Customer, SubUser, or AssumedRoleUser). | The caller type is unknown. | diagnosis |
| 400 | PlanNameDuplicate | Plan with specified name already exists. | The plan name already exists. | diagnosis |
| 400 | PlanNotExist | Plan doesn't exist. | The plan does not exist. | diagnosis |
| 400 | PolicyAlreadyBoundWithThisDataSource | This datasource has already been bound with the policy, please use another one. | The data source is already bound to this policy. Try binding a new policy. | diagnosis |
| 400 | PolicyAlreadyExist | The specified policy already exists. | The backup policy already exists. Check whether the input parameters are correct. | diagnosis |
| 403 | PolicyBindingCreatedByTagCannotDelete | The policy binding is created by tag rule in the policy, can not be deleted. | The data source binding was automatically generated by a tag rule in the backup policy and cannot be deleted. | diagnosis |
| 400 | PolicyBindingExists | This datasource has been bound to a policy (can not create backup plan or been bound to another policy). | The data source is already bound to a policy. You cannot create a backup plan or bind another policy to it. | diagnosis |
| 404 | PolicyBindingNotExist | PolicyBinding doesn't exist. | The policy binding does not exist. | diagnosis |
| 404 | PolicyNotExist | The specified policy doesn't exist. | The backup policy does not exist. Check whether the input parameters are correct. | diagnosis |
| 400 | PolicyOnExecution | The policy is on execution, please wait and retry. | The policy is being executed. Try again later. | diagnosis |
| 404 | ProtectedResourceNotExist | The protected resource dose not exist. | The protected resource does not exist. | diagnosis |
| 400 | QUOTA_NOT_ENOUGH | The quota is insufficient. You can contact your channel partner to request a quota increase. | The account quota is insufficient. Contact your channel partner to increase the quota. | diagnosis |
| 404 | ReplicationSourceVaultNotFound | The replication source vault does not exist. | The source backup vault does not exist. | diagnosis |
| 400 | ReplicationVaultCannotBeWormBeforeCreateReplication | The replication vault cannot be immutable before create replication. | Backup locking cannot be enabled for a replication target vault that is not configured with backup vault replication. | diagnosis |
| 400 | ReplicationVaultCannotBeWormIfSourceVaultNot | The replication vault cannot be immutable if the source vault is not immutable. | Backup locking is not enabled for the source vault. You cannot enable backup locking for the mirror vault. | diagnosis |
| 400 | ReplicationVaultEncryptionTypeNotMatch | Replication vault encryption type not match source vault. | The encryption method of the mirror vault is inconsistent with that of the source vault. Modify the encryption method of the mirror vault. | diagnosis |
| 400 | ReportFileTaskAlreadyExist | The task to generate the report file already exists. | A task for generating the report file already exists. | diagnosis |
| 404 | ResourceNotFound | The specified resource is not found. | The requested resource does not exist. Check whether the input parameters are correct. | diagnosis |
| 400 | ResourceProtected | The resource has been protected already. | The resource is already protected. | diagnosis |
| 400 | ResourceProtectedByBasic | The resource has been protected by cloud backup essential edition. | The resource is already protected by a Cloud Backup Essential Edition feature, such as ECS File Backup Essential Edition. | diagnosis |
| 400 | ResourceProtectedByBasic | The resource has been protected by basic edition. | The resource is already protected by Cloud Backup Essential Edition. | diagnosis |
| 403 | RiskControlProhibited | The user account is prohibited by RiskControl. | Your account is currently blocked by risk control. Log on to the Alibaba Cloud Management Console and submit a ticket. | diagnosis |
| 404 | RoleNotExist | The specified role doesn't exist. | The cross-service authorization role required by Cloud Backup does not exist. Grant the required permissions to Cloud Backup. | diagnosis |
| 400 | SameSourceAndDestinationDataSourceError | The source and destination data source can not be same. | The source and destination cannot be the same data source. | diagnosis |
| 403 | ServiceNotActivated | The service is not activated yet. | Cloud Backup has not been activated. | diagnosis |
| 400 | SnapshotAlreadyArchived | Can not archive archived snapshot. | The backup has been moved to the archive tier and cannot be archived again. | diagnosis |
| 400 | SnapshotDetecting | The snapshot or another snapshot in the same snapshot link is detecting. | The current backup or another backup in the same snapshot chain is undergoing virus detection. Virus detection is temporarily not allowed for this backup. | diagnosis |
| 400 | SnapshotExistsCanNotDeletePlan | The backup plan or policy binding can not be deleted when snapshots exist. | The backup plan still contains valid backups and cannot be deleted. Delete the backups first. If you want the backup plan to stop running before deleting the backups, pause the backup plan. | diagnosis |
| 400 | SnapshotHashRequired | Snapshot hash is required. | The backup hash value is missing. | diagnosis |
| 404 | SnapshotNotExist | The specified snapshot doesn't exist. | The backup snapshot does not exist. Verify that the input parameters are correct. | diagnosis |
| 400 | StandardPolicyMustSetVaultId | The standard policy must set vault id in the rules. | The vault ID is missing for the standard backup policy. | diagnosis |
| 400 | TagKeyCannotBeEmpty | The tag key in the tag filters can not be empty. | The key of the tag filter in the policy tag rule cannot be empty. | diagnosis |
| 404 | TaskNotFound | The specified task doesn't exist. | The specified task does not exist. Verify that the parameters are correct. | diagnosis |
| 0 | TaskTypeNotSupported | Unsupported task type. | The task type is invalid. Verify that the request parameters are correct. | diagnosis |
| 0 | TooManyClients | There are already too many clients and you cannot create more. | The number of clients in your current backup vault has reached the upper limit. You cannot create more clients. | diagnosis |
| 0 | TooManyVaults | There are already too many vaults and you cannot create more. | The number of backup vaults in your current account has reached the upper limit. You cannot create more backup vaults. | diagnosis |
| 400 | UdmBackupPlanMayExceedEcsDiskSnapshotQuota | This risky backup plan may cause too many recovery points to exist at the same time, exceeding the maximum number of snapshots (default 256) that can be created by a single disk, resulting in the failure of creating new snapshots. | The backup policy of this plan may cause more than 256 restore points to exist at the same time, which exceeds the maximum number of restore points that can be created for a single cloud disk. This causes new restore point creation to fail. | diagnosis |
| 400 | UdmEcsInstanceWithSnapshotsCanNotBeDeleted | The ecs instance with snapshots can not be unprotected, please delete snapshots first. | The ECS instance has available backup points and cannot be unprotected. Delete the available backup points first. | diagnosis |
| 400 | UdmEcsOnlyPolicyCanNotSetVaultId | The ecs-instance-backup-only policy can not set vault id in the rules. | The ECS full-server policy does not support specifying a backup vault. | diagnosis |
| 400 | Unsupported | The operation is not supported yet. | The operation is not supported. | diagnosis |
| 0 | VaultAlreadyExist | The specified vault already exists. | The backup vault already exists. Verify that the input parameters are correct. | diagnosis |
| 400 | VaultBoundPlanCannotBeDeleted | The vault bound to backup plan can not be deleted. | A backup vault that is associated with a backup plan cannot be deleted. | diagnosis |
| 400 | VaultBoundPolicyCannotBeDeleted | The vault has been bound to the policy, please go to the Policy Center, delete the policy and retry. | The backup vault is bound to a policy. Go to the policy center to delete the associated policy and try again. | diagnosis |
| 404 | VaultNotExist | The specified vault doesn't exist. | The backup vault does not exist. Verify that the input parameters are correct. | diagnosis |
| 404 | VaultNotFound | The vault is not found. | The backup vault was not found. | diagnosis |
| 404 | VaultReplicationNotExist | Vault replication doesn't exist. | The backup vault replication relationship does not exist. | diagnosis |
| 400 | VaultReplicationStopping | Vault replication is stopping. | The backup vault replication is being stopped. | diagnosis |
| 403 | VaultWithFileDetectionRunningCannotBeDeleted | The vault with file detection running cannot be deleted. | The vault contains valid backups that are undergoing virus detection and cannot be deleted. Wait until the virus detection is complete and try again. | diagnosis |
| 400 | WormVaultCannotBeDeleted | The vault has enabled backup lock and cannot be deleted. | This backup vault has backup lock enabled and cannot be deleted. | diagnosis |
| 400 | WormVaultRetentionCannotBeReduced | The retention days of immutable vault cannot be reduced. | The retention period of a locked backup vault cannot be shortened. | diagnosis |
| 400 | WormVaultSnapshotsCannotBeDeleted | You cannot delete snapshots in the backup locked vault. | The snapshot is in a locked backup vault and cannot be deleted. | diagnosis |
| 400 | WormVaultSupportedForStandardOnly | Only Standard type vault supports WORM. | Only standard backup vaults support locking. | diagnosis |
| 400 | WormVaultSupportedForStandardOnly | You can only enable backup lock for standard backup vaults. | Only genearl backup vaults support enabling backup lock. | diagnosis |