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:Why ping packets can reach my VPCs attached to CEN but cannot reach the Telnet port?

Last Updated:Jun 21, 2023

Issue

After two virtual private clouds (VPCs) are attached to the same Cloud Enterprise Network (CEN) instance, ping packets can reach the Elastic Compute Service (ECS) instances, Server Load Balancer (SLB) instances, and ApsaraDB RDS instances in the VPCs but cannot reach the Telnet port.

Possible causes

Check for the following possible causes:

  • The security groups of the ECS instances are improperly configured.

  • The access control lists (ACLs) of the SLB instances are improperly configured.

  • The whitelists of the ApsaraDB RDS instances are improperly configured.

  • The VPCs are deployed in different regions, and no inter-region connection is established between the VPCs.

Solutions

Important
  • Before you perform high-risk operations, such as modifying the configurations or data of Alibaba Cloud instances, we recommend that you check the disaster recovery and fault tolerance capabilities of the instances to ensure data security.

  • Before you modify the configurations or data of an instance, such as an ECS instance or an ApsaraDB RDS instance, we recommend that you create snapshots or enable the backup feature for the instance. For example, you can enable the log backup feature for an ApsaraDB RDS instance.

  • If you have granted permissions on sensitive information or submitted sensitive information in the Alibaba Cloud Management Console, we recommend that you modify the sensitive information at the earliest opportunity. Sensitive information includes usernames and passwords.

  1. Check the security groups of the ECS instances.

    Make sure that the security groups of the ECS instances allow ECS instances, SLB instances, and ApsaraDB RDS instances to receive Telnet packets. For more information, see Search for security groups and Add a security group rule.

  2. Check the ACLs of the SLB instances. Make sure that the ACLs allow the desired IP addresses and CIDR blocks to access the SLB instances. For more information, see ACL overview.

  3. Check the whitelists of the ApsaraDB RDS instances. Make sure that the IP addresses and CIDR blocks that need to access the ApsaraDB RDS instances are on the whitelists of the ApsaraDB RDS instances. For more information, see Configure whitelists.

  4. Check whether the VPCs are deployed in different regions. If yes, you must establish an inter-region connection between the VPCs. Fore more information, see Manage inter-region connections.

Applicable scope

  • CEN