This topic describes the release notes for the Apache RocketMQ SDK for Go. You can choose a version of the SDK for Go that meets your business requirements to send and receive messages based on the description of this topic.

Recommended versions

ApsaraMQ for RocketMQ 5.0 instances are fully compatible with the Apache RocketMQ SDK for Go. The following version is tested and verified by Alibaba Cloud engineers. We recommend that you use it to send and receive messages.

Recommended version: rocketmq-client-csharp-v5.0.0https://github.com/apache/rocketmq-clients/releases/tag/rocketmq-client-golang-5.0.0

Historical versions

For more information about historical versions, see Releases.