Symptoms
You log on to the Message Queue for Apache Kafka console. On the Message Query page, you set the Search Method to Search by Point in Time and specify a Point in Time. The query returns messages whose Created At time is significantly different from the specified time, or whose Created At value is empty.
Causes
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If the specified time is outside the range of message timestamps within the partition (either before the earliest or after the latest), the consumer offset is reset to the latest offset. Consequently, the Created At column shows the timestamp of the message at this latest offset.
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A null value in the Created At column indicates that the message was sent from an older client version whose message format does not include a timestamp attribute.
Solutions
If the Created At value is null, upgrade your client to version 2.2.0 or later, preferably version 2.4.0.