Since July 31, 2021, Alibaba Cloud no longer provides ApsaraDB RDS instances that run PostgreSQL 9.4. After the specified date, Alibaba Cloud provides only technical support for existing RDS instances that run PostgreSQL 9.4. If your RDS instance runs PostgreSQL 9.4, we recommend that you upgrade the database engine version of the instance to a later version at the earliest opportunity. For more information, see Upgrade the major engine version of an ApsaraDB RDS for PostgreSQL instance.

Effective date

July 31, 2021

End-of-sale product

ApsaraDB RDS instances that run PostgreSQL 9.4

Causes

The open source PostgreSQL community no longer provides maintenance for PostgreSQL 9.4 since February 13, 2020. If you continue to use PostgreSQL 9.4, you may encounter potential risks.

Impacts

Recommended download method

  • If you are using an RDS instance that runs PostgreSQL 9.4, we recommend that you upgrade the database engine version of the instance to a later version. This way, you can prevent the known vulnerabilities and issues that are found in PostgreSQL 9.4. For more information, see Upgrade the major engine version of an ApsaraDB RDS for PostgreSQL instance.
  • If you want to purchase a new RDS instance that runs PostgreSQL, we recommend that you select PostgreSQL 10 or later.
  • If you are using an RDS instance that runs PostgreSQL 9.4, you cannot restore the data of the RDS instance to a new RDS instance from July 31, 2021. For more information about the restoration feature, see Restore the data of an ApsaraDB RDS for PostgreSQL instance. If you want to restore the data of the RDS instance to a new RDS instance, submit a ticket.