All Products
Search
Document Center

Alibaba Cloud Linux:What do I do if an Alibaba Cloud Linux 3 instance cannot start after alinux-base-setup-3.2-7.al8 is installed?

Last Updated:Jun 20, 2025

This topic describes the cause of and solution to the issue that an Alibaba Cloud Linux 3 instance cannot start after the alinux-base-setup-3.2-7.al8 component is installed, and how to prevent it.

Problem description

After the alinux-base-setup-3.2-7.al8 component is installed on an Elastic Compute Service (ECS) instance that runs Alibaba Cloud Linux 3, the instance can run as expected but cannot be restarted. When you connect to the instance by using Virtual Network Computing (VNC), the instance's operating system is stuck at the GRand Unified Bootloader (GRUB) interface.

image

Cause

The alinux-base-setup component manages and configures default system parameters and includes GRUB configuration. GRUB is reloaded upon instance restart. However, a bug in the alinux-base-setup-3.2-7.al8 component corrupts the GRUB configuration, resulting in an instance restart failure.

Solution

  1. Connect to the instance by using VNC.

  2. View the device ID of the boot partition.

    search --no-floppy --file /boot/grub2/grub.cfg
  3. Load the GRUB configuration file.

    Replace <ID> with the device ID of the boot partition.

    configfile (<ID>)/boot/grub2/grub.cfg
  4. After the instance starts, upgrade the alinux-base-setup component to the latest version.

    sudo yum clean all
    sudo yum update -y alinux-base-setup
  5. Restart the instance for the configuration to take effect.

    sudo reboot

Prevention

Perform the following steps to prevent the preceding issue:

  1. View the alinux-base-setup version.

    rpm -q alinux-base-setup
  2. (Optional) If the alinux-base-setup version is 3.2-7, upgrade it.

    sudo yum clean all
    sudo yum update -y alinux-base-setup
  3. Restart the instance for the configuration to take effect.

    Warning

    The restart operation stops the instance for a short period and may interrupt the services running on the instance, resulting in data loss. Before you restart the instance, we recommend backing up critical instance data. We also recommend restarting the instance during off-peak hours.

    sudo reboot