When an Alibaba Cloud Service Mesh (ASM) ingress gateway is deleted, the Server Load Balancer (SLB) instance configured for the ASM ingress gateway is also deleted. This topic describes the cause of the issue and provides a solution.
Problem description
When an ASM ingress gateway is deleted, the SLB instance configured for the ASM ingress gateway is also deleted.
Cause
If Create SLB Instance is specified when an ASM ingress gateway is created, an SLB instance is automatically created. In this case, when the ASM ingress gateway is deleted, the SLB instance that is automatically created is also deleted. 
Note If Use Existing SLB Instance is specified when an ASM ingress gateway is created, the SLB instance is retained after the ASM ingress gateway is deleted.

Solution
To retain the SLB instance that is automatically created for an ASM ingress gateway when you delete the ASM ingress gateway, perform the following steps:
- Obtain the IP address of the ingress gateway.
- Log on to the ASM console.
- In the left-side navigation pane, choose .
- On the Mesh Management page, find the ASM instance that you want to configure. Click the name of the ASM instance or click Manage in the Actions column.
- On the Mesh Management page, click the name of the ASM instance. In the left-side navigation pane, choose .
- On the Ingress Gateway page, obtain the IP address of the ingress gateway whose SLB instance you want to retain.
- Obtain the ID of the SLB instance.
- Log on to the Server Load Balancer console.
- In the left-side navigation pane, choose .
- On the Instances page, enter the IP address of the ingress gateway obtained in Step 1 in the search box. In the search results, you can obtain the ID of the SLB instance.
- Modify the YAML file of the ASM gateway.
- Delete the ASM ingress gateway and check whether the SLB instance that is automatically created for the ASM ingress gateway is retained.