This topic answers frequently asked questions about fleet management.
Does fleet management support multiple Fleet instances?
Yes. By default, ACK One provides a quota for one Fleet instance. To create more instances, you must request a quota increase in Quota Center.
Connectivity requirements
The Fleet instance's VPC must be able to access the associated cluster's API server endpoint.
The associated cluster's VPC must be able to access the Fleet instance's API server endpoint.
If the Fleet instance and the associated cluster are in different VPCs, you must connect the VPCs to allow access between their API server endpoints. You can use Cloud Enterprise Network (CEN) to connect the VPCs, or enable public endpoints for both to connect them over the public network.
Manage Fleet instances with the kubectl CLI
Yes, you can use the kubectl CLI to deploy resources to a Fleet instance. A Fleet instance is fully compatible with the Kubernetes API server and supports the deployment of native Kubernetes resources. You can also package applications with Helm and use the Helm CLI to deploy them to a Fleet instance. ACK One provides the AMC Kubectl Plugin to simplify application and job management in multi-cluster scenarios. For more information, see AMC command-line help.
Error when adding an associated cluster
Symptom
When you add an associated cluster, the console displays the following error message: secrets "sec-c58faedb8a7864d3****-public" not found.
Cause
A network connectivity issue occurred between the Fleet instance and the cluster that you want to associate.
Solution
If the Fleet instance and the associated cluster are in different VPCs, you must connect the VPCs to allow access between their API server endpoints. You can use Cloud Enterprise Network (CEN) to connect the VPCs, or enable public endpoints for both to connect them over the public network. For more information about CEN, see Cloud Enterprise Network.
Resolve the "namespace terminating" issue
When you disassociate a cluster, some API Services in the associated cluster may become unavailable. Consequently, the ack-multiple-clusters and ack-cluster-gateway fleet namespaces get stuck in the Terminating state and cannot be completely deleted. This prevents the cluster from being associated again. The solution is as follows:
Run the following command to retrieve the JSON file for the namespace.
Replace
<YOUR_NAMESPACE>with the name of your namespace.kubectl get namespace <YOUR_NAMESPACE> -o json > <YOUR_NAMESPACE>.jsonOpen the JSON file and delete the
finalizersarray from thespecsection.Run the following command to finalize the deletion of the namespace.
Replace
<YOUR_NAMESPACE>with the name of your namespace.kubectl replace --raw "/api/v1/namespaces/<YOUR_NAMESPACE>/finalize" -f ./<YOUR_NAMESPACE>.jsonRun the
kubectl get nscommand to verify that the namespace has been deleted.
Associate an improperly disassociated cluster
A Fleet can become unusable if it is accidentally deleted or if the SLB instance for its API server is deleted. In this case, you may need to add a sub-cluster that was not properly disassociated from the old Fleet to a new one. You may encounter errors during the association process. Follow these steps to successfully associate the cluster.
Log in to the ACK One console. In the navigation pane on the left, choose .
On the Associated Clusters page, expand the Fleet list, select the new Fleet, and then click Add associated clusters.
In the Add associated clusters panel, select the cluster and click OK.
On the Associated Clusters page, find the cluster you just associated and click Disassociate.
Click Add associated clusters again, select the same cluster, and then click OK.