防勒索服务备份大量数据时需要消耗服务器内存和磁盘空间进行缓存,当备份文件过多、过大或程序异常时,可能导致资源占用过高引发备份失败。本文提供磁盘空间不足和内存占用过高两种场景的排查方法,并介绍通过修改备份缓存配置来优化资源使用的解决方案。
防勒索功能和云备份产品共用同一客户端,因此对防勒索客户端的配置修改,将同样作用于云备份,请在调整前充分评估对云备份服务的影响。
磁盘空间不足
问题现象
防勒索备份任务占用服务器的磁盘空间过大,备份缓存目录占用大量磁盘空间,导致服务器磁盘告警或备份失败。
问题原因
正常情况下,防勒索备份占用服务器的磁盘空间为临时占用,待备份数据上传到云端后,服务器上的备份数据会自动删除。在备份文件过多、过大或程序运行异常时,会出现备份占用服务器的磁盘空间过大的情况。
解决方案:修改备份缓存配置
您可以参考以下步骤修改备份缓存的位置、状态及占用系统内存空间的上限。
如果服务器已开启客户端自保护,需先关闭该功能。
登录云安全中心控制台。
在左侧导航栏,选择。在控制台左上角,选择需防护资产所在的区域:中国内地或非中国内地。
在主机资产页面,单击目标服务器操作列的查看。
在防御状态区域,关闭客户端自保护防护开关。

使用具有管理员权限的用户登录需要操作的服务器。
找到并进入防勒索客户端的安装路径。各版本默认安装目录请参见本文附录:查看客户端版本和安装目录。
进入防勒索客户端的安装目录(默认为
../client目录),创建hbr.config文件。在
hbr.config文件中按照以下参数添加数据ID及元数据缓存信息,并保存该文件。重要无需重启,配置参数即可生效。
修改后的配置参数,只对后续新建的备份任务有效,对已经创建的备份任务无法进行缓存加速备份。
通过配置
hbr.config文件中的参数,可以设置缓存数据存放的位置、缓存数据占用系统内存空间的上限等缓存配置。hbr.config文件的配置示例如下:
disable_blob_cache = false max_blob_cache_weight = 0.15 cache_prefix = D:\CacheFolder max_retain_count = 16 disable_file_cache = false file_cache_max_size_hint = 32GB file_cache_disk_free_space_hint = 1GB file_cache_max_retain_count = 2参数
说明
disable_blob_cache
是否启用数据ID缓存。启用数据ID缓存可以添加备份源服务器的数据ID及元数据缓存来减少备份过程中的网络请求,从而利用数据缓存加速备份。取值:
true:不启用数据ID缓存。
false:启用数据ID缓存。
max_blob_cache_weight
控制数据ID缓存最多使用系统内存的百分比。默认值0.15,即15%的系统总内存。取值范围为(0,1)。
cache_prefix
控制缓存存放位置的路径字符串,取值为绝对路径。
max_retain_count
控制最大保留数据ID缓存个数。
disable_file_cache
是否启用元数据缓存。取值包括:
true:不启用元数据缓存。
false:启用元数据缓存。
file_cache_max_size_hint
表示文件cache最多占用的空间。默认值32GB。如果文件cache占用的磁盘空间超过该值,文件备份失败并提示文件cache空间不足,请根据实际情况调高file_cache_max_size_hint。比如1000万文件每次的备份缓存大概占用1.5GB磁盘空间,具体磁盘占用空间与备份源的文件个数、文件总数据量、文件全路径长度有关。在备份期间新生成1份缓存空间,那么预估需要为磁盘预留的空间是:1.5GB *(file_cache_max_retain_count + 1)+ file_cache_disk_free_space_hint
说明仅对防勒索客户端V2.13.1版本及以上生效。
file_cache_disk_free_space_hint
表示文件cache所在磁盘的剩余空间,默认值为1GB。如果磁盘剩余空间小于该值,文件备份失败并提示文件cache空间不足,请根据实际情况调整缓存空间。
说明仅对防勒索客户端V2.13.1版本及以上生效。
file_cache_max_retain_count
表示为每个备份路径保留的文件cache个数,默认值为2。例如,当设置为2时本地将保留最近两次备份的缓存,如果删除最新的备份之后,仍然可以找到最新的上次备份。
说明仅对防勒索客户端V2.13.1版本及以上生效。
内存占用过高(OOM)
问题现象
备份任务状态为备份失败,且错误提示信息为OOM(Out of Memory)。备份任务执行期间,hbrclient进程持续存在并占用大量内存,备份任务结束后hbrclient进程通常会被终止。
问题原因
在备份文件过多、过大或程序运行异常时,可能会导致备份任务占用服务器的内存资源过高。常见原因包括:
防护目录包含网络挂载路径(如OSS、NAS),导致频繁数据访问。
备份网络带宽未限制,备份吞吐量过大。
服务器内存配置偏低,无法满足备份需求。
解决方案
可以根据具体业务需求选取以下一种或多种方案。
排除网络挂载路径
请勿在防勒索的防护目录中直接添加网络挂载路径(如挂载到ECS服务器上的OSS、NAS地址),此操作可能因频繁的数据访问而导致内存占用过高,并产生额外的API调用费用。您可以通过以下方式处理:
使用云备份服务:对于OSS和NAS数据,建议使用专用的云备份服务。具体操作,请参见快速入门-OSS备份、快速入门-本地NAS备份。
升级客户端:升级至最新版防勒索客户端,系统将自动把挂载目录纳入排除列表。
拆分防护目录
将防护策略中的防护目录地址拆分为多个子目录。在同一个防护策略中,多个防护目录会串行执行备份。由于每个拆分目录的数据量有所减少,单个备份任务消耗的资源也会降低。
例如,将防护目录/user/bin拆分为多个子目录。具体操作,请参见管理防护策略。。

拆分防护目录地址后,云安全中心会按照拆分后的目录执行备份计划,不会影响已备份的数据恢复。
限制备份网络带宽
适当限制备份的吞吐量,可以降低备份对磁盘、内存和CPU的使用。在编辑防护策略面板,修改备份网络带宽限制。具体操作,请参见管理防护策略。

备份网络带宽限制设置为0时,表示不限制带宽。
调整CPU占用限制
如果服务器资源配置与备份数据量相匹配,可以尝试调高备份的CPU使用占比。调高CPU占用后可以提高备份的并发处理能力,缩短备份时间,减少内存的累计占用。
调整CPU占用限制前,请您务必全面评估系统性能及当前负载状况,确保系统具备承受增加负荷的能力。
例如,服务器共有8个核,可将默认占用的1核修改为2核。进入防勒索客户端的安装目录(默认为../client目录),在hbr.config配置文件中添加配置cpu_max_procs = 2。
若hbr.config配置文件不存在,可以新建一个hbr.config文件,只需添加上述的cpu_max_procs = 2配置即可,下次备份任务启动时生效。各版本客户端的默认安装目录,请参见附录:查看客户端版本和安装目录。
升级资源配置
备份数据量较大时,需要使用的内存资源较多。如果服务器的内存较小无法满足备份需求,您需要升级服务器的内存配置。具体资源对照,请参见备份所需要的资源说明。
如果您使用的是云服务器 ECS,升级配置步骤,请参见修改实例规格。
附录:查看客户端版本和安装目录
查看客户端版本
可以在页面,查看防勒索客户端的版本。
查看客户端安装目录
不同版本的防勒索客户端的默认安装目录如下:
客户端版本 | 服务器的操作系统 | 防勒索客户端的安装目录 |
1.X.X | Windows | C:\Program Files (x86)\Alibaba\Aegis\hbr\client |
Linux | /usr/local/aegis/hbr/client | |
2.X.X | Windows | C:\Program Files (x86)\Alibaba\Aegis\hbrclient\client |
Linux | /usr/local/aegis/hbrclient/client |
其他常见问题
防勒索备份缓存数据占用了服务器过多的C盘空间,能修改缓存数据的位置吗?
可以。您可以通过修改防勒索备份客户端的配置文件修改防勒索备份缓存数据的位置。具体操作,请参见防勒索备份占用过多磁盘空间解决方案。
已购买的防勒索数据保护容量不够用怎么办?
当已购买的防勒索数据保护容量不足时,可能导致服务器数据备份失败。可通过扩容或释放防勒索容量空间来解决此问题。
扩容防勒索容量空间
防勒索容量不足会导致服务器数据备份失败,无法恢复服务器数据。建议及时升级防勒索容量以避免此类风险。
操作步骤:
登录云安全中心控制台
在左侧导航栏,选择。在控制台左上角,选择需防护资产所在的区域:中国内地或非中国内地。
在防勒索页面,单击已使用容量/总容量下的升级,完成容量扩容。
建议配置: 每台服务器配置50 GB的数据防护容量。
释放防勒索容量空间
减少服务器数量
通过删除防护策略下的非生产状态服务器(测试服务器、闲置服务器等)来节约防勒索容量空间。具体操作,请参见管理防护策略中的服务器。
减少防护目录
可以在创建防护策略时,选择自定义策略,通过备份指定目录,节约防勒索容量空间。具体操作,请参见创建防护策略及客户端。
删除历史备份数据
确认某服务器的历史备份数据无需保留后,可删除该服务器已备份的历史数据来释放防勒索容量空间。具体操作,请参见删除已备份数据。
联系我们
如果以上方法都无法解决,可获取在线人工帮助,并提供以下信息:
设备总内存和可用内存;
备份期间备份进程占用的内存;
备份文件总数和备份数据量;
备份客户端的版本;
磁盘IO和网络吞吐量;
云监控数据:备份前和备份期间的CPU和内存信息截图。具体查看步骤,请参见请参见云产品监控。