全部产品
Search
文档中心

云数据库 RDS:CopyDatabaseBetweenInstances - RDS SQL Server实例间复制数据库

更新时间:Aug 28, 2026

该接口用于在RDS SQL Server实例间复制数据库。

接口说明

适用引擎

RDS SQL Server

相关功能文档

重要 使用该接口前,请仔细阅读功能文档,确保完全了解使用接口的前提条件及使用后造成的影响后,再进行操作。

RDS SQL Server 实例间数据库复制

使用限制

  • 源实例和目标实例需在同一个阿里云账号下。

  • 目标实例中不得存在与源实例待复制数据库同名的数据库。

  • 目标实例的可用存储空间需大于源实例中待复制数据库占用的空间。存储空间不足时,请及时扩容

  • 源实例和目标实例需位于同一地域(可用区可不同),且网络类型需一致。

  • 源和目标实例不支持 Serverless 实例类型。迁移 Serverless 实例,请通过 DTS 迁移

  • 传值时,BackupId 或 RestoreTime 参数必须任传其一,都不传将报错。

调试

您可以在OpenAPI Explorer中直接运行该接口,免去您计算签名的困扰。运行成功后,OpenAPI Explorer可以自动生成SDK代码示例。

调试

授权信息

下表是API对应的授权信息,可以在RAM权限策略语句的Action元素中使用,用来给RAM用户或RAM角色授予调用此API的权限。具体说明如下:

  • 操作:是指具体的权限点。

  • 访问级别:是指每个操作的访问级别,取值为写入(Write)、读取(Read)或列出(List)。

  • 资源类型:是指操作中支持授权的资源类型。具体说明如下:

    • 对于必选的资源类型,用前面加 * 表示。

    • 对于不支持资源级授权的操作,用全部资源表示。

  • 条件关键字:是指云产品自身定义的条件关键字。

  • 关联操作:是指成功执行操作所需要的其他权限。操作者必须同时具备关联操作的权限,操作才能成功。

操作

访问级别

资源类型

条件关键字

关联操作

rds:CopyDatabaseBetweenInstances

create

*DBInstance

acs:rds:{#regionId}:{#accountId}:dbinstance/{#dbinstanceId}

请求参数

名称

类型

必填

描述

示例值

DBInstanceId

string

源实例 ID。可调用 DescribeDBInstances 获取。

rm-bp172446ys9cf****

TargetDBInstanceId

string

目标实例 ID。可调用 DescribeDBInstances 获取。

rm-bp1m71wvzfiq7****

DbNames

string

待复制的数据库名称列表,格式如下:{"源实例的数据库名称":"目标实例的数据库名称"}。复制多个库时,用英文逗号(,)分隔。示例如下:

  • 复制单个库:{"zhttest":"zhttest"}

  • 复制多个库:{"zhttest01":"zhttest01","zhttest02":"zhttest02"}

说明

目标实例的数据库名称可与源实例不同,但复制前需确保目标实例中不存在同名数据库。

{"zhttest":"zhttest"}

BackupId

string

源实例备份集 ID。按备份集复制数据库时,可以通过查询备份列表接口 DescribeBackups 获取备份集 ID。

说明

调用接口时,BackupIdRestoreTime 需传入任意一个。

259321****

RestoreTime

string

按时间点复制数据库,可以选择备份保留周期内的任意时间点。格式:yyyy-MM-ddTHH:mm:ssZ(UTC 时间)。

说明

调用接口时,BackupIdRestoreTime 需传入任意一个。

2025-06-08T17:41:14Z

SyncUserPrivilege

string

是否复制用户和权限,取值:

  • YES:表示复制用户和权限。如果目标实例中有同名的用户,则该用户将叠加源实例的同名用户的权限。

  • NO(默认值):表示不复制用户和权限。

NO

返回参数

名称

类型

描述

示例值

object

返回参数详情。

RequestId

string

请求 ID。

803D11AF-C370-465B-AB46-CB3A642DC303

示例

正常返回示例

JSON格式

{
  "RequestId": "803D11AF-C370-465B-AB46-CB3A642DC303"
}

错误码

HTTP status code

错误码

错误信息

描述

400 %s DB Operation Failed:%s.
400 InvalidBackupSetID Invalid backup set id. 备份集不存在。请调用DescribeBackups接口查看已存在的备份集。
400 DBCountLimitExceeded Db count limit exceeded. 超过了数据库计数限制。
400 BackupRestoreNotSupported.BasicHA Basic instances cannot be restored to high availability instances, and high availability instances cannot be restored to basic instances. 基础版实例不能恢复到高可用实例,高可用实例不能恢复到基础版实例。
400 BackupRestoreNotSupported.HADedicatedAlwaysOn High availability instances cannot be restored to dedicated cluster instances or AlwaysOn instances. 操作失败,高可用实例不能还原到专属集群实例或者企业集群版实例。
400 BackupRestoreNotSupported.ShareDedicatedAlwaysOn Shared instances cannot be restored to dedicated cluster instances, AlwaysOn instances, or high availability instances. 共享实例不能还原到专属集群实例或者企业集群版实例或者高可用版实例。
400 OperationDenied.RestoreTime The instance with snapshot backup enabled can only be restored to the instance with snapshot backup enabled. 开启快照备份的实例,只能恢复到开启快照备份的实例。
400 OperationDenied.SnapshotBackupSet Snapshot backup set can only be restored to the instance with snapshot backup enabled. 开启快照备份的实例且备份集类型为快照备份的,只能恢复到开启快照备份的实例。
400 CanNotCopyDBHasTDEEnabled The source database has enabled the TDE feature. You cannot copy it to another instance. 源数据库已启用TDE功能,无法复制到其他实例。
400 InvalidBackupDBNames.NotFound The specified BackupDBNames is not found.
400 InvalidBackupDBNames.Malformed The specified backup database is not valid.
400 InvalidDBName.Format Specified DB name is not valid. 无效的数据库名称。请重新命名,数据库名称由小写字母,数字、下划线组成,字母开头,字母或数字结尾,最长16个字符。
400 InvalidDBInstanceName.NotFound Invalid DBInstanceId NotFound.
400 EngineNotSupported The engine does not support the operation. 当前引擎不支持此操作。
400 InvalidTargetDBInstanceName.Format Specified Target DB instance name is not valid.
400 MasterDBInstanceState.NotSupport The Master instance state does not support this operation.
400 TargetInstanceEngineNotSupported The specified Engine cannot be supported the operation.
400 InvalidInstancesRegion.Malformed The instance region is not the same as the target instance region.
400 InvalidStartTime.Format The specified parameter "StartTime" is not valid. 开始时间格式不正确。格式要求为标准GMT格式,即YYYY-MM-DDThh:mmZ。示例如下: DescribeDBInstancePerformance:2012-06-11T15:00Z。 DescribeErrorLogs:2011-06-11T16:00Z。
400 InvalidEndTime.Format The specified parameter "EndTime" is not valid. 操作失败,结束时间格式不正确。格式要求为标准GMT格式,即YYYY-MM-DDThh:mmZ。例如:2012-06-11T15:00Z。
400 InvalidParameterCombination The end time must be greater than the start time 结束时间必须晚于开始时间。
400 InvalidBackupSetLocation.Format Specified backup set location is not valid. 指定的备份集位置无效。
400 InvalidCrossRegionTrans Cross region instance trans is not supported 不支持跨区域实例传输。
400 ErrorParametersConflict Parameter BackupsetID and restoretime can only exist one. 参数BackupID和restoretime只能存在一个。
400 InvalidDBName.NotFound Specified DB name does not exist. 指定的数据库名称不存在。请输入正确的数据库账号名称。
400 InvalidDBName.Duplicate Specified DB name already exists in the This instance. 当前实例中已存在相同的数据库名称。请更换名称。
400 ReadDBInstanceNotSupport The operation is not permitted due to type of the instance. 只读实例不允许执行该操作。
400 InvalidRecoveryDbInstance.StorageSize The disk space of the new instance cannot be less than that of the current instance 操作失败,新实例的磁盘空间不能小于当前实例的空间。
400 InvalidRecoveryDBNames.Format The specified parameter DBNames is not valid. 实例名称无效,请检查参数是否正确。
400 InvalidBackupIdOrRestoreTime.NotFound The specified parameter BackupId or RestoreTime is not valid. 操作失败,参数BackupId或RestoreTime无效。
400 Forbidden.RegionNotFound The provided RegionId does not exist in our record. 操作失败,当前提供的地域标识在记录中不存在。
400 ImageNotFound The specified Image is disabled or is deleted. 指定的镜像被禁用或删除。
400 InvalidZone.NotSupportedForStorageType The specified zone is closed or invalid for Specified DBInstanceStorageType. 指定的区域已关闭或对于指定的DBInstanceStorageType无效。
400 InvalidEngineOrEngineVersion The specified params engine or engineVersion should not be null. 指定的参数engine或engineVersion不应为null。
400 InvalidGeneralGroupNameOrGdnInstanceName The specified params generalGroupName or gdnInstanceName should not be null. 指定的参数generalGroupName或gdInsttanceName不应为空。
400 InvalidVSwitchId.NotFound Specified virtual switch is not found in specified VPC. 该VPC内无可用交换机。
400 CDDC.TargetHostIDNotAvailable The target host ID is not available. 目标主机不可用,请更换主机。
400 CDDC.AvailableHostsNotEnoughInZone Not enough available hosts are in the target zone. 目标可用区没有足够的主机资源,请在可用区中创建主机。
400 ReadOnlyInstanceNotSupport Specified ReadOnly Instance not support this operation. 操作失败,只读实例不支持此操作。
400 InvalidShareDbInstanceClassNotSupport The current instance classType is not support operation. 当前实例类型不支持操作
400 InvalidQuantity.NotSupported The specified instance quantity is not supported. 实例数量不符合订购限制,请检查。
400 IncorrectMasterDBInstanceState Master instance state does not support this operation. 主实例状态不支持此操作。
400 InvalidDBInstance.ReadDBInstanceExceeded Current DB Instance exceeding the allowed amount of read instance.
400 InvalidEngineVersion.Malformed Specified engine version is not valid. 数据库引擎版本无效,请确认后重试。
400 InvalidEssdStorageSize The cloud ESSD storage size is invalid. 云盘存储规格有误,请检查存储规格配置。
400 IncorrectInstanceNetworkType The specified parameter InstanceNetworkType is not valid. 参数InstanceNetworkType错误
400 AtLeastTwoVSwitchParamExists The specified params(Vswitchs) at least two. 指定的参数(Vswitchs)至少有两个,可用区和Vswitchs对应。
400 InvalidIzNo.NotSupported Specified VPC zone is not supported. VPC的可用区不匹配,请修改后重试。
400 InvalidBackupSet Specified database does not exists in the backup set. 备份集中没有指定的数据库
400 InvalidRestoreTimeSpecified Unable to restore to the specified time, because the database is in cold storage at this time. Please choose a valid restore point. 不能恢复到指定的时间点,因为数据库在这个时间点处于冷存中,请选择一个其他合理的时间。
400 InvalidRestoreDB Unable to restore, because the database is in cold storage now. Please skip this database. 不能恢复当前的数据库,因为数据库是一个冷存库,请跳过这个数据库
400 Order.ComboInstanceNotAllowOperate A package instance is not allowed to operate independently. 套餐实例不允许单独操作。
400 Price.PricingPlanResultNotFound Pricing plan price result not found. 定价计划价格结果没有找到。
400 Order.NoRealNameAuthentication You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. 您还未通过实名认证,不符合购买条件,请登录费用与成本进行实名认证。
400 InsufficientAvailableQuota Your account quota limit is less than 0, please recharge before trying to purchase. 您的账户可用额度小于0,请先充值后再尝试购买。
400 CommodityServiceCalling.Exception Failed to call commodity service. 调用商品服务返回失败。
400 RegionDissolvedEOM Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. 客户您好,阿里云计划对当前地域进行优化调整,该区域云服务将停止运营,为确保您的业务连续性及数据迁移工作的平稳过渡,您目前无法操作新购类型的订单,感谢理解与支持。
400 Commodity.InvalidComponent The module you purchased is not legal, please buy it again. 您购买的模块不合法,请重新购买。
400 RegionEndTimeDissolvedAustralia Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. 客户您好,该地域已裁撤。
400 Price.CommoditySys Commodity system call exception. 商品系统调用异常。
400 Pay.InsufficientBalance Insufficient available balance. 可用金不足。
400 Order.PeriodInvalid There is a problem with the period you selected, please choose again. 您选购的周期有问题,请重新选购。
400 pay.noCreditCard Account not bound to credit card. 账户未绑定信用卡。
400 Order.InstHasUnpaidOrder There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. 您选购的服务存在未支付订单,请支付或作废后再下单。
400 noAvailablePaymentMethod No payment method is specified for your account. We recommend that you add a payment method. 没有为您的账户指定付款方式。我们建议您添加一种付款方式。
400 BasicInfoUncompleted Your information is incomplete. Complete your information before the operation. 您的基本信息未完善,请在操作前先完善您的基本信息。
400 Risk.RiskControlRejection Your account is abnormal, please contact customer service for details. 您的账户出现异常,详情请联系客服。
400 Api.NotSupport Specified api is not supported. 当前接口不支持。
400 ContainForbiddenLabelError There is a label that prohibits placing orders. Please contact your distributor for assistance. 存在禁止下单的标签,请联系您的分销商处理
400 InvalidDBInstanceId.NotFound The DBInstanceId provided does not exist in records. 提供的DBInstanceId不存在。
400 InvalidInstanceLevel.DiskType Specified instance level not support request disk type 当前实例规格不支持该存储类型。
400 InvalidParam Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. 指定的 wal_level 参数无效。实例中仍然存在复制槽,因此无法将其设置为replica。
400 KmsApiError User secret key invalid. 用户密钥失效。
400 System.SaleValidateFailed Sales expression validation system error. 销售表达式校验系统错误。
400 Abs.InvalidAccount.NotFound account is not found. 账户不存在。
400 SqlExecuteFailedOrTimeout sql command execution failed or timed out:%s. sql命令执行失败或执行超时
400 ColdData.EngineVersionNotSupport The current instance engine version not support coldDataEnabled. 当前实例引擎版本不支持归档冷数据。
400 ColdData.MinorVersionNotSupport The current instance minor version not support coldDataEnabled. 当前内核版本不支持归档冷数据。
400 IncorrectTargetClasscode The current instance type does not support this operation. 当前规格不支持此操作。
400 InvalidConnectionString.Duplicate Specified connection string already exists in the RDS. 链接地址名重复,请重新设置连接字符串。
400 RequiredParam.NotFound Required input param is not found. 没有传入必要的参数。
400 Parameters.Invalid Parameter error, please check the parameters. 参数错误,请检查参数。
400 BackupPolicyNotSupport Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. 数据归档不支持跨地域备份和秒级快照,请检查备份策略。
400 InvalideStatus.Format The instance status does not support this operation. 实例状态不支持此操作。
400 InvalidReleasedKeepPolicy.Format Specified Released Keep Policy is not valid. 实例释放后的归档备份保留策略无效。
400 InvalidDBInstanceEngineType.Format the DB instance engine type does not support this operation. DB实例引擎类型不支持此操作。
400 Pay.NoCreditCard No credit cards. 无信用卡。
400 VpcNetworkTypeNotSupport The vpc network type instance does not support this operation. vpc网络类型实例不支持此操作。
400 MirrorInsExists Specified DB instance mirror ins already existed. 当前数据库实例镜像已存在。
400 UnsupportedClassCode The specified DB instance class stops selling. 实例规格停止售卖。
400 OrdTCommodityQueryError Failed to query for product. 查询产品失败。
400 ProductInstanceReleased The instance has been released. Please check before placing the order. 实例已释放,请核实后下单。
400 RegionEndTimeDissolvedIndia The region is no longer supported. 指定的地域无效。
400 InvalidCharacter.DbOrAccount The database name or account name contains invalid characters. 数据库名称或者账号名称包含非法字符。
500 ExternalFailure The request processing has failed due to external service failure. 请求服务失败,请稍后重试。
500 RequestMetaDataFailed The service request failed. Please try again later or contact service personnel. 请求服务失败,请稍后再试或联系服务人员。
500 InvokeProxyFailure The request processing has failed due to service failure of rds api. 由于rds api服务失败,请求处理失败。
403 StorageLimitExceeded Exceeding the allowed Storage of DB instance.
403 InvalidTempInstance.NotSupport The temp db Instance is not support. 操作失败,当前实例已被锁定。
403 InvalidTargetDBInstanceName.Format Specified Target DB instance name is not valid. 目标实例名称不正确。
403 IncorrectDBInstanceState The current database instance state does not support the operation. 操作失败,数据库状态不支持此操作。请查看数据库信息,确保数据库状态为运行中。
403 IncorrectDBInstanceType Current DB instance engine and type does not support operations. 操作失败,当前数据库实例引擎和类型不支持。
403 Forbidden.SnapshotRecovery Snapshot backup does not support partial restore 操作失败,快照备份不支持部分还原。
403 OperationDenied.Resource Specified DB instance class or storage is not available in all Availability Zones. 资源不足,请变更实例规格或存储规格后再试。
403 ReadonlyDBInstanceStorageExceeded You can not create the order with the db instance because The masterInstance storage value exceeding the readonlyInstance storage value. 操作失败,主实例存储值超过只读实例存储值,无法使用数据库实例创建订单。
403 MasterDBInstanceClassNotSupport You can not create the readonly instance with the master instance class does not support. 操作失败,当前主实例规格不支持创建只读实例。
403 ReadonlyDBInstanceClassNotSupport You can not create the readonly instance with the instance class does not support. 操作失败,当前实例规格不支持创建只读实例。
403 ReadonlyDBInstanceClassLowerThanMasterInstance The readonly instance db instance class are lower than master instance db instance class. 只读实例数据库实例规格低于主实例数据库实例规格。
403 InvalidSwitchType.Malformed The specified parameter InvalidSwitchType is not valid. 参数InvalidSwitchType无效。
403 UnsupportedCopyDbHighAvailabilityToBasic Replicate Database from RDS Category:HighAvailability to RDS Category:Basic is not supported. 不支持将数据库从高可用复制到基础版。
403 InvalidInstanceVersion Source instance version is greater than the target instance version. 源实例版本大于目标实例版本。
403 UnsupportedCopyDbShareToHighAvailability Replicate Database from RDS Category:Share to RDS Category:HighAvailability is not supported. 不支持将数据库从共享版本复制到高可用版本。
403 UnsupportedCopyDbAlwaysOnToBasic Replicate Database from RDS Category:AlwaysOn to RDS Category:Basic is not supported. 不支持将数据库从集群版复制到基础版。
403 UnsupportedCopyDbBasicToShare Replicate Database from RDS Category:Basic to RDS Category:Share is not supported. 不支持将数据库从基础版复制到共享版。
403 UnsupportedCopyDbAlwaysOnToHighAvailability Replicate Database from RDS Category:AlwaysOn to RDS Category:HighAvailability is not supported. 不支持将数据库从集群版复制到高可用版。
403 UnsupportedCopyDbShareToBasic Replicate Database from RDS Category:Share to RDS Category:Basic is not supported. 不支持将数据库从共享版复制到基础版。
403 UnsupportedCopyDbHighAvailabilityToShare Replicate Database from RDS Category:HighAvailability to RDS Category:Share is not supported. 不支持将数据库从高可用版复制到共享版。
403 UnsupportedCopyDbShareToAlwaysOn Replicate Database from RDS Category:Share to RDS Category:AlwaysOn is not supported. 不支持将数据库从共享版复制到集群版。
403 UnsupportedCopyDbAlwaysOnToShare Replicate Database from RDS Category:AlwaysOn to RDS Category:Share is not supported. 不支持将数据库从集群版复制到共享版。
403 InvalidParamTableMeta.RestoreTime The specified restore time cannot be covered by the existing backup chain. Please try specifying a different restore time.
403 CurrentRecoveryModelNotSupportThisAction Current recovery model not supported this action. 当前的恢复模式不支持此操作
403 OrderStatus.UnPaid The specified db instance has unpaid order. 实例当前存在未支付订单,请支付后重试。
403 InvalidReduceDiskSize The storage capacity after the scale-down must be larger than the used amount. 缩容目标容量不能小于当前存储空间使用量
403 CloudSSDNotSupport Cloud ssd does not support this operation, please upgrade to essd. SSD盘不支持此操作,请升级至ESSD。
403 InvalidUserOperatorPermission The user permission does not support this operation. 用户权限不支持此操作。
403 InvalidVswitchId Specified conn vswitch id is not valid. 指定的VSwitchId格式不正确或为空
403 IncorrectMinorVersion Current engine minor version does not support operations. 当前引擎小版本不支持此操作。
403 OperationDenied.ZoneResource There is no available zone for inventory. 没有可用的库存区域。
403 NotInFlowController Sorry,no permission. 非集团上云用户不可用,无权限。
403 InvalidKmsKey Kms key is disabled. Kms key已禁用。
403 InvalidInstanceLevel.Malformed Current DB instance level does not support this operation. 当前数据库实例级别不支持此操作。
404 InvalidDBInstance.NotFound The specified instance does not exist or is not supported. 没有找到指定的实例,请检查实例的正确性。
404 StorageLimitExceeded Exceeding the allowed Storage of DB instance. 已超过磁盘空间限制,请清理磁盘空间。
404 InvalidInstanceStorageType.NotFound The specified DBInstanceStorageType is not found. 实例存储类型参数(InstanceStorageType)未配置,请重新配置。
404 InvalidRegion.NotFound Specified Region does not exist in the RDS 地域无效。
404 IncorrectVswitchId The specified parameter VSwitchId is not valid. 交换机参数无效。
404 InsufficientResourceCapacity Current cluster resources are insufficient. Try again later. 当前集群的资源不足,请您稍后再试。
404 InvalidParam Invalid params to call rds open api, BakDBNames is not empty. 调用RDS打开API的参数无效,BakDBNames不为空。
404 InvalidClusterKms The current instance does not authorized to access the Key Management Service. 当前实例未授权访问密钥管理服务。
404 Request.NotFound The requested resource is not available. 请求的资源不可用。
404 HostInfo.NotFound The specified host info is not found. 指定的主机信息不存在。
408 NetworkOrSqlTimeoutError Failed to create login due to potential SQL Server overload or other issues that may cause the login creation fail. Please retry later. 由于潜在的SQL Server过载或实例账号过多,导致查询超时失败。

访问错误中心查看更多错误码。

变更历史

更多信息,参考变更详情