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云备份:排查和处理文件备份客户端状态异常

更新时间:Sep 22, 2023

问题现象

在使用ECS文件备份(经典网络)和本地文件备份时,新版文件备份客户端状态异常,例如客户端状态为未知或已停止。

可能原因

  • 备份客户端服务hbrclient运行异常。

  • 安装备份客户端的服务器网络异常。

  • 备份客户端所在服务器由于更换网卡等原因导致备份客户端注册失败。

解决方案

检查备份客户端的服务运行状态、运行日志和网络情况,重新设置并激活备份客户端。

  1. 检查备份客户端是否在运行。

    • Windows系统

      方式一:打开任务管理器查看hbrclient进程运行状态。

      方式二:命令行执行services.msc命令,查看Alibaba Cloud Hybrid Backup Service服务运行状态。

    • Linux系统

      执行ps -ef | grep hbrclient命令查看hbrclient进程运行状态。如果存在结果,说明已经启动,一切运行正常。

    1. hbrclient服务没有运行,则重启云备份服务即可。Linux系统可执行service hbrclient restart重启云备份服务。

    2. hbrclient服务运行正常,执行步骤2

  2. 检查hbrclient.log日志。

    新版备份客户端默认安装路径参考如下,操作中请以实际安装路径为准。

    • Windows版本日志路径:本地磁盘(C)> Program Files > Aliyun Hybrid Backup Service Client > logs

    • Linux版本日志路径:/opt/alibabacloud/hbrclient/logs

    1. 打开hbrclient.log文件,搜索Failed to register client. AppError: ErrorCode=

    2. 若ErrorCode为InvalidInstanceId,则表示网络正常但备份客户端注册失败,执行步骤3

    3. 若ErrorCode不为InvalidInstanceId,则重启云备份服务,再观察客户端状态。Linux系统可执行service hbrclient restart重启云备份服务。

      当仍然搜索到ErrorCode不为InvalidInstanceId,请提交工单获取支持。

    4. 若未搜索到任何内容,执行步骤3

  3. 检查服务器网络状态。

    新版备份客户端默认安装路径参考如下,操作中请以实际安装路径为准。

    • Windows版本日志路径:本地磁盘(C)> Program Files > Aliyun Hybrid Backup Service Client > logs

    • Linux版本日志路径:/opt/alibabacloud/hbrclient/logs

    1. 打开network.log文件。

    2. 若日志文件中出现Failed on ping,则表示网络异常(包括防火墙和路由配置等异常)。请您联系服务器所在网络的IT支撑人员,根据网络接入点设置云备份对应地域的公网接入点或ECS内网接入点。

    3. 若未搜索到Failed on ping,执行步骤4

  4. 确认服务器是否换过网卡。

    联系服务器所在网络的IT支撑人员,确认安装过备份客户端的服务器是否更换过网卡。

    1. 若更换过网卡,则该操作会导致服务器MAC地址变化,导致备份客户端无法注册,从而备份客户端状态异常。请按照步骤6重新激活备份客户端。

    2. 若未更换过网卡,执行步骤5

  5. 检查服务器是否被克隆过。

    联系服务器所在网络的IT支撑人员,确认安装过备份客户端的服务器是否被克隆过。

    1. 若被克隆过,则该操作会导致安装的备份客户端也被克隆,从而导致克隆出来的服务器上的备份客户端注册失败。

      • 若原服务器备份客户端仍在使用,请在克隆出来的服务器上卸载备份客户端后,重新安装备份客户端即可。

      • 若原服务器备份客户端未使用,则在克隆出来的服务器上,按照步骤6重新激活客户端。

    2. 若未被克隆过,执行步骤6重新激活备份客户端。

  6. 重新激活客户端。

    1. 登录云备份Cloud Backup控制台

    2. 选择备份数据源。

      • ECS文件备份

        在左侧导航栏,选择备份 > ECS文件备份

      • 本地文件备份

        在左侧导航栏,选择备份 > 本地文件备份

    3. 在顶部菜单栏左上角,选择所在地域。

    4. 找到目标备份客户端,在其右侧的操作栏选择更多 > 重新激活客户端

    5. 重新激活客户端面板,拷贝命令。并在服务器上的客户端安装目录下执行该命令,等待激活成功。

    激活完成后,客户端状态显示为已激活

  7. 如果以上排查仍未解决问题,请提交工单获取支持。