当您创建跟踪并投递到日志服务SLS时,操作审计会自动帮您创建SLS Logstore和索引。如果您手动删除或修改索引,可能导致事件高级查询和事件告警功能不可用,此时您需要设置索引。
通过控制台设置索引
当操作审计事件高级查询和事件告警功能不可用时,您可以通过以下方式将索引设置为默认配置。
通过CloudShell设置索引
当操作审计事件高级查询和事件告警功能不可用时,您可以通过CloudShell重新创建索引。
登录CloudShell。
执行以下命令,一键创建索引。
actiontrail-update-index [project] [logstore] [regionId]说明请将project(日志项目名称)、logstore(日志库)、regionId(日志项目地域)替换为日志服务SLS中设置的参数。您可以在操作审计控制台跟踪详情页查询日志服务参数信息。
代码示例:
actiontrail-update-index actiontrail-ev**** actiontrail-test**** cn-hangzhou
高级查询报错"The project does not belong to you"
问题现象:在操作审计控制台使用高级查询时,提示"The project does not belong to you"错误,或显示"系统检测到您没有符合条件的跟踪"。
原因分析:该错误表明您没有权限访问指定的日志服务(SLS)项目。常见原因:
您使用的SLS项目(如normandy-actiontrail-log)不属于当前账号。
您作为RAM用户没有被授予该SLS项目的读取权限。
您尚未创建跟踪,导致系统没有自动生成对应的SLS项目。
解决方案:
联系阿里云账号管理员,授予您对应SLS项目的读取权限(
log:GetProject、log:GetLogStoreLogs等)。若您尚未创建跟踪,可在操作审计控制台创建跟踪并投递到SLS,系统会自动创建SLS项目。管控事件的项目名为
actiontrail-logs-<账号ID>-<随机后缀>,数据事件的地域化日志项目名为actiontrail-log-<账号ID>-<地域ID>。确认您使用的是正确的跟踪日志项目,而非其他账号或地域的项目。