Yerindeki veri merkeziniz, sanal makine (VM) ortamınız veya bulut ana bilgisayarınız bir Alibaba Cloud Virtual Private Cloud (VPC) ağına erişebiliyorsa, Server Migration Center (SMC) hizmetinin özel aktarım özelliğini kullanarak genel ağa kıyasla daha hızlı ve daha kararlı bir geçiş yapabilirsiniz.
Senaryolar
-
Senaryo 1: Kaynak sunucunun genel ağ erişimi yoktur, ancak veri merkezinin genel gidiş trafiği vardır.
Kaynak sunucuyu VPN Gateway, Express Connect veya Smart Access Gateway aracılığıyla bir VPC'ye bağlayın. Ardından, kaynak sunucunun SMC'ye erişmesi ve özel ağ üzerinden geçiş yapması için bir proxy sunucusu yapılandırın.
-
Senaryo 2: Kaynak sunucunun genel ağ erişimi vardır, ancak geçiş hızı sınırlıdır.
Kaynak sunucuyu VPN Gateway, Express Connect veya Smart Access Gateway aracılığıyla bir VPC'ye bağlayın ve SMC geçiş işini oluştururken özel aktarımı seçin.
Geçiş süreci
Aşağıdaki şekilde özel aktarım geçiş süreci gösterilmektedir.
SMC istemcisini indirin ve kaynak sunucuya yükleyin.
SMC istemcisini kaynak sunucuda çalıştırın ve geçiş kaynağını SMC konsoluna aktarmak için bir proxy sunucusu kullanın (İleri yönlü proxy'ler).
SMC konsolunda, özel aktarım kullanan bir geçiş işi oluşturun ve başlatın.
SMC, geçiş işine göre kaynaklar oluşturur ve Express Connect üzerinden bağlanan VPC'yi kullanarak verileri kaynak sunucudan Alibaba Cloud'a geçirir.
Geçiş sırasında, proxy sunucusu SMC'den gelen talimatları istemciye iletir. Bir hata oluşursa, SMC geçişi durdurur ve hata günlüğünü proxy sunucusu aracılığıyla istemciye gönderir.
İleri yönlü proxy'ler
İleri yönlü bir proxy, bir istemci ile bir sunucu arasında konumlanır. İstemcinin genel ağ erişimi olmadığında, istekleri proxy üzerinden gönderir; proxy bu istekleri hedef sunucuya iletir ve yanıtları geri döndürür.
İleri yönlü proxy'nin faydaları şunlardır:
İstemcilerin genel ağdaki kaynaklara erişmesine olanak tanır.
Sık erişilen genel verileri önbelleğe alarak sonraki isteklerin daha hızlı gerçekleşmesini sağlar.
Güvenliği artırmak amacıyla istemci erişimini yetkilendirir.
Genel kaynaklara erişilirken istemci bilgilerini gizler ve istemci erişimini günlüğe kaydeder.
Ön koşullar
Yerindeki veri merkeziniz, VPN Gateway, Express Connect veya Smart Access Gateway aracılığıyla bir Alibaba Cloud VPC'sine bağlıdır. Bir VPC'yi bir veri merkezine veya başka bir buluta bağlama.
Geçiş kaynağı ile ara örnek arasındaki veri aktarımı için veri merkezi güvenlik duvarında 8703 ve 8080 bağlantı noktaları açıktır.
Kaynak sunucu ve proxy sunucusu birbirleriyle iletişim kurabilir ve proxy sunucusu genel ağa erişebilir.
Yordam
-
Bir proxy sunucusu oluşturun ve 3128 bağlantı noktasını açın.
-
(Önerilen) CentOS 7 veya üzeri bir sürüm çalıştıran bir ECS örneği oluşturun. Özel başlatma sihirbazını kullanarak bir örnek oluşturma.
Varsayılan olarak, ECS örnekleri SMC özel uç noktalarına erişebilir. Aşağıdaki uç noktaların erişilebilir olduğunu doğrulayın:
https://.axt.aliyun.com. Örneğin, China (Hangzhou) bölgesi için uç nokta https://cn-hangzhou.axt.aliyun.com adresidir.
https://smc.vpc-proxy.aliyuncs.com.
-
Proxy sunucusu olarak kullanmak üzere Alibaba Cloud dışı bir sunucu oluşturun.
Proxy sunucusunun aşağıdaki SMC genel uç noktalarına erişebildiğinden emin olun: https://smc.aliyuncs.com.
-
-
Özel bağlantıya sahip VPC içindeki bir sunucuya Squid yükleyin.
-
WinSCP gibi bir uzaktan bağlantı aracı kullanarak Linux sunucuya bağlanın.
Bu örnekte CentOS 7.9 çalıştıran bir sunucu kullanılmaktadır.
-
Güvenlik duvarını devre dışı bırakmak için aşağıdaki komutları çalıştırın.
systemctl stop firewalld setenforce 0 -
Squid'i yüklemek için aşağıdaki komutu çalıştırın.
yum -y install squid -
/etc/squid/squid.confdosyasının kaynak sunucu CIDR bloğundan erişime izin veren bir kural içerip içermediğini kontrol edin.cat /etc/squid/squid.conf# Example rule allowing access from your local networks. # Adapt to list your (internal) IP networks from where browsing # should_be_allowed acl localnet src 0.0.xxx 255.255.255 # RFC 1122 "this" network (LAN) acl localnet src 10.0.xxx # RFC 1918 local private network (LAN) acl localnet src 100.xxx /10 # RFC 6598 shared address space (CGN) acl localnet src 169.xxx 0/16 # RFC 3927 link-local (directly plugged) machines acl localnet src 172.xxx 0/16 # RFC 1918 local private network (LAN) acl localnet src 192.xxx 0/16 # RFC 1918 local private network (LAN) acl localnet src fc00::/7 # RFC 4193 local private network range acl localnet src fe80::/10 # RFC 4291 link-local (directly plugged) machines acl SSL_ports port 443 acl Safe_ports port 80 # http acl Safe_ports port 21 # ftp acl Safe_ports port 443 # httpsKural mevcutsa, bir sonraki adıma geçin.
-
Kural mevcut değilse, aşağıdaki adımları uygulayın:
-
Squid yapılandırma dosyasını düzenlemek için aşağıdaki komutu çalıştırın:
vim /etc/squid/squid.conf -
ituşuna basın ve gerekli CIDR bloğunu ekleyin. Örneğin, tüm IP adreslerine izin vermek içinacl localnet src 0.0.0.0/0satırını ekleyin.acl localnet src 0.0.0.0/0satırını Squid yapılandırma dosyasının ACL bölümüne ekleyin. Örnek bir yapılandırma aşağıda verilmiştir:# Example rule allowing access from your local networks. # Adapt to list your (internal) IP networks from where browsing # should be allowed acl localnet src 0.0.0.0/0 acl localnet src 0.0.xxx.xxx.255.255 # RFC 1122 "this" network (LAN) acl localnet src 10.xxx # RFC 1918 local private network (LAN) acl localnet src 100.xxx # RFC 6598 shared address space (CGN) acl localnet src 169.xxx # RFC 3927 link-local (directly plugged) machines acl localnet src 192.xxx # RFC 1918 local private network (LAN) acl localnet src fc00::/7 # RFC 4193 local private network range acl localnet src fe80::/10 # RFC 4291 link-local (directly plugged) machines acl SSL_ports port 443 acl Safe_ports port 80 # http acl Safe_ports port 21 # ftp acl Safe_ports port 443 # https acl Safe_ports port 210 # xxxÖnemliSquid varsayılan olarak 3128 bağlantı noktasını kullanır. Bağlantı noktasını değiştirmek için yapılandırmadaki
http_port 3128değerini güncelleyin. Esctuşuna basın,:wqyazın ve Enter tuşuna basarak değişiklikleri kaydedip çıkın.
-
-
Squid'i başlatın ve etkinleştirin.
systemctl start squid systemctl enable squid
-
-
SMC istemcisini kullanarak bir geçiş kaynağı aktarın. SMC istemcisini kullanarak bir geçiş kaynağı aktarma.
SMC istemcisini indirip sıkıştırmasını açtıktan sonra, geçiş kaynağını aktarmadan önce istemci yapılandırma dosyasında proxy sunucusunu yapılandırın. Linux sisteminde proxy'yi yapılandırmak için:
-
go2aliyun_clientdizininde (veya VMware agentless connector için/root/smcdizininde)client_datadosyasını açın.Bu örnekte, genel amaçlı 64 bitlik bir Linux dağıtımı için SMC istemcisi kullanılmaktadır.
cd go2aliyun_client_linux_x86_64 # If you use the VMware agentless connector, switch to the /root/smc directory. vim client_data -
proxyyapılandırma öğesini bulun."net": { "net_mode": 0, "no_libcurl": false, "proxy": { "ip_port": "", "user_pwd": "" } }, -
ip_portdeğerini proxy sunucusunun IP adresi ve bağlantı noktası olarak ayarlayın.Örnek yapılandırma:
"proxy": { "ip_port": "172.168.XX.XX:3128", "user_pwd": "" }Esc tuşuna basın,
:wqyazın ve Enter tuşuna basarak değişiklikleri kaydedip çıkın. -
(İsteğe bağlı) Proxy sunucusu genel IP adresi olmayan bir ECS örneğiyse, SMC özel uç noktasını belirtin.
./go2aliyun_client --rerun --useaxt=cn-hangzhoucn-hangzhoudeğerini proxy sunucusunun bölge kimliği ile değiştirin.
-
-
SMC konsolunda bir geçiş işi oluşturun ve başlatın. Adım 2: Geçiş işi yapılandırma.
Geçiş işini yapılandırırken, Network Type değerini VPC olarak ayarlayın ve özel bağlantısı olan VPC ile vSwitch'i yapılandırın.