呼叫CreateRouteEntry在VPC路由器或邊界路由器(VBR)上建立自訂路由條目。
介面說明
- CreateRouteEntry 介面屬於非同步介面,即系統會回傳一個執行個體 ID,但該路由的新增尚未完成,系統後台的啟動任務仍在進行。您可以呼叫 DescribeRouteEntryList 查詢路由的新增狀態:
當路由處於 Creating 狀態時,表示路由新增中。
當路由處於 Created 狀態時,表示路由新增完成。
CreateRouteEntry 介面不支援在同一個 VPC 或者同一個 VBR 中併發新增自訂路由條目。
CreateRouteEntry 介面在併發情況下可能回傳 TaskConflict 錯誤碼,請酌情重試。
使用該介面為 VPC 路由器的路由表新增自訂路由條目時,請注意以下事項:
當新增的路由為前綴清單路由時,路由配額的計算為現存路由與前綴清單路由的最大路由條目數之和是否超過路由配額的限制。
-
同一個路由表中自訂路由條目不能超過 200 條。
-
自訂路由條目的目標網段(DestinationCidrBlock)不能和 VPC 內的交換器的網段相同,可以包含交換器的網段但是不能被交換器的網段包含。
-
自訂路由條目的目標網段(DestinationCidrBlock)可以配置為比雲端服務系統路由網段
100.64.0.0/10更明細的網段,但不支援與該網段相同。重要 由於目標網段為100.64.0.0/10的系統路由用於 VPC 內的雲端產品通訊,建議您謹慎配置更明細的路由,如果配置錯誤將導致雲端產品服務無法正常存取和使用。 -
同一路由表下的路由條目的目標網段(DestinationCidrBlock)不允許相同。
-
如果指定的目標網段(DestinationCidrBlock)是一個 IP 位址,會按照 32 位元遮罩來處理。
-
多條自訂路由條目可以指向同一個下一跳(NextHopId)。
-
自訂路由條目的下一跳(NextHopId)必須和路由表在同一個 VPC。
-
支援透過 NextHopList 參數配置 ECMP 路由:
-
新增普通(非 ECMP)自訂路由時,需指定 DestinationCidrBlock、NextHopType 和 NextHopId 參數,且不能指定 NextHopList 參數。
-
新增 ECMP 路由時,需指定 DestinationCidrBlock 和 NextHopList 參數,且不能指定 NextHopType 和 NextHopId 參數。
-
使用該介面為邊界路由器的路由表新增自訂路由條目時,請注意以下事項:
-
同一個路由表中自訂路由條目不能超過 200 條。
-
不支援 NextHopList 參數。
-
自訂路由條目的目標網段(DestinationCidrBlock)可以配置為比雲端服務系統路由網段
100.64.0.0/10更明細的網段,但不支援與該網段相同。重要 由於目標網段為100.64.0.0/10的系統路由用於 VPC 內的雲端產品通訊,建議您謹慎配置更明細的路由,如果配置錯誤將導致雲端產品服務無法正常存取和使用。 -
同一路由表下的路由條目的目標網段(DestinationCidrBlock)不允許相同。
-
如果指定的目標網段(DestinationCidrBlock)是一個 IP 位址,會按照 32 位元遮罩來處理。
-
多條自訂路由條目可以指向同一個下一跳(NextHopId)。
-
自訂路由條目的下一跳(NextHopId)必須是該 VBR 關聯的路由器介面。
-
只允許在 VBR 狀態是 Active,而且對應的實體專線狀態是 Enabled 且沒有被欠費鎖定的情況下在 VBR 上新建路由條目。
-
僅支援新增普通路由(非 ECMP),需指定 DestinationCidrBlock、NextHopType 和 NextHopId 參數,且不能指定 NextHopList 參數。
調試
您可以在OpenAPI Explorer中直接運行該介面,免去您計算簽名的困擾。運行成功後,OpenAPI Explorer可以自動產生SDK程式碼範例。
調試
授權資訊
|
操作 |
存取層級 |
資源類型 |
條件關鍵字 |
關聯操作 |
|
vpc:CreateRouteEntry |
create |
*RouteTable
|
無 | 無 |
請求參數
|
名稱 |
類型 |
必填 |
描述 |
樣本值 |
| RegionId |
string |
否 |
路由表所屬地域的 ID。 您可以透過呼叫 DescribeRegions 介面取得地域 ID。 |
cn-hangzhou |
| RouteTableId |
string |
是 |
要新增自訂路由條目的路由表 ID。 |
vtb-bp145q7glnuzd**** |
| DestinationCidrBlock |
string |
是 |
自訂路由條目的目標網段,支援 IPv4、IPv6、前綴清單的目標網段和前綴清單的執行個體 ID。需滿足以下要求:
|
192.168.0.0/24 |
| NextHopId |
string |
否 |
自訂路由條目的下一跳執行個體的 ID。 說明
若選擇 NextHopType 為 ECR,您可以透過 DescribeExpressConnectRouterAssociation 介面取得 AssociationId 作為下一跳 ID。 |
i-j6c2fp57q8rr4jlu**** |
| ClientToken |
string |
否 |
用戶端 Token,用於保證請求的冪等性。 從您的用戶端產生一個參數值,請確保不同請求間該參數值唯一。ClientToken 只支援 ASCII 字元。 說明
若您未指定,則系統自動使用 API 請求的 RequestId 作為 ClientToken 標識。每次 API 請求的 RequestId 不一樣。 |
02fb3da4-130e-11e9-8e44-001**** |
| RouteEntryName |
string |
否 |
要新增的自訂路由條目的名稱。 名稱長度為 1~128 個字元,不能以 |
test |
| Description |
string |
否 |
自訂路由條目的描述資訊。 描述長度為 1~256 個字元,不能以 |
test |
| NextHopType |
string |
否 |
自訂路由條目的下一跳的類型,取值:
枚舉值:
|
RouterInterface |
| NextHopList |
array<object> |
否 |
下一跳的資訊。 |
|
|
object |
否 |
下一跳的資訊。 |
||
| NextHopId |
string |
否 |
ECMP 路由的下一跳執行個體的 ID。 |
ri-2zeo3xzyf3cd8r4**** |
| NextHopType |
string |
否 |
ECMP 路由的下一跳的類型,目前僅取值:RouterInterface(路由器介面)。 |
RouterInterface |
| Weight |
integer |
否 |
ECMP 路由的下一跳的路由權重。 |
10 |
| DryRun |
boolean |
否 |
是否只預檢此次請求。取值:
|
false |
返回參數
|
名稱 |
類型 |
描述 |
樣本值 |
|
object |
自訂路由條目的 ID。 |
||
| RequestId |
string |
請求 ID。 |
0ED8D006-F706-4D23-88ED-E11ED28DCAC0 |
| RouteEntryId |
string |
自訂路由條目的 ID。 |
rte-sn6vjkioxte1gz83z**** |
樣本
正常返回樣本
JSON格式
{
"RequestId": "0ED8D006-F706-4D23-88ED-E11ED28DCAC0",
"RouteEntryId": "rte-sn6vjkioxte1gz83z****"
}
錯誤碼
|
HTTP status code |
錯誤碼 |
錯誤資訊 |
描述 |
|---|---|---|---|
| 400 | IllegalParam.CidrBlock | The specified CidrBlock is illegal. | 網段不合法。 |
| 400 | QuotaExceeded | Route entry quota exceeded in this route table. | |
| 400 | MissingParameter | Miss mandatory parameter. | |
| 400 | InvalidCidrBlock.Malformed | Specified CIDR block is not valid. | |
| 400 | InvalidCIDRBlock.Duplicate | Specified CIDR block is already exists. | |
| 400 | IncorrectVpcStatus | Current VPC status does not support this operation. | |
| 400 | IncorrectInstanceStatus | Current instance status does not support this operation. | |
| 400 | IncorrectRouteEntryStatus | Some route entry status blocked this operation. | |
| 400 | IncorrectVSwitchStatus | The current virtual switch status does not support this operation. | 建立交換器失敗,VPC中有交換器的狀態為Creating。 |
| 400 | InvalidCidrBlock | Specified CIDR block is not valid. | 可能的錯誤原因: 1. 您不在10.0.0.0/8的路由網段的白名單中,不能使用該網段。 2. 新增的自訂路由目標網段不能從屬於同一個VPC下面所有交換器的網段。 3. 由於100.64.0.0/10是雲端服務位址,您不能再新增該網段指向雲下IDC。 4. 除100.64.0.0/10以外,100.64.0.0/11、100.96.0.0/11等明細路由網段均不能使用在雲下IDC。 |
| 400 | InvalidNextHop.NotFound | Specified next hop does not exist. | |
| 400 | InvalidVRouter.NotFound | vRouter not exists. | |
| 400 | InvalidVPC.NotFound | vpc not exists. | |
| 400 | InvalidNexthopTypeAndList.BothNull | both nexthopType and nextHopList are null. | |
| 400 | InvalidNexthopTypeAndList.BothNotNull | both nexthopType and nextHopList are not null. | |
| 400 | InvalidRouterInterface | invalid router interface. | |
| 400 | InvalidOppositeRouterType | nexthop list cannot only contain router interface whose opposite router interface is on vbr. | |
| 400 | InvalidNexthopListSize | nexthop size is illegal. Must be between 2 and 4. | 必須指定2~4個路由器介面作為下一跳。 |
| 400 | InvalidEntryRuleQuota.NotFound | Route entry quota rule not exists. | |
| 400 | Forbidden.CheckEntryRuleQuota | Route entry quota rule check error. | |
| 400 | InvalidVBRStatus | invalid virtual border router status. | |
| 400 | InvalidPhysicalConnectionBusinessStatus | invalid physical connection business status. | |
| 400 | InvalidRouterType | Cannot specify nexthop list in vbr's route table. | VBR路由表中不存在指定的下一跳。 |
| 400 | IncorrectHaVipStatus | This operation is denied because satus of the specified HaVip is neither Available nor InUse. | 只有當HaVip的狀態是InUse時,才可以執行該操作。 |
| 400 | CountLimitExceed.HaVipRouteEntry | The count of route entry to HaVip in one route table is exceeded. | 指向該HaVip執行個體的路由項目數量已達上限。 |
| 400 | InvalidRouteEntry.Duplicate | The route entry already exist. | |
| 400 | InvalidParam | The Ecmp routerEntry with router interfaces local vgw vip not match. | |
| 400 | INVALID_WEIGHT_PARAM | Specified value of weight invalid | |
| 400 | FORBIDDEN_USE_VPC_AS_INTERNET_GATEWAY | The Specified CIDR must be in vpc CIDR. | |
| 400 | InvalidNexthop | The Specified nexthop illegal. | |
| 400 | INVALID_VPC_ID | The Specified VpcId not match. | 該VPC不存在,請您檢查輸入的VPC是否正確。 |
| 400 | InvalidRouteEntrySize | The Specified routerEntry size not legal. | 等價路由需要選擇2~4個路由器介面作為路由下一跳。 |
| 400 | TaskConflict | The operation is too frequent, please wait a moment and try again. | EIP 操作太頻繁。 |
| 400 | InvalidRouteEntry | Specified routeEntry not exist. | |
| 400 | InvalidDestinationCidrBlock | The specified destinationCidrBlock must not included in black list cidr. | |
| 400 | Forbidden.VRouterNotFound | Specified virtual switch is not found during access authentication. | |
| 400 | DefaultValidate.Error | validte fail. | |
| 400 | Region.NotSupport | The specified region does not currently support nextHopType for networkInterface | |
| 400 | OperationFailed.NotifyCenCreate | Failed to notify cen when create route entry. | |
| 400 | Forbidden.PrivateIpNotFound | Private ip address not exist. | |
| 400 | OperationUnsupported.InactiveMode | Vpc multi scope route only support active standby. | |
| 400 | InvalidRouteEntryName.Malformed | Specified RouteEntry name is not valid. | 無法修改,因為指定的路由項目名稱無效。 |
| 400 | IncorrectStatus.MultiScopeRiRouteEntry | MultiScope ri status must not in idle. | |
| 400 | OperationUnsupported.MoreThanOneVpnOrHavip | MultiScope can not support more than one vpn/havip. | |
| 400 | OperationUnsupported.EcmpRiTypeOrNumber | Emcp entry not supported if vpc-vbr or vbr-vlan ri does not exist. | |
| 400 | Duplicated.VpcNextHop | Route entry nexthop duplicate. | 下一個重複的路由項目。 |
| 400 | OperationUnsupported.SubRouteTableECMP | Vpc subRouteTable don't support ecmp or multiScope. | |
| 400 | InvalidNexthop.NotFound | VRouterEntry nexthop does not exist. | |
| 400 | IllegalParam.NextHopId | Instance not exists or not vpc vm. | |
| 400 | QuotaExceeded.HaVipRouteEntry | Vpc havip route entry quota exceed. | |
| 400 | InvalidNexthop.DirectEni | The direct Eni cannot be nexthop. | 直通ENI不能作為下一個躍點。 |
| 400 | OperationFailed.InvalidNexthop | vpc multi scope route must has a enable nexthop. | |
| 400 | OperationFailed.NotifyCenDelete | Failed to notify cen when delete route entry. | |
| 400 | InvalidNatGateway.NotFound | Natgateway not exist. | |
| 400 | OperationFailed.CxpRouteExist | Cxp route alreay existed. | |
| 400 | OperationFailed.GetEniInfo | Failed to get networkInterface info. | |
| 400 | OperationUnsupported.InvalidRouterInterfaceType | Only vpc vbr interface support ecmp route. | |
| 400 | InvalidHaVip.NotFound | The specified HaVip does not exist in the specified region. | |
| 400 | OperationFailed.MultiScopeType | The specified nexthop type is not support in multiScope. | |
| 400 | OperationFailed.DistibuteLock | Distibute lock fail. | 資源已經被鎖定,不允許操作。 |
| 400 | QuotaExceeded.VpnRouteEntry | Vpn route entry quota exceeded. | VPC路由表中指向VPN閘道器的路由項目已經達到配額限制。 |
| 400 | InvalidAttachment.NotFound | The attachment is not found. | Attachment 不存在。 |
| 400 | OperationFailed.ActiveNetworkInterfaceNotFound | No active network interface is found on the attachment. | Attachment 上不存在可用的彈性網路介面。 |
| 400 | InvalidNetworkInterface.NotFound | The network interface is not found on the attachment. | Attachment 上的彈性網路介面不存在。 |
| 400 | OperationFailed.QueryAttachmentInfo | Failed to query attachment information. | 查詢 Attachment 資訊失敗。 |
| 400 | IllegalParam.AttachmentId | The attachment is invalid. | Attachment 無效。 |
| 400 | OperationFailed.NotSupportIPV6 | The specified next hop does not support IPv6. | 指定的下一個躍點不支援 IPv6 功能。 |
| 400 | IncorrectStatus.Ipv6Address | The IPv6 address of the specified next hop is being assigned or deleted. | 指定的下一個躍點的 IPv6 位址目前正在建立或刪除中。 |
| 400 | OperationUnsupported.Ipv6EntryOnPrimaryNetworkInterface | You cannot create IPv6 route entries on a primary network interface. | 不允許建立下一個躍點為主要網路介面的 IPv6 路由。 |
| 400 | OperationUnsupported.SpecifyIpOnIpv6Entry | You cannot specify the private IP address when you create IPv6 route entries. | 建立 IPv6 路由不允許指定 Private IP 參數。 |
| 400 | OperationUnsupported.MutipleIpv6Address | You cannot specify a next hop that has bound multiple IPv6 addresses. | 不允許指定綁定了多個 IPv6 位址的下一跳。 |
| 400 | OperationDenied.Ipv6EntryOnCustomTable | You cannot create any IPv6 route entry on a custom route table. | 不允許在自訂路由表上建立 IPv6 路由。 |
| 400 | OperationDenied.CloudBoxVbrEntryAllowedInCustomRouteTable | The operation is not allowed because only the custom routing table can add a routing entry with the next hop pointing to the cloud box type VBR. | 指定操作被禁止,因為只有自訂路由表能夠新增下一跳指向雲盒類型 VBR 的路由條目。 |
| 400 | OperationDenied.RouteTableAssociateNotCloudBoxVSwitch | The operation is not allowed because of the routing table is bound to a non-cloud box type vswitch, and routing entries pointing to the cloud box VBR cannot be added. | 指定操作被禁止,因為路由表綁定到了非雲盒類型的vSwitch上,不能新增指向雲盒VBR的路由條目。 |
| 400 | OperationDenied.VbrMisMatchCloudBox | The operation is not allowed because the routing table is bound to a cloud box vswitch, and routing entries pointing to other cloud box VBRs cannot be added. | 指定操作被禁止,因為路由表綁定到了一個雲盒vSwitch上,不能新增指向其他雲盒VBR的路由條目。 |
| 400 | OperationDenied.VbrIdle | The operation is not allowed because the next hop of the added routing entry is a VBR type RI at the opposite end, which cannot be in an idle state. | 指定操作被禁止,因為新增的路由條目下一跳是對端為VBR類型的RI,不能處於閒置狀態。 |
| 400 | OperationDenied.RouterInterfaceToDifferentVpc | The operation is not allowed because the router interface is connected to different VPCs. | 指定操作被禁止,因為路由器介面指向不同的VPC。 |
| 400 | OperationDenied.RouterInterfaceFromDifferentZones | The operation is not allowed because the router interface resides in different zones. | 指定操作被禁止,因為路由器介面來自不同的可用區。 |
| 400 | OperationFailed.PconnTrafficNotEnable | The operation is failed because of PconnTrafficNotEnable. | 操作失敗,因為出方向流量未啟用。 |
| 400 | ResourceNotFound.VpcPeer | The specified resource of %s is not found. | 無法找到指定的VpcPeer。 |
| 400 | IncorrectStatus.VpcPeer | The status of %s [%s] is incorrect. | %s[%s] 的狀態不正確。 |
| 400 | OperationDenied.RouteTableTypeNotPermitted | The operation is not allowed because the type of route table is not permitted. | 指定路由表類型不允許建立路由條目。 |
| 400 | OperationDenied.GatewayRouteTableNotPermitted | The operation is not allowed to create a route pointing to this nextHop type on gateway route table. | 閘道器路由表中不支援建立指向此執行個體類型的路由項目。 |
| 400 | UnsupportedFeature.VpcPeerIpv6 | IPv6 route entries for VPC peering connections cannot be created in this region. | 此路由器介面對端是 VPC,此地域不支援建立此類型下一跳的 IPv6 路由。 |
| 400 | OperationDenied.VpcIpv6NotEnabled | IPv6 has not been enabled for the VPC. | 由於該 VPC 未啟用 IPv6 功能,操作被拒絕。 |
| 400 | IncorrectStatus.Ipv4Gateway | The status of Ipv4Gateway is incorrect. | |
| 400 | ResourceNotFound.PrefixList | The specified resource of prefixList is not found. | 輸入的prefixList不存在。 |
| 400 | UnsupportedFeature.CreatePrefixListEcmpRouteEntry | The feature of creating ecmp route entry with prefixList is not supported. | 目前不支援使用前綴清單建立 ECMP 路由。 |
| 400 | OperationDenied.RouterInterfaceIpv6NotEnabled | Routerinterface does not support IPv6. | router interface不支援IPv6。 |
| 400 | OperationDenied.NextHopTypeNotPermitted | The operation is not allowed because the nextHop type is invalid. | 不允許建立下一跳為此類型的路由。 |
| 400 | ResourceAlreadyAssociated.PrefixList | The operation failed because the specified prefixList route entry already exists. | 操作失敗,此首碼清單路由存在。 |
| 400 | OperationFailed.CidrConflictWithPrefixList | The specified CIDR block already exists in a prefixList route entry. | 路由Cidr與已存在的首碼清單路由衝突。 |
| 400 | ResourceNotFound.Ipv4Gateway | Specified Ipv4Gateway does not exist. | 未找到指定的IPv4閘道器,無法刪除。 |
| 400 | Mismatch.HaVipIdAndRouteTableId | The HaVip and RouteTable are mismatched. | 傳入的高可用性虛擬IP與路由表不屬於同一個VPC。 |
| 400 | OperationFailed.OperationLocked | The operation failed because the nextHop instance is in the O&M lock state. | 路由下一跳執行個體處於維運鎖定狀態,無法操作。 |
| 400 | Mismatch.Ipv4GatewayIdAndRouteTableId | The specified IPv4Gateway and RouteTable are not matched. | 操作失敗,傳入的 IPv4 閘道和路由表不屬於同一 VPC。 |
| 400 | OperationUnsupported.DestinationCidrBlockOverlapWithVSwitch | The destination IPv6 network segment specified in the route entry overlaps with the vSwitch network segment. | 路由項目中指定的目標 IPv6 網段與 vSwitch 網段重疊。 |
| 400 | ResourceNotAssociated.Cen | The Vpc and Cen are not associated. | 操作失敗,本VPC未關聯到此CEN中。 |
| 400 | IncorrectStatus.CenRelation | The status of Vpc in Cen is incorrect. | 操作失敗,VPC在CEN中狀態未達穩態。 |
| 400 | OperationDenied.CenTypeInvalid | The operation is not allowed because of Cen type is invalid.. | 不支援在路由表中建立路由指向此類型的Cen。 |
| 400 | ResourceNotFound.Cen | The specified resource of Cen is not found. | 操作失敗,傳入Cen資源不存在。 |
| 400 | ResourceNotFound.NetworkInterface | The specified resource of network interface is not found. | 指定的網卡不存在。 |
| 400 | RouteConflict.AlreadyExist | Route conflict exists in routing table. | 路由表中存在路由衝突。 |
| 400 | IncorrectStatus.RouterInterface | The specified RouterInterface status is invalid. | 目前執行個體的狀態無法進行刪除,請等待狀態變更後再次進行操作。 |
| 400 | InvalidNexthop.UnsupportedEniBizType | The biz type of NetworkInterface is illegal. | 作為路由下一跳的網卡業務類型非法。 |
| 400 | OperationDenied.RouterInterfaceIpv6 | RouterInterface does not support IPv6. | RouterInterface 不支援 IPv6。 |
| 400 | InvalidNextHopType | Specified parameter "NextHopType" is not valid. | 該下一跳類型不合法。 |
| 400 | OperationDenied.VbrAttachEcrInMiddleStatus | The operation is not allowed because of VBR attach or detach ECR in middle status. | 由於邊界路由器正處於載入或者卸載專線閘道器過程中,當前操作無法執行,請您稍等後重試。 |
| 400 | ResourceNotAssociated.Ecr | The ECR is not associated. | 當前資源未與專線閘道器關聯,無法執行此操作,請核對後重試。 |
| 400 | UnsupportedFeature.RouterInterfaceIpv6 | The feature of ipv6 is not supported for the routerInterface. | 該路由器介面不支援ipv6。 |
| 400 | InvalidVpnInstanceId.NotFound | The specified VPN was not found. | 指定的VPN執行個體未找到。 |
| 400 | OperationFailed.ScopeActiveRouteEntryType | Operation failed because the type of the active route entry is not supported. | 操作失敗,不支援此活動路由條目的類型。 |
| 400 | OperationFailed.ScopeStandbyRouteEntryQuota | Operation failed because the quota for standby route entries in the scope has been exceeded. | 操作失敗,因為超出了備用路由條目的配額。 |
| 400 | OperationFailed.ScopeActiveRouteEntryQuota | Operation failed because the quota for active route entries in the scope has been exceeded. | 操作失敗,因為超出了活動路由條目的配額。 |
| 400 | OperationUnsupported.ScopeInvalidRouteType | The specified route type is unsupported. | 不支援此路由類型。 |
| 400 | OperationFailed.EcmpInvalidRouterInterfaceOppositeType | Operation failed because the opposite type of the router interface is invalid for ECMP configuration. | 操作失敗,該 RI 的對端類型對於 ECMP 是無效的。 |
| 400 | OperationUnsupported.Ipv6EcmpRouteEntry | The EcmpRouteEntry is not supported for IPv6. | IPv6不支援Ecmp路由。 |
| 400 | OperationUnsupported.Ipv6CidrBlock | The specified IPv6 CIDR block is unsupported. | 不支援此IPv6CidrBlock。 |
| 400 | OperationUnsupported.Ipv6ForVBR | IPv6 route entry is not supported for VirtualBorderRouter. | VBR不支援IPv6路由。 |
| 400 | IncorrectStatus.RouteTableStatus | The status of the specified RouteTable is incorrect. | 指定的路由表未處於穩定狀態。 |
| 400 | OperationFailed.InvalidNextHopType | Operation failed because Ecmp routeEntry has more than one ri entry and can only support one non-ri entry. | 建立路由項目失敗,因為ECMP(Equal-Cost Multipath Routing)路由只支援一個非RI(non-ri)類型作為下一個躍點。 |
| 400 | UnsupportedRegion | The feature is not supported in current region. | 本地區不支援操作prefixList路由。 |
| 400 | UnsupportedFeature.VpcAdvancedFeature | The VPC does not support some advanced features. | 您指定的 VSwitch 所在的 VPC 未支援進階特性,請更換其他 VSwitch 重試。 |
| 400 | OperationDenied.CreateEcmpForPublishedRouteEntry | Operation denied because of can not create EcmpRouteEntry for published RouteEntry. | 已發佈路由不支援建立主備路由或負載平衡路由。 |
| 400 | OperationDenied.TrAttachmentIpv6Disabled | The operation is not allowed because tr attachment Ipv6 is disabled. | Tr Attachment未開啟Ipv6能力。 |
| 400 | Mismatch.EniIdAndRouteTableId | The operation is not allowed because eni and route table not in same vpc. | 操作失敗,因為指定的彈性網卡和路由表不屬於同一個Vpc。 |
| 400 | InvalidDescription.Malformed | The Description is illegal. | 指定的資源描述格式不合法。長度為2~256個字元,不能以http://和https://開頭。 |
| 400 | OperationFailed.InstanceDismatchCurrentVpc | The specified instance does not exist in current vpc. | |
| 400 | OperationDenied.RouterInterfaceStatusNotAllowed | The operation is not allowed because of RouterInterfaceStatusNotAllowed. | 路由器介面狀態異常。 |
| 400 | OperationFailed.Ipv6AddressNotBind | The specified next hop has no IPv6 address. | IPv6路由的下一跳沒有IPv6位址。 |
| 400 | OperationUnsupported.MultipleIpv6Address | Operation unsupported because specific route next hop instance has multiple IPv6 address. | 操作不支援,因為指定的路由下一跳執行個體綁定了多個IPv6位址。 |
| 400 | IncorrectStatus.NextHop | The status of %s [%s] is incorrect. | 指定的下一跳資源處於非穩態。 |
| 400 | ResourceNotFound.RouteTargetGroup | The specified resource of %s is not found. | 指定資源%s不存在。 |
| 400 | IncorrectStatus.PrefixListRelation | The related prefix list relation is in an intermediate state and cannot perform the current operation. | 相關的前綴清單關聯關係處於中間狀態,無法執行目前操作。 |
| 400 | OperationDenied.BatchCreateRouteEntryToCen | Failed to batch create route entries to CEN. The CEN side rejected this route distribution operation. | 向 CEN 批次建立路由條目失敗,CEN 側拒絕了本次路由下發操作。 |
| 400 | IncorrectBusinessStatus.PhysicalConnection | Invalid physical connection business status. | 實體專線目前業務狀態不支援操作。 |
| 500 | VPC.ERROR | error code 500,Internal server error. | |
| 500 | InternalError | The request processing has failed due to some unknown error, exception or failure. | 請求處理由於某些未知錯誤失敗。 |
| 500 | IncorrectStatus.Ipv4Gateway | The status of Ipv4Gateway is incorrect. | IPv4Gateway 狀態處於非穩定狀態。 |
| 403 | IncorrectInstanceStatus | The current status of the resource does not support this operation. | |
| 404 | InvalidParameter | Instance not exists or not vpc vm | |
| 404 | InvalidNatGatewayId.NotFound | Specified value of NatGatewayId is not found in our record. | |
| 404 | InvalidInstanId.NotFound | Specified instance does not exist. | |
| 404 | InvalidNextHopId.NotFound | Specified next hop does not exist. | |
| 404 | InvalidRouteTableId.NotFound | Specified route table does not exist. | |
| 404 | InvalidHaVipId.NotFound | The specified HaVip does not exist in the specified VPC. | 指定的 HaVip 不在指定的地域中,請您檢查選擇的地域是否正確。 |
| 404 | InvalidNetworkInterface.NotFound | The specified networkInterface does not exist. | |
| 404 | InvalidVpc.NotFound | Specified vpc is not found in our record. | |
| 404 | InvalidIpv6Gateway.NotFound | Specified Ipv6Gateway does not exist. | |
| 404 | ResourceNotFound.GatewayLoadBalancerEndpoint | GatewayLoadBalancerEndpoint instance not found. | 未找到GatewayLoadBalancerEndpoint執行個體。 |
訪問錯誤中心查看更多錯誤碼。
變更歷史
更多資訊,參考變更詳情。