為 VPC 新增附加網段。
介面說明
-
一個 VPC 最多支援新增的附加網段個數如下:
一個 VPC 最多支援新增 5 個附加 IPv4 網段。
一個 VPC 最多支援新增 5 個附加 IPv6 網段。
-
AssociateVpcCidrBlock 介面不支援併發為同一個 VPC 新增附加網段。
調試
您可以在OpenAPI Explorer中直接運行該介面,免去您計算簽名的困擾。運行成功後,OpenAPI Explorer可以自動產生SDK程式碼範例。
調試
授權資訊
|
操作 |
存取層級 |
資源類型 |
條件關鍵字 |
關聯操作 |
|
vpc:AssociateVpcCidrBlock |
create |
*VPC
|
無 | 無 |
請求參數
|
名稱 |
類型 |
必填 |
描述 |
樣本值 |
| RegionId |
string |
是 |
需要新增附加網段的 VPC 所在地域 ID。 您可以透過呼叫 DescribeRegions 介面取得地域 ID。 |
ch-hangzhou |
| VpcId |
string |
是 |
需要新增附加網段的 VPC 的 ID。 |
vpc-o6wrloqsdqc9io3mg**** |
| SecondaryCidrBlock |
string |
否 |
需要新增的附加 IPv4 網段,網段要求如下:
設定限制如下:
說明
不透過 IPAM 位址集區為 VPC 新增附加網段時,參數 SecondaryCidrBlock 和參數 Ipv6CidrBlock 必須輸入其中一個且不能同時輸入。 |
192.168.0.0/16 |
| SecondaryCidrMask |
integer |
否 |
透過輸入遮罩的方式從 IPAM 位址集區為 VPC 新增附加 IPv4 網段。 說明
指定 IPAM 位址集區為 VPC 新增附加 IPv4 網段時,參數 SecondaryCidrBlock 或 SecondaryCidrMask 至少需輸入其中一個。 |
16 |
| IPv6CidrBlock |
string |
否 |
VPC 的指定 IPv6 網段。 說明
參數 SecondaryCidrBlock 和參數 Ipv6CidrBlock 不能同時輸入。 |
2408:XXXX:0:6a::/56 |
| Ipv6Isp |
string |
否 |
VPC 的 IPv6 位址區段類型,取值:
說明
如果是開通了單線頻寬白名單的使用者,該欄位可以設定為 ChinaTelecom(中國電信)、ChinaUnicom(中國聯通)和 ChinaMobile(中國移動)。 |
BGP |
| IpVersion |
string |
否 |
IP 位址的版本類型。取值:
|
IPV4 |
| IpamPoolId |
string |
否 |
IPAM 位址集區執行個體 ID。 |
ipam-pool-sycmt3p2a9v63i**** |
| Ipv6CidrMask |
integer |
否 |
透過輸入遮罩的方式從 IPAM 位址集區為 VPC 新增 IPv6 網段。 說明
指定 IPAM 位址集區為 VPC 新增附加 IPv6 網段時,參數 IPv6CidrBlock 或 Ipv6CidrMask 至少需輸入其中一個。 |
56 |
返回參數
|
名稱 |
類型 |
描述 |
樣本值 |
|
object |
請求 ID。 |
||
| RequestId |
string |
請求 ID。 |
C1221A1F-2ACD-4592-8F27-474E02883159 |
| CidrBlock |
string |
為 VPC 新增的附加網段。 |
192.168.0.0/16 |
| IpVersion |
string |
附加網段的 IP 位址類型。 |
IPV4 |
樣本
正常返回樣本
JSON格式
{
"RequestId": "C1221A1F-2ACD-4592-8F27-474E02883159",
"CidrBlock": "192.168.0.0/16",
"IpVersion": "IPV4"
}
錯誤碼
|
HTTP status code |
錯誤碼 |
錯誤資訊 |
描述 |
|---|---|---|---|
| 400 | InvalidVpc.NotFound | %s | |
| 400 | IncorrectStatus.Vpc | %s | |
| 400 | ParamExclusive.SecondaryCidrAndIpv6Cidr | %s | |
| 400 | OperationUnsupported.VpcMultiCidr | %s | |
| 400 | MissingParam.SecondaryCidrOrIpv6Cidr | %s | |
| 400 | OperationUnsupported.IPv6ULA | %s | |
| 400 | OperationFailed.Ipv6CidrBlockExisted | %s | |
| 400 | InvalidIpv6ULACidrBlock.Malformed | %s | |
| 400 | QuotaExceeded.GUAIpv6CidrBlock | %s | |
| 400 | IllegalParam.Ipv6CidrType | %s | |
| 400 | OperationUnsupported.OnlyULA | %s | |
| 400 | InvalidCidrBlock.Malformed | Specified CIDR block is not valid. | |
| 400 | IllegalParam.SecondaryCidrBlock | %s | |
| 400 | Duplicated.SecondaryCidrBlock | %s | |
| 400 | OperationFailed.ConflictWithEntry | %s | |
| 400 | QuotaExceeded.VpcMultiCidr | %s | |
| 400 | MissingParam.SecondaryCidrBlockOrIpv6CidrBlock | Either SecondaryCidrBlock or Ipv6CidrBlock must be specified. | 缺少必填參數附加網段或 IPv6 網段。 |
| 400 | MissingParam.VpcId | You must specify VpcId. | 缺少必填參數 VpcId。 |
| 400 | UnsupportedFeature.Ipv6Isp | The Ipv6Isp feature is not supported. | 指定的 Ipv6Isp 功能不支援。 |
| 400 | IllegalParam.IpVersion | %s | |
| 400 | OperationDenied.GUAIpv6CidrBlock | The operation is not allowed because this ipv6 CIDR is not reserved. | |
| 400 | OperationFailed.IPv6CidrNotReserved | Operation failed because this ipv6 cidr is not reserved. | |
| 400 | InvalidCidrBlock | Specified CIDR block is already exists. | |
| 400 | IllegalParam.IpamPool | The specified IPAM pool cannot be empty. | IPAM Pool 不可為空。 |
| 400 | MissingParam.SecondaryCidrMask | The parameter SecondaryCidrMask must be input. | 需要輸入 SecondaryCidrMask 參數。 |
| 400 | IllegalParam.SecondaryCidrMask | The specified Secondary CIDR Mask is illegal. | 指定的 SecondaryCidrMask 不合法。 |
| 400 | OperationDenied.RequestRegionInvalid | The operation is not allowed because the request is not invoked in the region of the IPAM pool. | 操作被拒絕,因為未在位址集區所在地域呼叫請求。 |
| 400 | OperationDenied.IpamPoolNotInRegion | The operation is not allowed because the IPAM pool not in specific region does not support creating VPC or associating CIDR for VPC. | 操作被拒絕,因為無法從不具備地域屬性的位址集區中建立 VPC 或為 VPC 新增附加網段。 |
| 400 | MissingParam.CidrOrCidrMask | The CIDR or CIDR Mask must be input. | 從 IPAM 位址集區建立資源時,請輸入 Cidr 或 CidrMask。 |
| 400 | OperationDenied.CidrInExcludeCidrs | The operation is not allowed because the input CIDR is within the illegal CIDRs. | 操作被拒絕,原因是輸入的 CIDR 位於不合法的 CIDR 範圍內。 |
| 400 | OperationDenied.AvailableCidrInsufficient | The operation is not allowed because available CIDR is insufficient. | 操作被拒絕,原因是可用的 CIDR 資源不足。 |
| 400 | UnsupportedFeature.Ipam | IPAM is not supported in this region. | |
| 400 | UnsupportedFeature.VpcIpamIpv6 | The specified IPAM pool does not support the IPv6 feature. | 指定的 IPAM 位址集區不支援 IPv6 功能。 |
| 400 | OperationDenied.CidrUnavailableInPool | The operation is not allowed because the CIDR is unavailable in the IPAM pool. | 操作被拒絕,原因是 CIDR 在 IPAM 位址池中不可用。 |
| 400 | InvalidIpv6CidrBlock.Malformed | Param Ipv6CidrBlock is malformed. | 參數 IPv6 網段不合法。 |
| 400 | MissingParam.IpVersion | The parameter IpVersion is missing. | 缺少參數 IpVersion。 |
| 400 | Mismatch.IpVersionAndIpamPoolIpVersion | The input IpVersion is inconsistent with the IpVersion of the input IPAM pool. | 輸入的 IpVersion 與輸入的位址集區 IpVersion 不一致。 |
| 400 | IllegalParam.Ipv6CidrBlock | The parameter of Ipv6CidrBlock is illegal. | IPv6 網段不合法。 |
| 400 | OperationFailed.Ipv6CidrBlockOverLapped | The input IPv6 CIDR block overlaps with the existing ones. | 輸入的 IPv6 網段與現有網段重疊。 |
| 400 | QuotaExceeded.IPv6CidrBlock | The number of IPv6 CIDR blocks in the VPC exceeds the limit. | VPC 中的 IPv6 網段數量超過限制。 |
| 400 | OperationDenied.MaskOfCidrIsNotAllowed | The input mask or mask of the input CIDR is not allowed. | 輸入的子網路遮罩或 CIDR 的子網路遮罩不在允許的範圍內。 |
| 400 | IllegalParam.Ipv6Isp | The specified Ipv6Isp is illegal. | 指定的 Ipv6Isp 參數不合法。 |
| 400 | IllegalParam.CidrMask | The input CIDR mask is illegal. | 指定的網段子網路遮罩不合法。 |
| 400 | OperationDenied.CidrMaskTooLarge | The operation is denied because the CIDR mask %s is larger than the allocationMaxNetmask %s of the pool. | 參數 Cidr 的遮罩或參數 CidrMask 超過了位址集合規規則中的最大網路遮罩長度。 |
| 500 | OperationFailed.ResourceNotEnough | Insufficient resources. | |
| 403 | Forbbiden | User not authorized to operate on the specified resource. | EIP 不屬於當前呼叫者,請您檢查該 EIP 是否可被您呼叫。 |
| 404 | ResourceNotFound.IpamPool | The dependent IPAM pool is not found. | 依賴資源 IPAM Pool 不存在。 |
訪問錯誤中心查看更多錯誤碼。
變更歷史
更多資訊,參考變更詳情。