本文主要介紹遷移在SMC遷移時,遷移任務出錯提示“S11_* 目標執行個體代理服務網路連接出錯”的問題描述、問題原因及其解決方案。
問題描述
在SMC遷移時,遷移任務出錯提示“S11_* 目標執行個體代理服務網路連接出錯”,其中S11_*可能的錯誤碼如下:
S11_U28
S11_U7
S11_U56
S11_U6
問題原因
源系統SMC用戶端進行目標執行個體代理服務網路連接時出錯,可能原因如下:
目標執行個體指中轉執行個體或目標執行個體,您可以在遷移任務詳情頁找到遷移中轉執行個體ID或目標執行個體ID。
目標執行個體的代理服務(8080連接埠)異常。
原始伺服器到目標執行個體的IP:8080連接埠網路訪問不通。
解決方案
檢查目標執行個體的代理服務是否正常。
登入ECS管理主控台。
在左側導覽列,選擇。
在頂部功能表列處,選擇目標ECS執行個體所在地區。

確認目標執行個體是否為正常啟動並執行狀態。
如果執行個體為運行中,則直接執行步驟e。
如果執行個體已釋放,則需重建遷移任務。具體操作,請參見步驟二:建立並啟動遷移任務。
單擊目標執行個體的執行個體ID,單擊定時與自動化任務頁簽,單擊發送命令。
Windows系統:在命令內容中輸入
netstat -ano | findstr 8080,單擊立即執行。Linux系統:在命令內容中輸入
netstat -ano | grep 8080,單擊立即執行。
如果執行成功並有8080相關內容輸出,則表示目標執行個體內代理服務正常。
檢查目標執行個體的安全性群組的入方向是否已放開8080連接埠,或者是否有其他安全性群組規則衝突限制。
說明預設情況下SMC遷移任務會自動給目標執行個體關聯一個臨時安全性群組,在目標執行個體的入方向放開8080連接埠。
使用除了原始伺服器之外的其他伺服器,訪問
http://<目標執行個體IP>:8080測試是否正常。Linux系統:
curl http://<目標執行個體IP>:8080。Windows系統:使用瀏覽器訪問
http://<目標執行個體IP>:8080。
如果返回正常的JSON格式內容如
{"code":-101,"message":"smc p2vs get ok."},則表示正常。說明預設情況下使用目標執行個體的公網IP,如果選擇了私網模式,則使用目標執行個體的私網IP。
檢查源系統網路服務是否正常。
檢查系統本網服務是否正常,檢查hosts、DNS等配置是否正常。
遷移任務預設使用公網模式傳輸,需要確保源系統可訪問公網。
如果遷移任務選擇了私網模式傳輸,則需要確保源系統到目標VPC/交換器的私網已打通。具體操作,請參見私網傳輸遷移。
說明如果不清楚是否打通私網,一般情況下建議選擇公網模式傳輸,如果錯選了私網模式可重新選擇公網模式後再試。
檢測源系統到目標執行個體的網路訪問是否正常。
放開目標執行個體的安全性群組的入方向ICMP協議,使用ping命令測試原始伺服器到目標執行個體的網路是否正常。
如果不通,則需要排查本網配置或中間網路裝置,如防火牆或代理的出方向是否有IP訪問限制。
訪問
http://<目標執行個體IP>:8080,測試原始伺服器到目標執行個體8080連接埠是否連通。Linux系統:
curl http://<目標執行個體IP>:8080。Windows系統:使用瀏覽器訪問
http://<目標執行個體IP>:8080。
如果返回正常的JSON格式內容如
{"code":-101,"message":"smc p2vs get ok."}則表示已通,否則表示不通,需要排查本網配置或中間網路裝置,如防火牆或代理的出方向是否有IP或者連接埠訪問限制。檢查是否開啟了阿里雲Cloud Firewall,是否配置了存取控制策略導致網路訪問被攔截。例如互連網邊界防火牆、VPC邊界防火牆等。具體操作,請參見防火牆開關。
問題排查解決後,運行SMC用戶端再試。具體操作,請參見運行SMC用戶端。