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Identity as a Service:IDaas 同步刪除RAM帳號失敗

更新時間:Apr 23, 2025

問題現象

在阿里雲IDaaS(EIAM)中刪除了某個使用者,並且已開啟帳號同步功能,但對應的RAM帳號未能同步刪除。

可能原因

  1. RAM帳號處於特殊狀態(如綁定MFA、配置AccessKey或加入使用者組)。

  2. 同步範圍設定不正確(檢查刪除的使用者組織和設定的同步範圍中的組織是否相同。如果組織不同,不會觸發同步刪除操作)。

  3. 參數配置錯誤導致同步請求異常。

注意事項

  1. 備份重要訊息:在刪除RAM帳號前,請確保該帳號下沒有關聯的重要資源或許可權配置。

  2. 影響評估:刪除RAM帳號後,該帳號及其扮演的角色將被強制退出登入狀態,且無法自動回復。

  3. 許可權管理:確保執行上述操作的管理員具備足夠的許可權,例如AliyunRAMFullAccess

解決方案

由於 IDaaS 無法自動同步刪除處於特殊狀態的 RAM 帳號,建議採取以下手動操作:

步驟一:移除RAM帳號的特殊狀態

  1. 移除使用者組

    1. 登入阿里雲RAM控制台

    2. 在左側導覽列選擇身份管理 > 使用者

    3. 找到目標RAM帳號,點擊其名稱進入詳情頁面。

    4. 在使用者組地區,將該帳號從所有使用者組中移除。

  2. 解除綁定MFA裝置(如果存在):

    1. 在RAM控制台中,進入目標RAM帳號的詳情頁面。

    2. 在 身份管理 > 使用者 > 認證管理下的安全資訊管理地區,解除綁定 MFA 裝置。詳情請參見:為RAM使用者解除綁定MFA裝置

  3. 刪除 AccessKey(如果存在):

    1. 在目標RAM帳號的詳情頁面,進入AccessKey管理地區。

    2. 刪除所有已配置的AccessKey。

步驟二:手動刪除RAM帳號

  1. 登入RAM控制台。

  2. 在左側導覽列選擇身份管理 > 使用者

  3. 找到目標RAM帳號,在操作列中單擊刪除

  4. 根據提示完成刪除操作。