全部產品
Search
文件中心

Enterprise Distributed Application Service:端雲互聯問題

更新時間:Jun 30, 2024

本文介紹如何快速解決使用端雲互聯時,可能遇到的拒絕請求問題。

說明

Cloud Toolkit 2020.9.1及以上版本中,增加端雲互聯一鍵診斷功能,可以提供診斷結果,協助您排查etrans通道啟動異常、服務串連不通以及其它可能出現的問題。請您及時升級Cloud Toolkit。

問題描述

當您使用端雲互聯時,註冊中心拒絕請求,並收到以下錯誤資訊:

code:403,msg: access denied

問題原因

由於註冊中心通過時間戳記保證服務註冊的安全性,如果本地的系統時間不準確會導致雲端註冊中心拒絕請求。

解決方案

請校準系統時間並進行重試。

本地應用能否與雲端組件互聯?

可以,請將Cloud Toolkit升級到2020.9.1及以上版本。升級完成後,本地應用內的所有請求均能通過跳板機轉寄到雲端的Spring Cloud Gateway、資料庫、Redis和訊息等組件。