本介面用於停止一台ECS執行個體,支援選擇不同的停機方式、停機模式以及批次操作模式停止執行個體。
介面說明
該介面為非同步介面,執行個體的停止不是立即完成的,成功呼叫後,執行個體會先進入停止中(Stoping)狀態,您可以呼叫 DescribeInstanceStatus 查看執行個體狀態,當返回的狀態為Stopped 時代表停止成功。
使用須知
被安全性鎖定的執行個體不能透過呼叫該介面停止。更多資訊,請參見資源安全性鎖定對呼叫 API 的影響。
開啟 VPC 內執行個體節省停機模式後,您可以透過設定
StoppedMode=KeepCharging開啟普通停機模式,ECS 執行個體停止後會繼續計費,並為您保留 ECS 執行個體規格庫存和公網 IP 位址。
調試
您可以在OpenAPI Explorer中直接運行該介面,免去您計算簽名的困擾。運行成功後,OpenAPI Explorer可以自動產生SDK程式碼範例。
調試
授權資訊
|
操作 |
存取層級 |
資源類型 |
條件關鍵字 |
關聯操作 |
|
ecs:StopInstance |
update |
*Instance
|
無 | 無 |
請求參數
|
名稱 |
類型 |
必填 |
描述 |
樣本值 |
| InstanceId |
string |
是 |
指定的執行個體 ID。 |
i-bp67acfmxazb4ph**** |
| ConfirmStop |
boolean |
否 |
該參數即將被棄用,為提高相容性暫作保留。您在呼叫該介面時請忽略該參數。 |
true |
| ForceStop |
boolean |
否 |
停止執行個體時的是否強制關機策略。取值範圍:
預設值為 false。 |
false |
| StoppedMode |
string |
否 |
停止按量付費 ECS 執行個體時,設定的停機模式。取值:
預設值:如果您在 ECS 控制台上開啟 VPC 內執行個體節省停機模式(更多資訊,請參見開啟預設啟用節省停機模式),並符合開啟條件,則預設值為 |
KeepCharging |
| DryRun |
boolean |
否 |
是否只預檢此次請求。取值範圍:
預設值為 false。 |
true |
| Hibernate |
boolean |
否 |
說明
該參數正在邀測中,暫不支援使用。 |
hide |
返回參數
|
名稱 |
類型 |
描述 |
樣本值 |
|
object |
|||
| RequestId |
string |
請求 ID。 |
1C488B66-B819-4D14-8711-C4EAAA13AC01 |
樣本
正常返回樣本
JSON格式
{
"RequestId": "1C488B66-B819-4D14-8711-C4EAAA13AC01"
}
錯誤碼
|
HTTP status code |
錯誤碼 |
錯誤資訊 |
描述 |
|---|---|---|---|
| 400 | InvalidParameter.Encrypted.KmsNotEnable | The operation failed because KMS is not activated. Please activate KMS in the KMS console and try again. | |
| 400 | DiskError | IncorrectDiskStatus. | 指定的磁碟狀態不合法。 |
| 500 | InternalError | The request processing has failed due to some unknown error. | |
| 403 | IncorrectInstanceStatus | The current status of the resource does not support this operation. | |
| 403 | InstanceLockedForSecurity | The specified operation is denied as your instance is locked for security reasons. | 磁碟掛載的執行個體因安全原因被鎖定。 |
| 403 | InstanceType.ParameterMismatch | The input parameter ConfirmStop must be true when an instance have localstorage. | 當執行個體使用本機儲存時,輸入參數 ConfirmStop 必須為 true。 |
| 403 | InstanceExpiredOrInArrears | The specified operation is denied as your prepay instance is expired (prepay mode) or in arrears (afterpay mode). | |
| 403 | InvalidInstanceId.NotSupport | Classic network Instance does not support this operation. | 搶占式執行個體不支援此操作。 |
| 403 | InvalidParameter.KMSKeyId.CMKUnauthorized | The CMK needs to be added ECS tag | |
| 403 | InvalidParameter.KMSKeyId.CMKNotEnabled | The CMK needs to be enabled. | |
| 403 | InvalidParameter.KMSKeyId.KMSUnauthorized | The ECS service is not authorized to access your KMS key. Please grant the ECS service permission to use the key and try again. | |
| 403 | HibernationConfigured.InstanceOperationForbidden | The operation is not permitted due to limit of the hibernation configured instance. | 不符合開啟休眠選項的執行個體的相關限制,操作不被允許。 |
| 403 | HibernationConfigured.NotEnabled | The instance hibernation configured option is not enabled. | |
| 403 | InvalidOperation.KMSKeyIdNotFound | The specified KMSKeyId does not exist. Please verify that the key ID is correct and that the key resides in the current region. | |
| 403 | InvalidOperation.KMSServiceNotOpen | KMS service is currently not open. | KMS 服務尚未啟用。 |
| 403 | OperationDenied.SystemInstanceNotSupport | The system instance does not support the %s operation because %s. | |
| 404 | InvalidInstanceId.NotFound | The specified InstanceId does not exist. | 指定的執行個體不存在,請您檢查執行個體 ID 是否正確。 |
| 503 | LimitedOperation.ServiceUnavailable | The service is currently unavailable. Please try again later. | 目前服務不可用。請稍後重試。 |
訪問錯誤中心查看更多錯誤碼。
變更歷史
更多資訊,參考變更詳情。