全部產品
Search
文件中心

Elastic Compute Service:StopInstance

更新時間:Sep 14, 2026

本介面用於停止一台ECS執行個體,支援選擇不同的停機方式、停機模式以及批次操作模式停止執行個體。

介面說明

該介面為非同步介面,執行個體的停止不是立即完成的,成功呼叫後,執行個體會先進入停止中(Stoping)狀態,您可以呼叫 DescribeInstanceStatus 查看執行個體狀態,當返回的狀態為Stopped 時代表停止成功。

使用須知

  • 被安全性鎖定的執行個體不能透過呼叫該介面停止。更多資訊,請參見資源安全性鎖定對呼叫 API 的影響。

  • 開啟 VPC 內執行個體節省停機模式後,您可以透過設定StoppedMode=KeepCharging開啟普通停機模式,ECS 執行個體停止後會繼續計費,並為您保留 ECS 執行個體規格庫存和公網 IP 位址。

調試

您可以在OpenAPI Explorer中直接運行該介面,免去您計算簽名的困擾。運行成功後,OpenAPI Explorer可以自動產生SDK程式碼範例。

調試

授權資訊

下表是API對應的授權資訊,可以在RAM權限原則語句的Action元素中使用,用來給RAM使用者或RAM角色授予調用此API的許可權。具體說明如下:

  • 操作:是指具體的許可權點。

  • 存取層級:是指每個操作的存取層級,取值為寫入(Write)、讀取(Read)或列出(List)。

  • 資源類型:是指操作中支援授權的資源類型。具體說明如下:

    • 對於必選的資源類型,用前面加 * 表示。

    • 對於不支援資源級授權的操作,用全部資源表示。

  • 條件關鍵字:是指雲產品自身定義的條件關鍵字。

  • 關聯操作:是指成功執行操作所需要的其他許可權。操作者必須同時具備關聯操作的許可權,操作才能成功。

操作

存取層級

資源類型

條件關鍵字

關聯操作

ecs:StopInstance

update

*Instance

acs:ecs:{#regionId}:{#accountId}:instance/{#instanceId}

無 無

請求參數

名稱

類型

必填

描述

樣本值

InstanceId

string

是

指定的執行個體 ID。

i-bp67acfmxazb4ph****

ConfirmStop

boolean

否

該參數即將被棄用,為提高相容性暫作保留。您在呼叫該介面時請忽略該參數。

true

ForceStop

boolean

否

停止執行個體時的是否強制關機策略。取值範圍:

  • true:強制關機。相當於典型的斷電操作,所有未寫入儲存裝置的快取資料會遺失。

  • false:正常關機流程。

預設值為 false。

false

StoppedMode

string

否

停止按量付費 ECS 執行個體時,設定的停機模式。取值:

  • StopCharging:節省停機模式。開啟節省停機模式後:

    • 運算資源(vCPU、記憶體、GPU)、映像 License 費用、固定公網 IP 的固定頻寬模式暫停計費。

    • 系統磁碟、資料磁碟、彈性公網 IP 的固定頻寬模式持續計費。

    • 由於運算資源被回收,啟動時可能因庫存不足導致啟動失敗,請您稍後再試或更換執行個體規格。

    • 如果執行個體停止前綁定了彈性公網 IP 位址,重新啟動後 IP 位址不變;否則,固定公網 IP 位址可能會變,但私網 IP 位址不會變。

    更多資訊,請參見節省停機模式。

    重要 如執行個體自身不支援節省停機模式,API 端不會進行錯誤攔截,優先保證執行個體停機。不支援節省停機的執行個體類型:本機磁碟執行個體、包年包月執行個體等。

  • KeepCharging:普通停機模式。執行個體停止後仍繼續收費。

預設值:如果您在 ECS 控制台上開啟 VPC 內執行個體節省停機模式(更多資訊,請參見開啟預設啟用節省停機模式),並符合開啟條件,則預設值為StopCharging。否則,預設值為KeepCharging。

KeepCharging

DryRun

boolean

否

是否只預檢此次請求。取值範圍:

  • true:傳送檢查請求,不會停止執行個體。檢查項目包括是否填寫了必選參數、請求格式、業務限制和 ECS 庫存。如果檢查不通過,則返回對應錯誤。如果檢查通過,則返回錯誤碼DryRunOperation。

  • false:傳送正常請求,通過檢查後直接停止執行個體。

預設值為 false。

true

Hibernate

boolean

否

說明

該參數正在邀測中,暫不支援使用。

hide

返回參數

名稱

類型

描述

樣本值

object

RequestId

string

請求 ID。

1C488B66-B819-4D14-8711-C4EAAA13AC01

樣本

正常返回樣本

JSON格式

{
  "RequestId": "1C488B66-B819-4D14-8711-C4EAAA13AC01"
}

錯誤碼

HTTP status code

錯誤碼

錯誤資訊

描述

400 InvalidParameter.Encrypted.KmsNotEnable The operation failed because KMS is not activated. Please activate KMS in the KMS console and try again.
400 DiskError IncorrectDiskStatus. 指定的磁碟狀態不合法。
500 InternalError The request processing has failed due to some unknown error.
403 IncorrectInstanceStatus The current status of the resource does not support this operation.
403 InstanceLockedForSecurity The specified operation is denied as your instance is locked for security reasons. 磁碟掛載的執行個體因安全原因被鎖定。
403 InstanceType.ParameterMismatch The input parameter ConfirmStop must be true when an instance have localstorage. 當執行個體使用本機儲存時,輸入參數 ConfirmStop 必須為 true。
403 InstanceExpiredOrInArrears The specified operation is denied as your prepay instance is expired (prepay mode) or in arrears (afterpay mode).
403 InvalidInstanceId.NotSupport Classic network Instance does not support this operation. 搶占式執行個體不支援此操作。
403 InvalidParameter.KMSKeyId.CMKUnauthorized The CMK needs to be added ECS tag
403 InvalidParameter.KMSKeyId.CMKNotEnabled The CMK needs to be enabled.
403 InvalidParameter.KMSKeyId.KMSUnauthorized The ECS service is not authorized to access your KMS key. Please grant the ECS service permission to use the key and try again.
403 HibernationConfigured.InstanceOperationForbidden The operation is not permitted due to limit of the hibernation configured instance. 不符合開啟休眠選項的執行個體的相關限制,操作不被允許。
403 HibernationConfigured.NotEnabled The instance hibernation configured option is not enabled.
403 InvalidOperation.KMSKeyIdNotFound The specified KMSKeyId does not exist. Please verify that the key ID is correct and that the key resides in the current region.
403 InvalidOperation.KMSServiceNotOpen KMS service is currently not open. KMS 服務尚未啟用。
403 OperationDenied.SystemInstanceNotSupport The system instance does not support the %s operation because %s.
404 InvalidInstanceId.NotFound The specified InstanceId does not exist. 指定的執行個體不存在,請您檢查執行個體 ID 是否正確。
503 LimitedOperation.ServiceUnavailable The service is currently unavailable. Please try again later. 目前服務不可用。請稍後重試。

訪問錯誤中心查看更多錯誤碼。

變更歷史

更多資訊,參考變更詳情。