全部產品
Search
文件中心

Elastic Compute Service:ModifyInstanceVpcAttribute

更新時間:Sep 07, 2026

修改一台專有網路類型ECS執行個體的專有網路VPC、私網IP位址、安全性群組或交換器。

介面說明

呼叫介面時,ECS 執行個體的狀態必須是已停止(Stopped)。

  • 修改執行個體的私網 IP 位址或交換器時,請注意:

    • 新建的 ECS 執行個體必須經過重新啟動才能呼叫該介面。

    • 成功修改一次後,ECS 執行個體必須經過重新啟動才能繼續呼叫該介面進行修改。

  • 修改執行個體的專有網路 VPC 時,請注意:

    • 執行個體:

      • 執行個體狀態:不能為已鎖定、等待釋放、已過期、過期回收中、欠費回收中。更多資訊,請參見執行個體生命週期介紹。

      • 不支援已關聯負載平衡執行個體的 ECS 執行個體。

      • 執行個體不能在其它雲端服務中被使用。例如,執行個體不能在遷移中、不能已在更換 VPC 或執行個體內部署的資料庫不能被 DTS 服務管理等。

    • 網路:

      • 不支援配置了 EIP 網卡可見模式或多 EIP 網卡可見模式的執行個體。

      • 不支援綁定了高可用虛擬 IP(HaVip)的執行個體。

      • 不支援交換器綁定了自訂路由表的執行個體。

      • 不支援開通了全球加速(GA)的執行個體。

      • 不支援綁定輔助彈性網卡的執行個體。

      • 不支援已分配 IPv6 位址的執行個體。

      • 不支援主網卡有多 IP 的執行個體。

      • 傳入的交換器必須屬於目標 VPC。

      • 修改前後交換器可用區必須一致。

      • 如果指定主網卡私網 IP,則 IP 必須在交換器位址段內且可用。如果不指定則隨機分配,且目標交換器的可用 IP 數充足。

      • 如果您使用的是其他帳號共享給您的 VPC,那麼您需要確保目標安全性群組是由您的帳號在該共享 VPC 中建立的,而不是由 VPC 所有者的帳號建立的安全性群組。

調試

您可以在OpenAPI Explorer中直接運行該介面,免去您計算簽名的困擾。運行成功後,OpenAPI Explorer可以自動產生SDK程式碼範例。

調試

授權資訊

下表是API對應的授權資訊,可以在RAM權限原則語句的Action元素中使用,用來給RAM使用者或RAM角色授予調用此API的許可權。具體說明如下:

  • 操作:是指具體的許可權點。

  • 存取層級:是指每個操作的存取層級,取值為寫入(Write)、讀取(Read)或列出(List)。

  • 資源類型:是指操作中支援授權的資源類型。具體說明如下:

    • 對於必選的資源類型,用前面加 * 表示。

    • 對於不支援資源級授權的操作,用全部資源表示。

  • 條件關鍵字:是指雲產品自身定義的條件關鍵字。

  • 關聯操作:是指成功執行操作所需要的其他許可權。操作者必須同時具備關聯操作的許可權,操作才能成功。

操作

存取層級

資源類型

條件關鍵字

關聯操作

ecs:ModifyInstanceVpcAttribute

update

*Instance

acs:ecs:{#regionId}:{#accountId}:instance/{#instanceId}

*VSwitch

acs:vpc:{#regionId}:{#accountId}:vswitch/{#vswitchId}

  • vpc:tag
  • vpc:VPC
無

請求參數

名稱

類型

必填

描述

樣本值

InstanceId

string

是

執行個體 ID。

說明

呼叫該介面時,ECS 執行個體的狀態必須是已停止(Stopped),其他對於執行個體的限制條件,請認真閱讀介面說明部分。

i-bp1iudwa5b1tqag1****

VSwitchId

string

是

交換器 ID。

  • 傳入的 ID 為執行個體的目前交換器時,表明執行個體不變更交換器。

  • 傳入的 ID 為一台新的交換器,並且參數VpcId為空時,新舊交換器必須屬於同一個可用區、同一個專有網路 VPC。

  • 當參數VpcId不為空時,該參數傳入的交換器 ID 必須屬於 VpcId,並且和原交換器屬於同一個可用區。

vsw-bp1s5fnvk4gn3tw12****

PrivateIpAddress

string

否

新的私網 IP 位址。

說明

參數PrivateIpAddress依賴於VSwitchId,指定的 IP 位址必須在虛擬交換器子網路網段中。

預設值:當不傳該值時,從虛擬交換器子網路網段中隨機分配。

172.17.**.**

VpcId

string

否

目標 VPC ID。

vpc-bp1vwnn14rqpyiczj****

SecurityGroupId

array

否

執行個體修改 VPC 後加入的安全性群組 ID 清單。當且僅當傳入VpcId參數時,需要同時傳入該參數。

  • 安全性群組所屬的 VPC 必須與目標 VPC 一致。

  • 指定修改後執行個體加入的安全性群組清單,可以是一個或者多個。安全性群組個數與執行個體能夠加入安全性群組的限制有關。具體限制,請參見使用限制。

  • 清單內安全性群組類型必須一致。

  • 支援切換安全性群組的類型。 當 ECS 執行個體跨類型切換安全性群組時,您需要充分了解兩種安全性群組規則的配置區別,避免影響執行個體網路。更多資訊,請參見安全性群組概述。

sg-o6w9l8bc8dgmkw87****

string

否

安全性群組 ID。

sg-o6w9l8bc8dgmkw87****

返回參數

名稱

類型

描述

樣本值

object

RequestId

string

請求 ID。

473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E

樣本

正常返回樣本

JSON格式

{
  "RequestId": "473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E"
}

錯誤碼

HTTP status code

錯誤碼

錯誤資訊

描述

400 InvalidTarget.TrafficMirrorSession Instance is target of traffic mirror session.
400 InvalidSource.TrafficMirrorSession Instance is source of traffic mirror session.
400 InvalidPrivateIpAddress.Malformed Specified private IP address is malformed. 指定的 PrivateIpAddress 不合法。
400 InvalidPrivateIpAddress.Duplicated Specified private IP address is duplicated.
400 IncorrectVSwitchStatus The current status of virtual switch does not support this operation. 指定的虛擬交換器處於 pending 狀態,無法刪除。
400 IncorrectInstanceStatus The current status of instance does not support this operation. 目前執行個體狀態不支援此類操作。
400 OperationDenied Specified operation is denied as your instance is not in VPC. 指定的快照不允許建立資料磁碟。
400 InvalidVSwitchId.Mismatch Specified instance and virtual switch are not in the same zone. 指定的執行個體和指定的虛擬交換器不屬於同一個可用區。
400 InvalidPrivateIpAddress.Mismatch Specified private IP address is not in the CIDR block of virtual switch. 指定的私網 IP 不在指定虛擬交換器的網段中。
400 InvalidPrivateIp.Changing Previous action is not finished yet. 執行個體修改私網 IP 未完成,不能再進行修改。
400 PrimaryEniHasSubIp Primary network interface of the specified instance has more than one private ip. 操作被拒絕,不支援主網卡有多 IP 的執行個體。
400 VSwitchIdNotMatch The subnet of private ip is different to the instance, please unbind ha vip. 虛擬交換器位址區段不包含指定的 IP,請檢查。
400 InvalidOperation.EniCountExceeded The number of ENIs in an enterprise security group has reached the maximum limit.
400 InvalidParameter.SecurityGroupId Security group ids are invalid. 安全性群組 ID 無效。
400 InvalidVSwitch.IllegalStatus The operation is not allowed in the current VSwitch state. Expecting state includes "Created", but current state is "%s". 目前交換器狀態不支援該操作。
400 QuotaExceeded.PrivateIpAddress There are not enough private IPs in the specified VSwitch. 虛擬交換器下的私有 IP 已經被使用完,請您使用其他的虛擬交換器。
401 InvalidOperation.SecurityGroupNotAuthorized The specified security group is not authorized to operate. 沒有權限操作目前安全性群組。
500 InternalError The request processing has failed due to some unknown error.
403 OperationDenied The Specified operation is denied as your instance is locked for security reasons.
403 InvalidIp.Ipv6Assigned The specified instance has been assigned IPv6 address.
403 SecurityGroupInstanceLimitExceed %s 安全性群組的執行個體數已達上限。
403 InvalidInstance.HasTransitionRecord The operation is denied because the specified instance has a migration plan.
403 InvalidInstanceStatus.NotNormal The Specified operation is denied due to instance status.
403 InvalidVpcId.SharedVpc The Specified operation is denied as your targe vpc is SharedVpc.
403 InvalidOperation.NotAllowed The operation is denied because the specified VPC has advanced features enabled.
403 InvalidParameter.ToSecurityGroupId %s
403 InvalidOperation.ResourceManagedByCloudProduct %s 雲端產品託管的安全性群組不支援修改操作。
403 InvalidOperation.VswAndEcsAvailabilityZoneMismatch Specified instance and virtual switch are not in the same zone. 執行個體和目標交換器不屬於同一個可用區。
403 InvalidOperation.CloudBoxEcsNotSupport Cloud box ecs instance does not support modifying VPC. CloudBox 執行個體不支援修改 VPC。
403 AclLimitExceed %s 網路卡或執行個體的安全性群組規則數量超過限額值。
404 InvalidInstanceId.NotFound The specified InstanceId does not exist. 指定的執行個體不存在,請您檢查執行個體 ID 是否正確。
404 InvalidVSwitchId.NotFound Specified virtual switch does not exist. 指定的虛擬交換器 ID 不存在。
404 NoSuchResource The specified resource is not found. 指定的資源不存在。
404 InvalidParameter.InvalidInstanceId The specified InstanceId does not exist.
404 InvalidParameter.VSwitchId The specified virtual vswitch does not exist. 指定的 VSwitchId 不存在。您可以呼叫 DescribeVSwitches 查詢已建立的交換器資訊。
404 InvalidRegion.ValueNotSupported The specified Region does not exist.
404 InvalidInstance.AttachedEni The Specified operation is denied due to elastic network interface. 指定執行個體的 ENI 狀態不支援修改操作。您必須了解該介面的注意事項,更多資訊請參見 ModifyInstanceVpcAttribute 介面文件。
404 InvalidIp.MultiPrimaryIp The Specified operation is denied due to multi private ip. 指定執行個體有多個私網 IP,不支援修改操作。您必須了解該介面的注意事項,更多資訊請參見 ModifyInstanceVpcAttribute 介面文件。
404 InvalidIp.Ipv6 The Specified operation is denied due to ipv6.
404 InvalidVSwitch.NotBelongToVpc %s 指定的 VSwitchId 不屬於指定的 VPC。請檢查參數值是否正確。
404 InvalidParameter.EniNo %s
404 InvalidSecurityGroupId.NotFound %s 指定的安全性群組在該使用者帳號下不存在,請您檢查安全性群組 id 是否正確。
404 InvalidParameter.SecurityGroupIdRepeated %s
404 InvalidSecurityGroupType.NotSupportClassic The specified SecurityGroupIds have classic group type. 指定的安全性群組的網路類型為傳統網路。請檢查 SecurityGroupIds 參數值是否正確。
404 InvalidSecurityGroupVpc.NotBelongToOneVpc The specified SecurityGroupIds are belong to different vpc. 指定的安全性群組 ID 屬於不同的 VPC。請檢查 SecurityGroupIds 參數值是否正確。您可以呼叫 DescribeSecurityGroups 查詢指定安全性群組所屬的 VPC。
404 EnterpriseGroupLimited.MutliGroupType The specified instance can not join multi SecurityGroup types.
404 InvalidParameter.AlreadyInTargetVpc The specified instance is already in the destination VPC.
404 InvalidParameter.SecurityGroupId The specified SecurityGroupId.N is invalid or does not exist.
404 JoinedGroupLimitExceed The specified instance has exceed quota of SecurityGroup.
404 InvalidParameter.MustBeEmpty The specified parameter SecurityGroupId.N and VpcId need be empty. 指定的 SecurityGroupId.N 和 VpcId 參數必須為空。當您只需要修改交換器時,不需要指定 SecurityGroupId.N 和 VpcId 參數。
404 InvalidParameter.NotEnoughIpInVSwitch The specified virtual switch has not enough available ip.
404 InvalidDependence.MutliDirectlyEip The Specified operation is denied due to multi directly Eips.
404 InvalidDependence.HaVip The Specified operation is denied due to HaVip.
404 InvalidDependence.NextHopOfCustomRouter The Specified operation is denied due to next hop of Custom Router. 目前存在自訂路由指向該執行個體,暫不支援修改 VPC。
404 InvalidDependence.BeenUsedAsAppServer The Specified operation is denied due to AppServer.
404 InvalidDependence.GrantAccess The Specified operation is denied due to grant access. 當前執行個體存在反向存取規則,暫不支援修改 VPC。
404 InvalidDependence.BindGA The Specified operation is denied due to GA.
404 InvalidDependence.SLB The Specified operation is denied as your instance with alb or clb. 操作被拒絕,不支援已關聯負載平衡執行個體的 ECS 執行個體。

訪問錯誤中心查看更多錯誤碼。

變更歷史

更多資訊,參考變更詳情。