建立一個協定服務匯出目錄。
介面說明
-
該介面僅適用於 CPFS 檔案系統。
-
前提條件
目標 CPFS 檔案系統必須處於 Running 狀態,已建立協定服務。
-
其他
協定服務的匯出 VPC 網段不可與檔案系統 VPC 網段重疊。
一個協定服務上的多個匯出 VPC 之間網段不可重疊。
同一個協定服務最多可以建立 10 個匯出目錄。
建立協定服務匯出目錄會消耗指定 vSwitch 上的 IP 位址(最多消耗 32 個 IP 位址),請確保目標 vSwitch IP 資源充足。
調試
您可以在OpenAPI Explorer中直接運行該介面,免去您計算簽名的困擾。運行成功後,OpenAPI Explorer可以自動產生SDK程式碼範例。
調試
授權資訊
請求參數
|
名稱 |
類型 |
必填 |
描述 |
樣本值 |
| ProtocolServiceId |
string |
是 |
協定服務 ID。 |
ptc-197ed6a00f2b**** |
| FileSystemId |
string |
是 |
檔案系統 ID。 說明
目標 CPFS 檔案系統必須處於 Running 狀態才可呼叫本介面,建立後約需 20-40 分鐘達到 Running 狀態,可透過 DescribeFileSystems 輪詢 Status 欄位(Running 為就緒)。 |
cpfs-099394bd928c**** |
| VpcId |
string |
否 |
協定服務匯出的專有網路 ID。 說明
所選 VPC 的 CIDR 不可與目標 CPFS 檔案系統的 VPC CIDR 重疊。可透過 VPC 產品的 DescribeVpcs API 查詢各 VPC 的 CidrBlock 欄位進行比較,選擇不衝突且與檔案系統同可用區的 VPC。 |
vpc-2vct297b8157bth9z**** |
| VSwitchId |
string |
否 |
協定服務匯出的交換器 ID。 當檔案系統的儲存冗餘類型不為 同城冗餘(ZRS)時,若設定了 VpcId,則該欄位必填。 說明
該 VSwitch 必須與目標 CPFS 檔案系統處於同一可用區(ZoneId 一致)。可透過 DescribeFileSystems 查詢檔案系統的 ZoneId 欄位,再選擇相同可用區的 VSwitch。 |
vsw-2vc3c2lybvdllxyq4**** |
| FsetId |
string |
否 |
需匯出的 Fileset ID。 限制:
|
fset-1902718ea0ae**** |
| Path |
string |
否 |
需匯出的 CPFS 目錄的路徑。 限制:
格式:
|
/ |
| AccessGroupName |
string |
否 |
權限群組名稱。 預設值:DEFAULT_VPC_GROUP_NAME |
DEFAULT_VPC_GROUP_NAME |
| Description |
string |
否 |
協定服務匯出目錄的描述。控制台中顯示為匯出目錄名稱。 限制:
|
此匯出目錄的描述 |
| ClientToken |
string |
否 |
保證請求冪等性,從您的用戶端生成一個參數值,確保不同的請求間該參數值唯一。 ClientToken 只支援 ASCII 字元,且不能超過 64 個字元。更多資訊,請參見如何保證冪等性。 說明
若使用者未指定,則系統自動使用 API 請求的 RequestId 作為 ClientToken 標識。每次 API 請求的 RequestId 可能不一樣。 |
473469C7-AA6F-4DC5-B3DB-A3DC0DE3**** |
| DryRun |
boolean |
否 |
是否對此次建立請求執行預檢。 預檢操作會協助您檢查參數有效性、依賴條件等,並不會實際建立執行個體,也不會產生費用。 取值:
|
true |
| VSwitchIds |
array |
否 |
協定服務匯出的交換器 ID 清單。 |
|
|
string |
否 |
協定服務匯出的交換器 ID 清單。 當檔案系統的儲存冗餘類型為 同城冗餘(ZRS)時,若設定了 VpcId,則該欄位必須設定 Vpc 下三個不同可用區的交換器 ID。 |
vsw-123xxx |
返回參數
|
名稱 |
類型 |
描述 |
樣本值 |
|
object |
Schema of Response |
||
| RequestId |
string |
請求 ID。 |
473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E |
| ExportId |
string |
協定服務匯出目錄 ID。 |
exp-19abf5beab8d**** |
樣本
正常返回樣本
JSON格式
{
"RequestId": "473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E",
"ExportId": "exp-19abf5beab8d****"
}
錯誤碼
|
HTTP status code |
錯誤碼 |
錯誤資訊 |
描述 |
|---|---|---|---|
| 400 | MissingFileSystemId | FileSystemId is mandatory for this action. | 未指定 FileSystemId 參數。 |
| 400 | MissingProtocolServiceId | ProtocolServiceId is mandatory for this action. | 未指定 ProtocolServiceId 參數。 |
| 403 | Instance.IncorrectStatus | The specified instance is in an incorrect status. | 目前狀態不允許操作。 |
| 403 | InvalidVSwitchId.IpShortage | The specified vswitch ip shortage. | |
| 403 | InvalidFset.InUse | Fset already used by other export. | 指定的 Fileset 已被使用。 |
| 403 | MntPathConflict.InvalidParam | FilesetId and Path must and can only be specified one. | Fileset 和 Path 只能且必須指定一個。 |
| 403 | OperationDenied.TooManyDepth | The operation is denied due to Fsets path too deep. | 智慧目錄路徑深度超過閾值。 |
| 403 | OperationDenied.InvalidPtcStatus | The operation is denied due to invalid protocol service status. | 目前協定服務狀態不支援此操作。 |
| 403 | OperationDenied.InvalidState | The operation is denied due to invalid file system state. | |
| 403 | OperationDenied.CrossVPCExceedLimit | Cross vpc mount exceed limit. | 跨 VPC 匯出目錄數量超過目前通訊協定服務規格上限。 |
| 403 | OperationDenied.NoMountTargetQuota | No mount target quota on this protocol service. | 協定服務的匯出目錄配額已耗盡。 |
| 403 | OperationDenied.NotSupported | The operation is denied due to not supported. | 檔案系統不支援協定機服務。 |
| 404 | InvalidFileSystem.NotFound | The specified file system does not exist. | 指定的檔案系統不存在。 |
| 404 | InvalidProtocolService.NotFound | The specified protocol service does not exist. | 指定的通訊協定服務不存在。 |
| 404 | InvalidVpcId.ConflictVpcCidr | Vpc cidr conflict with file system | 指定 VPC 與檔案系統 VPC 網段重疊。 |
| 404 | InvalidFsetId.NotFound | The specified fileset ID does not exist. | |
| 404 | Fset.IncorrectStatus | The specified fset is in an incorrect status. | 指定的 Fileset 無法使用。 |
| 404 | InvalidFileSystemPath.InvalidCharacters | The specified fileset path contains invalid characters. | 指定的 Fileset 路徑包含非法字元。 |
| 404 | InvalidAccessGroupName.NotFound | The specified access group does not exist. | 指定的權限群組不存在。 |
| 404 | InvalidAccessGroupName.NotAccessRule | There has no rule in access group. | 指定的權限群組中無規則。 |
| 404 | InvalidDescription.InvalidFormat | Description format is invalid. | 指定的描述格式無效。 |
| 404 | InvalidParameter.VpcNotFound | The specified VPC does not exist. | 指定的 VPC 網路不存在。 |
| 404 | InvalidParameter.VswNotFound | The specified VSwitch does not exist. |
訪問錯誤中心查看更多錯誤碼。
變更歷史
更多資訊,參考變更詳情。