Quando um servidor de back-end do GWLB falha em uma verificação de integridade ou é removido, o novo tráfego é direcionado para outros servidores disponíveis. Contudo, o tráfego existente continua a fluir para o servidor indisponível, o que pode resultar em perda de pacotes. Ao ativar o rebalanceamento em um grupo de servidores, você instrui o GWLB a redirecionar esse tráfego existente para os demais servidores disponíveis.
Por que usar o rebalanceamento
status do rebalanceamento | Desativado | Ativado |
Diagrama de cenário | ||
Como o tráfego existente é tratado | O tráfego existente continua fluindo para o servidor indisponível, o que pode causar perda de pacotes. | O tráfego existente é imediatamente redirecionado para outros servidores disponíveis, garantindo a continuidade do service. |
O recurso de rebalanceamento oferece as seguintes vantagens:
Permite atualizações e manutenções contínuas em appliances virtuais de rede (NVAs), como firewalls de terceiros.
Elimina a necessidade de lógica especial na aplicação para lidar com interrupções de tráfego causadas por failovers de NVA.
Como o rebalanceamento funciona
Após um servidor de back-end falhar em uma verificação de integridade ou ser removido:
O novo tráfego é direcionado diretamente para outros servidores disponíveis.
-
O tratamento do tráfego existente depende de várias condições.
Motivo da indisponibilidade
Drenagem de conexão
Rebalanceamento
Resultado
Falha na verificação de integridade
Não aplicável
✅
Redirecionado para outros servidores disponíveis
❌
Continua sendo encaminhado para o servidor indisponível
✅
Redirecionado para outros servidores disponíveis
❌
Continua sendo encaminhado para o servidor indisponível
Remoção do servidor
✅
✅
Continua sendo encaminhado para o servidor indisponível durante o período de tempo limite da drenagem de conexão.
Após a expiração do tempo limite da drenagem de conexão, o tráfego é redirecionado para outros servidores disponíveis.
✅
❌
Continua sendo encaminhado para o servidor indisponível
❌
✅
Redirecionado para outros servidores disponíveis
❌
❌
Continua sendo encaminhado para o servidor indisponível
ative o rebalanceamento
Console
No console do GWLB, acesse a página Server Group e crie um grupo de servidores e, na seção Advanced Settings, ative ou desative a opção Rebalance Existing Traffic.
Como alternativa, para um grupo de servidores existente, abra a página Modify Basic Information para ativar ou desativar Rebalance Existing Traffic.
Após a ativação desse recurso, o GWLB rebalanceia o tráfego existente para servidores íntegros quando um servidor falha ou é removido. Se o seu tráfego utilizar um protocolo com estado, configure as NVAs nos servidores de back-end de acordo.
API
Para ativar ou desativar o rebalanceamento, chame a operação CreateServerGroup ou UpdateServerGroupAttribute e defina o parâmetro ServerFailoverMode.
Os valores válidos para o parâmetro ServerFailoverMode são:
NoRebalance (padrão): Não rebalanceia o tráfego existente.
Rebalance: Rebalanceia o tráfego existente.
Para consultar o status do recurso de rebalanceamento, chame a operação ListServerGroups.
Se o seu tráfego usar um protocolo com estado, configure as appliances virtuais de rede (NVAs) nos servidores de back-end de acordo.
Por exemplo, para tráfego TCP, o firewall deve ser configurado para permitir que uma sessão TCP seja estabelecida sem um segmento SYN inicial.
-
Como funciona:
O TCP utiliza um handshake de três vias para estabelecer uma conexão. Esse processo envolve o cliente enviando um segmento SYN, o servidor respondendo com um segmento SYN-ACK e o cliente enviando um segmento ACK para concluir a conexão.
Quando o GWLB rebalanceia o tráfego existente, ele pode mover uma conexão existente de uma NVA para outra. Essa operação pode transferir uma sessão TCP para uma nova NVA. Se a nova NVA não oferecer suporte ao estabelecimento de uma sessão TCP sem um segmento SYN inicial, ela descartará a conexão. Portanto, a NVA deve ser capaz de aceitar perfeitamente essas conexões "sem SYN" no meio do fluxo para evitar interrupções.
Exemplo de configuração: Em um firewall FortiGate, ative
tcp-session-without-synna política do firewall. Para mais informações, consulte a documentação oficial do fornecedor do seu firewall.
Quando o rebalanceamento é acionado, o tráfego existente que era encaminhado para servidores não íntegros ou removidos é redistribuído para os servidores íntegros restantes no grupo de servidores.
Avalie a redundância de capacidade do seu grupo de servidores para garantir que, se qualquer servidor falhar, os servidores restantes possam lidar com o tráfego redistribuído e evitar sobrecargas causadas por um pico repentino de tráfego. Verifique o nível de carga de cada servidor no grupo de servidores antes de fazer alterações e reserve uma redundância de capacidade suficiente.