Todos os produtos
Search
Central de documentação

ApsaraDB RDS:UpgradeDBInstanceMajorVersion

Última atualização: Jul 07, 2026

Inicia uma atualização de versão principal para uma instância do RDS PostgreSQL.

Descrição da operação

Mecanismos suportados

RDS PostgreSQL

Documentação relacionada

Esta operação de API incorre em taxas. Antes de chamar esta API, revise a documentação relacionada para entender as taxas, os pré-requisitos e os possíveis impactos.

Atualizar a versão principal do banco de dados de uma instância do RDS PostgreSQL

Experimente agora

Experimente esta API no OpenAPI Explorer, sem necessidade de assinatura manual. Chamadas bem-sucedidas geram automaticamente código SDK correspondente aos seus parâmetros. Faça o download com segurança de credenciais integrada para uso local.

Testar

Autorização RAM

A tabela abaixo descreve a autorização necessária para chamar esta API. Você pode defini-la em uma política do Resource Access Management (RAM). As colunas da tabela estão detalhadas abaixo:

  • Ação: As ações que podem ser usadas no elemento Action das instruções de política de permissão do RAM para conceder permissões para executar a operação.

  • API: A API que você pode chamar para executar a ação.

  • Nível de acesso: O nível de acesso predefinido concedido para cada API. Valores válidos: create, list, get, update e delete.

  • Tipo de recurso: O tipo de recurso que suporta autorização para executar a ação. Indica se a ação suporta permissão em nível de recurso. O recurso especificado deve ser compatível com a ação. Caso contrário, a política será ineficaz.

    • Para APIs com permissões em nível de recurso, os tipos de recursos obrigatórios são marcados com um asterisco (*). Especifique o Nome de Recurso Alibaba Cloud (ARN) correspondente no elemento Resource da política.

    • Para APIs sem permissões em nível de recurso, é exibido como Todos os Recursos. Use um asterisco (*) no elemento Resource da política.

  • Chave de condição: As chaves de condição definidas pelo serviço. A chave permite controle granular, aplicando-se somente a ações ou a ações associadas a recursos específicos. Além das chaves de condição específicas do serviço, o Alibaba Cloud fornece um conjunto de chaves de condição comuns aplicáveis a todos os serviços compatíveis com RAM.

  • Ação dependente: As ações dependentes necessárias para executar a ação. Para concluir a ação, o usuário RAM ou a função RAM deve ter permissões para executar todas as ações dependentes.

Ação

Nível de acesso

Tipo de recurso

Chave de condição

Ação dependente

rds:UpgradeDBInstanceMajorVersion

update

*DBInstance

acs:rds:*:{#accountId}:dbinstance/{#DBInstanceId}

Nenhuma Nenhuma

Parâmetros da solicitação

Parâmetro

Tipo

Obrigatório

Descrição

Exemplo

DBInstanceClass

string

Não

O novo tipo da instância. O novo tipo de instância deve ter pelo menos a mesma CPU e memória da instância de origem. Este parâmetro não é obrigatório se UpgradeMode estiver definido como inPlaceUpgrade ou zeroDownTimeUpgrade.

Por exemplo, se a instância de origem tiver o tipo de instância pg.n2.small.2c, que fornece 1 vCPU e 2 GB de memória, você pode atualizá-la para pg.n2.medium.2c, que fornece 2 vCPUs e 4 GB de memória.

Nota

Para obter mais informações sobre os tipos de instância do ApsaraDB RDS for PostgreSQL, consulte Tipos de instância primária do ApsaraDB RDS for PostgreSQL.

pg.n2.medium.2c

DBInstanceStorage

integer

Não

O novo espaço de armazenamento da instância. Unidade: GB. Este parâmetro não é obrigatório se UpgradeMode estiver definido como inPlaceUpgrade ou zeroDownTimeUpgrade.

Valores válidos:

  • Disco em nuvem ESSD PL1: 20 a 3.200

  • Disco em nuvem ESSD PL2: 500 a 3.200

  • Disco em nuvem ESSD PL3: 1.500 a 3.200

  • Ultra disco: 40 a 2.000

Nota

Você pode reduzir o espaço de armazenamento ao atualizar uma instância que usa discos locais de alto desempenho. Para obter detalhes sobre o espaço de armazenamento mínimo necessário, consulte Atualizar a versão principal do mecanismo de uma instância do ApsaraDB RDS for PostgreSQL.

20

PayType

string

Sim

O método de cobrança. O valor é fixo como Postpaid, que especifica o método pós-pago.

Nota

Para alterar o método de cobrança da instância após a atualização, consulte Converter uma instância pós-paga em uma instância por assinatura.

Postpaid

InstanceNetworkType

string

Não

O novo tipo de rede da instância. Este parâmetro é fixo como VPC. Esta atualização é suportada apenas para instâncias em uma VPC.

Se sua instância estiver na Rede Clássica, você deve primeiro alterar seu tipo de rede para VPC. Para obter mais informações sobre como visualizar ou alterar o tipo de rede, consulte Alterar o tipo de rede de uma instância do ApsaraDB RDS for PostgreSQL.

VPC

SwitchTimeMode

string

Não

Especifica quando realizar o switchover. Este parâmetro se aplica apenas quando SwitchOver está definido como true.

Valores válidos:

  • Immediate: Realiza o switchover imediatamente.

  • MaintainTime: Realiza o switchover durante a janela de manutenção. Para alterar a janela de manutenção, chame a operação ModifyDBInstanceMaintainTime.

Immediate

SwitchTime

string

Não

Reservado. Não configure este parâmetro.

2021-07-10T13:15:12Z

SwitchOver

string

Não

Especifica se o tráfego deve ser alternado para a nova instância após a atualização.

Valores válidos:

  • true: Realiza um switchover automático. Esta opção é normalmente usada para realizar a atualização final após você confirmar que suas cargas de trabalho são executadas de forma estável na nova versão.

  • false: Não realiza um switchover automático. Esta opção é normalmente usada para testar a compatibilidade de suas cargas de trabalho com a nova versão antes da atualização final.

Nota
  • Se você realizar um switchover:

    • O switchover não pode ser revertido. Use esta opção com cautela.

    • Durante o switchover, a instância de origem torna-se somente leitura e não pode processar solicitações de gravação. Recomendamos realizar o switchover durante horários de menor movimento.

    • Você não pode realizar um switchover se a instância de origem tiver instâncias somente leitura. Nesse caso, você deve atualizar sem um switchover, e as instâncias somente leitura existentes não são clonadas. Após a atualização, você deve criar novas instâncias somente leitura para a instância primária atualizada.

  • Se você não realizar um switchover:

false

CollectStatMode

string

Não

Especifica quando coletar estatísticas para o banco de dados.

  • Before: Coleta estatísticas antes do switchover. Isso ajuda a manter as cargas de trabalho estáveis. Se a instância armazenar uma grande quantidade de dados, a atualização pode levar mais tempo.

  • After: Coleta estatísticas após o switchover. Isso acelera a atualização. Após a atualização, o acesso a tabelas para as quais nenhuma estatística foi gerada pode resultar em planos de execução imprecisos. Durante os horários de pico, isso também pode causar a indisponibilidade do banco de dados.

Nota

Em um cenário sem switchover, Before significa que as estatísticas são coletadas antes que a nova instância fique disponível, e After significa que elas são coletadas depois que ela se torna disponível.

After

TargetMajorVersion

string

Não

A versão principal do mecanismo de destino para a atualização. Este valor deve corresponder à versão especificada na pré-verificação.

Nota

Para realizar uma pré-verificação da atualização da versão principal do mecanismo, chame a operação UpgradeDBInstanceMajorVersionPrecheck.

13.0

DBInstanceId

string

Não

O ID da instância de origem.

pgm-bp1gm3yh0ht1****

VPCId

string

Não

O ID da VPC. Este parâmetro não é obrigatório se UpgradeMode estiver definido como inPlaceUpgrade ou zeroDownTimeUpgrade.

Para consultar o ID da VPC da instância de origem, chame a operação DescribeDBInstanceAttribute.

vpc-bp1opxu1zkhn00gzv****

VSwitchId

string

Não

O ID do VSwitch para a instância de destino. Este parâmetro não é obrigatório se UpgradeMode estiver definido como inPlaceUpgrade ou zeroDownTimeUpgrade.

  • Se a instância de origem for uma instância da Basic Edition, especifique o ID do VSwitch para a instância de destino.

  • Se a instância de origem for uma instância da High-availability Edition, você pode especificar os IDs do VSwitch para as instâncias primária e secundária. Separe os IDs com uma vírgula (,).

Nota

O VSwitch que você especificar deve estar na mesma zona que a instância de origem. Para consultar os IDs do VSwitch, chame a operação DescribeVSwitches.

vsw-bp10aqj6o4lclxdrm****,vsw-bp10aqj6o4lclxdrm****

PrivateIpAddress

string

Não

O endereço IP privado da instância de destino. Você não precisa definir este parâmetro, pois o sistema atribui automaticamente um endereço IP com base no VPCId e VSwitchId especificados.

172.16.XX.XX

UsedTime

string

Não

Reservado. Não configure este parâmetro.

1

Period

string

Não

Reservado. Não configure este parâmetro.

Month

DBInstanceStorageType

string

Não

O novo tipo de armazenamento da instância.

Valores válidos:

  • cloud_ssd: Disco em nuvem SSD

  • cloud_essd: Disco em nuvem ESSD PL1

  • cloud_essd2: Disco em nuvem ESSD PL2

  • cloud_essd3: Disco em nuvem ESSD PL3

  • general_essd: Ultra disco

As atualizações de versão principal do mecanismo usam snapshots de disco em nuvem. Os seguintes tipos de armazenamento são suportados para a nova instância após a atualização:

  • Se a instância de origem usar um disco em nuvem SSD, você pode selecionar um disco em nuvem SSD.

  • Se a instância de origem usar um disco em nuvem ESSD, você pode selecionar disco em nuvem ESSD PL1, disco em nuvem ESSD PL2, disco em nuvem ESSD PL3 ou ultra disco.

  • Se a instância de origem usar um disco local de alto desempenho, você pode selecionar disco em nuvem ESSD PL1, disco em nuvem ESSD PL2, disco em nuvem ESSD PL3 ou ultra disco.

cloud_essd

ZoneId

string

Não

O ID da zona primária de destino. Este parâmetro não é obrigatório se UpgradeMode estiver definido como inPlaceUpgrade ou zeroDownTimeUpgrade.

Para consultar os IDs de zona, chame a operação DescribeRegions.

O ApsaraDB RDS for PostgreSQL permite que você coloque a nova instância em uma zona diferente dentro da mesma região como parte da atualização.

cn-hangzhou-j

ZoneIdSlave1

string

Não

O ID da zona secundária de destino. Este parâmetro é aplicável apenas a instâncias da High-availability Edition e não é obrigatório se UpgradeMode estiver definido como inPlaceUpgrade ou zeroDownTimeUpgrade.

O ApsaraDB RDS for PostgreSQL permite que você coloque a nova instância secundária em uma zona diferente dentro da mesma região como parte da atualização.

Para consultar os IDs de zona, chame a operação DescribeRegions.

cn-hangzhou-j

ZoneIdSlave2

string

Não

Reservado. Não configure este parâmetro.

cn-hangzhou-j

UpgradeMode

string

Não

O modo de atualização. Este parâmetro é obrigatório se SwitchOver estiver definido como true. Valores válidos:

  • inPlaceUpgrade: Uma atualização no local. A atualização da versão principal do mecanismo é realizada na instância de origem e nenhuma nova instância é criada. Após a atualização, a versão principal do mecanismo da instância de origem é atualizada, e a instância mantém seu pedido existente, nome da instância, tags, regras de alerta do CloudMonitor e regras de backup.

  • blueGreenDeployment: Uma implantação blue-green. Este modo mantém a instância de origem e cria uma nova instância que executa a versão principal de destino. Nenhuma cobrança é incorrida durante a criação da nova instância. Após a criação, tanto a instância de origem quanto a nova instância são cobradas. A nova instância não herda nenhum desconto da instância de origem.

  • zeroDownTimeUpgrade: Uma atualização com tempo de inatividade zero. O sistema usa pg_upgrade para atualizar a instância de origem para a versão de destino e usa replicação lógica nativa para atualizações incrementais. Você pode acionar um switchover durante a atualização e validar a instância de versão superior antes do switchover. Desde o início da atualização até você acionar o switchover, a instância permanece disponível para operações de leitura e gravação. Durante o switchover, a instância fica no modo somente leitura por alguns segundos.

inPlaceUpgrade

CustomExtraInfo

string

Não

AllowDDL

boolean

Não

Elementos de resposta

Elemento

Tipo

Descrição

Exemplo

object

Parâmetros de resposta.

DBInstanceId

string

O ID da instância.

pgm-bp1gm3yh0ht1****

OrderId

string

O ID do pedido.

21128667463****

RequestId

string

O ID da solicitação.

006729E5-2A33-5955-89E3-651D3F44EBE6

TaskId

integer

Reservado.

416980000

Exemplos

Resposta de sucesso

JSON formato

{
  "DBInstanceId": "pgm-bp1gm3yh0ht1****",
  "OrderId": "21128667463****",
  "RequestId": "006729E5-2A33-5955-89E3-651D3F44EBE6",
  "TaskId": 416980000
}

Códigos de erro

Código de status HTTP

Código de erro

Mensagem de erro

Descrição

400 InvalidUpgradePrecheckResult The upgrade precheck failed. No successful precheck task found in the past 7 days
400 TargetEngineVersion.Parameters.NotFound targetEngineVersion is missing in the request.
400 InvalidDBInstanceStorageType The specified DBInstanceStorageType is invalid.
400 InvalidInstanceNetworkType The specified InstanceNetworkType is invalid.
400 InvalidVPCId The specified VPCId is invalid.
400 InvalidDedicatedHostGroupId The specified DedicatedHostGroupId is invalid.
400 InvalidPayType The specified PayType is invalid.
400 InvalidEngineVersion The specified EngineVersion is invalid.
400 InvalidDBInstanceStorage The specified DBInstanceStorage is invalid.
400 InvalidSwitchOver The specified SwitchOver is invalid.
400 PrimaryInstanceWithReadonlyNotSupport The specified primary instance with the read-only instance does not support the operation.
400 InvalidSwitchTimeMode The specified SwitchTimeMode is invalid.
400 InvalidSwitchTime The specified SwitchTime is invalid.
400 InvalidCollectStats The specified CollectStats is invalid.
400 IncorrectDBInstanceState The current instance state does not support this operation.
400 InvalidDBinstanceClass.ValueNotSupported The specified parameter DBinstanceClass is invalid.
400 InvalidUpgradeMode The Specified UpgradeMode is not valid.
400 Order.ComboInstanceNotAllowOperate A package instance is not allowed to operate independently.
400 Price.PricingPlanResultNotFound Pricing plan price result not found.
400 Order.NoRealNameAuthentication You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication.
400 InsufficientAvailableQuota Your account quota limit is less than 0, please recharge before trying to purchase.
400 CommodityServiceCalling.Exception Failed to call commodity service.
400 RegionDissolvedEOM Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support.
400 Commodity.InvalidComponent The module you purchased is not legal, please buy it again.
400 RegionEndTimeDissolvedAustralia Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024.
400 Price.CommoditySys Commodity system call exception.
400 Pay.InsufficientBalance Insufficient available balance.
400 Order.PeriodInvalid There is a problem with the period you selected, please choose again.
400 pay.noCreditCard Account not bound to credit card.
400 Order.InstHasUnpaidOrder There is an unpaid order for the service you have purchased. Please pay or void it before placing the order.
400 noAvailablePaymentMethod No payment method is specified for your account. We recommend that you add a payment method.
400 BasicInfoUncompleted Your information is incomplete. Complete your information before the operation.
400 Risk.RiskControlRejection Your account is abnormal, please contact customer service for details.
400 Api.NotSupport Specified api is not supported.
400 ContainForbiddenLabelError There is a label that prohibits placing orders. Please contact your distributor for assistance.
400 InvalidDBInstanceId.NotFound The DBInstanceId provided does not exist in records.
400 InvalidInstanceLevel.DiskType Specified instance level not support request disk type
400 InvalidParam Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica.
400 KmsApiError User secret key invalid.
400 System.SaleValidateFailed Sales expression validation system error.
400 Abs.InvalidAccount.NotFound account is not found.
400 SqlExecuteFailedOrTimeout sql command execution failed or timed out:%s.
400 ColdData.EngineVersionNotSupport The current instance engine version not support coldDataEnabled.
400 ColdData.MinorVersionNotSupport The current instance minor version not support coldDataEnabled.
400 IncorrectTargetClasscode The current instance type does not support this operation.
400 InvalidConnectionString.Duplicate Specified connection string already exists in the RDS.
400 RequiredParam.NotFound Required input param is not found.
400 Parameters.Invalid Parameter error, please check the parameters.
400 BackupPolicyNotSupport Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy.
400 InvalideStatus.Format The instance status does not support this operation.
400 InvalidReleasedKeepPolicy.Format Specified Released Keep Policy is not valid.
400 InvalidDBInstanceEngineType.Format the DB instance engine type does not support this operation.
400 Pay.NoCreditCard No credit cards.
400 VpcNetworkTypeNotSupport The vpc network type instance does not support this operation.
400 MirrorInsExists Specified DB instance mirror ins already existed.
400 UnsupportedClassCode The specified DB instance class stops selling.
400 InvalidBackupSet The specified database does not exist in the backup set.
400 OrdTCommodityQueryError Failed to query for product.
400 ProductInstanceReleased The instance has been released. Please check before placing the order.
400 RegionEndTimeDissolvedIndia The region is no longer supported.
400 InvalidVSwitchId.Format The specified vswitch Id format is incorrect.
400 UpgradeModeNotSupport For instances with local SSD, this upgrade Mode is not allowed. For instances with cloud SSD, it is recommended to upgrade minor version at first.
500 InvalidUpgradeMode The Specified Parameter UpgradeMode is not valid.
500 ExternalFailure The request processing has failed due to external service failure.
500 RequestMetaDataFailed The service request failed. Please try again later or contact service personnel.
500 InvokeProxyFailure The request processing has failed due to service failure of rds api.
403 OrderStatus.UnPaid The specified db instance has unpaid order.
403 InvalidReduceDiskSize The storage capacity after the scale-down must be larger than the used amount.
403 CloudSSDNotSupport Cloud ssd does not support this operation, please upgrade to essd.
403 InvalidUserOperatorPermission The user permission does not support this operation.
403 InvalidVswitchId Specified conn vswitch id is not valid.
403 IncorrectMinorVersion Current engine minor version does not support operations.
403 OperationDenied.ZoneResource There is no available zone for inventory.
403 NotInFlowController Sorry,no permission.
403 InvalidKmsKey Kms key is disabled.
403 InvalidInstanceLevel.Malformed Current DB instance level does not support this operation.
404 InvalidDBInstanceName.NotFound The database instance does not exist.
404 IncorrectDBInstanceLockMode Current DB instance lock mode does not support this operation.
404 InvalidClusterKms The current instance does not authorized to access the Key Management Service.
404 Request.NotFound The requested resource is not available.
404 HostInfo.NotFound The specified host info is not found.

Consulte Códigos de Erro para uma lista completa.

Notas de versão

Consulte Notas de Versão para uma lista completa.