Altera o método de cobrança de uma instância do ApsaraDB RDS.
Descrição da operação
Mecanismos de banco de dados compatíveis
MySQL
PostgreSQL
SQL Server
MariaDB
Referências
Serão geradas taxas se a chamada for bem-sucedida. Antes de chamar esta operação, você deve ler a seguinte documentação.
Alterar o método de cobrança de uma instância do ApsaraDB RDS for MySQL de pay-as-you-go para assinatura ou Alterar o método de cobrança de uma instância do ApsaraDB RDS for MySQL de assinatura para pay-as-you-go
Alterar o método de cobrança de uma instância do ApsaraDB RDS for PostgreSQL de pay-as-you-go para assinatura ou Alterar o método de cobrança de uma instância do ApsaraDB RDS for PostgreSQL de assinatura para pay-as-you-go
Alterar o método de cobrança de uma instância do ApsaraDB RDS for SQL Server de pay-as-you-go para assinatura ou Alterar o método de cobrança de uma instância do ApsaraDB RDS for SQL Server de assinatura para pay-as-you-go
Alterar o método de cobrança de uma instância do ApsaraDB RDS for MariaDB de pay-as-you-go para assinatura ou Alterar o método de cobrança de uma instância do ApsaraDB RDS for MariaDB de assinatura para pay-as-you-go
Experimente agora
Testar
Autorização RAM
|
Ação |
Nível de acesso |
Tipo de recurso |
Chave de condição |
Ação dependente |
|
rds:TransformDBInstancePayType |
update |
*DBInstance
|
|
Nenhuma |
Parâmetros da solicitação
|
Parâmetro |
Tipo |
Obrigatório |
Descrição |
Exemplo |
| ClientToken |
string |
Não |
O token do cliente que é usado para garantir a idempotência da solicitação. Você pode usar o cliente para gerar o token, mas deve garantir que o token seja exclusivo entre diferentes solicitações. O token pode conter apenas caracteres ASCII e não pode exceder 64 caracteres de comprimento. |
ETnLKlblzczshOTUbOCz**** |
| DBInstanceId |
string |
Sim |
O ID da instância. Você pode chamar a operação DescribeDBInstances para consultar o ID da instância. |
rm-uf6wjk5**** |
| UsedTime |
integer |
Não |
A duração da assinatura da instância. Valores válidos:
Nota
Este parâmetro deve ser especificado quando PayType estiver definido como Prepaid. |
1 |
| PayType |
string |
Sim |
O novo método de cobrança da instância. Valores válidos:
|
Prepaid |
| Period |
string |
Não |
O ciclo de renovação da instância. Valores válidos:
Nota
Este parâmetro deve ser especificado se você definir PayType como Prepaid. |
Month |
| BusinessInfo |
string |
Não |
As informações comerciais adicionais sobre a instância. |
123456789 |
| AutoRenew |
string |
Não |
Especifica se deve ativar o recurso de renovação automática para a instância. Valores válidos:
Nota
|
true |
| AutoUseCoupon |
boolean |
Não |
Especifica se devem ser usados vouchers para compensar taxas. Valores válidos:
|
true |
| PromotionCode |
string |
Não |
O código do cupom. |
726122650073 |
Elementos de resposta
|
Elemento |
Tipo |
Descrição |
Exemplo |
|
object |
Os parâmetros de resposta. |
||
| DBInstanceId |
string |
O ID da instância. |
rm-uf6wjk5**** |
| RequestId |
string |
O ID da solicitação. |
5E6E09DE-5B12-4BFF-A55E-1C86EDE06D9A |
| ExpiredTime |
string |
O horário de expiração. Nota
Se você chamar esta operação para alterar o método de cobrança de uma instância de assinatura para pay-as-you-go, este parâmetro não será retornado. |
2020-04-20T10:00:00Z |
| OrderId |
integer |
O ID do pedido. |
20515760028**** |
| ChargeType |
string |
O tipo de pagamento.
|
POSTPAY |
Exemplos
Resposta de sucesso
JSON formato
{
"DBInstanceId": "rm-uf6wjk5****",
"RequestId": "5E6E09DE-5B12-4BFF-A55E-1C86EDE06D9A",
"ExpiredTime": "2020-04-20T10:00:00Z",
"OrderId": 0,
"ChargeType": "POSTPAY"
}
Códigos de erro
|
Código de status HTTP |
Código de erro |
Mensagem de erro |
Descrição |
|---|---|---|---|
| 400 | InvalidDBInstanceName.NotFound | The specified DB instance name does not exist. | A instância especificada não existe ou não é suportada. |
| 400 | InvalidInstanceUseType.NotSupport | Specified instanceUseType does not support in RDS. | A operação falhou. O instanceUseType especificado não é suportado no ApsaraDB RDS. |
| 400 | InvalidOrderCharge.NotSupport | The specified order charge does not support in RDS. | |
| 400 | InvalidOrderTask.NotSupport | The Current InstanceId exist Order Task in RDS. | A operação falhou. A tarefa do pedido já existe. |
| 400 | IncorrectDBInstanceType | Current DB instance type does not support this operation. | |
| 400 | IncompleteAccountInfo | Your information is incomplete. Complete your information before the operation. | Falha na operação. Os campos marcados com um asterisco (*) nas informações da conta são obrigatórios. Preencha os campos obrigatórios. Caminho: Central da Conta > Informações Básicas. |
| 400 | IncompleteTaxInfo | Your tax information is incomplete. Complete your information before the operation. | Falha na operação. As informações fiscais estão incompletas. Preencha as informações obrigatórias. |
| 400 | InvalidPaymentMethod.Incomplete | No payment method is specified for your account. We recommend that you add a payment method. | Sua conta não possui um método de pagamento válido. Adicione um método de pagamento. |
| 400 | InvalidPaymentMethod.Missing | Your payment method is incomplete. We recommend that you add a payment method. | A conta atual não possui um método de pagamento válido. Adicione um método de pagamento. |
| 400 | InsuffcientBalanceOrBankAccount | Add a payment method or add funds to the prepayment balance. Get started by creating an instance. | Sua conta não possui um método de pagamento válido. Adicione um método de pagamento ou recarregue seu saldo de pré-pagamento. |
| 400 | InvalidPaymentMethod.NoAccess | No payment method is specified for your account. Please contact your Customer Manager or open a ticket. | |
| 400 | InvalidPaymentMethod.InsufficientBalance | No payment method is specified for your account. We recommend that you add a payment method or add funds to the prepayment balance. | |
| 400 | OrderTaskAlreadyExists | Order task already exists. | A operação falhou. A tarefa do pedido já existe. |
| 400 | InvalidOldInstanceType.NotSupport | Specified oldInstanceType does not support in RDS. | A versão atual da instância não oferece suporte a esta operação. |
| 400 | OperationDenied.TimeLimit | The interval between the two conversion operations must be greater than 15 minutes. | A operação falhou. O intervalo entre duas operações de conversão de método de cobrança deve ser superior a 15 minutos. |
| 400 | InvalidDBInstanceId.Malformed | The specified parameter DBInstanceId is not valid. | |
| 400 | InvalidPayType.Malformed | The specified parameter PayType is not valid. | |
| 400 | InvalidResource.Format | The specified parameter Resource is not valid. | O recurso é inválido. |
| 400 | InvalidPayType.Format | The specified parameter PayType is not valid. | A operação falhou. O tipo de pagamento é inválido. |
| 400 | InvalidUsedTime.Format | The specified parameter UsedTime is not valid. | O parâmetro UsedTime não foi especificado. |
| 400 | InvalidPeriod.Format | The specified parameter Period is not valid. | |
| 400 | InvalidPeriodOrUsedTime.Format | The specified parameter Period and UsedTime are not valid. | |
| 400 | InvalidDiscountCoupon.Malformed | The specified discount coupon is not valid. | |
| 400 | InsufficientQuota.NoEnough | Your current quota is insufficient. Please contact your channel partner to increase your quota. | Sua cota atual é insuficiente. Entre em contato com seu parceiro de canal para aumentar a cota. |
| 400 | SYSTEM.ILLEGALARGUMENT | The current instance does not have a valid configuration when change the payType from Prepaid to Postpaid. | Não existe nenhuma configuração válida para a instância atual alternar de assinatura para pay-as-you-go. |
| 400 | AccountMoneyValidate.error | Insufficient funds available in the account. | O saldo disponível da conta é insuficiente. |
| 400 | ContainForbiddenLabel.error | There is a label that prohibits placing an order, and the order cannot be placed. | Existe uma tag de bloqueio de pedido. Não é possível realizar pedidos. |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | A chamada para o serviço de commodity retornou uma falha. |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | Ocorreu uma exceção com a sua conta. Entre em contato com o atendimento ao cliente para obter detalhes. |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | O módulo adquirido é inválido. Adquira um módulo válido. |
| 400 | InvalidParam.PREPAY | The prepaid instance purchase limit has been exceeded, and changing the payment method to prepaid is not allowed. | A rede clássica foi descontinuada. A instância atual usa o tipo de rede clássica e excedeu o limite de tempo de compra para instâncias de assinatura. A alteração do método de faturamento para assinatura não é permitida. |
| 400 | InvalidParam.POSTPAY | It is not allowed to switch the payment method to postpaid after exceeding the purchase time limit for postpaid instances. | A rede clássica foi descontinuada. A instância atual usa o tipo de rede clássica e excedeu o limite de tempo de compra para instâncias pay-as-you-go. A alteração do método de faturamento para pay-as-you-go não é permitida. |
| 400 | Order.InstHasUnsettledBills | You currently have outstanding bills, please settle them first. | Sua conta possui faturas em atraso. Regularize as faturas em atraso primeiro. |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | Operações individuais não são permitidas para instâncias de pacote. |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | O resultado do preço do plano de preços não foi encontrado. |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | Você não concluiu a verificação de nome real e não está elegível para fazer uma compra. Faça login em Despesas e Custos para concluir a verificação de nome real. |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | O crédito disponível da sua conta é menor que 0. Recarregue sua conta antes de tentar fazer uma compra. |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | O Alibaba Cloud planeja otimizar e ajustar a região atual. Os serviços em nuvem nesta região serão descontinuados. Para garantir a continuidade dos seus negócios e uma migração de dados tranquila, você não pode fazer novos pedidos de compra no momento. Agradecemos sua compreensão e apoio. |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | A região foi desativada. |
| 400 | Price.CommoditySys | Commodity system call exception. | Ocorreu uma exceção ao chamar o sistema de commodities. |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | O período de assinatura selecionado é inválido. Selecione um período de assinatura válido. |
| 400 | pay.noCreditCard | Account not bound to credit card. | A conta não está associada a um cartão de crédito. |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | Existe um pedido não pago para o serviço selecionado. Pague ou cancele o pedido antes de fazer um novo. |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | Suas informações básicas estão incompletas. Complete suas informações básicas antes de realizar esta operação. |
| 400 | Api.NotSupport | Specified api is not supported. | A operação de API atual não é suportada. |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | Existe uma tag de bloqueio de pedido. Entre em contato com seu distribuidor para obter assistência. |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | O DBInstanceId especificado não existe. |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | O tipo de instância atual não oferece suporte ao tipo de armazenamento especificado. |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | O parâmetro de entrada é inválido. |
| 400 | KmsApiError | User secret key invalid. | A chave do usuário é inválida. |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | Sua conta da Alibaba Cloud não existe ou sua AccessKey expirou. |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | A execução do comando SQL falhou ou expirou. |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | A versão atual do mecanismo DPI da instância não suporta o arquivamento de dados frios. |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | A versão atual do kernel não suporta o arquivamento de dados frios. |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | O tipo de instância atual não oferece suporte a esta operação. |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | O nome do endereço de conexão está duplicado. Reconfigure a string de conexão. |
| 400 | RequiredParam.NotFound | Required input param is not found. | Parâmetros obrigatórios estão ausentes. |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | O parâmetro está incorreto. Verifique o parâmetro. |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | O arquivamento de dados frios não oferece suporte a backup entre regiões ou backup de snapshot de alta frequência. Verifique a política de backup. |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | O status da instância não suporta esta operação. |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | A política de retenção de dados de backup arquivados após a liberação da instância é inválida. |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | O tipo de mecanismo de banco de dados da instância não oferece suporte a esta operação. |
| 400 | Pay.NoCreditCard | No credit cards. | |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | Esta operação não é suportada para instâncias do tipo de rede VPC. |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | A imagem da instância de banco de dados atual já existe. |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | O tipo de instância não está mais disponível para compra. |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | O banco de dados especificado não existe no conjunto de backup. |
| 400 | OrdTCommodityQueryError | Failed to query for product. | Falha ao consultar o produto. |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | A instância foi liberada. Verifique a instância antes de fazer o pedido. |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | A região foi desativada. |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | A solicitação para o serviço falhou. Tente novamente mais tarde. |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | A solicitação de serviço falhou. Tente novamente mais tarde ou entre em contato com o suporte. |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | A solicitação falhou porque o serviço da API do RDS apresentou falha. |
| 403 | OperationDenied.LockMode | The operation is not permitted when the instance locked. | A operação falhou porque a instância está bloqueada. O saldo da sua conta pode ser insuficiente. Renove a instância para desbloqueá-la. |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | Existe um pedido não pago para a instância atual. Pague o pedido e tente novamente. |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | A capacidade de destino para redução de escala não pode ser menor que o uso de armazenamento atual. |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | Os discos em nuvem SSD não suportam esta operação. Faça upgrade para ESSD. |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | As permissões do usuário não suportam esta operação. |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | O VSwitchId especificado está em um formato incorreto ou está vazio. |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | A versão secundária atual do mecanismo não suporta esta operação. |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | Não há regiões de inventário disponíveis. |
| 403 | NotInFlowController | Sorry,no permission. | Este recurso está disponível apenas para usuários de nuvem corporativa. Você não tem as permissões necessárias. |
| 403 | InvalidKmsKey | Kms key is disabled. | A chave KMS está desativada. |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | O nível atual da instância de banco de dados não oferece suporte a esta operação. |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | A instância atual não está autorizada a acessar o Key Management Service (KMS). |
| 404 | Request.NotFound | The requested resource is not available. | O recurso solicitado não está disponível. |
| 404 | HostInfo.NotFound | The specified host info is not found. | As informações do host especificado não existem. |
Consulte Códigos de Erro para uma lista completa.
Notas de versão
Consulte Notas de Versão para uma lista completa.