Todos os produtos
Search
Central de documentação

ApsaraDB RDS:StartDBInstance

Última atualização: Jul 07, 2026

Retoma uma instância.

Descrição da operação

Mecanismos de banco de dados compatíveis

  • MySQL

  • PostgreSQL

  • SQL Server

Referências

Nota

Antes de chamar esta operação, leia os tópicos a seguir e certifique-se de que você compreende totalmente os pré-requisitos e os impactos desta operação.

Iniciar uma instância ApsaraDB RDS for SQL

Experimente agora

Experimente esta API no OpenAPI Explorer, sem necessidade de assinatura manual. Chamadas bem-sucedidas geram automaticamente código SDK correspondente aos seus parâmetros. Faça o download com segurança de credenciais integrada para uso local.

Testar

Autorização RAM

A tabela abaixo descreve a autorização necessária para chamar esta API. Você pode defini-la em uma política do Resource Access Management (RAM). As colunas da tabela estão detalhadas abaixo:

  • Ação: As ações que podem ser usadas no elemento Action das instruções de política de permissão do RAM para conceder permissões para executar a operação.

  • API: A API que você pode chamar para executar a ação.

  • Nível de acesso: O nível de acesso predefinido concedido para cada API. Valores válidos: create, list, get, update e delete.

  • Tipo de recurso: O tipo de recurso que suporta autorização para executar a ação. Indica se a ação suporta permissão em nível de recurso. O recurso especificado deve ser compatível com a ação. Caso contrário, a política será ineficaz.

    • Para APIs com permissões em nível de recurso, os tipos de recursos obrigatórios são marcados com um asterisco (*). Especifique o Nome de Recurso Alibaba Cloud (ARN) correspondente no elemento Resource da política.

    • Para APIs sem permissões em nível de recurso, é exibido como Todos os Recursos. Use um asterisco (*) no elemento Resource da política.

  • Chave de condição: As chaves de condição definidas pelo serviço. A chave permite controle granular, aplicando-se somente a ações ou a ações associadas a recursos específicos. Além das chaves de condição específicas do serviço, o Alibaba Cloud fornece um conjunto de chaves de condição comuns aplicáveis a todos os serviços compatíveis com RAM.

  • Ação dependente: As ações dependentes necessárias para executar a ação. Para concluir a ação, o usuário RAM ou a função RAM deve ter permissões para executar todas as ações dependentes.

Ação

Nível de acesso

Tipo de recurso

Chave de condição

Ação dependente

rds:StartDBInstance

update

*DBInstance

acs:rds:{#regionId}:{#accountId}:dbinstance/{#dbinstanceId}

Nenhuma Nenhuma

Parâmetros da solicitação

Parâmetro

Tipo

Obrigatório

Descrição

Exemplo

RegionId

string

Não

O ID da região. Você pode chamar a operação DescribeRegions para consultar a lista de regiões mais recente.

cn-hangzhou

DedicatedHostGroupId

string

Não

O ID do cluster dedicado. Este parâmetro é compatível se você chamar esta operação para suspender uma instância RDS no cluster dedicado. Você pode chamar a operação DescribeDedicatedHostGroups para consultar o ID do cluster dedicado.

dhg-39****

DBInstanceId

string

Sim

O ID da instância. Você pode chamar a operação DescribeDBInstances para consultar o ID da instância.

rm-bp****

TargetDedicatedHostIdForMaster

string

Não

O ID do host no qual a instância primária é criada. Este parâmetro está disponível apenas para instâncias criadas em clusters dedicados.

Nota

Este parâmetro deve ser especificado quando DBInstanceTransType estiver definido como 2.

dh-bp****

TargetDedicatedHostIdForSlave

string

Não

O ID do host no qual a instância secundária é criada. Este parâmetro está disponível apenas para instâncias criadas em clusters dedicados.

Nota

Este parâmetro deve ser especificado quando DBInstanceTransType estiver definido como 2.

dh-bp****

TargetDedicatedHostIdForLog

string

Não

Um parâmetro obsoleto. Você não precisa especificar este parâmetro.

dh-bp****

EffectiveTime

string

Não

O horário efetivo. Este parâmetro está disponível apenas para instâncias criadas em clusters dedicados.

  • Immediate

  • MaintainTime: A alteração entra em vigor durante a janela de manutenção planejada. Para mais informações, consulte ModifyDBInstanceMaintainTime.

  • SpecificTime: A alteração entra em vigor em um momento especificado.

Valor padrão: MaintainTime.

Immediate

SpecifiedTime

string

Não

O horário de alternância. Este parâmetro está disponível apenas para instâncias criadas em clusters dedicados. Especifique o horário no padrão ISO 8601 no formato yyyy-MM-ddTHH:mm:ssZ. O horário deve estar em UTC.

Nota

Este parâmetro deve ser especificado quando EffectiveTime estiver definido como Specified.

2019-10-21T10:00:00Z

TargetDBInstanceClass

string

Não

O tipo de instância da instância necessária. Este parâmetro está disponível apenas para instâncias criadas em clusters dedicados.

rds.ebmhfc6.20xlarge

EngineVersion

string

Não

A versão do mecanismo de banco de dados da instância. Este parâmetro está disponível apenas para instâncias criadas em clusters dedicados.

5.7

DBInstanceTransType

integer

Não

O método de migração de dados da instância. Este parâmetro está disponível apenas para instâncias criadas em clusters dedicados. Valores válidos:

  • 0 (padrão): O sistema preferencialmente faz upgrade ou downgrade da instância sem migração. Se os recursos no host onde a instância reside forem insuficientes, o sistema migra a instância para outro host adequado.

  • 1: O sistema faz upgrade ou downgrade da instância sem migração. Se o upgrade ou downgrade não for compatível, o sistema reporta um erro.

  • 2: O sistema migra os dados da instância do host onde a instância reside para outro host. Você também deve especificar DedicatedHostGroupId, TargetDedicatedHostIdForMaster e TargetDedicatedHostIdForSlave. Se você definir DBInstanceTransType como 2, não será possível migrar os dados da instância para o host onde a instância reside. Se você migrar os dados da instância para o host onde a instância reside, a migração falhará.

0

Storage

integer

Não

A capacidade de armazenamento da instância. Este parâmetro está disponível apenas para instâncias criadas em clusters dedicados. Valores válidos: 5 a 2000. Unidade: GB. Se você não especificar este parâmetro, a capacidade de armazenamento da instância permanecerá inalterada.

1000

VSwitchId

string

Não

O ID do vSwitch. Este parâmetro está disponível apenas para instâncias criadas em clusters dedicados.

vsw-****

ZoneId

string

Não

O ID da zona. Este parâmetro está disponível apenas para instâncias criadas em clusters dedicados.

cn-hangzhou-a

Elementos de resposta

Elemento

Tipo

Descrição

Exemplo

object

Os parâmetros de resposta.

MigrationId

integer

O ID da tarefa de migração. Este parâmetro está disponível apenas para instâncias criadas em clusters dedicados.

740

RequestId

string

O ID da solicitação.

A417FB41-A3D9-464E-AD0A-C7FE05C72E98

TaskId

integer

O ID da tarefa.

238028563

Exemplos

Resposta de sucesso

JSON formato

{
  "MigrationId": 740,
  "RequestId": "A417FB41-A3D9-464E-AD0A-C7FE05C72E98",
  "TaskId": 238028563
}

Códigos de erro

Código de status HTTP

Código de erro

Mensagem de erro

Descrição

400 InvalidStatus.Format Specified Status is not valid
400 UnsupportExtendDisk.NotSupport Specified DB instance is unsupport extend disk.
400 Order.ComboInstanceNotAllowOperate A package instance is not allowed to operate independently.
400 Price.PricingPlanResultNotFound Pricing plan price result not found.
400 Order.NoRealNameAuthentication You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication.
400 InsufficientAvailableQuota Your account quota limit is less than 0, please recharge before trying to purchase.
400 CommodityServiceCalling.Exception Failed to call commodity service.
400 RegionDissolvedEOM Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support.
400 Commodity.InvalidComponent The module you purchased is not legal, please buy it again.
400 RegionEndTimeDissolvedAustralia Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024.
400 Price.CommoditySys Commodity system call exception.
400 Pay.InsufficientBalance Insufficient available balance.
400 Order.PeriodInvalid There is a problem with the period you selected, please choose again.
400 pay.noCreditCard Account not bound to credit card.
400 Order.InstHasUnpaidOrder There is an unpaid order for the service you have purchased. Please pay or void it before placing the order.
400 noAvailablePaymentMethod No payment method is specified for your account. We recommend that you add a payment method.
400 BasicInfoUncompleted Your information is incomplete. Complete your information before the operation.
400 Risk.RiskControlRejection Your account is abnormal, please contact customer service for details.
400 Api.NotSupport Specified api is not supported.
400 ContainForbiddenLabelError There is a label that prohibits placing orders. Please contact your distributor for assistance.
400 InvalidDBInstanceId.NotFound The DBInstanceId provided does not exist in records.
400 InvalidInstanceLevel.DiskType Specified instance level not support request disk type
400 InvalidParam Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica.
400 KmsApiError User secret key invalid.
400 System.SaleValidateFailed Sales expression validation system error.
400 Abs.InvalidAccount.NotFound account is not found.
400 SqlExecuteFailedOrTimeout sql command execution failed or timed out:%s.
400 ColdData.EngineVersionNotSupport The current instance engine version not support coldDataEnabled.
400 ColdData.MinorVersionNotSupport The current instance minor version not support coldDataEnabled.
400 IncorrectTargetClasscode The current instance type does not support this operation.
400 InvalidConnectionString.Duplicate Specified connection string already exists in the RDS.
400 RequiredParam.NotFound Required input param is not found.
400 Parameters.Invalid Parameter error, please check the parameters.
400 BackupPolicyNotSupport Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy.
400 InvalidReleasedKeepPolicy.Format Specified Released Keep Policy is not valid.
400 InvalidDBInstanceEngineType.Format the DB instance engine type does not support this operation.
400 Pay.NoCreditCard No credit cards.
400 VpcNetworkTypeNotSupport The vpc network type instance does not support this operation.
400 MirrorInsExists Specified DB instance mirror ins already existed.
400 UnsupportedClassCode The specified DB instance class stops selling.
400 InvalidBackupSet The specified database does not exist in the backup set.
400 OrdTCommodityQueryError Failed to query for product.
400 ProductInstanceReleased The instance has been released. Please check before placing the order.
400 RegionEndTimeDissolvedIndia The region is no longer supported.
500 ExternalFailure The request processing has failed due to external service failure.
500 RequestMetaDataFailed The service request failed. Please try again later or contact service personnel.
500 InvokeProxyFailure The request processing has failed due to service failure of rds api.
403 OrderStatus.UnPaid The specified db instance has unpaid order.
403 InvalidReduceDiskSize The storage capacity after the scale-down must be larger than the used amount.
403 CloudSSDNotSupport Cloud ssd does not support this operation, please upgrade to essd.
403 InvalidUserOperatorPermission The user permission does not support this operation.
403 InvalidVswitchId Specified conn vswitch id is not valid.
403 IncorrectMinorVersion Current engine minor version does not support operations.
403 OperationDenied.ZoneResource There is no available zone for inventory.
403 NotInFlowController Sorry,no permission.
403 InvalidKmsKey Kms key is disabled.
403 InvalidInstanceLevel.Malformed Current DB instance level does not support this operation.
404 InvalidClusterKms The current instance does not authorized to access the Key Management Service.
404 Request.NotFound The requested resource is not available.
404 HostInfo.NotFound The specified host info is not found.

Consulte Códigos de Erro para uma lista completa.

Notas de versão

Consulte Notas de Versão para uma lista completa.