Restaura dados em uma instância existente entre regiões.
Descrição da operação
Antes da restauração, você pode chamar a operação CheckCreateDdrDBInstance para verificar se um conjunto de backups entre regiões pode ser usado para restauração entre regiões.
Mecanismos de banco de dados compatíveis
MySQL.
Referências
Antes de chamar esta operação, leia os tópicos a seguir e certifique-se de compreender totalmente os pré-requisitos e os impactos desta operação.
Experimente agora
Testar
Autorização RAM
|
Ação |
Nível de acesso |
Tipo de recurso |
Chave de condição |
Ação dependente |
|
rds:RestoreDdrTable |
create |
*DBInstance
|
Nenhuma | Nenhuma |
Parâmetros da solicitação
|
Parâmetro |
Tipo |
Obrigatório |
Descrição |
Exemplo |
| DBInstanceId |
string |
Sim |
O ID da instância de origem. |
rm-bp**** |
| RegionId |
string |
Não |
O ID da região da instância de destino. Você pode chamar a operação DescribeRegions para consultar a lista de regiões mais recente. |
cn-hangzhou |
| ClientToken |
string |
Não |
O token do cliente usado para garantir a idempotência da solicitação. Você pode usar o cliente para gerar o token, mas deve garantir que o token seja único entre diferentes solicitações. O token pode conter apenas caracteres ASCII e não pode exceder 64 caracteres. |
ETnLKlblzczshOTUbOCz**** |
| RestoreType |
string |
Sim |
O método usado para restaurar dados. Valores válidos:
Valor padrão: 0. |
0 |
| BackupId |
string |
Não |
O ID do conjunto de backups entre regiões. Você pode chamar a operação DescribeCrossRegionBackups para consultar os IDs dos conjuntos de backups disponíveis para uma instância. Nota
Se você definir o parâmetro RestoreType como 0, também deverá especificar o parâmetro BackupId. |
279563 |
| RestoreTime |
string |
Não |
O ponto no tempo para o qual você deseja restaurar os dados. O ponto no tempo especificado deve ser anterior à hora atual. Especifique a hora no padrão ISO 8601 no formato yyyy-MM-ddTHH:mm:ssZ. A hora deve estar em UTC. Nota
Se RestoreType estiver definido como BackupTime, você deverá especificar este parâmetro. |
2020-04-25T16:00:00Z |
| SourceRegion |
string |
Não |
O ID da região da instância de origem se você deseja restaurar dados para um ponto no tempo. Nota
Se você definir RestoreType como 1, também deverá especificar este parâmetro. |
cn-beijing |
| SourceDBInstanceName |
string |
Não |
O ID da instância de origem cujos dados você deseja restaurar para um ponto no tempo. Nota
Se você definir o parâmetro RestoreType como 1, também deverá especificar o parâmetro SourceDBInstanceName. |
rm-bp**** |
| TableMeta |
string |
Sim |
Os nomes dos bancos de dados e tabelas que você deseja restaurar. O valor está no seguinte formato: |
[{"type":"db","name":"testdb1","newname":"testdb1","tables":[{"type":"table","name":"test1","newname":"test1_backup"},{"type":"table","name":"test2","newname":"test2_backup"}]}] |
| ResourceGroupId |
string |
Não |
O ID do grupo de recursos. |
rg-acfmy**** |
Elementos de resposta
|
Elemento |
Tipo |
Descrição |
Exemplo |
|
object |
Os parâmetros de resposta. |
||
| DBInstanceId |
string |
O ID da instância. |
rm-uf6wjk5**** |
| RequestId |
string |
O ID da solicitação. |
75BBF1EF-1E90-4950-BFFB-252D26E8259B |
Exemplos
Resposta de sucesso
JSON formato
{
"DBInstanceId": "rm-uf6wjk5****",
"RequestId": "75BBF1EF-1E90-4950-BFFB-252D26E8259B"
}
Códigos de erro
|
Código de status HTTP |
Código de erro |
Mensagem de erro |
Descrição |
|---|---|---|---|
| 400 | InvalidRestoreType.Format | Specified restore type is not valid. | O tipo de restauração especificado é inválido. Defina um tipo de restauração válido. |
| 400 | InvalidRestoreTime.Format | Specified restore time is not valid. | A operação falhou. O horário de restauração especificado é inválido. Defina um horário de restauração válido. |
| 400 | InvalidBakset.Invalid | Specified bakset is not valid. | O conjunto de backups especificado não oferece suporte a esta operação. |
| 400 | InvalidParamTableMetaForRestore.Content | new dbname or table in TableMeta cannot be same with old when restore to source instance | |
| 400 | InvalidParamTableMeta | Invalid parameter TableMeta is null or not json format | O parâmetro TableMeta é inválido. Verifique a validade deste parâmetro. |
| 400 | InvalidBakHistoryDO | BakHistory is inbalid when check restore TableMeta | |
| 400 | InvalidParamTableMeta.Content | TableMeta missing old dbname or new dbname, please check | Os metadados da tabela contêm nomes de tabela duplicados. |
| 400 | InvalidParamTableMeta.Duplicate | TableMeta has duplicate db or table with other newname, commons or system | A operação falhou. O banco de dados ou a tabela especificada para restauração já existe no banco de dados. |
| 400 | InvalidSourceRestoreDBName.NotFound | specific source restore dbname is not found in db list | A operação falhou. O banco de dados especificado a ser restaurado não existe no conjunto de backup. |
| 400 | InvalidDBName.Duplicate | Specified DB name already exists in the This instance. | O nome do banco de dados atual é inválido. Redefina o nome do banco de dados. |
| 400 | InvalidParameters.Format | Specified parameters is not valid. | A operação falhou. O formato do parâmetro especificado é inválido. |
| 400 | InvalidAvZone.Format | Specified AvZone is not valid. | A operação falhou. A zona está incorreta. Verifique e tente novamente. |
| 400 | InvalidRegion.Format | Specified Region is not valid. | A região especificada é inválida. Verifique se o parâmetro é válido. |
| 400 | InvalidVpcParameter | Specified VPCId VSwitchId or IPAddress or TunnelId is not valid. | A operação falhou. Verifique a correção dos parâmetros da VPC. |
| 400 | MissingUserID | The request is missing a user_id parameter. | O ID do usuário não existe. |
| 400 | MissingUID | The request is missing a uid parameter. | A operação falhou porque o UID está ausente na solicitação atual. |
| 400 | NoAvailableDisasterRestoreBakset | No available disaster restore bakset. | A operação falhou. Nenhum conjunto de recuperação está disponível. |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | Operações individuais não são permitidas para instâncias de pacote. |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | O resultado do preço do plano de preços não foi encontrado. |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | Você não concluiu a verificação de nome real e não está elegível para fazer uma compra. Faça login em Despesas e Custos para concluir a verificação de nome real. |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | O crédito disponível da sua conta é menor que 0. Recarregue sua conta antes de tentar fazer uma compra. |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | A chamada para o serviço de commodity retornou uma falha. |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | O Alibaba Cloud planeja otimizar e ajustar a região atual. Os serviços em nuvem nesta região serão descontinuados. Para garantir a continuidade dos seus negócios e uma migração de dados tranquila, você não pode fazer novos pedidos de compra no momento. Agradecemos sua compreensão e apoio. |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | O módulo adquirido é inválido. Adquira um módulo válido. |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | A região foi desativada. |
| 400 | Price.CommoditySys | Commodity system call exception. | Ocorreu uma exceção ao chamar o sistema de commodities. |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | O período de assinatura selecionado é inválido. Selecione um período de assinatura válido. |
| 400 | pay.noCreditCard | Account not bound to credit card. | A conta não está associada a um cartão de crédito. |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | Existe um pedido não pago para o serviço selecionado. Pague ou cancele o pedido antes de fazer um novo. |
| 400 | noAvailablePaymentMethod | No payment method is specified for your account. We recommend that you add a payment method. | Nenhum método de pagamento está especificado para a conta. Adicione um método de pagamento. |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | Suas informações básicas estão incompletas. Complete suas informações básicas antes de realizar esta operação. |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | Ocorreu uma exceção com a sua conta. Entre em contato com o atendimento ao cliente para obter detalhes. |
| 400 | Api.NotSupport | Specified api is not supported. | A operação de API atual não é suportada. |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | Existe uma tag de bloqueio de pedido. Entre em contato com seu distribuidor para obter assistência. |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | O DBInstanceId especificado não existe. |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | O tipo de instância atual não oferece suporte ao tipo de armazenamento especificado. |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | O parâmetro de entrada é inválido. |
| 400 | KmsApiError | User secret key invalid. | A chave do usuário é inválida. |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | Sua conta da Alibaba Cloud não existe ou sua AccessKey expirou. |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | A execução do comando SQL falhou ou expirou. |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | A versão atual do mecanismo DPI da instância não suporta o arquivamento de dados frios. |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | A versão atual do kernel não suporta o arquivamento de dados frios. |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | O tipo de instância atual não oferece suporte a esta operação. |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | O nome do endereço de conexão está duplicado. Reconfigure a string de conexão. |
| 400 | RequiredParam.NotFound | Required input param is not found. | Parâmetros obrigatórios estão ausentes. |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | O parâmetro está incorreto. Verifique o parâmetro. |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | O arquivamento de dados frios não oferece suporte a backup entre regiões ou backup de snapshot de alta frequência. Verifique a política de backup. |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | O status da instância não suporta esta operação. |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | A política de retenção de dados de backup arquivados após a liberação da instância é inválida. |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | O tipo de mecanismo de banco de dados da instância não oferece suporte a esta operação. |
| 400 | Pay.NoCreditCard | No credit cards. | |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | Esta operação não é suportada para instâncias do tipo de rede VPC. |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | A imagem da instância de banco de dados atual já existe. |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | O tipo de instância não está mais disponível para compra. |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | O banco de dados especificado não existe no conjunto de backup. |
| 400 | OrdTCommodityQueryError | Failed to query for product. | Falha ao consultar o produto. |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | A instância foi liberada. Verifique a instância antes de fazer o pedido. |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | A região foi desativada. |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | A solicitação para o serviço falhou. Tente novamente mais tarde. |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | A solicitação de serviço falhou. Tente novamente mais tarde ou entre em contato com o suporte. |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | A solicitação falhou porque o serviço da API do RDS apresentou falha. |
| 403 | IncorrectDBInstanceType | Current DB instance type does not support this operation. | A operação falhou. Esta operação não é suportada no status atual da instância. |
| 403 | IncorrectDBInstanceState | Current DB instance state does not support this operation. | O status da instância de proxy não está ativado. |
| 403 | ChildDBInstanceExists | Current DB instance had child instance. | A operação falhou. Já existe uma instância somente leitura. |
| 403 | InvalidBackupLogStatus | Current backup log enable status does not support this operation. | A operação falhou. O backup de log não está ativado. A restauração para um ponto no tempo não está disponível. |
| 403 | IncorrectBackupSetMethod | Current backup set method does not support operations. | A operação falhou. O conjunto de backup especificado não suporta a restauração de banco de dados e tabelas. |
| 403 | IncorrectBackupSetState | Current backup set state does not support operations. | A operação falhou. O status do conjunto de backup atual não suporta esta operação. |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | Existe um pedido não pago para a instância atual. Pague o pedido e tente novamente. |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | A capacidade de destino para redução de escala não pode ser menor que o uso de armazenamento atual. |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | Os discos em nuvem SSD não suportam esta operação. Faça upgrade para ESSD. |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | As permissões do usuário não suportam esta operação. |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | O VSwitchId especificado está em um formato incorreto ou está vazio. |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | A versão secundária atual do mecanismo não suporta esta operação. |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | Não há regiões de inventário disponíveis. |
| 403 | NotInFlowController | Sorry,no permission. | Este recurso está disponível apenas para usuários de nuvem corporativa. Você não tem as permissões necessárias. |
| 403 | InvalidKmsKey | Kms key is disabled. | A chave KMS está desativada. |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | O nível atual da instância de banco de dados não oferece suporte a esta operação. |
| 404 | RestoreType.NotFound | RestoreType is not found. | O tipo de restauração (RestoreType) não foi encontrado. |
| 404 | InvalidBackupSetID.NotFound | Specified backup set ID does not exist. | O conjunto de backup não existe. Visualize os conjuntos de backup existentes. |
| 404 | InsufficientResourceCapacity | There is insufficient capacity available for the requested instance. | |
| 404 | InvalidBackup.NotFound | The available backup does not exist in recovery time. | |
| 404 | InvalidBinlog.NotFound | The available binlog does not exist in recovery time. | O log binário no ponto de restauração especificado é inválido. |
| 404 | InvalidDB.NotFound | Specified db does not exist or DB status does not support. | O banco de dados especificado não existe ou o status do banco de dados não oferece suporte a esta operação. |
| 404 | InvalidDBInstance.NotFound | Specified instance does not exist or not support. | A instância especificada não foi encontrada. Verifique se a instância é válida. |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | A instância atual não está autorizada a acessar o Key Management Service (KMS). |
| 404 | Request.NotFound | The requested resource is not available. | O recurso solicitado não está disponível. |
| 404 | HostInfo.NotFound | The specified host info is not found. | As informações do host especificado não existem. |
Consulte Códigos de Erro para uma lista completa.
Notas de versão
Consulte Notas de Versão para uma lista completa.