Edita uma whitelist. Você pode chamar esta operação para criar, modificar ou excluir uma whitelist.
Descrição da operação
Mecanismos de banco de dados compatíveis
RDS MySQL
RDS PostgreSQL
RDS SQL Server
Experimente agora
Testar
Autorização RAM
|
Ação |
Nível de acesso |
Tipo de recurso |
Chave de condição |
Ação dependente |
|
rds:ModifyWhitelistTemplate |
update |
*全部资源
|
Nenhuma | Nenhuma |
Parâmetros da solicitação
|
Parâmetro |
Tipo |
Obrigatório |
Descrição |
Exemplo |
| IpWhitelist |
string |
Sim |
Os endereços IP em uma whitelist. Separe vários endereços IP com vírgulas (,). Cada endereço IP na whitelist deve ser único. As entradas na whitelist devem estar em um dos seguintes formatos:
Nota
: Um máximo de 1.000 endereços IP ou blocos CIDR podem ser adicionados para cada instância. Se você deseja adicionar um grande número de endereços IP, recomendamos que os agrupe em blocos CIDR, como 10.23.XX.XX/24. |
139.196.X.X,101.132.X.X |
| TemplateId |
integer |
Não |
O ID do modelo de whitelist. Este parâmetro é obrigatório quando você modifica ou exclui uma whitelist. Você pode chamar a operação DescribeAllWhitelistTemplate para obter o ID da whitelist. |
539 |
| TemplateName |
string |
Não |
O nome da whitelist de IP. Este parâmetro é obrigatório quando você cria uma whitelist. O valor deste parâmetro não pode ser modificado após a criação da whitelist. O valor deve ser exclusivo para uma conta Alibaba Cloud e começar com uma letra. Você pode chamar a operação DescribeWhitelistTemplate para obter o nome da whitelist. |
template_123 |
| RegionId |
string |
Não |
O ID da região. Você pode chamar a operação DescribeRegions para consultar a lista de regiões mais recente. |
cn-hangzhou |
| ResourceGroupId |
string |
Não |
O ID do grupo de recursos. Para mais informações sobre grupos de recursos, consulte a documentação relacionada. |
rg-acfmy**** |
Elementos de resposta
|
Elemento |
Tipo |
Descrição |
Exemplo |
|
object |
Os parâmetros de resposta. |
||
| Code |
string |
O código de resposta retornado. Valores válidos:
|
200 |
| Data |
object |
Os dados retornados. |
|
| Status |
string |
O código de status retornado. Valores válidos:
|
ok |
| HttpStatusCode |
integer |
O código de status HTTP retornado. Valores válidos:
|
200 |
| Message |
string |
A mensagem retornada. |
successful |
| RequestId |
string |
O ID da solicitação. |
08A3B71B-FE08-4B03-974F-CC7EA6DB1828 |
| Success |
boolean |
Indica se a solicitação foi bem-sucedida. Valores válidos:
|
true |
Exemplos
Resposta de sucesso
JSON formato
{
"Code": "200",
"Data": {
"Status": "ok"
},
"HttpStatusCode": 200,
"Message": "successful",
"RequestId": "08A3B71B-FE08-4B03-974F-CC7EA6DB1828",
"Success": true
}
Códigos de erro
|
Código de status HTTP |
Código de erro |
Mensagem de erro |
Descrição |
|---|---|---|---|
| 400 | InvalidIPList.Format | Specified IPList is not valid. | |
| 400 | InvalidParameter | Invalid parameter. | |
| 400 | InvalidWhitelistTemplateName.Duplicated | Whitelist template name duplicated. | |
| 400 | InvalidSecurityIPList.QuotaExceeded | Specified security IP list is not valid: Exceeding the allowed amount of IP address in the list. | |
| 400 | SecurityIPList.Format | Specified SecurityIPList is not valid. | |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | |
| 400 | Price.CommoditySys | Commodity system call exception. | |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | |
| 400 | pay.noCreditCard | Account not bound to credit card. | |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | |
| 400 | noAvailablePaymentMethod | No payment method is specified for your account. We recommend that you add a payment method. | |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | |
| 400 | Api.NotSupport | Specified api is not supported. | |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | |
| 400 | KmsApiError | User secret key invalid. | |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | |
| 400 | RequiredParam.NotFound | Required input param is not found. | |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | |
| 400 | Pay.NoCreditCard | No credit cards. | |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | |
| 400 | OrdTCommodityQueryError | Failed to query for product. | |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | |
| 401 | WhitelistIPLength.Forbidden | Whitelist ip length exceeeds the limit. | |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | |
| 403 | NotInFlowController | Sorry,no permission. | |
| 403 | InvalidKmsKey | Kms key is disabled. | |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | |
| 404 | WhitelistTemplateId.NotFound | Whitelist Template id not found. | |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | |
| 404 | Request.NotFound | The requested resource is not available. | |
| 404 | HostInfo.NotFound | The specified host info is not found. |
Consulte Códigos de Erro para uma lista completa.
Notas de versão
Consulte Notas de Versão para uma lista completa.