Todos os produtos
Search
Central de documentação

ApsaraDB RDS:ModifyPGHbaConfig

Última atualização: Jul 07, 2026

Modifica o arquivo pg_hba.conf de uma instância do ApsaraDB RDS for PostgreSQL.

Descrição da operação

Mecanismos de banco de dados compatíveis

RDS PostgreSQL.

Referências

Nota

: Antes de chamar esta operação, leia atentamente a documentação a seguir. Certifique-se de compreender totalmente os pré-requisitos e os impactos da chamada desta operação.

Experimente agora

Experimente esta API no OpenAPI Explorer, sem necessidade de assinatura manual. Chamadas bem-sucedidas geram automaticamente código SDK correspondente aos seus parâmetros. Faça o download com segurança de credenciais integrada para uso local.

Testar

Autorização RAM

A tabela abaixo descreve a autorização necessária para chamar esta API. Você pode defini-la em uma política do Resource Access Management (RAM). As colunas da tabela estão detalhadas abaixo:

  • Ação: As ações que podem ser usadas no elemento Action das instruções de política de permissão do RAM para conceder permissões para executar a operação.

  • API: A API que você pode chamar para executar a ação.

  • Nível de acesso: O nível de acesso predefinido concedido para cada API. Valores válidos: create, list, get, update e delete.

  • Tipo de recurso: O tipo de recurso que suporta autorização para executar a ação. Indica se a ação suporta permissão em nível de recurso. O recurso especificado deve ser compatível com a ação. Caso contrário, a política será ineficaz.

    • Para APIs com permissões em nível de recurso, os tipos de recursos obrigatórios são marcados com um asterisco (*). Especifique o Nome de Recurso Alibaba Cloud (ARN) correspondente no elemento Resource da política.

    • Para APIs sem permissões em nível de recurso, é exibido como Todos os Recursos. Use um asterisco (*) no elemento Resource da política.

  • Chave de condição: As chaves de condição definidas pelo serviço. A chave permite controle granular, aplicando-se somente a ações ou a ações associadas a recursos específicos. Além das chaves de condição específicas do serviço, o Alibaba Cloud fornece um conjunto de chaves de condição comuns aplicáveis a todos os serviços compatíveis com RAM.

  • Ação dependente: As ações dependentes necessárias para executar a ação. Para concluir a ação, o usuário RAM ou a função RAM deve ter permissões para executar todas as ações dependentes.

Ação

Nível de acesso

Tipo de recurso

Chave de condição

Ação dependente

rds:ModifyPGHbaConfig

update

*DBInstance

acs:rds:{#regionId}:{#accountId}:dbinstance/{#dbinstanceId}

  • rds:ResourceTag
Nenhuma

Parâmetros da solicitação

Parâmetro

Tipo

Obrigatório

Descrição

Exemplo

ClientToken

string

Não

Um parâmetro reservado. Você não precisa especificar este parâmetro.

1

DBInstanceId

string

Sim

O ID da instância. Você pode chamar a operação DescribeDBInstances para consultar o ID da instância.

pgm-bp1lymyn1v3i****

OpsType

string

Sim

O método usado para modificar o arquivo pg_hba.conf. Valores válidos:

  • add: adiciona um ou mais registros. Se você usar este método, certifique-se de que o valor do parâmetro PriorityId para cada novo registro seja diferente do valor do parâmetro PriorityId de qualquer registro existente.

  • delete: exclui um ou mais registros. Se você usar este método, o registro que corresponde ao valor especificado do parâmetro PriorityId será excluído do arquivo pg_hba.conf.

  • modify: modifica um ou mais registros. Se você usar este método, o registro que corresponde ao valor especificado do parâmetro PriorityId será modificado.

  • update: substitui a configuração existente no arquivo pg_hba.conf pela nova configuração.

add

HbaItem

array<object>

Sim

Uma matriz que consiste nos detalhes dos serviços de domínio AD.

object

Sim

Address

string

Sim

Os endereços IP a partir dos quais os usuários especificados podem acessar os bancos de dados especificados. Se você definir este parâmetro como 0.0.0.0/0, os usuários especificados terão permissão para acessar os bancos de dados especificados a partir de todos os endereços IP.

0.0.0.0/0

Database

string

Sim

O nome do banco de dados. Se você definir este parâmetro como all, os usuários especificados terão permissão para acessar todos os bancos de dados na instância.

Se você especificar várias entradas, separe-as com vírgulas (,).

all

Mask

string

Não

A máscara do endereço IP. Se o valor do parâmetro Address for um endereço IP, você poderá usar este parâmetro para especificar a máscara do endereço IP.

0

Method

string

Sim

O método de autenticação. Valores válidos:

  • trust

  • reject

  • scram-sha-256

  • md5

  • password

  • gss

  • sspi

  • ldap

  • radius

  • cert

  • pam

ldap

Option

string

Não

As opções do método de autenticação. Neste tópico, o LDAP é usado como exemplo. Você deve configurar este parâmetro. Para obter mais informações, consulte Métodos de autenticação.

ldapserver=192.168.XX.XX ldapbasedn="CN=Users,DC=pgsqldomain,DC=net" ldapbinddn="CN=pgadminuser,CN=Users,DC=pgsqldomain,DC=net" ldapbindpasswd="Test123!" ldapsearchattribute="sAMAccountName"

PriorityId

integer

Sim

A prioridade do registro. Se você definir este parâmetro como 0, o registro terá a prioridade mais alta. Valores válidos: 0 a 10000.

Este parâmetro é usado para identificar cada registro. Ao adicionar um registro, o valor do parâmetro PriorityId para o novo registro deve ser diferente do valor do parâmetro PriorityId de qualquer registro existente. Ao modificar ou excluir um registro, você também deve modificar ou excluir o valor do parâmetro PriorityId para esse registro.

2

Type

string

Sim

O tipo de conexão.

Valores válidos:

  • host: O registro corresponde a conexões TCP/IP, incluindo conexões SSL e conexões não SSL.

  • hostssl: O registro corresponde apenas a conexões TCP/IP estabelecidas por SSL.

  • hostnossl: O registro corresponde apenas a conexões TCP/IP que não são estabelecidas por conexões SSL.

Nota

Você pode definir este parâmetro como hostssl somente quando a criptografia SSL estiver ativada para a instância. Para obter mais informações, consulte Configurar criptografia SSL para uma instância do ApsaraDB RDS for PostgreSQL.

host

User

string

Sim

O usuário que tem permissão para acessar os bancos de dados especificados. Você deve especificar o usuário usado para fazer login na instância RDS. Se você especificar várias entradas, separe-as com vírgulas (,).

ldapuser

Elementos de resposta

Elemento

Tipo

Descrição

Exemplo

object

Os parâmetros de resposta.

RequestId

string

O ID da solicitação.

458E0781-C46C-55F5-A0E5-1DD284B28A3F

Exemplos

Resposta de sucesso

JSON formato

{
  "RequestId": "458E0781-C46C-55F5-A0E5-1DD284B28A3F"
}

Códigos de erro

Código de status HTTP

Código de erro

Mensagem de erro

Descrição

400 HbaItem.InvalidType Specified hba item type is invalid.
400 HbaItem.InvalidMethod Specified hba item auth method is invalid.
400 HbaItem.InvalidIPMask Specified hba item ip mask is invalid.
400 HbaItem.InvalidPriority Specified hba item priorityId is out of range or duplicate.
400 HbaItemOpsType.Invalid Specified hba opsType is invalid.
400 InvalidConfigValue The ConfigValue is not valid
400 MinorVersionNotSupport The current database minor version does not support the operation.
400 InvalidDBInstanceName.NotFound The specified DB instance name does not exist.
400 IncorrectDBInstanceType Current DB instance type does not support this operation.
400 InvalidIP.Format The specified IP address is illegal or invalid.
400 Order.ComboInstanceNotAllowOperate A package instance is not allowed to operate independently.
400 Price.PricingPlanResultNotFound Pricing plan price result not found.
400 Order.NoRealNameAuthentication You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication.
400 InsufficientAvailableQuota Your account quota limit is less than 0, please recharge before trying to purchase.
400 CommodityServiceCalling.Exception Failed to call commodity service.
400 RegionDissolvedEOM Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support.
400 Commodity.InvalidComponent The module you purchased is not legal, please buy it again.
400 RegionEndTimeDissolvedAustralia Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024.
400 Price.CommoditySys Commodity system call exception.
400 Pay.InsufficientBalance Insufficient available balance.
400 Order.PeriodInvalid There is a problem with the period you selected, please choose again.
400 pay.noCreditCard Account not bound to credit card.
400 Order.InstHasUnpaidOrder There is an unpaid order for the service you have purchased. Please pay or void it before placing the order.
400 noAvailablePaymentMethod No payment method is specified for your account. We recommend that you add a payment method.
400 BasicInfoUncompleted Your information is incomplete. Complete your information before the operation.
400 Risk.RiskControlRejection Your account is abnormal, please contact customer service for details.
400 Api.NotSupport Specified api is not supported.
400 ContainForbiddenLabelError There is a label that prohibits placing orders. Please contact your distributor for assistance.
400 InvalidDBInstanceId.NotFound The DBInstanceId provided does not exist in records.
400 InvalidInstanceLevel.DiskType Specified instance level not support request disk type
400 InvalidParam Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica.
400 KmsApiError User secret key invalid.
400 System.SaleValidateFailed Sales expression validation system error.
400 Abs.InvalidAccount.NotFound account is not found.
400 SqlExecuteFailedOrTimeout sql command execution failed or timed out:%s.
400 ColdData.EngineVersionNotSupport The current instance engine version not support coldDataEnabled.
400 ColdData.MinorVersionNotSupport The current instance minor version not support coldDataEnabled.
400 IncorrectTargetClasscode The current instance type does not support this operation.
400 InvalidConnectionString.Duplicate Specified connection string already exists in the RDS.
400 RequiredParam.NotFound Required input param is not found.
400 Parameters.Invalid Parameter error, please check the parameters.
400 BackupPolicyNotSupport Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy.
400 InvalideStatus.Format The instance status does not support this operation.
400 InvalidReleasedKeepPolicy.Format Specified Released Keep Policy is not valid.
400 InvalidDBInstanceEngineType.Format the DB instance engine type does not support this operation.
400 Pay.NoCreditCard No credit cards.
400 VpcNetworkTypeNotSupport The vpc network type instance does not support this operation.
400 MirrorInsExists Specified DB instance mirror ins already existed.
400 UnsupportedClassCode The specified DB instance class stops selling.
400 InvalidBackupSet The specified database does not exist in the backup set.
400 OrdTCommodityQueryError Failed to query for product.
400 ProductInstanceReleased The instance has been released. Please check before placing the order.
400 RegionEndTimeDissolvedIndia The region is no longer supported.
500 ExternalFailure The request processing has failed due to external service failure.
500 RequestMetaDataFailed The service request failed. Please try again later or contact service personnel.
500 InvokeProxyFailure The request processing has failed due to service failure of rds api.
403 HbaItemPriorityIdAlreadyExist Specified hba item priorityId is exist.
403 IncorrectDBInstanceState Current DB instance state does not support this operation.
403 OrderStatus.UnPaid The specified db instance has unpaid order.
403 InvalidReduceDiskSize The storage capacity after the scale-down must be larger than the used amount.
403 CloudSSDNotSupport Cloud ssd does not support this operation, please upgrade to essd.
403 InvalidUserOperatorPermission The user permission does not support this operation.
403 InvalidVswitchId Specified conn vswitch id is not valid.
403 IncorrectMinorVersion Current engine minor version does not support operations.
403 OperationDenied.ZoneResource There is no available zone for inventory.
403 NotInFlowController Sorry,no permission.
403 InvalidKmsKey Kms key is disabled.
403 InvalidInstanceLevel.Malformed Current DB instance level does not support this operation.
404 HbaItemPriorityIdNotFound Specified hba item priorityId is not found.
404 IncorrectDBInstanceLockMode Current DB instance lock mode does not support this operation.
404 InvalidClusterKms The current instance does not authorized to access the Key Management Service.
404 Request.NotFound The requested resource is not available.
404 HostInfo.NotFound The specified host info is not found.

Consulte Códigos de Erro para uma lista completa.

Notas de versão

Consulte Notas de Versão para uma lista completa.