Modifica o modelo de parâmetros de uma instância.
Descrição da operação
Experimente agora
Testar
Autorização RAM
|
Ação |
Nível de acesso |
Tipo de recurso |
Chave de condição |
Ação dependente |
|
rds:ModifyParameterGroup |
update |
*全部资源
|
Nenhuma | Nenhuma |
Parâmetros da solicitação
|
Parâmetro |
Tipo |
Obrigatório |
Descrição |
Exemplo |
| ParameterGroupId |
string |
Sim |
O ID do modelo de parâmetros. Você pode chamar a operação DescribeParameterGroups para consultar o ID do modelo de parâmetros. |
rpg-13ppdh**** |
| ParameterGroupName |
string |
Não |
O nome do modelo de parâmetros.
Nota
Se você não especificar este parâmetro, o nome original do modelo de parâmetros será mantido. |
testgroup1 |
| ParameterGroupDesc |
string |
Não |
A nova descrição do modelo de parâmetros. A descrição pode ter até 200 caracteres de comprimento. Nota
Se você não especificar este parâmetro, a descrição original do modelo de parâmetros será mantida. |
test |
| Parameters |
string |
Não |
Uma string JSON que consiste em parâmetros e seus valores no modelo de parâmetros. Formato: {"Parâmetro 1":"Valor do Parâmetro 1","Parâmetro 2":"Valor do Parâmetro 2"...}. Para obter mais informações sobre os parâmetros que podem ser modificados, consulte Modificar os parâmetros de uma instância do ApsaraDB RDS for MySQL ou Modificar os parâmetros de uma instância do ApsaraDB RDS for PostgreSQL. Nota
|
{"back_log":"3000"} |
| RegionId |
string |
Sim |
O ID da região. Você pode chamar a operação DescribeRegions para consultar a lista de regiões mais recente. Nota
A região de um modelo de parâmetros não pode ser alterada. Você pode chamar a operação CloneParameterGroup para replicar um modelo de parâmetros para uma região específica. |
cn-hangzhou |
| ModifyMode |
string |
Não |
O modo de modificação do modelo de parâmetros. Valores válidos:
Nota
Se você definir o parâmetro ModifyMode como Collectivity, o sistema adicionará o valor do parâmetro Parameters ao modelo de parâmetros original ou modificará os parâmetros correspondentes no modelo de parâmetros original. Outros parâmetros no modelo de parâmetros original não serão afetados.
Nota
Se você definir o parâmetro ModifyMode como Individual, o sistema usará o valor do parâmetro Parameters para substituir as configurações de parâmetros no modelo de parâmetros original. |
Collectivity |
| ResourceGroupId |
string |
Não |
O ID do grupo de recursos. Você pode chamar a operação DescribeDBInstanceAttribute para consultar o ID do grupo de recursos. |
rg-acfmy**** |
Elementos de resposta
|
Elemento |
Tipo |
Descrição |
Exemplo |
|
object |
Os parâmetros de resposta. |
||
| ParameterGroupId |
string |
O ID do modelo de parâmetros. |
rpg-13ppdh**** |
| RequestId |
string |
O ID da solicitação. |
857DC00B-7B85-4853-8B27-AD65EB618BC6 |
Exemplos
Resposta de sucesso
JSON formato
{
"ParameterGroupId": "rpg-13ppdh****",
"RequestId": "857DC00B-7B85-4853-8B27-AD65EB618BC6"
}
Códigos de erro
|
Código de status HTTP |
Código de erro |
Mensagem de erro |
Descrição |
|---|---|---|---|
| 400 | InvalidParameters.Malformed | The specified parameter "Parameters" is not valid. | |
| 400 | ParamGroupsNotExist | This paramGroups not exist | |
| 400 | %s |
The following parameters are prohibited: %s |
|
| 400 | ParamGroupsNameInvalid | The parameter group name is invalid. | |
| 400 | InvalidParameterGroupId.Malformed | Specified parameterGroupId is not valid. | |
| 400 | ParamGroupsNotExistOrTypeNotSupport | The parameter group does not exist or its type is not supported. | |
| 400 | ParamNotExist | This param Not Exist | |
| 400 | ParamTypeError | The parameter type error. | |
| 400 | ParamGroupsDescInvalid | The maximum length of parameter group description is exceeded. | |
| 400 | InvalidParameterValue.NotStandard | Invalid parameter format. | |
| 400 | InvalidParameters.Prohibited | Specified parameter is not valid: %s. | |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | |
| 400 | Price.CommoditySys | Commodity system call exception. | |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | |
| 400 | pay.noCreditCard | Account not bound to credit card. | |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | |
| 400 | noAvailablePaymentMethod | No payment method is specified for your account. We recommend that you add a payment method. | |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | |
| 400 | Api.NotSupport | Specified api is not supported. | |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | |
| 400 | KmsApiError | User secret key invalid. | |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | |
| 400 | RequiredParam.NotFound | Required input param is not found. | |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | |
| 400 | Pay.NoCreditCard | No credit cards. | |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | |
| 400 | OrdTCommodityQueryError | Failed to query for product. | |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | |
| 403 | NotInFlowController | Sorry,no permission. | |
| 403 | InvalidKmsKey | Kms key is disabled. | |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | |
| 404 | Request.NotFound | The requested resource is not available. | |
| 404 | HostInfo.NotFound | The specified host info is not found. |
Consulte Códigos de Erro para uma lista completa.
Notas de versão
Consulte Notas de Versão para uma lista completa.