Modifica as configurações de conexão de um endpoint de proxy de banco de dados.
Descrição da operação
Experimente agora
Testar
Autorização RAM
|
Ação |
Nível de acesso |
Tipo de recurso |
Chave de condição |
Ação dependente |
|
rds:ModifyDBProxyEndpoint |
update |
*DBInstance
|
|
Nenhuma |
Parâmetros da solicitação
|
Parâmetro |
Tipo |
Obrigatório |
Descrição |
Exemplo |
| DBInstanceId |
string |
Sim |
O ID da instância. Você pode chamar a operação DescribeDBInstances para consultar o ID da instância. |
rm-bp145737x5bi6**** |
| DBProxyEndpointId |
string |
Não |
O ID do endpoint de proxy. Você pode chamar a operação DescribeDBProxyEndpoint para consultar o ID do endpoint de proxy. Nota
|
gos787jog2wk0y**** |
| ConfigDBProxyFeatures |
string |
Não |
Os recursos que você deseja ativar para o endpoint de proxy. Se você especificar mais de um recurso, separe-os com ponto e vírgula (;). Formato: Valores válidos de recursos:
Valores de status válidos:
Nota
|
ReadWriteSpliting:1;ConnectionPersist:0 |
| RegionId |
string |
Não |
O ID da região. Você pode chamar a operação DescribeRegions para consultar a lista de regiões mais recente. |
cn-hangzhou |
| ReadOnlyInstanceMaxDelayTime |
string |
Não |
O limite máximo de latência permitido para a divisão de leitura e gravação. Se a latência em uma instância somente leitura exceder o limite especificado, o sistema não encaminhará mais solicitações de leitura para a instância somente leitura. Se você não especificar este parâmetro, o valor original deste parâmetro será mantido. Valores válidos: 0 a 3600. Nota
|
30 |
| CausalConsistReadTimeout |
string |
Não |
O período de tempo limite de leitura de consistência. Unidade: milissegundos. Valor padrão: 10 Unidade: milissegundos. Valores válidos: 0 a 60000 |
10 |
| ReadOnlyInstanceDistributionType |
string |
Não |
A política usada para alocar pesos de leitura. Valores válidos:
Nota
Você deve especificar este parâmetro quando a divisão de leitura e gravação estiver ativada. Para obter mais informações sobre a política de alocação de permissões, consulte Modificar o limite de latência e os pesos de leitura das instâncias do ApsaraDB RDS for MySQL e Ativar e configurar o recurso de proxy de banco de dados para uma instância do ApsaraDB RDS for PostgreSQL. |
Standard |
| ReadOnlyInstanceWeight |
string |
Não |
Os pesos de leitura da instância e de suas instâncias somente leitura. Um peso de leitura deve ser um múltiplo de 100 e não pode exceder 10000. Formatos:
|
{"rm-uf6wjk5****":"500","rr-tfhfgk5xxx":"200"...} |
| DBInstanceId |
string |
Sim |
O ID da instância. Você pode chamar a operação DescribeDBInstances para consultar o ID da instância. |
rm-bp145737x5bi6**** |
| DbEndpointOperator |
string |
Não |
O tipo de operação que você deseja realizar. Valores válidos:
|
Modify |
| DbEndpointAliases |
string |
Não |
A descrição do terminal de proxy. |
test-proxy |
| DbEndpointType |
string |
Não |
O tipo do terminal de proxy. Este é um parâmetro reservado. Você não precisa especificar este parâmetro. |
RWSplit |
| DbEndpointReadWriteMode |
string |
Não |
Os atributos de leitura e gravação do terminal de proxy. Valores válidos:
Nota
|
ReadWrite |
| DBProxyEngineType |
string |
Não |
Um parâmetro obsoleto. Você não precisa especificar este parâmetro. |
normal |
| VSwitchId |
string |
Não |
O ID do vSwitch na zona em que o endpoint de proxy é especificado. O valor padrão é o ID do vSwitch que corresponde ao terminal padrão do proxy de banco de dados. Você pode chamar a operação DescribeVSwitches para consultar os vSwitches existentes. |
vsw-uf6adz52c2p**** |
| EffectiveTime |
string |
Não |
O horário de vigência. Valores válidos:
Valor padrão: MaintainTime. |
MaintainTime |
| EffectiveSpecificTime |
string |
Não |
O ponto no tempo que você deseja especificar. Especifique o horário no padrão ISO 8601 no formato aaaa-MM-ddTHH:mm:ssZ. O horário deve estar em UTC. Nota
Se EffectiveTime estiver definido como SpecificTime, você deverá especificar este parâmetro. |
2023-05-06T07:08:09Z |
| DbEndpointMinSlaveCount |
string |
Não |
O número mínimo de instâncias reservadas. |
2 |
| VpcId |
string |
Não |
The VPC ID of the zone in which the proxy endpoint is specified. The default value is the VPC ID that corresponds to the default terminal of the database proxy. You can call the DescribeDBInstanceAttribute operation to query the default VPC of an instance. |
vpc-2zeusejj****** |
Elementos de resposta
|
Elemento |
Tipo |
Descrição |
Exemplo |
|
object |
Os parâmetros de resposta. |
||
| RequestId |
string |
O ID da solicitação. |
6B50D92C-1960-4D4F-A290-AFADD6B1A5C8 |
Exemplos
Resposta de sucesso
JSON formato
{
"RequestId": "6B50D92C-1960-4D4F-A290-AFADD6B1A5C8"
}
Códigos de erro
|
Código de status HTTP |
Código de erro |
Mensagem de erro |
Descrição |
|---|---|---|---|
| 400 | InvalidVpcInstanceId | The specified VPC instance ID is invalid. | |
| 400 | InvalidEndPoint.Format | The specified EndPoint is not valid. | |
| 400 | InvalidEndpointType.Format | The specified EndpointType is invalid. | The value of the EndpointType parameter is invalid. Check the value of this parameter. |
| 400 | IncorrectDBInstanceNetType | The current database instance network type does not support the operation. | The operation failed. The operation is not supported for the network type of the RDS instance. |
| 400 | EndpointNum.Error | The number of endpoint is invalid. | The number of proxy terminals is not supported. Check the maximum number of proxy terminals that are allowed. |
| 400 | EndpointTypeOperation.NotSupport | The endpoint type does not support the operation. | The operation is not supported for the type of proxy terminal that you configure. |
| 400 | InvalidDBInstanceName | Specified parameter DBInstanceName is not valid. | The value of the DBInstanceName parameter is invalid. Check that the value of this parameter is not null or an empty string. |
| 400 | ClusterEndpoint.StatusNotValid | The cluster endpoint status is invalid. | The status of the endpoint is invalid. |
| 400 | MaxscaleNotSupport | Current custins can not support Maxscale. | This operation is not supported for instances with maxscale. |
| 400 | InvalidAvZone.Format | Specified AvZone is not valid. | The value of the AvZone parameter is invalid. Check the value of this parameter. |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | A package instance is not allowed to operate independently. |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | Pricing plan price result not found. |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the cost and cost for real-name authentication. |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | Your account available limit is less than 0, please recharge before trying to purchase. |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | Failed to call commodity service return. |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | Hello, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will stop operating. In order to ensure your business continuity and smooth transition of data migration, you are currently unable to operate new purchase orders. Thank you for your understanding and support. |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | The module you purchased is not legal, please buy it again. |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | Hello customer, this area has been abolished. |
| 400 | Price.CommoditySys | Commodity system call exception. | Commodity system call exception. |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | Insufficient available balance. |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | There is a problem with the period you selected, please choose again. |
| 400 | pay.noCreditCard | Account not bound to credit card. | |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. |
| 400 | noAvailablePaymentMethod | No payment method is specified for your account. We recommend that you add a payment method. | No payment method has been specified for your account. We recommend that you add a payment method. |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | Your basic information is not complete, please complete your basic information before operation. |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | Your account is abnormal, please contact customer service for details. |
| 400 | Api.NotSupport | Specified api is not supported. | The current interface does not support. |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | You cannot place the order because a tag indicates that order placement is prohibited. Contact your distributor. |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | The DBInstanceId provided does not exist. |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | The current instance type does not support the specified storage type. |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | The specified wal_level parameter is invalid. There is still a copy slot in the instance, so it cannot be set to replica. |
| 400 | KmsApiError | User secret key invalid. | The user key is invalid. |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | A system error occurs when the sales expression is verified. |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | The account does not exist. |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | SQL command execution failed or timed out |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | The current instance engine version not support coldDataEnabled. |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | The current instance minor version not support coldDataEnabled. |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | This operation is not supported by the instance type. |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | The link address name is duplicate. Please reset the connection string. |
| 400 | RequiredParam.NotFound | Required input param is not found. | |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | Parameter error, please check the parameters. |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | Specified Released Keep Policy is not valid. |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | This operation is not supported for the database engine of the instance. |
| 400 | Pay.NoCreditCard | No credit cards. | No credit cards. |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | The vpc network type instance does not support this operation. |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | Specified DB instance mirror ins already existed. |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | The specified DB instance class stops selling. |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | The specified database does not exist in the backup set. |
| 400 | OrdTCommodityQueryError | Failed to query for product. | Failed to query product. |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | The instance has been released, please verify and place an order. |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | The region is no longer supported. |
| 400 | APICallingFailed | Api calling failed. | An internal error occurred. |
| 400 | InvalidVSwitchId.Format | The specified vswitch Id format is incorrect. | |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | The request processing has failed due to external service failure. |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | The service request failed. Please try again later or contact service personnel. |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | The request failed to be processed due to an RDS API failure. |
| 403 | MaxScaleLevel.NotSupport | The current maxscale ins_num does not support this operation. | The operation failed. The specifications of the database proxy are low. |
| 403 | ReadDBInstance.NotFound | The current database instance does not contain any read only instance. | The current database instance does not have a read-only instance. |
| 403 | IncorrectKindCode | The current KindCode of the custins does not support the operation. | |
| 403 | IncorrectDBInstanceState | The current database instance state does not support the operation. | The operation failed. The RDS instance is not running. |
| 403 | IncorrectDBInstanceEngine | Current DB Instance engine does not support this operation. | The operation failed. The operation is not supported for the database engine that is run on the RDS instance. |
| 403 | IncorrectDBInstanceType | Current DB instance type does not support this operation. | The operation failed. The RDS instance is not in a ready state. |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | The instance has an unpaid order. Please pay first and try again. |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | The scale-in target capacity cannot be less than the current storage space usage |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | The user is not authorized to perform this operation. |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | This operation is not supported for the current minor engine version. |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | There is no available zone for inventory. |
| 403 | NotInFlowController | Sorry,no permission. | Sorry,no permission. |
| 403 | InvalidKmsKey | Kms key is disabled. | |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | The specified database instance type does not support this operation. |
| 404 | EndpointConfig.Invalid | Please check the endpoint config parameter. | Please check the endpoint configuration parameter. |
| 404 | Readins.NotFound | The current instance does not contain any read only instance. The operation is not supported. | The operation failed. The RDS instance is not attached with read-only RDS instances. |
| 404 | Endpoint.NotFound | Specified endpoint is not found. | The port that is associated with the dedicated proxy endpoint cannot be found. |
| 404 | EndpointType.NotFound | The specified endpoint type is not found. | The operation failed. Unknown types of proxy terminals are detected. |
| 404 | InvalidReadDBInstance.NotFound | The specified read only database instance does not exist. | The read-only RDS instance is not created, or the values of the request parameters are invalid. |
| 404 | InvalidParam | The specified Weight is invalid. | The weight is invalid. |
| 404 | Maxscale.NotFound | The related maxscale instance is not found. | The operation failed. No associated MaxScale instances can be found. |
| 404 | IncorrectVswitchId | The specified parameter VSwitchId is not valid. | The vSwitch ID is invalid. |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | The instance does not have permissions to access Key Management Service (KMS). |
| 404 | Request.NotFound | The requested resource is not available. | The requested resources are unavailable. |
| 404 | HostInfo.NotFound | The specified host info is not found. |
Consulte Códigos de Erro para uma lista completa.
Notas de versão
Consulte Notas de Versão para uma lista completa.