Todos os produtos
Search
Central de documentação

ApsaraDB RDS:ModifyDBProxy

Última atualização: Jul 07, 2026

Ativa ou modifica o recurso de proxy de banco de dados para uma instância.

Descrição da operação

Mecanismos de banco de dados compatíveis

  • MySQL

  • PostgreSQL

Nota

A partir de 17 de outubro de 2023, as instâncias do ApsaraDB RDS for MySQL que executam o RDS Cluster Edition oferecem um proxy de banco de dados dedicado gratuito para cada unidade em fases. Para mais informações, consulte [Ofertas especiais/Alterações de preço] Um proxy dedicado é fornecido gratuitamente para instâncias do ApsaraDB RDS for MySQL no RDS Cluster Edition.

Referências

Nota

Antes de chamar esta operação, leia os tópicos a seguir e certifique-se de que compreende totalmente os pré-requisitos e os impactos desta operação.

Experimente agora

Experimente esta API no OpenAPI Explorer, sem necessidade de assinatura manual. Chamadas bem-sucedidas geram automaticamente código SDK correspondente aos seus parâmetros. Faça o download com segurança de credenciais integrada para uso local.

Testar

Autorização RAM

A tabela abaixo descreve a autorização necessária para chamar esta API. Você pode defini-la em uma política do Resource Access Management (RAM). As colunas da tabela estão detalhadas abaixo:

  • Ação: As ações que podem ser usadas no elemento Action das instruções de política de permissão do RAM para conceder permissões para executar a operação.

  • API: A API que você pode chamar para executar a ação.

  • Nível de acesso: O nível de acesso predefinido concedido para cada API. Valores válidos: create, list, get, update e delete.

  • Tipo de recurso: O tipo de recurso que suporta autorização para executar a ação. Indica se a ação suporta permissão em nível de recurso. O recurso especificado deve ser compatível com a ação. Caso contrário, a política será ineficaz.

    • Para APIs com permissões em nível de recurso, os tipos de recursos obrigatórios são marcados com um asterisco (*). Especifique o Nome de Recurso Alibaba Cloud (ARN) correspondente no elemento Resource da política.

    • Para APIs sem permissões em nível de recurso, é exibido como Todos os Recursos. Use um asterisco (*) no elemento Resource da política.

  • Chave de condição: As chaves de condição definidas pelo serviço. A chave permite controle granular, aplicando-se somente a ações ou a ações associadas a recursos específicos. Além das chaves de condição específicas do serviço, o Alibaba Cloud fornece um conjunto de chaves de condição comuns aplicáveis a todos os serviços compatíveis com RAM.

  • Ação dependente: As ações dependentes necessárias para executar a ação. Para concluir a ação, o usuário RAM ou a função RAM deve ter permissões para executar todas as ações dependentes.

Ação

Nível de acesso

Tipo de recurso

Chave de condição

Ação dependente

rds:ModifyDBProxy

update

*DBInstance

acs:rds:{#regionId}:{#accountId}:dbinstance/{#dbinstanceId}

  • rds:ResourceTag
  • rds:InstanceNetworkType
Nenhuma

Parâmetros da solicitação

Parâmetro

Tipo

Obrigatório

Descrição

Exemplo

DBInstanceId

string

Sim

O ID da instância. Você pode chamar a operação DescribeDBInstances para consultar o ID da instância.

rm-uf6wjk5****

ConfigDBProxyService

string

Sim

Especifica se o recurso de proxy de banco de dados deve ser ativado ou desativado. Valores válidos:

  • Startup: ativa o recurso.

  • Shutdown: desativa o recurso.

  • Modify: modifica a configuração do recurso.

Startup

DBProxyInstanceNum

string

Não

O número de instâncias de proxy ativadas. Valores válidos: 1 a 16. Valor padrão: 1.

Nota

A capacidade do proxy de banco de dados de processar solicitações aumenta com o número de instâncias de proxy ativadas. Você pode monitorar a carga na instância e especificar um número apropriado de instâncias de proxy com base nos dados de monitoramento de carga.

1

RegionId

string

Não

O ID da região. Você pode chamar a operação DescribeRegions para consultar a lista de regiões mais recente.

cn-hangzhou

InstanceNetworkType

string

Não

O tipo de rede da instância. Somente o tipo de rede VPC é compatível. Defina o valor como VPC.

Nota

Se você ativar o recurso de proxy de banco de dados para a instância, deverá especificar este parâmetro.

VPC

VPCId

string

Não

O ID da virtual private cloud (VPC) à qual a instância pertence. Você pode chamar a operação DescribeDBInstanceAttribute para consultar o ID.

Nota

Se você ativar o recurso de proxy de banco de dados para a instância, deverá especificar este parâmetro.

vpc-****

VSwitchId

string

Não

O ID do vSwitch ao qual a instância pertence. Você pode chamar a operação DescribeDBInstanceAttribute para consultar o ID.

Nota

Se você ativar o recurso de proxy de banco de dados para a instância, deverá especificar este parâmetro.

vsw-****

DBProxyEngineType

string

Não

Um parâmetro obsoleto. Você não precisa especificar este parâmetro.

normal

DBProxyInstanceType

string

Não

O tipo de proxy de banco de dados. Valores válidos:

  • common: proxy de banco de dados de uso geral

  • exclusive (padrão): proxy de banco de dados dedicado

exclusive

DBInstanceId

string

Sim

O ID da instância. Você pode chamar a operação DescribeDBInstances para consultar o ID da instância.

rm-uf6wjk5****

ResourceGroupId

string

Não

O ID do grupo de recursos.

rg-acfmy****

PersistentConnectionStatus

string

Não

Especifica se as conexões persistentes devem ser ativadas. Valores válidos:

  • Enabled

  • Disabled

Nota
  • Este parâmetro está disponível apenas para instâncias que executam MySQL.

  • Se você deseja modificar as conexões persistentes, deve definir o parâmetro ConfigDBProxyService como Modify.

Disabled

DBProxyNodes

array<object>

Não

Os nós de proxy.

object

Não

Os detalhes do nó de proxy.

cpuCores

string

Não

O número de núcleos de CPU do nó. Valores válidos: 1 a 16.

Nota

Este parâmetro é obrigatório quando você configura o parâmetro DBProxyNodes.

1

nodeCounts

string

Não

O número de nós de proxy na zona. Valores válidos: 1 e 2.

Nota

Este parâmetro é obrigatório quando você configura o parâmetro DBProxyNodes.

2

zoneId

string

Não

O ID da zona na qual o nó reside.

Nota

Este parâmetro é obrigatório quando você configura o parâmetro DBProxyNodes.

cn-hangzhou-c

Elementos de resposta

Elemento

Tipo

Descrição

Exemplo

object

Os parâmetros de resposta.

RequestId

string

O ID da solicitação.

FC452BB1-EED8-4278-95C7-0324B3710DF1

Exemplos

Resposta de sucesso

JSON formato

{
  "RequestId": "FC452BB1-EED8-4278-95C7-0324B3710DF1"
}

Códigos de erro

Código de status HTTP

Código de erro

Mensagem de erro

Descrição

400 MaxscaleAlreadyExist The Maxscale is already existed. The specified Maxscale already exists.
400 MaxscaleNotSupport Maxscale not supported Dedicated proxy is not supported by the instance. Please check the configuration information about enabling dedicated proxy.
400 NetWork.NotFound NetWork.NotFound The network is unavailable.
400 InvalidVpcParameter Either VPC ID or vSwitch ID is incorrect. Please check again. The operation failed. Check the value of the VPCId parameter.
400 MaxscaleInternalError Database proxy status is CLASS_CHANGING. The specifications of the database proxy are being changed. Restart the RDS instance later.
400 InvalidDBInstanceName Specified parameter DBInstanceName is not valid. The value of the DBInstanceName parameter is invalid. Check that the value of this parameter is not null or an empty string.
400 InvalidOptimizationCategory.Format Specified optimization category is not valid. The specified OptimizationCategory parameter is invalid.
400 MinorVersionNotSupport The current database minor version does not support the operation. The current instance kernel iteration does not support this operation. You can upgrade the kernel iteration.
400 InvalidParameters.Format Specified parameter is not valid The operation failed. The values of some parameters are invalid.
400 InvalidTunnelId Specified conn tunnel is not valid.
400 InvalidRegion.Format Specified Region is not valid. The region ID is invalid. Check the region ID.
400 InvalidDBProxyNodes.General general-purpose proxy does not support more than 2 nodes. Generic proxy does not support more than 2 nodes.
400 InvalidDBProxyNodes.ZoneIdAndNodeCounts The number of node count and zone count is mismatch. The number of zones or nodes is invalid.
400 InvalidDBProxyNodes.ZoneId The number of zone is request 1 or 2. The ZoneId of the DBProxyNodes field can only be one or two zones.
400 Order.ComboInstanceNotAllowOperate A package instance is not allowed to operate independently. A package instance is not allowed to operate independently.
400 Price.PricingPlanResultNotFound Pricing plan price result not found. Pricing plan price result not found.
400 Order.NoRealNameAuthentication You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the cost and cost for real-name authentication.
400 InsufficientAvailableQuota Your account quota limit is less than 0, please recharge before trying to purchase. Your account available limit is less than 0, please recharge before trying to purchase.
400 CommodityServiceCalling.Exception Failed to call commodity service. Failed to call commodity service return.
400 RegionDissolvedEOM Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. Hello, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will stop operating. In order to ensure your business continuity and smooth transition of data migration, you are currently unable to operate new purchase orders. Thank you for your understanding and support.
400 Commodity.InvalidComponent The module you purchased is not legal, please buy it again. The module you purchased is not legal, please buy it again.
400 RegionEndTimeDissolvedAustralia Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. Hello customer, this area has been abolished.
400 Price.CommoditySys Commodity system call exception. Commodity system call exception.
400 Pay.InsufficientBalance Insufficient available balance. Insufficient available balance.
400 Order.PeriodInvalid There is a problem with the period you selected, please choose again. There is a problem with the period you selected, please choose again.
400 pay.noCreditCard Account not bound to credit card.
400 Order.InstHasUnpaidOrder There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. There is an unpaid order for the service you have purchased. Please pay or void it before placing the order.
400 noAvailablePaymentMethod No payment method is specified for your account. We recommend that you add a payment method. No payment method has been specified for your account. We recommend that you add a payment method.
400 BasicInfoUncompleted Your information is incomplete. Complete your information before the operation. Your basic information is not complete, please complete your basic information before operation.
400 Risk.RiskControlRejection Your account is abnormal, please contact customer service for details. Your account is abnormal, please contact customer service for details.
400 Api.NotSupport Specified api is not supported. The current interface does not support.
400 ContainForbiddenLabelError There is a label that prohibits placing orders. Please contact your distributor for assistance. You cannot place the order because a tag indicates that order placement is prohibited. Contact your distributor.
400 InvalidDBInstanceId.NotFound The DBInstanceId provided does not exist in records. The DBInstanceId provided does not exist.
400 InvalidInstanceLevel.DiskType Specified instance level not support request disk type The current instance type does not support the specified storage type.
400 InvalidParam Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. The specified wal_level parameter is invalid. There is still a copy slot in the instance, so it cannot be set to replica.
400 KmsApiError User secret key invalid. The user key is invalid.
400 System.SaleValidateFailed Sales expression validation system error. A system error occurs when the sales expression is verified.
400 Abs.InvalidAccount.NotFound account is not found. The account does not exist.
400 SqlExecuteFailedOrTimeout sql command execution failed or timed out:%s. SQL command execution failed or timed out
400 ColdData.EngineVersionNotSupport The current instance engine version not support coldDataEnabled. The current instance engine version not support coldDataEnabled.
400 ColdData.MinorVersionNotSupport The current instance minor version not support coldDataEnabled. The current instance minor version not support coldDataEnabled.
400 IncorrectTargetClasscode The current instance type does not support this operation. This operation is not supported by the instance type.
400 InvalidConnectionString.Duplicate Specified connection string already exists in the RDS. The link address name is duplicate. Please reset the connection string.
400 RequiredParam.NotFound Required input param is not found.
400 Parameters.Invalid Parameter error, please check the parameters. Parameter error, please check the parameters.
400 BackupPolicyNotSupport Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy.
400 InvalideStatus.Format The instance status does not support this operation.
400 InvalidReleasedKeepPolicy.Format Specified Released Keep Policy is not valid. Specified Released Keep Policy is not valid.
400 InvalidDBInstanceEngineType.Format the DB instance engine type does not support this operation. This operation is not supported for the database engine of the instance.
400 Pay.NoCreditCard No credit cards. No credit cards.
400 VpcNetworkTypeNotSupport The vpc network type instance does not support this operation. The vpc network type instance does not support this operation.
400 MirrorInsExists Specified DB instance mirror ins already existed. Specified DB instance mirror ins already existed.
400 UnsupportedClassCode The specified DB instance class stops selling. The specified DB instance class stops selling.
400 InvalidBackupSet The specified database does not exist in the backup set. The specified database does not exist in the backup set.
400 OrdTCommodityQueryError Failed to query for product. Failed to query product.
400 ProductInstanceReleased The instance has been released. Please check before placing the order. The instance has been released, please verify and place an order.
400 RegionEndTimeDissolvedIndia The region is no longer supported. The region is no longer supported.
400 InvalidDBProxyNodes.ZoneIdNotUnique ZoneIds is not unique. The Availability Zone ID is not unique.
400 MaxscaleServiceLinkedRole.NotFound Service linked role 'AliyunServiceRoleForRDSProxyOnEcs' not found. The database proxy service linked role was not found, please check.
400 MappingInstanceLevel.NotFound Can not find the mapping instance level. The mapping instance specification was not found.
500 ExternalFailure The request processing has failed due to external service failure. The request processing has failed due to external service failure.
500 RequestMetaDataFailed The service request failed. Please try again later or contact service personnel. The service request failed. Please try again later or contact service personnel.
500 InvokeProxyFailure The request processing has failed due to service failure of rds api. The request failed to be processed due to an RDS API failure.
403 InvalidConnVPCId Specified conn vpc id is not valid. The specified VPC ID is invalid.
403 IncorrectDBInstanceType The database instance type does not support the operation. The operation failed. The operation is not supported for the database engine of the RDS instance.
403 IncorrectDBInstanceEngine Current DB Instance engine does not support this operation. The operation failed. The operation is not supported for the database engine that is run on the RDS instance.
403 IncorrectKindCode Current custins kindCode does not support this operation. The operation failed. The operation is not supported for the database engine that is run on the RDS instance.
403 IncorrectDBInstanceState Current DB instance state does not support this operation.
403 InvalidVswitchId Specified conn vswitch id is not valid.
403 OrderStatus.UnPaid The specified db instance has unpaid order. The instance has an unpaid order. Please pay first and try again.
403 InvalidReduceDiskSize The storage capacity after the scale-down must be larger than the used amount. The scale-in target capacity cannot be less than the current storage space usage
403 CloudSSDNotSupport Cloud ssd does not support this operation, please upgrade to essd.
403 InvalidUserOperatorPermission The user permission does not support this operation. The user is not authorized to perform this operation.
403 IncorrectMinorVersion Current engine minor version does not support operations. This operation is not supported for the current minor engine version.
403 OperationDenied.ZoneResource There is no available zone for inventory. There is no available zone for inventory.
403 NotInFlowController Sorry,no permission. Sorry,no permission.
403 InvalidKmsKey Kms key is disabled.
403 InvalidInstanceLevel.Malformed Current DB instance level does not support this operation. The specified database instance type does not support this operation.
404 MaxscaleCreating The relative maxscale instance is being created or deleted.
404 Maxscale.NotFound The relative maxscale instance is not found. No associated maxscale instance is found.
404 InvalidVSwitchId.NotFound The specified VSwitch is invalid.
404 InvalidParam The parameter is invalid. The operation failed. The values of some parameters are invalid.
404 InsufficientResourceCapacity The target availability zone does not have sufficient resources. The target Availability Zone does not have enough resources.
404 InvalidDBInstance.NotFound The specified instance does not exist or is not supported. The RDS instance cannot be found. Check the ID or name of the RDS instance.
404 InvalidClusterKms The current instance does not authorized to access the Key Management Service. The instance does not have permissions to access Key Management Service (KMS).
404 Request.NotFound The requested resource is not available. The requested resources are unavailable.
404 HostInfo.NotFound The specified host info is not found.

Consulte Códigos de Erro para uma lista completa.

Notas de versão

Consulte Notas de Versão para uma lista completa.