Todos os produtos
Search
Central de documentação

ApsaraDB RDS:ModifyDBInstanceTDE

Última atualização: Jul 14, 2026

Ativa ou modifica o recurso de Criptografia Transparente de Dados (TDE) para uma instância do ApsaraDB RDS.

Descrição da operação

Mecanismo DPI suportado

  • ApsaraDB RDS for MySQL

  • ApsaraDB RDS for PostgreSQL

  • ApsaraDB RDS for SQL Server

Documentação de recursos relacionados

Importante Antes de chamar esta operação, leia atentamente a documentação a seguir para compreender totalmente os pré-requisitos e os impactos desta operação.

Experimente agora

Experimente esta API no OpenAPI Explorer, sem necessidade de assinatura manual. Chamadas bem-sucedidas geram automaticamente código SDK correspondente aos seus parâmetros. Faça o download com segurança de credenciais integrada para uso local.

Testar

Autorização RAM

Nenhuma autorização necessária para esta operação. Se você encontrar problemas com esta operação, entre em contato com o suporte técnico.

Parâmetros da solicitação

Parâmetro

Tipo

Obrigatório

Descrição

Exemplo

DBInstanceId

string

Sim

O ID da instância. Você pode chamar DescribeDBInstances para consultar o ID da instância.

rm-uf6wjk5****

TDEStatus

string

Sim

O status da TDE. Valores válidos:

  • Enabled

  • Disabled

Enabled

DBName

string

Não

O nome do banco de dados para o qual você deseja ativar a TDE. Você pode especificar vários bancos de dados separados por vírgulas (,), até 50 bancos de dados.

Nota

Este parâmetro é ativo e obrigatório apenas para SQL Server 2019 Standard Edition, 2022 Standard Edition, 2025 Standard Edition e instâncias SQL Server Enterprise.

testDB

EncryptionKey

string

Não

O ID da chave personalizada.

Nota

Este parâmetro está disponível apenas para instâncias do ApsaraDB RDS for MySQL ou ApsaraDB RDS for PostgreSQL.

749c1df7-****-****-****-****

RoleArn

string

Não

O descritor global de recursos da função RAM. O descritor é usado para especificar uma função RAM. Para obter detalhes, consulte Visão geral das funções RAM.

Nota

Este parâmetro está disponível apenas para instâncias do ApsaraDB RDS for MySQL e ApsaraDB RDS for PostgreSQL.

acs:ram::1406926****:role/aliyunrdsinstanceencryptiondefaultrole

Certificate

string

Não

O arquivo de certificado.

Formato:

  • Endpoint público: oss-<RegionId>.aliyuncs.com:<BucketName>:<CertificateFileName (com extensão de arquivo)>

  • Endpoint de rede interna: oss-<RegionId>-internal.aliyuncs.com:<BucketName>:<CertificateFileName (com extensão de arquivo)>

Nota
  • Este parâmetro é ativo apenas para SQL Server 2019 Standard Edition, 2022 Standard Edition, 2025 Standard Edition e instâncias SQL Server Enterprise.

  • Você pode chamar DescribeRegions para consultar IDs de regiões ativas.

oss-ap-southeast-1.aliyuncs.com:****:key.cer

PrivateKey

string

Não

O arquivo de chave privada.

Formato:

  • Endpoint público: oss-<RegionId>.aliyuncs.com:<BucketName>:<PrivateKeyFileName (com extensão de arquivo)>

  • Endpoint de rede interna: oss-<RegionId>-internal.aliyuncs.com:<BucketName>:<PrivateKeyFileName (com extensão de arquivo)>

Nota
  • Este parâmetro é ativo apenas para SQL Server 2019 Standard Edition, 2022 Standard Edition, 2025 Standard Edition e instâncias SQL Server Enterprise.

  • Você pode chamar DescribeRegions para consultar IDs de regiões ativas.

oss-ap-southeast-1.aliyuncs.com:****:key.pvk

PassWord

string

Não

A senha do certificado.

Nota

Este parâmetro é ativo apenas para SQL Server 2019 Standard Edition, 2022 Standard Edition, 2025 Standard Edition e instâncias SQL Server Enterprise.

1qaz@WSX

IsRotate

boolean

Não

Especifica se deve haver rotação da chave. Valores válidos:

  • true: Realiza a rotação da chave.

  • false (padrão): Não realiza a rotação da chave.

Nota

Este parâmetro está disponível apenas para instâncias do ApsaraDB RDS for PostgreSQL.

false

Elementos de resposta

Elemento

Tipo

Descrição

Exemplo

object

Os parâmetros de resposta.

RequestId

string

O ID da solicitação.

777C4593-8053-427B-99E2-105593277CAB

Exemplos

Resposta de sucesso

JSON formato

{
  "RequestId": "777C4593-8053-427B-99E2-105593277CAB"
}

Códigos de erro

Código de status HTTP

Código de erro

Mensagem de erro

Descrição

400 %s DB Operation Failed:%s.
400 InvalidTDEstatus Specified TDEStatus has already configed in the This instance.
400 MissingDBName The request is missing a DBName parameter.
400 InvalidTDEstatus.Format The Specified TDEStatus is not valid. O status de criptografia transparente de dados é inválido.
400 Invalid.PrivateKey The requested privateKey parameter is invalid. O parâmetro de chave privada especificado é inválido.
400 Invalid.Certificate The requested certificate parameter is invalid. O parâmetro de certificado solicitado é inválido.
400 CertOrPrivateKeyOrPasswordNotMatched The public certificate, private key, and password do not match. A senha do certificado e da chave privada não correspondem.
400 InvalidTDEKey Kms key is disabled. A chave KMS foi desativada.
400 InvalidTDEStatus.NotFound The specified TDEStatus does not exist. O status de TDE especificado não existe.
400 PermissionDenied The current account has not been authorized to allow RDS to access user's KMS services, authorization needs to be granted to this account. A conta atual não autorizou o ApsaraDB RDS a acessar o Key Management Service (KMS). Autorize o RDS a acessar o KMS consultando a documentação sobre como autorizar o RDS a acessar o KMS.
400 Order.ComboInstanceNotAllowOperate A package instance is not allowed to operate independently. Operações individuais não são permitidas para instâncias de pacote.
400 Price.PricingPlanResultNotFound Pricing plan price result not found. O resultado do preço do plano de precificação não foi encontrado.
400 Order.NoRealNameAuthentication You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. Você não concluiu a verificação de nome real e não está elegível para fazer compras. Faça login em Despesas e Custos para concluir a verificação de nome real.
400 InsufficientAvailableQuota Your account quota limit is less than 0, please recharge before trying to purchase. O saldo da sua conta é menor que 0. Recarregue sua conta antes de tentar comprar.
400 CommodityServiceCalling.Exception Failed to call commodity service. A chamada ao serviço de commodity falhou.
400 RegionDissolvedEOM Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. O Alibaba Cloud planeja otimizar e ajustar a região atual. Os serviços em nuvem nesta região serão descontinuados. Para garantir a continuidade dos seus negócios e uma migração de dados tranquila, você não pode fazer novos pedidos de compra no momento.
400 Commodity.InvalidComponent The module you purchased is not legal, please buy it again. O módulo adquirido é inválido. Adquira um módulo válido.
400 RegionEndTimeDissolvedAustralia Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. A região especificada foi desativada.
400 Price.CommoditySys Commodity system call exception. Ocorreu uma exceção ao chamar o sistema de commodities.
400 Pay.InsufficientBalance Insufficient available balance.
400 Order.PeriodInvalid There is a problem with the period you selected, please choose again. O período de assinatura selecionado é inválido. Selecione um período válido.
400 pay.noCreditCard Account not bound to credit card. Nenhum cartão de crédito disponível.
400 Order.InstHasUnpaidOrder There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. Existe um pedido não pago para o serviço selecionado. Pague ou cancele o pedido existente antes de fazer um novo.
400 noAvailablePaymentMethod No payment method is specified for your account. We recommend that you add a payment method. Nenhum método de pagamento está especificado para a conta. Adicione um método de pagamento.
400 BasicInfoUncompleted Your information is incomplete. Complete your information before the operation. Suas informações básicas estão incompletas. Complete suas informações básicas antes de realizar esta operação.
400 Risk.RiskControlRejection Your account is abnormal, please contact customer service for details. Ocorreu uma exceção na sua conta. Entre em contato com o atendimento ao cliente para obter detalhes.
400 Api.NotSupport Specified api is not supported. A operação de API atual não é suportada.
400 ContainForbiddenLabelError There is a label that prohibits placing orders. Please contact your distributor for assistance. Existe uma tag de bloqueio de pedido. Entre em contato com seu distribuidor para resolver esse problema.
400 InvalidDBInstanceId.NotFound The DBInstanceId provided does not exist in records. O DBInstanceId especificado não existe.
400 InvalidInstanceLevel.DiskType Specified instance level not support request disk type O tipo de instância atual não suporta o tipo de armazenamento especificado.
400 InvalidParam Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. O parâmetro de entrada é inválido.
400 KmsApiError User secret key invalid. A chave do usuário é inválida.
400 System.SaleValidateFailed Sales expression validation system error.
400 Abs.InvalidAccount.NotFound account is not found. Sua conta Alibaba Cloud não existe ou seu AccessKey expirou.
400 SqlExecuteFailedOrTimeout sql command execution failed or timed out:%s. A execução do comando SQL falhou ou expirou.
400 ColdData.EngineVersionNotSupport The current instance engine version not support coldDataEnabled. A versão atual do mecanismo DPI da instância não suporta arquivamento de dados frios.
400 ColdData.MinorVersionNotSupport The current instance minor version not support coldDataEnabled. A versão atual do kernel não suporta arquivamento de dados frios.
400 IncorrectTargetClasscode The current instance type does not support this operation. O tipo de instância atual não suporta esta operação.
400 InvalidConnectionString.Duplicate Specified connection string already exists in the RDS. O nome do endereço de conexão está duplicado. Defina a string de conexão novamente.
400 RequiredParam.NotFound Required input param is not found. Parâmetros obrigatórios estão ausentes.
400 Parameters.Invalid Parameter error, please check the parameters. Ocorreu um erro de parâmetro. Verifique os parâmetros.
400 BackupPolicyNotSupport Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. O arquivamento de dados não suporta backup entre regiões ou snapshots de nível secundário. Verifique a política de backup.
400 InvalideStatus.Format The instance status does not support this operation. O status da instância não suporta esta operação.
400 InvalidReleasedKeepPolicy.Format Specified Released Keep Policy is not valid. A política de retenção de dados de backup arquivados após a liberação da instância é inválida.
400 InvalidDBInstanceEngineType.Format the DB instance engine type does not support this operation. O tipo de mecanismo de banco de dados da instância não suporta esta operação.
400 Pay.NoCreditCard No credit cards.
400 VpcNetworkTypeNotSupport The vpc network type instance does not support this operation. Esta operação não é suportada para instâncias com tipo de rede VPC.
400 MirrorInsExists Specified DB instance mirror ins already existed. A imagem da instância de banco de dados atual já existe.
400 UnsupportedClassCode The specified DB instance class stops selling. O tipo de instância não está mais disponível para compra.
400 InvalidBackupSet The specified database does not exist in the backup set. O banco de dados especificado não existe no conjunto de backup.
400 OrdTCommodityQueryError Failed to query for product. Falha ao consultar o produto.
400 ProductInstanceReleased The instance has been released. Please check before placing the order. A instância foi liberada. Verifique a instância antes de fazer o pedido.
400 RegionEndTimeDissolvedIndia The region is no longer supported. A região especificada é inválida.
400 BYOKCertExpired The certificate has exceeded the validity period. O certificado expirou.
500 ExternalFailure The request processing has failed due to external service failure. A solicitação ao serviço falhou. Tente novamente mais tarde.
500 RequestMetaDataFailed The service request failed. Please try again later or contact service personnel. A solicitação de serviço falhou. Tente novamente mais tarde ou entre em contato com o suporte.
500 InvokeProxyFailure The request processing has failed due to service failure of rds api. A solicitação falhou devido a uma falha no serviço de API do RDS.
403 IncorrectDBInstanceType Current DB instance type does not support this operation. A operação falhou. Esta operação não é suportada no status atual da instância.
403 IncorrectEngineVersion Current engine version does not support operations.
403 IncorrectDBInstanceLockMode Current DB instance lock mode does not support this operation.
403 IncorrectDBInstanceState Current DB instance state does not support this operation. O status atual da instância não suporta esta operação.
403 DBSizeExceeded Exceeding the allowed DB size of DB instance. O tamanho do banco de dados excede o limite.
403 IncorrectMinorVersion Current engine minor version does not support operations. A versão secundária do mecanismo atual não suporta esta operação.
403 ByokRoleArnNotFound The roleArn can not be null. O parâmetro roleArn não pode estar vazio.
403 InvalidKmsKey Kms key is disabled. A chave KMS está desativada.
403 OrderStatus.UnPaid The specified db instance has unpaid order. Existe um pedido não pago para a instância atual. Pague o pedido e tente novamente.
403 InvalidReduceDiskSize The storage capacity after the scale-down must be larger than the used amount. A capacidade de destino para redução de escala não pode ser menor que o uso atual de armazenamento.
403 CloudSSDNotSupport Cloud ssd does not support this operation, please upgrade to essd. Discos em nuvem SSD não suportam esta operação. Atualize para ESSD.
403 InvalidUserOperatorPermission The user permission does not support this operation. As permissões do usuário não suportam esta operação.
403 InvalidVswitchId Specified conn vswitch id is not valid. O VSwitchId especificado está em um formato incorreto ou está vazio.
403 OperationDenied.ZoneResource There is no available zone for inventory. Não existem regiões de inventário disponíveis.
403 NotInFlowController Sorry,no permission. Este recurso está indisponível. Você não tem permissão porque não é um usuário de nuvem empresarial.
403 InvalidInstanceLevel.Malformed Current DB instance level does not support this operation. O nível atual da instância de banco de dados não suporta esta operação.
403 UnsupportedByBlueGreenDeployment Operation prohibited due to blue green deployment. Esta operação não é permitida porque existe uma implantação blue-green.
403 CrossBackupStrategyNotSupport Cross region backup strategy is not supported. As políticas de backup entre regiões não são suportadas.
404 InvalidClusterKms this cluster not kms service.
404 InsufficientResourceCapacity There is insufficient capacity available for the requested instance.
404 InvalidDBName.NotFound Specified one or more DB name does not exist or DB status does not support. A operação falhou porque o nome da instância de banco de dados não existe.
404 Request.NotFound The requested resource is not available. O recurso solicitado não está disponível.
404 HostInfo.NotFound The specified host info is not found. As informações do host especificado não existem.

Consulte Códigos de Erro para uma lista completa.

Notas de versão

Consulte Notas de Versão para uma lista completa.