Modifica as informações de peso do endpoint de uma instância ApsaraDB RDS Cluster Edition.
Descrição da operação
Mecanismos aplicáveis
RDS MySQL.
Experimente agora
Testar
Autorização RAM
|
Ação |
Nível de acesso |
Tipo de recurso |
Chave de condição |
Ação dependente |
|
rds:ModifyDBInstanceEndpoint |
update |
*DBInstance
|
Nenhuma | Nenhuma |
Parâmetros da solicitação
|
Parâmetro |
Tipo |
Obrigatório |
Descrição |
Exemplo |
| ClientToken |
string |
Não |
O token do cliente usado para garantir a idempotência da solicitação e evitar envios repetidos. O valor deste parâmetro é gerado pelo cliente. O valor é uma string ASCII com até 64 caracteres e não pode conter caracteres não ASCII. |
6000170000591aed949d0f**** |
| DBInstanceId |
string |
Sim |
O ID da instância. Você pode chamar DescribeDBInstances para consultar o ID da instância. |
rm-**** |
| DBInstanceEndpointId |
string |
Sim |
O ID do endpoint da instância. Você pode chamar DescribeDBInstanceEndpoints para consultar o ID do endpoint. |
ep-**** |
| DBInstanceEndpointDescription |
string |
Não |
A descrição personalizada do endpoint. |
for readonly business |
| NodeItems |
array<object> |
Não |
A lista de informações dos nós do endpoint. |
|
|
object |
Não |
Os detalhes do nó. |
||
| DBInstanceId |
string |
Não |
O ID da instância. Você pode chamar DescribeDBInstances para consultar o ID da instância. |
rm-**** |
| NodeId |
string |
Não |
O ID do nó. Você pode consultar o ID do nó usando os seguintes métodos:
|
rn-xxxx-**** |
| Weight |
integer |
Não |
O peso atual do nó. O tráfego de leitura é distribuído com base neste valor. Valores válidos: 0 a 100. |
50 |
Elementos de resposta
|
Elemento |
Tipo |
Descrição |
Exemplo |
|
object |
Os parâmetros de resposta. |
||
| Data |
object |
Os campos retornados. |
|
| DBInstanceEndpointId |
string |
O ID do endpoint da instância. |
ep-**** |
| DBInstanceName |
string |
O ID da instância. |
rm-**** |
| RequestId |
string |
O ID da solicitação. |
F2911788-25E8-42E5-A3A3-1B38D263F01E |
Exemplos
Resposta de sucesso
JSON formato
{
"Data": {
"DBInstanceEndpointId": "ep-****",
"DBInstanceName": "rm-****"
},
"RequestId": "F2911788-25E8-42E5-A3A3-1B38D263F01E"
}
Códigos de erro
|
Código de status HTTP |
Código de erro |
Mensagem de erro |
Descrição |
|---|---|---|---|
| 400 | InvalidSourceCategory | specified source category is invalid. | |
| 400 | InvalidDBInstanceConnType.Format | Specified DB instance conn type is not valid. | |
| 400 | APICallingFailed | Meta db calling failed. | |
| 400 | InvalidNodeItems.JsonFormat | NodeItems is not a json string. | |
| 400 | EmptyEndpointNodeConfig | Specified endpoint has no nodes, add node to endpoint first. | |
| 400 | InvalidNodeItems.RONodeIdPrimary | ReadOnly endpoint can not contain primary node. | |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | |
| 400 | Price.CommoditySys | Commodity system call exception. | |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | |
| 400 | pay.noCreditCard | Account not bound to credit card. | |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | |
| 400 | noAvailablePaymentMethod | No payment method is specified for your account. We recommend that you add a payment method. | |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | |
| 400 | Api.NotSupport | Specified api is not supported. | |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | |
| 400 | KmsApiError | User secret key invalid. | |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | |
| 400 | RequiredParam.NotFound | Required input param is not found. | |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | |
| 400 | Pay.NoCreditCard | No credit cards. | |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | |
| 400 | OrdTCommodityQueryError | Failed to query for product. | |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | |
| 403 | IncorrectDBInstanceState | Current DB instance state does not support this operation. | |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | |
| 403 | NotInFlowController | Sorry,no permission. | |
| 403 | InvalidKmsKey | Kms key is disabled. | |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | |
| 404 | IncorrectDBInstanceLockMode | Current DB instance lock mode does not support this operation. | |
| 404 | InvalidDBInstanceName.NotFound | Invalid DBInstanceId NotFound. | |
| 404 | Endpoint.NotFound | Specified endpoint is not existed. | |
| 404 | InvalidConnectionString.NotFound | Specified connection string or net type is not found. | |
| 404 | InvalidWeight.Format | The Specified Weight format is not valid. | |
| 404 | InvalidDBInstance.NotFound | Specified instance does not exist or not support. | |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | |
| 404 | Request.NotFound | The requested resource is not available. | |
| 404 | HostInfo.NotFound | The specified host info is not found. |
Consulte Códigos de Erro para uma lista completa.
Notas de versão
Consulte Notas de Versão para uma lista completa.