Modifica os itens de configuração de uma instância do ApsaraDB RDS.
Descrição da operação
Mecanismos suportados
ApsaraDB RDS for PostgreSQL
ApsaraDB RDS for SQL Server
Os itens de configuração suportados atualmente incluem ApsaraDB RDS for PostgreSQL PgBouncer, Criptografia de disco em nuvem do ApsaraDB RDS for PostgreSQL, Criptografia de disco em nuvem do ApsaraDB RDS for SQL Server e Limpeza de log de erros do ApsaraDB RDS for SQL Server.
Experimente agora
Testar
Autorização RAM
|
Ação |
Nível de acesso |
Tipo de recurso |
Chave de condição |
Ação dependente |
|
rds:ModifyDBInstanceConfig |
none |
*DBInstance
|
Nenhuma | Nenhuma |
Parâmetros da solicitação
|
Parâmetro |
Tipo |
Obrigatório |
Descrição |
Exemplo |
| DBInstanceId |
string |
Sim |
O ID da instância. Você pode chamar DescribeDBInstances para obter o ID da instância. |
pgm-2ze**** |
| ConfigName |
string |
Sim |
O nome do item de configuração a ser modificado. Este parâmetro é usado em conjunto com ConfigValue. |
pgbouncer |
| ConfigValue |
string |
Sim |
O valor do item de configuração a ser modificado. Este parâmetro é usado em conjunto com ConfigName. |
true |
| ResourceGroupId |
string |
Não |
O ID do grupo de recursos. Você pode chamar DescribeDBInstanceAttribute para obter o ID do grupo de recursos. |
rg-bp67acfmxazb4p**** |
| ClientToken |
string |
Não |
O token do cliente usado para garantir a idempotência da solicitação. Você pode usar o cliente para gerar o token, mas deve garantir que o token seja exclusivo entre diferentes solicitações. O token pode conter apenas caracteres ASCII e não pode exceder 64 caracteres de comprimento. |
6000170000591aed949d0f**** |
| SwitchTime |
string |
Não |
O horário em que a modificação entra em vigor. Recomendamos que você realize alterações de especificação durante horários de menor movimento. Formato: yyyy-MM-ddTHH:mm:ssZ (UTC). |
2025-05-06T09:24:00Z |
| SwitchTimeMode |
string |
Não |
O horário de alternância. Valores válidos:
|
Immediate |
Elementos de resposta
|
Elemento |
Tipo |
Descrição |
Exemplo |
|
object |
Os parâmetros de resposta. |
||
| RequestId |
string |
O ID da solicitação. |
76364A52-E0AB-5CC8-9818-CF1DC482C092 |
Exemplos
Resposta de sucesso
JSON formato
{
"RequestId": "76364A52-E0AB-5CC8-9818-CF1DC482C092"
}
Códigos de erro
|
Código de status HTTP |
Código de erro |
Mensagem de erro |
Descrição |
|---|---|---|---|
| 400 | %s | DB Operation Failed:%s. | |
| 400 | InvalidDBInstanceName.NotFound | The specified DB instance name does not exist. | O ID da instância especificado não existe. Verifique o ID da instância e tente novamente. |
| 400 | MinorVersionNotSupport | The current database minor version does not support the operation. | A versão secundária atual do mecanismo da instância não suporta esta operação. Tente atualizar a versão secundária do mecanismo. |
| 400 | InvalidConfigName | The ConfigName is not valid. | O ConfigName especificado é inválido. |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | Instâncias em um pacote não podem ser operadas individualmente. |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | O resultado do plano de preços não foi encontrado. |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | Você não concluiu a verificação de nome real e não está elegível para fazer uma compra. Faça login em Despesas e Custos para concluir a verificação de nome real. |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | O saldo da sua conta é menor que 0. Recarregue sua conta antes de tentar fazer uma compra. |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | A chamada para o serviço de commodities falhou. |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | A Alibaba Cloud planeja otimizar e ajustar a região atual. Os serviços em nuvem nesta região cessarão as operações. Para garantir a continuidade dos seus negócios e uma migração de dados tranquila, você não pode fazer novos pedidos de compra neste momento. Agradecemos sua compreensão e apoio. |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | O módulo que você adquiriu é inválido. Adquira o módulo novamente. |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | A região especificada foi desativada. |
| 400 | Price.CommoditySys | Commodity system call exception. | Ocorreu uma exceção ao chamar o sistema de commodities. |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | O período de assinatura selecionado é inválido. Selecione um período de assinatura diferente. |
| 400 | pay.noCreditCard | Account not bound to credit card. | A conta não está vinculada a um cartão de crédito. |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | Existe um pedido não pago para o serviço selecionado. Pague ou cancele o pedido existente antes de fazer um novo. |
| 400 | noAvailablePaymentMethod | No payment method is specified for your account. We recommend that you add a payment method. | Nenhum método de pagamento está especificado para sua conta. Adicione um método de pagamento. |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | Suas informações estão incompletas. Complete suas informações antes de prosseguir. |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | Sua conta apresenta uma exceção. Entre em contato com o atendimento ao cliente para obter detalhes. |
| 400 | Api.NotSupport | Specified api is not supported. | A operação atual não é suportada. |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | Existe uma tag de bloqueio de pedidos. Entre em contato com seu distribuidor para resolver este problema. |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | A instância especificada não existe. Verifique se a instância existe e se não foi excluída. |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | O tipo de instância atual não suporta este tipo de armazenamento. |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | A operação falhou. O parâmetro é inválido. |
| 400 | KmsApiError | User secret key invalid. | A chave do usuário é inválida. |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | A conta não existe. |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | O comando SQL falhou ao executar ou atingiu o tempo limite. |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | A versão atual do mecanismo DPI da instância não suporta arquivamento de dados frios. |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | A versão atual do kernel não suporta arquivamento de dados frios. |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | O tipo de instância atual não suporta esta operação. |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | O nome do endereço de conexão está duplicado. Especifique uma string de conexão diferente. |
| 400 | RequiredParam.NotFound | Required input param is not found. | Um parâmetro obrigatório está ausente. |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | O parâmetro é inválido. Verifique os parâmetros. |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | O arquivamento de dados frios não suporta backup entre regiões ou backup de snapshot de alta frequência. Verifique a política de backup. |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | O status da instância não suporta esta operação. |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | A política de retenção de dados de backup arquivados após a liberação da instância é inválida. |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | O tipo de mecanismo de banco de dados da instância não suporta esta operação. |
| 400 | Pay.NoCreditCard | No credit cards. | |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | Esta operação não é suportada para instâncias do tipo de rede VPC. |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | A imagem da instância de banco de dados já existe. |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | O tipo de instância não está mais disponível para compra. |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | O banco de dados especificado não existe no conjunto de backup. |
| 400 | OrdTCommodityQueryError | Failed to query for product. | Falha ao consultar o produto. |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | A instância foi liberada. Verifique a instância antes de fazer um pedido. |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | A região especificada foi desativada. |
| 400 | InvalidSourceCategory | specified source category is invalid. | A categoria de origem especificada é inválida. |
| 400 | InvalidParameter | Invalid parameter. | O parâmetro é inválido. |
| 400 | InvalidConfigValue | The ConfigValue is not valid. | A operação falhou. As configurações de parâmetros especificadas são inválidas. |
| 400 | InvalidParameters.Format | Specified parameters is not valid. | O parâmetro é inválido. |
| 400 | DuckDBOperationConflictBetweenPrimaryAndReadOnlyInstance | Current instance is already attached to another duckdb instance, operation is conflict. | A instância atual já está associada a outra instância analítica baseada em DuckDB, o que entra em conflito com a operação DuckDB atual. |
| 400 | KmsServiceLinkedRoleNotGranted | The service linked role is not granted, please check. | |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | A solicitação falhou. Tente novamente mais tarde. |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | A solicitação falhou. Tente novamente mais tarde ou entre em contato com o suporte técnico. |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | A solicitação falhou devido a uma falha no serviço da API do RDS. |
| 403 | IncorrectDBInstanceType | Current DB instance type does not support this operation. | A operação falhou. O mecanismo e o tipo atuais da instância de banco de dados não são suportados. |
| 403 | IncorrectDBInstanceLockMode | Current DB instance lock mode does not support this operation. | |
| 403 | IncorrectDBInstanceState | Current DB instance state does not support this operation. | A operação falhou. O status atual da instância não suporta esta operação. Tente novamente mais tarde. |
| 403 | CloudDiskEncryptionNotSupport | The encryption key is not allowed for general-purpose instance. | Instâncias de uso geral não suportam criptografia de disco em nuvem. |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | A instância possui um pedido não pago. Pague o pedido e tente novamente. |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | A capacidade alvo para redução de escala não pode ser inferior ao uso atual de armazenamento. |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | Esta operação não é suportada para discos SSD. Faça upgrade para ESSD. |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | As permissões do usuário não suportam esta operação. |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | O VSwitchId especificado está em um formato inválido ou está vazio. |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | A versão secundária atual do mecanismo não suporta esta operação. |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | Não existem zonas de inventário disponíveis. |
| 403 | NotInFlowController | Sorry,no permission. | Esta operação não está disponível para usuários de nuvem não corporativos. Você não tem as permissões necessárias. |
| 403 | InvalidKmsKey | Kms key is disabled. | A chave KMS está desativada. |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | A operação falhou. O código de especificação especificado não suporta o número de endpoints especificado. Verifique o número de shards e o número atual de endpoints. |
| 403 | UnsupportedByBlueGreenDeployment | Operation prohibited due to blue green deployment. | Esta operação não é permitida porque existe uma implantação azul-verde. |
| 403 | EncryptionKeyNotSupport | The encryption key is not support to generate encryption disk. | A chave especificada não suporta a criação de instâncias criptografadas com disco em nuvem. |
| 403 | IncorrectDBState | The current DB state does not support this operation. | A operação falhou. O status atual do banco de dados é inválido. Por exemplo, o banco de dados está sendo criado ou sendo migrado para a nuvem. |
| 403 | UnsupportedReadOrBakReadState | Current DB instance has read or bak read running in unsupport states | A instância de banco de dados atual já está sendo executada em um estado não suportado com leitura ou leitura de backup ativada. |
| 403 | IncorrectAccountPrivilegeType | the current account privilege type does not support this operation. | O tipo de permissão da conta atual não suporta esta operação. |
| 403 | DBInstanceStatusNotActive | The status of the current instance is not active. | A operação falhou. Verifique o status de execução da instância. |
| 403 | ReadOnlyInstanceNotSupport | Read-only instance does not support this operation. | A operação falhou porque as instâncias somente leitura não suportam esta operação. |
| 403 | Invalid.Parameter | Specified parameters is not valid. | O parâmetro especificado é inválido. |
| 403 | TargetMajorVesionNotSupported | The specified major version is not supported. | A versão principal de destino não é suportada. |
| 403 | ReadInstanceNotSupport | Instances with read-only do not support this operation. | Esta operação não é suportada para instâncias que possuem instâncias somente leitura. |
| 403 | IncorrectDBInstance | The current DB instance does not support this operation. | A operação falhou. A instância atual não suporta esta operação. |
| 404 | InvalidDBInstance.NotFound | Specified instance does not exist or not support. | A instância especificada não existe ou não suporta esta operação. |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | A instância atual não está autorizada a acessar o Key Management Service. |
| 404 | Request.NotFound | The requested resource is not available. | O recurso solicitado não está disponível. |
| 404 | HostInfo.NotFound | The specified host info is not found. | As informações do host especificado não existem. |
| 404 | InvalidAccountName.NotFound | The specified account is not found. | A conta não foi encontrada. Se você estiver criando uma conta ou redefinindo uma senha, especifique sua conta. |
| 404 | InvalidReadDBInstance.NotFound | The specified read only database instance does not exist. | A instância somente leitura não foi criada ou o parâmetro da instância da solicitação é inválido. |
Consulte Códigos de Erro para uma lista completa.
Notas de versão
Consulte Notas de Versão para uma lista completa.