Modifica as configurações de propriedade de uma instância ApsaraDB RDS for SQL Server.
Descrição da operação
Motor de banco de dados compatível
SQL Server
Referências
Você pode chamar esta operação para modificar as propriedades do banco de dados de uma instância ApsaraDB RDS for SQL Server e arquivar dados de uma instância que usa discos em nuvem para um bucket do Object Storage Service (OSS). Antes de chamar esta operação para arquivar dados em um bucket do OSS, você deve ativar o recurso de arquivamento de dados no console do ApsaraDB RDS. Para mais informações, consulte Modificar propriedades do banco de dados e Arquivar dados de disco em nuvem em um bucket do OSS.
Antes de chamar esta operação, leia os tópicos a seguir e certifique-se de que compreende totalmente os pré-requisitos e os impactos desta operação.
Experimente agora
Testar
Autorização RAM
|
Ação |
Nível de acesso |
Tipo de recurso |
Chave de condição |
Ação dependente |
|
rds:ModifyDatabaseConfig |
update |
*DBInstance
|
Nenhuma | Nenhuma |
Parâmetros da solicitação
|
Parâmetro |
Tipo |
Obrigatório |
Descrição |
Exemplo |
| DBInstanceId |
string |
Sim |
O ID da instância. |
rm-t4nnu1my39q****** |
| DBName |
string |
Sim |
O nome do banco de dados. Nota
Você pode especificar apenas um nome de banco de dados. |
testDB |
| DatabasePropertyName |
string |
Sim |
A propriedade do banco de dados que você deseja modificar.
|
compatibility_level |
| DatabasePropertyValue |
string |
Sim |
O valor da propriedade do banco de dados que você deseja modificar.
|
150 |
Parâmetros nativos no SQL Server
| Parâmetro | Valor válido | Bloqueio exclusivo necessário no banco de dados para alterar o valor | Versão mínima do SQL Server |
| compatibility_level | 100110120130140150160 | Não | SQL Server 2008 |
| parameterization | FORCEDSIMPLE | Não | Todas |
| delayed_durability | DISABLEDALLOWEDFORCED | Não | SQL Server 2014 |
| accelerated_database_recovery | ONOFF | Sim | SQL Server 2019 |
| read_committed_snapshot | ONOFF | Sim | SQL Server 2008 |
| page_verify | CHECKSUMTORN_PAGE_DETECTION. Não é possível alterar o valor para TORN_PAGE_DETECTION. | Não | Todas |
| auto_update_statistics | ONOFF | Não | Todas |
| auto_update_statistics_async | ONOFF | Não | SQL Server 2012 |
| allow_snapshot_isolation | ONOFF | Não | Todas |
| ansi_null_default | ONOFF | Não | Todas |
| ansi_nulls | ONOFF | Não | Todas |
| ansi_warnings | ONOFF | Não | Todas |
| ansi_padding | ONOFF | Não | Todas |
| concat_null_yields_null | ONOFF | Não | Todas |
| recursive_triggers | ONOFF | Não | Todas |
| auto_close | OFF | Não | Todas |
Parâmetros personalizados do ApsaraDB RDS
Observação Os parâmetros personalizados do ApsaraDB RDS começam com rds_.
| Parâmetro | Valor válido | Bloqueio exclusivo necessário no banco de dados para alterar o valor | Versão mínima do SQL Server | Descrição |
| rds_optimize_db_file_grow | 1 | Não | Todas | O tamanho incremental de todos os arquivos do banco de dados. Valor: 256. Unidade: MB. |
| rds_set_db_online | 1 | Não | Todas | Especifica se o status do banco de dados deve ser alterado para Online. Se o banco de dados já estiver no estado Online, ignore este parâmetro. |
| rds_shrink_database_log | 1 | Não | Todas | Quando a operação de redução é realizada no banco de dados, o sucesso da redução depende de se log_resue_wait_desc do log está definido como Nothing. |
| rds_update_db_stats | 1 | Não | Todas | Quando as estatísticas no banco de dados são atualizadas, a camada subjacente usa o procedimento armazenado sp_updatestats integrado ao SQL Server. |
| rds_rebuild_db_index | 1 | Não | Todas | Se você deseja atualizar todos os índices não clusterizados cuja taxa de fragmentação é superior a 50% no banco de dados, certifique-se de que as seguintes condições sejam atendidas:-O tamanho do banco de dados é inferior a 10 GB.-O espaço em disco restante é superior a 10 GB. |
Elementos de resposta
|
Elemento |
Tipo |
Descrição |
Exemplo |
|
object |
Os parâmetros de resposta. |
||
| Code |
string |
O código. |
200 |
| Message |
string |
A mensagem retornada. |
successful |
| RequestId |
string |
O ID da solicitação. |
F5C79A20-E931-5389-BC04-DEBA2D3ABD8D |
Exemplos
Resposta de sucesso
JSON formato
{
"Code": "200",
"Message": "successful",
"RequestId": "F5C79A20-E931-5389-BC04-DEBA2D3ABD8D"
}
Códigos de erro
|
Código de status HTTP |
Código de erro |
Mensagem de erro |
Descrição |
|---|---|---|---|
| 400 | SqlExecuteFailedOrTimeout | %s. | |
| 400 | InvalidDatabasePropertyValue | Specified value for the database property is not valid. | |
| 400 | InvalidDatabaseProperty | Specified name for the database property is not valid. | |
| 400 | DatabasePropertyModificationFail | Database property modification failed, possibly due to high workload on the database or inability to obtain an exclusive lock. Please attempt to modify the property during periods of low workload. | |
| 400 | InvalidDatabaseVersion | Specified database property is not compatible with the SQL Server major version. | |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | |
| 400 | UserAlreadyExistInDb | The current login already has a mapped user with the same name in the specific database. please try removing the existing user and retrying. | |
| 400 | InvalidDiskType | Current disk type does not support this operation. | |
| 400 | CurrentInsHasColdDB | The current instance has cold storage db. | |
| 400 | CurrentInsHasColdStorage | Current instance has cold storage. | |
| 400 | ColdDBHasSameNameWithOnlineDB | The instance has cold db and online db with the same name. | |
| 400 | DiskSpaceInsufficientForColdOperation | Insufficient disk space to bring db online. | |
| 400 | InvalidRestoreTimeSpecified | Unable to restore to the specified time, because the database is in cold storage at this time. Please choose a valid restore point. | |
| 400 | InvalidRestoreDB | Unable to restore, because the database is in cold storage now. Please skip this database. | |
| 400 | CurrentDBIsInColdStorage | current db is cold db. | |
| 400 | ColdDBNumExceedsLimit | the number of cold db exceeds the limit. | |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | |
| 400 | Price.CommoditySys | Commodity system call exception. | |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | |
| 400 | pay.noCreditCard | Account not bound to credit card. | |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | |
| 400 | noAvailablePaymentMethod | No payment method is specified for your account. We recommend that you add a payment method. | |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | |
| 400 | Api.NotSupport | Specified api is not supported. | |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | |
| 400 | KmsApiError | User secret key invalid. | |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | |
| 400 | RequiredParam.NotFound | Required input param is not found. | |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | |
| 400 | Pay.NoCreditCard | No credit cards. | |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | |
| 400 | OrdTCommodityQueryError | Failed to query for product. | |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | |
| 400 | InvalidCharacter.DbOrAccount | The database name or account name contains invalid characters. | |
| 400 | StatisticsUpdateNotSupported | Updating statistics is not supported. | |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | |
| 403 | InvalidDB.NotFound | Specified db does not exist or DB status does not support. | |
| 403 | IncorrectDBInstanceState | Current DB instance state does not support this operation. | |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | |
| 403 | NotInFlowController | Sorry,no permission. | |
| 403 | InvalidKmsKey | Kms key is disabled. | |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | |
| 404 | Request.NotFound | The requested resource is not available. | |
| 404 | HostInfo.NotFound | The specified host info is not found. | |
| 409 | ConflictingDatabaseOperation | There is already some operation on the database and the current operation should wait till it is done. |
Consulte Códigos de Erro para uma lista completa.
Notas de versão
Consulte Notas de Versão para uma lista completa.