Obtém o relatório de pré-verificação para uma atualização de versão principal do RDS MySQL e do RDS PostgreSQL.
Descrição da operação
Mecanismo aplicável
RDS MySQL
RDS PostgreSQL.
Documentação do recurso
Antes de chamar esta API, leia a documentação relevante do recurso. Certifique-se de compreender totalmente os pré-requisitos e o impacto desta operação.
Experimente agora
Testar
Autorização RAM
Parâmetros da solicitação
|
Parâmetro |
Tipo |
Obrigatório |
Descrição |
Exemplo |
| DBInstanceId |
string |
Sim |
O ID da instância. Você pode chamar a operação DescribeDBInstances para obter este ID. |
pgm-bp1c808s731l**** |
| PageSize |
integer |
Não |
O número de entradas por página no relatório de verificação. Valores válidos:
|
30 |
| PageNumber |
integer |
Não |
O número da página do relatório de verificação. O valor deve ser um número inteiro maior que 0. Valor padrão: 1. |
1 |
| TargetMajorVersion |
string |
Não |
A versão principal de destino do mecanismo da instância. A versão principal de destino do mecanismo deve ser posterior à versão principal atual do mecanismo. |
12.0 |
| TaskId |
integer |
Não |
O ID da tarefa de pré-verificação. A operação UpgradeDBInstanceMajorVersionPrecheck retorna este ID no parâmetro TaskId da resposta. |
416980000 |
Elementos de resposta
|
Elemento |
Tipo |
Descrição |
Exemplo |
|
object |
Detalhes dos parâmetros retornados. |
||
| RequestId |
string |
O ID da solicitação. |
D1586777-41B5-5F9E-81E8-93DFDD379024 |
| PageNumber |
integer |
O número da página. |
1 |
| PageRecordCount |
integer |
O número de entradas por página. |
30 |
| TotalRecordCount |
integer |
O número total de entradas retornadas. |
1 |
| Items |
array<object> |
Os relatórios de pré-verificação para atualizações de versão principal do mecanismo. |
|
|
object |
Os detalhes do relatório de pré-verificação para uma atualização de versão principal do mecanismo. |
||
| TargetMajorVersion |
string |
A versão principal do mecanismo da instância para a qual você deseja fazer a atualização. |
12.0 |
| EffectiveTime |
string |
O horário de expiração do relatório de pré-verificação. O horário segue o padrão ISO 8601 no formato yyyy-MM-ddTHH:mm:ssZ. O horário é exibido em UTC. |
1635748703000 |
| SourceMajorVersion |
string |
A versão principal original do mecanismo da instância. |
11.0 |
| Result |
string |
O resultado da pré-verificação para uma atualização de versão principal do mecanismo. Valores válidos:
Nota
Se o valor deste parâmetro for Fail, você deve verificar o valor do parâmetro Detail para resolver o problema e executar a pré-verificação novamente. Para obter mais informações sobre problemas comuns e soluções, consulte Introdução ao relatório de verificação para uma instância do ApsaraDB RDS for PostgreSQL. |
Success |
| TaskId |
integer |
O ID da tarefa de pré-verificação para uma atualização de versão principal do mecanismo. |
416980000 |
| Detail |
string |
O conteúdo do relatório de pré-verificação para uma atualização de versão principal do mecanismo. |
[user_check_report]User check success\n[pg_upgrade_internal.log]Performing... |
| CheckTime |
string |
O horário em que a pré-verificação foi realizada. O horário segue o padrão ISO 8601 no formato yyyy-MM-ddTHH:mm:ssZ. O horário é exibido em UTC. |
1635143903000 |
| RecommendDiskSize |
integer |
A capacidade mínima de armazenamento necessária para a atualização. Unidade: GB. Nota
Este parâmetro é retornado apenas para instâncias do ApsaraDB RDS for PostgreSQL. |
100 |
| RecommendLeastMemSize |
integer |
A memória mínima necessária para a atualização. Unidade: GB. Nota
Este parâmetro é retornado apenas para instâncias do ApsaraDB RDS for PostgreSQL. |
8 |
| RecommendMemSize |
integer |
O tamanho de memória recomendado para a atualização. Unidade: GB. Se o tamanho da memória da instância for maior ou igual ao tamanho de memória recomendado, a atualização será realizada na velocidade máxima para minimizar o tempo de somente leitura da instância. Nota
Este parâmetro é retornado apenas para instâncias do ApsaraDB RDS for PostgreSQL. |
32 |
| UpgradeMode |
string |
Exemplos
Resposta de sucesso
JSON formato
{
"RequestId": "D1586777-41B5-5F9E-81E8-93DFDD379024",
"PageNumber": 1,
"PageRecordCount": 30,
"TotalRecordCount": 1,
"Items": [
{
"TargetMajorVersion": "12.0",
"EffectiveTime": "1635748703000",
"SourceMajorVersion": "11.0",
"Result": "Success",
"TaskId": 416980000,
"Detail": "[user_check_report]User check success\\n[pg_upgrade_internal.log]Performing...",
"CheckTime": "1635143903000",
"RecommendDiskSize": 100,
"RecommendLeastMemSize": 8,
"RecommendMemSize": 32,
"UpgradeMode": ""
}
]
}
Códigos de erro
|
Código de status HTTP |
Código de erro |
Mensagem de erro |
Descrição |
|---|---|---|---|
| 400 | InvalidDBInstanceName.NotFound | The specified DB instance name does not exist. | |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | |
| 400 | Price.CommoditySys | Commodity system call exception. | |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | |
| 400 | pay.noCreditCard | Account not bound to credit card. | |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | |
| 400 | noAvailablePaymentMethod | No payment method is specified for your account. We recommend that you add a payment method. | |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | |
| 400 | Api.NotSupport | Specified api is not supported. | |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | |
| 400 | KmsApiError | User secret key invalid. | |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | |
| 400 | RequiredParam.NotFound | Required input param is not found. | |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | |
| 400 | Pay.NoCreditCard | No credit cards. | |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | |
| 400 | OrdTCommodityQueryError | Failed to query for product. | |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | |
| 403 | NotInFlowController | Sorry,no permission. | |
| 403 | InvalidKmsKey | Kms key is disabled. | |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | |
| 404 | Request.NotFound | The requested resource is not available. | |
| 404 | HostInfo.NotFound | The specified host info is not found. |
Consulte Códigos de Erro para uma lista completa.
Notas de versão
Consulte Notas de Versão para uma lista completa.