Consulta os arquivos de backup incluídos em uma tarefa de migração de dados de backup de uma instância do ApsaraDB RDS for SQL Server.
Descrição da operação
Mecanismos de banco de dados compatíveis
SQL Server
Observações de uso
Esta operação não é compatível com instâncias que executam o SQL Server 2017 EE ou o SQL Server 2019 EE.
Experimente agora
Testar
Autorização RAM
|
Ação |
Nível de acesso |
Tipo de recurso |
Chave de condição |
Ação dependente |
|
rds:DescribeOssDownloads |
get |
*DBInstance
|
|
Nenhuma |
Parâmetros da solicitação
|
Parâmetro |
Tipo |
Obrigatório |
Descrição |
Exemplo |
| DBInstanceId |
string |
Sim |
O ID da instância. Você pode chamar a operação DescribeDBInstances para consultar o ID da instância. |
rm-uf6wjk5**** |
| MigrateTaskId |
string |
Sim |
O ID da tarefa de migração. Você pode chamar a operação DescribeMigrateTasks para consultar o ID da tarefa de migração. |
5625458541 |
| ResourceGroupId |
string |
Não |
O ID do grupo de recursos. |
rg-acfmy**** |
Elementos de resposta
|
Elemento |
Tipo |
Descrição |
Exemplo |
|
object |
Os parâmetros de resposta. |
||
| DBInstanceId |
string |
O ID da instância. |
rm-uf6wjk5**** |
| Items |
object |
||
| OssDownload |
array<object> |
Detalhes do arquivo de backup. |
|
|
object |
|||
| BackupMode |
string |
O tipo de backup. Valores válidos:
|
Database |
| CreateTime |
string |
A hora em que o arquivo de backup foi criado na lista de downloads. A hora segue o padrão ISO 8601 no formato yyyy-MM-ddTHH:mm:ssZ. A hora é exibida em UTC. |
2017-08-17T12:45:15Z |
| Description |
string |
A descrição do arquivo de backup. |
App description |
| EndTime |
string |
O fim do intervalo de tempo durante o qual os dados foram consultados. A hora segue o padrão ISO 8601 no formato yyyy-MM-ddTHH:mm:ssZ. A hora é exibida em UTC. |
2017-08-27T12:45:15Z |
| FileName |
string |
O nome do arquivo de backup armazenado no bucket do Object Storage Service (OSS). |
test |
| FileSize |
string |
O tamanho do arquivo de backup. Unidade: MB. |
2 |
| IsAvailable |
string |
Indica se o arquivo de backup está disponível. Valores válidos: True e False. |
True |
| Status |
string |
O estado do arquivo de backup. Valores válidos:
|
Finished |
| MigrateTaskId |
string |
O ID da tarefa de migração. |
562154852 |
| RequestId |
string |
O ID da solicitação. |
A5409D02-D661-4BF3-8F3D-0A814D0574E7 |
Exemplos
Resposta de sucesso
JSON formato
{
"DBInstanceId": "rm-uf6wjk5****",
"Items": {
"OssDownload": [
{
"BackupMode": "Database",
"CreateTime": "2017-08-17T12:45:15Z",
"Description": "App description",
"EndTime": "2017-08-27T12:45:15Z",
"FileName": "test",
"FileSize": "2",
"IsAvailable": "True",
"Status": "Finished"
}
]
},
"MigrateTaskId": "562154852",
"RequestId": "A5409D02-D661-4BF3-8F3D-0A814D0574E7"
}
Códigos de erro
|
Código de status HTTP |
Código de erro |
Mensagem de erro |
Descrição |
|---|---|---|---|
| 400 | Abs.InvalidAccount.NotFound | account is not found. | |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | |
| 400 | Price.CommoditySys | Commodity system call exception. | |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | |
| 400 | pay.noCreditCard | Account not bound to credit card. | |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | |
| 400 | noAvailablePaymentMethod | No payment method is specified for your account. We recommend that you add a payment method. | |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | |
| 400 | Api.NotSupport | Specified api is not supported. | |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | |
| 400 | KmsApiError | User secret key invalid. | |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | |
| 400 | RequiredParam.NotFound | Required input param is not found. | |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | |
| 400 | Pay.NoCreditCard | No credit cards. | |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | |
| 400 | OrdTCommodityQueryError | Failed to query for product. | |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | |
| 403 | NotInFlowController | Sorry,no permission. | |
| 403 | InvalidKmsKey | Kms key is disabled. | |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | |
| 404 | Request.NotFound | The requested resource is not available. | |
| 404 | HostInfo.NotFound | The specified host info is not found. |
Consulte Códigos de Erro para uma lista completa.
Notas de versão
Consulte Notas de Versão para uma lista completa.