Consulta os dados de desempenho do proxy de banco de dados de uma instância do ApsaraDB RDS.
Descrição da operação
Mecanismos suportados
-
RDS MySQL
-
RDS PostgreSQL
A partir de 17 de outubro de 2023, o ApsaraDB RDS MySQL Cluster Edition fornece gradualmente um proxy de banco de dados dedicado gratuito por instância em cada zona de borda. Para mais informações, consulte Oferta: um proxy de banco de dados dedicado gratuito para o RDS MySQL Cluster Edition.
Documentação de funções relacionadas
Antes de usar esta API, leia atentamente a documentação da função para compreender totalmente os pré-requisitos e os possíveis impactos do uso desta API antes de realizar qualquer operação.
Experimente agora
Testar
Autorização RAM
|
Ação |
Nível de acesso |
Tipo de recurso |
Chave de condição |
Ação dependente |
|
rds:DescribeDBProxyPerformance |
get |
*DBInstance
|
|
Nenhuma |
Parâmetros da solicitação
|
Parâmetro |
Tipo |
Obrigatório |
Descrição |
Exemplo |
| DBInstanceId |
string |
Sim |
O ID da instância. Você pode chamar a operação DescribeDBInstances para consultar o ID da instância. |
rm-t4n3a**** |
| DBProxyInstanceType |
string |
Não |
O tipo da instância de proxy de banco de dados. Valores válidos:
|
exclusive |
| StartTime |
string |
Sim |
O início do intervalo de tempo a ser consultado. Especifique a hora no padrão ISO 8601 no formato aaaa-MM-ddTHH:mm:ssZ. A hora deve estar em UTC. |
2019-09-19T01:00:00Z |
| EndTime |
string |
Sim |
O fim do intervalo de tempo a ser consultado. A hora de término deve ser posterior à hora de início. Especifique a hora no padrão ISO 8601 no formato aaaa-MM-ddTHH:mm:ssZ. A hora deve estar em UTC. |
2019-09-21T18:00:00Z |
| RegionId |
string |
Sim |
O ID da região. Você pode chamar a operação DescribeRegions para consultar a lista de regiões mais recente. |
cn-hangzhou |
| MetricsName |
string |
Sim |
As métricas de desempenho que você deseja consultar. Se a instância executar o MySQL, você poderá consultar apenas a métrica de desempenho Maxscale_CpuUsage, que indica a utilização da CPU da instância. Se a instância executar o PostgreSQL, você poderá consultar as seguintes métricas de desempenho:
Se você desejar consultar mais de uma métrica de desempenho, separe as métricas de desempenho com vírgulas (,). Você pode especificar até seis métricas de desempenho em uma única solicitação. |
Maxscale_CpuUsage |
| DBInstanceId |
string |
Sim |
O ID da instância. Você pode chamar a operação DescribeDBInstances para consultar o ID da instância. |
rm-t4n3a**** |
| DBProxyEngineType |
string |
Não |
Um parâmetro reservado. Você não precisa especificar este parâmetro. |
normal |
| Dimension |
string |
Não |
A dimensão. |
service,node server,node service |
Elementos de resposta
|
Elemento |
Tipo |
Descrição |
Exemplo |
|
object |
Os parâmetros de resposta. |
||
| EndTime |
string |
A hora de término da consulta. |
2019-09-21T18:00:00Z |
| StartTime |
string |
A hora de início da consulta. |
2019-09-19T01:00:00Z |
| DBInstanceId |
string |
O ID da instância. |
lsme**** |
| RequestId |
string |
O ID da solicitação. |
DD31056F-A0CE-41D7-AD39-689B6ABAE982 |
| DBProxyEngineType |
string |
Um parâmetro interno. Você não precisa especificar este parâmetro. |
normal |
| PerformanceKeys |
object |
||
| PerformanceKey |
array<object> |
A lista de desempenho. |
|
|
array<object> |
As informações de desempenho. |
||
| ValueFormat |
string |
The format in which the value of the performance metric is returned. |
docker_container_cpu |
| Key |
string |
The performance parameter. |
cpu_ratio |
| Values |
object |
||
| PerformanceValue |
array<object> |
The performance metrics. |
|
|
object |
Performance value details. |
||
| Date |
string |
The date and time when the value of the performance metric was recorded. The time follows the ISO 8601 standard in the yyyy-MM-ddTHH:mm:ssZ format. The time is displayed in UTC. |
2019-10-10T09:00:00Z |
| Value |
string |
The value of the performance metric. |
2.83 |
| Service |
string |
The service dimension. |
mr-xxx |
| Node |
string |
Proxy node ID |
pn-xxx |
| Server |
string |
Database node ID |
rn-xxx |
Exemplos
Resposta de sucesso
JSON formato
{
"EndTime": "2019-09-21T18:00:00Z",
"StartTime": "2019-09-19T01:00:00Z",
"DBInstanceId": "lsme****",
"RequestId": "DD31056F-A0CE-41D7-AD39-689B6ABAE982",
"DBProxyEngineType": "normal",
"PerformanceKeys": {
"PerformanceKey": [
{
"ValueFormat": "docker_container_cpu",
"Key": "cpu_ratio",
"Values": {
"PerformanceValue": [
{
"Date": "2019-10-10T09:00:00Z",
"Value": "2.83"
}
]
},
"Service": "mr-xxx",
"Node": "pn-xxx",
"Server": "rn-xxx"
}
]
}
}
Códigos de erro
|
Código de status HTTP |
Código de erro |
Mensagem de erro |
Descrição |
|---|---|---|---|
| 400 | InvalidDBInstanceName | Specified parameter DBInstanceName is not valid. | The value of the DBInstanceName parameter is invalid. Check that the value of this parameter is not null or an empty string. |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | A package instance is not allowed to operate independently. |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | Pricing plan price result not found. |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the cost and cost for real-name authentication. |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | Your account available limit is less than 0, please recharge before trying to purchase. |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | Failed to call commodity service return. |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | Hello, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will stop operating. In order to ensure your business continuity and smooth transition of data migration, you are currently unable to operate new purchase orders. Thank you for your understanding and support. |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | The module you purchased is not legal, please buy it again. |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | Hello customer, this area has been abolished. |
| 400 | Price.CommoditySys | Commodity system call exception. | Commodity system call exception. |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | Insufficient available balance. |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | There is a problem with the period you selected, please choose again. |
| 400 | pay.noCreditCard | Account not bound to credit card. | |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | Your basic information is not complete, please complete your basic information before operation. |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | Your account is abnormal, please contact customer service for details. |
| 400 | Api.NotSupport | Specified api is not supported. | The current interface does not support. |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | You cannot place the order because a tag indicates that order placement is prohibited. Contact your distributor. |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | The DBInstanceId provided does not exist. |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | The current instance type does not support the specified storage type. |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | The specified wal_level parameter is invalid. There is still a copy slot in the instance, so it cannot be set to replica. |
| 400 | KmsApiError | User secret key invalid. | The user key is invalid. |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | A system error occurs when the sales expression is verified. |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | The account does not exist. |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | SQL command execution failed or timed out |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | The current instance engine version not support coldDataEnabled. |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | The current instance minor version not support coldDataEnabled. |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | This operation is not supported by the instance type. |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | The link address name is duplicate. Please reset the connection string. |
| 400 | RequiredParam.NotFound | Required input param is not found. | |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | Parameter error, please check the parameters. |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | Specified Released Keep Policy is not valid. |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | This operation is not supported for the database engine of the instance. |
| 400 | Pay.NoCreditCard | No credit cards. | No credit cards. |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | The vpc network type instance does not support this operation. |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | Specified DB instance mirror ins already existed. |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | The specified DB instance class stops selling. |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | The specified database does not exist in the backup set. |
| 400 | OrdTCommodityQueryError | Failed to query for product. | Failed to query product. |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | The instance has been released, please verify and place an order. |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | The region is no longer supported. |
| 400 | NoAvailablePaymentMethod | No payment method is specified for account. We recommend that you add a payment method. | Account does not specify a payment method. We recommend that you add a payment method. |
| 400 | InvalidTargetEntity.Malformed | the specified target entity is not found. | The queried entity does not exist |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | The request processing has failed due to external service failure. |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | The service request failed. Please try again later or contact service personnel. |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | The request failed to be processed due to an RDS API failure. |
| 403 | ParamNotFound | The parameter is not found for the interface. | The parameter is not found for the interface. |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | The instance has an unpaid order. Please pay first and try again. |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | The scale-in target capacity cannot be less than the current storage space usage |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | The user is not authorized to perform this operation. |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | This operation is not supported for the current minor engine version. |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | There is no available zone for inventory. |
| 403 | NotInFlowController | Sorry,no permission. | Sorry,no permission. |
| 403 | InvalidKmsKey | Kms key is disabled. | |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | The specified database instance type does not support this operation. |
| 404 | Endpoint.NotFound | Specified endpoint is not found. | The port that is associated with the dedicated proxy endpoint cannot be found. |
| 404 | InvalidDBInstanceName.NotFound | The DBInstanceId provided does not exist in our records. | The instance ID cannot be found. |
| 404 | Maxscale.NotFound | The relative maxscale instance is not found. | No associated maxscale instance is found. |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | The instance does not have permissions to access Key Management Service (KMS). |
| 404 | Request.NotFound | The requested resource is not available. | The requested resources are unavailable. |
| 404 | HostInfo.NotFound | The specified host info is not found. | |
| 408 | InvalidOthers.Timeout | Query timed out.Please try again or narrow down the query scope. | Request timed out, please try again or narrow the time range |
Consulte Códigos de Erro para uma lista completa.
Notas de versão
Consulte Notas de Versão para uma lista completa.