Esta operação retorna o status e a configuração de uma instância de replicação nativa.
Descrição da operação
Engines compatíveis
RDS MySQL
Documentação relacionada
Experimente agora
Testar
Autorização RAM
Parâmetros da solicitação
|
Parâmetro |
Tipo |
Obrigatório |
Descrição |
Exemplo |
| RegionId |
string |
Sim |
O ID da região. Você pode chamar a operação DescribeRegions para consultar a lista de regiões mais recente. |
cn-hangzhou |
| DBInstanceId |
string |
Sim |
O ID da instância. Você pode chamar a operação DescribeDBInstances para consultar o ID da instância. |
rm-uf6wjk5**** |
| ResourceGroupId |
string |
Não |
O ID do grupo de recursos. |
rg-acfmx**** |
Elementos de resposta
|
Elemento |
Tipo |
Descrição |
Exemplo |
|
object |
Os detalhes dos parâmetros de resposta. |
||
| RequestId |
string |
O ID da solicitação. |
847BA085-B377-4BFA-8267-F82345ECE1D2 |
| ExternalReplication |
string |
Indica se a replicação nativa está ativada. Valores válidos:
|
ON |
| ReplicationSource |
string |
A origem de replicação para a replicação nativa. |
192.168.XX.XX |
| ReplicationState |
string |
O estado da replicação. Valores válidos:
|
Stopped |
| ReplicationDelay |
string |
O atraso da replicação, em segundos. |
0 |
| ReplicationErrorMessage |
string |
A mensagem de erro da replicação. |
Got fatal error 1236 from master when reading data from binary log... |
| ReplicationIp |
string |
O endereço IP da réplica. |
192.168.10.x |
| ReplicationPort |
string |
A porta da réplica. |
3306 |
| GtidExecuted |
string |
O identificador de transação global (GTID) executado. |
bd2a34b9-8b8d-11ef-8917-00163e1298b9:1-20567 |
| ImportStatus |
string |
Indica se os dados completos foram importados com sucesso. |
COMPLETED |
| SlaveStatusList |
array<object> |
[{"SlaveIoRunning": "Yes", "SlaveSqlRunning": "Yes", "SecondsBehindMaster": 0, "SlaveIoState": "Waiting for master to send event", "SlaveSqlRunningState": "Slave has read all relay log; waiting for more updates", "ExecutedGtidSet": "bd2a34b9-8b8d-11ef-8917-00163e1298b9:1-20567", "MasterHost": "192.168.10.100", "MasterUser": "repl_user", "MasterUuid": "bd2a34b9-8b8d-11ef-8917-00163e1298b9", "LastErrno": 0, "LastSqlErrno": 0, "LastIoErrno": 0, "LastSqlError": "", "LastIoError": "", "ChannelName": "my_test_channel", "ReplicateDoDb": "test_db,test_db_1", "ReplicateIgnoreDb": "information_schema,performance_schema", "ReplicateDoTable": "test_table,test_table_1", "ReplicateIgnoreTable": "temp_table,temp_table_1", "ReplicateWildDoTable": "test_table.%", "ReplicateWildIgnoreTable": "temp_table.%"}] |
|
|
object |
|||
| SlaveIoRunning |
string |
Indica se a thread de I/O da réplica está em execução. |
Yes |
| SlaveSqlRunning |
string |
Indica se a thread SQL da réplica está em execução. |
Yes |
| SecondsBehindMaster |
integer |
0 |
|
| SlaveIoState |
string |
Waiting for master to send event |
|
| SlaveSqlRunningState |
string |
Slave has read all relay log; waiting for more updates |
|
| ExecutedGtidSet |
string |
bd2a34b9-8b8d-11ef-8917-00163e1298b9:1-20567 |
|
| MasterHost |
string |
192.168.10.100 |
|
| MasterUser |
string |
repl_user |
|
| MasterUuid |
string |
bd2a34b9-8b8d-11ef-8917-00163e1298b9 |
|
| LastErrno |
integer |
O código de erro mais recente. Um valor de |
0 |
| LastSqlErrno |
integer |
O código de erro da thread SQL. Um valor de |
0 |
| LastIoErrno |
integer |
O código de erro da thread de I/O. Um valor de |
0 |
| LastSqlError |
string |
A mensagem de erro da thread SQL. |
|
| LastIoError |
string |
A mensagem de erro da thread de I/O. |
|
| ChannelName |
string |
my_test_channel |
|
| ReplicateDoDb |
string |
test_db,test_db_1 |
|
| ReplicateIgnoreDb |
string |
information_schema,performance_schema |
|
| ReplicateDoTable |
string |
test_table,test_table_1 |
|
| ReplicateIgnoreTable |
string |
temp_table,temp_table_1 |
|
| ReplicateWildDoTable |
string |
test_table.% |
|
| ReplicateWildIgnoreTable |
string |
temp_table.% |
Exemplos
Resposta de sucesso
JSON formato
{
"RequestId": "847BA085-B377-4BFA-8267-F82345ECE1D2",
"ExternalReplication": "ON",
"ReplicationSource": "192.168.XX.XX",
"ReplicationState": "Stopped",
"ReplicationDelay": "0",
"ReplicationErrorMessage": "Got fatal error 1236 from master when reading data from binary log...",
"ReplicationIp": "192.168.10.x",
"ReplicationPort": "3306",
"GtidExecuted": "bd2a34b9-8b8d-11ef-8917-00163e1298b9:1-20567",
"ImportStatus": "COMPLETED",
"SlaveStatusList": [
{
"SlaveIoRunning": "Yes",
"SlaveSqlRunning": "Yes",
"SecondsBehindMaster": 0,
"SlaveIoState": "Waiting for master to send event",
"SlaveSqlRunningState": "Slave has read all relay log; waiting for more updates",
"ExecutedGtidSet": "bd2a34b9-8b8d-11ef-8917-00163e1298b9:1-20567",
"MasterHost": "192.168.10.100",
"MasterUser": "repl_user",
"MasterUuid": "bd2a34b9-8b8d-11ef-8917-00163e1298b9",
"LastErrno": 0,
"LastSqlErrno": 0,
"LastIoErrno": 0,
"LastSqlError": "",
"LastIoError": "",
"ChannelName": "my_test_channel",
"ReplicateDoDb": "test_db,test_db_1",
"ReplicateIgnoreDb": "information_schema,performance_schema",
"ReplicateDoTable": "test_table,test_table_1",
"ReplicateIgnoreTable": "temp_table,temp_table_1",
"ReplicateWildDoTable": "test_table.%",
"ReplicateWildIgnoreTable": "temp_table.%"
}
]
}
Códigos de erro
|
Código de status HTTP |
Código de erro |
Mensagem de erro |
Descrição |
|---|---|---|---|
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | Operações individuais não são permitidas para instâncias de pacote. |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | O resultado do preço do plano de preços não foi encontrado. |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | Você não concluiu a verificação de nome real e não está elegível para fazer uma compra. Faça login em Despesas e Custos para concluir a verificação de nome real. |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | O crédito disponível da sua conta é menor que 0. Recarregue sua conta antes de tentar fazer uma compra. |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | A chamada para o serviço de commodity retornou uma falha. |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | O Alibaba Cloud planeja otimizar e ajustar a região atual. Os serviços em nuvem nesta região serão descontinuados. Para garantir a continuidade dos seus negócios e uma migração de dados tranquila, você não pode fazer novos pedidos de compra no momento. Agradecemos sua compreensão e apoio. |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | O módulo adquirido é inválido. Adquira um módulo válido. |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | A região foi desativada. |
| 400 | Price.CommoditySys | Commodity system call exception. | Ocorreu uma exceção ao chamar o sistema de commodities. |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | O período de assinatura selecionado é inválido. Selecione um período de assinatura válido. |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | Existe um pedido não pago para o serviço selecionado. Pague ou cancele o pedido antes de fazer um novo. |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | Suas informações básicas estão incompletas. Complete suas informações básicas antes de realizar esta operação. |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | Ocorreu uma exceção com a sua conta. Entre em contato com o atendimento ao cliente para obter detalhes. |
| 400 | Api.NotSupport | Specified api is not supported. | A operação de API atual não é suportada. |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | Existe uma tag de bloqueio de pedido. Entre em contato com seu distribuidor para obter assistência. |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | O DBInstanceId especificado não existe. |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | O tipo de instância atual não oferece suporte ao tipo de armazenamento especificado. |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | O parâmetro de entrada é inválido. |
| 400 | KmsApiError | User secret key invalid. | A chave do usuário é inválida. |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | Sua conta da Alibaba Cloud não existe ou sua AccessKey expirou. |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | A execução do comando SQL falhou ou expirou. |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | A versão atual do mecanismo DPI da instância não suporta o arquivamento de dados frios. |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | A versão atual do kernel não suporta o arquivamento de dados frios. |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | O tipo de instância atual não oferece suporte a esta operação. |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | O nome do endereço de conexão está duplicado. Reconfigure a string de conexão. |
| 400 | RequiredParam.NotFound | Required input param is not found. | Parâmetros obrigatórios estão ausentes. |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | O parâmetro está incorreto. Verifique o parâmetro. |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | O arquivamento de dados frios não oferece suporte a backup entre regiões ou backup de snapshot de alta frequência. Verifique a política de backup. |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | O status da instância não suporta esta operação. |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | A política de retenção de dados de backup arquivados após a liberação da instância é inválida. |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | O tipo de mecanismo de banco de dados da instância não oferece suporte a esta operação. |
| 400 | Pay.NoCreditCard | No credit cards. | |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | Esta operação não é suportada para instâncias do tipo de rede VPC. |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | A imagem da instância de banco de dados atual já existe. |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | O tipo de instância não está mais disponível para compra. |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | O banco de dados especificado não existe no conjunto de backup. |
| 400 | OrdTCommodityQueryError | Failed to query for product. | Falha ao consultar o produto. |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | A instância foi liberada. Verifique a instância antes de fazer o pedido. |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | A região foi desativada. |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | A solicitação para o serviço falhou. Tente novamente mais tarde. |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | A solicitação de serviço falhou. Tente novamente mais tarde ou entre em contato com o suporte. |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | A solicitação falhou porque o serviço da API do RDS apresentou falha. |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | Existe um pedido não pago para a instância atual. Pague o pedido e tente novamente. |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | A capacidade de destino para redução de escala não pode ser menor que o uso de armazenamento atual. |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | Os discos em nuvem SSD não suportam esta operação. Faça upgrade para ESSD. |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | As permissões do usuário não suportam esta operação. |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | O VSwitchId especificado está em um formato incorreto ou está vazio. |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | A versão secundária atual do mecanismo não suporta esta operação. |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | Não há regiões de inventário disponíveis. |
| 403 | NotInFlowController | Sorry,no permission. | Este recurso está disponível apenas para usuários de nuvem corporativa. Você não tem as permissões necessárias. |
| 403 | InvalidKmsKey | Kms key is disabled. | A chave KMS está desativada. |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | O nível atual da instância de banco de dados não oferece suporte a esta operação. |
| 403 | IncorrectDBInstanceType | Current DB instance type does not support this operation. | A operação falhou. Esta operação não é suportada no status atual da instância. |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | A instância atual não está autorizada a acessar o Key Management Service (KMS). |
| 404 | Request.NotFound | The requested resource is not available. | O recurso solicitado não está disponível. |
| 404 | HostInfo.NotFound | The specified host info is not found. | As informações do host especificado não existem. |
| 404 | InvalidReplicationChannel.NotFound | Specified replication channel does not exist. | A tarefa de replicação especificada não existe. |
Consulte Códigos de Erro para uma lista completa.
Notas de versão
Consulte Notas de Versão para uma lista completa.