Todos os produtos
Search
Central de documentação

ApsaraDB RDS:DescribeCrossRegionBackups

Última atualização: Jul 07, 2026

Consulta os arquivos de backup de dados entre regiões de uma instância.

Descrição da operação

Mecanismos de banco de dados compatíveis

  • Instâncias do ApsaraDB RDS for MySQL com discos locais

  • RDS PostgreSQL

  • RDS SQL Server

Referências

Nota

Antes de chamar esta operação, leia atentamente a documentação a seguir. Certifique-se de compreender totalmente os pré-requisitos e os impactos da chamada desta operação.

Nota

Para obter mais informações sobre como consultar arquivos de backup de log entre regiões, consulte DescribeCrossRegionLogBackupFiles.

Experimente agora

Experimente esta API no OpenAPI Explorer, sem necessidade de assinatura manual. Chamadas bem-sucedidas geram automaticamente código SDK correspondente aos seus parâmetros. Faça o download com segurança de credenciais integrada para uso local.

Testar

Autorização RAM

A tabela abaixo descreve a autorização necessária para chamar esta API. Você pode defini-la em uma política do Resource Access Management (RAM). As colunas da tabela estão detalhadas abaixo:

  • Ação: As ações que podem ser usadas no elemento Action das instruções de política de permissão do RAM para conceder permissões para executar a operação.

  • API: A API que você pode chamar para executar a ação.

  • Nível de acesso: O nível de acesso predefinido concedido para cada API. Valores válidos: create, list, get, update e delete.

  • Tipo de recurso: O tipo de recurso que suporta autorização para executar a ação. Indica se a ação suporta permissão em nível de recurso. O recurso especificado deve ser compatível com a ação. Caso contrário, a política será ineficaz.

    • Para APIs com permissões em nível de recurso, os tipos de recursos obrigatórios são marcados com um asterisco (*). Especifique o Nome de Recurso Alibaba Cloud (ARN) correspondente no elemento Resource da política.

    • Para APIs sem permissões em nível de recurso, é exibido como Todos os Recursos. Use um asterisco (*) no elemento Resource da política.

  • Chave de condição: As chaves de condição definidas pelo serviço. A chave permite controle granular, aplicando-se somente a ações ou a ações associadas a recursos específicos. Além das chaves de condição específicas do serviço, o Alibaba Cloud fornece um conjunto de chaves de condição comuns aplicáveis a todos os serviços compatíveis com RAM.

  • Ação dependente: As ações dependentes necessárias para executar a ação. Para concluir a ação, o usuário RAM ou a função RAM deve ter permissões para executar todas as ações dependentes.

Ação

Nível de acesso

Tipo de recurso

Chave de condição

Ação dependente

rds:DescribeCrossRegionBackups

get

*DBInstance

acs:rds:{#regionId}:{#accountId}:dbinstance/{#dbinstanceId}

  • rds:ResourceTag
  • rds:ResourceTag
  • rds:ResourceTag
Nenhuma

Parâmetros da solicitação

Parâmetro

Tipo

Obrigatório

Descrição

Exemplo

DBInstanceId

string

Sim

O ID da instância.

rm-uf6wjk5****

RegionId

string

Sim

O ID da região.

cn-hangzhou

CrossBackupRegion

string

Não

O ID da região na qual o arquivo de backup de dados entre regiões está armazenado.

cn-shanghai

CrossBackupId

integer

Não

O ID do arquivo de backup de dados entre regiões.

Nota

Você deve especificar o parâmetro CrossBackupId. Como alternativa, você deve especificar os parâmetros StartTime e EndTime.

14562

StartTime

string

Não

O início do intervalo de tempo a ser consultado. Especifique a hora no padrão ISO 8601 no formato aaaa-MM-ddTHH:mm:ssZ. A hora deve estar em UTC.

2024-03-05T02:21:00Z

EndTime

string

Não

O fim do intervalo de tempo a ser consultado. Especifique a hora no padrão ISO 8601 no formato aaaa-MM-ddTHH:mm:ssZ. A hora deve estar em UTC.

2024-03-05T02:24:37Z

PageSize

integer

Não

O número de entradas por página. Valores válidos:

  • 30

  • 50

  • 100

Valor padrão: 30.

30

PageNumber

integer

Não

O número da página. Valores válidos: qualquer número inteiro positivo diferente de zero.

Valor padrão: 1.

1

BackupId

integer

Não

O ID do arquivo de backup.

603524****

ResourceGroupId

string

Não

O ID do grupo de recursos.

rg-acfmy****

Elementos de resposta

Elemento

Tipo

Descrição

Exemplo

object

Os parâmetros de resposta.

EndTime

string

O fim do intervalo de tempo a ser consultado.

2019-06-15T12:10:00Z

Items

object

Item

array<object>

Os arquivos de backup de dados entre regiões.

array<object>

BackupEndTime

string

O horário em que o arquivo de backup de dados entre regiões foi gerado.

2024-03-05T02:23:37Z

BackupMethod

string

O método usado para gerar o arquivo de backup de dados entre regiões. Valores válidos:

  • L: backup lógico

  • P: backup físico

P

BackupSetScale

integer

O nível no qual o arquivo de backup de dados entre regiões é gerado.

  • 0: backup em nível de instância

  • 1: backup em nível de banco de dados

0

BackupSetStatus

integer

O status do backup de dados entre regiões. Valores válidos:

  • 0: O backup de dados entre regiões foi bem-sucedido.

  • 1: O backup de dados entre regiões falhou.

0

BackupStartTime

string

O horário em que o backup de dados entre regiões foi iniciado.

2024-03-05T02:22:45Z

BackupType

string

O tipo do backup de dados entre regiões. Valores válidos:

  • F: backup completo de dados

  • I: backup incremental de dados

F

Category

string

A edição RDS da instância. Valores válidos:

  • Basic: RDS Basic Edition.

  • HighAvailability: RDS High-availability Edition.

  • Finance: RDS Enterprise Edition. Esta edição está disponível apenas para o site China (aliyun.com).

HighAvailability

ConsistentTime

string

O ponto no tempo indicado pelos dados no arquivo de backup de dados entre regiões.

2024-03-05T02:22:54Z

CrossBackupId

integer

O ID do arquivo de backup de dados entre regiões.

1249****

CrossBackupRegion

string

O ID da região na qual os arquivos de backup entre regiões da instância estão armazenados.

cn-shanghai

CrossBackupSetFile

string

O nome do pacote compactado que contém o arquivo de backup de dados entre regiões.

cn-hangzhou_rm-****_hins81xxx_data_20190612134426_qp.xb

CrossBackupSetLocation

string

O local onde o arquivo de backup de dados entre regiões está armazenado.

oss

CrossBackupSetSize

integer

O tamanho do arquivo de backup de dados entre regiões. Unidade: bytes.

5312836

DBInstanceStorageType

string

O tipo de armazenamento. Valores válidos:

  • local_ssd: SSDs locais. Este é o tipo de armazenamento recomendado.

  • cloud_ssd: SSD padrão.

  • cloud_essd: ESSD (enhanced SSD).

ssd

Engine

string

O mecanismo de banco de dados da instância.

mysql

EngineVersion

string

A versão do mecanismo de banco de dados.

5.6

InstanceId

integer

O ID da instância. Este parâmetro é usado para determinar se a instância que gerou o arquivo de backup de dados entre regiões é uma instância primária ou secundária.

8161***

RestoreRegions

object

RestoreRegion

array

As regiões para as quais o arquivo de backup de dados entre regiões pode ser restaurado.

string

A região para a qual o arquivo de backup de dados entre regiões pode ser restaurado.

"cn-hangzhou", "cn-shanghai"

PageNumber

integer

O número da página. As páginas começam na página 1.

Valor padrão: 1.

1

PageRecordCount

integer

O número de arquivos de backup de dados entre regiões na página atual.

30

RegionId

string

O ID da região da instância.

cn-hangzhou

RequestId

string

O ID da solicitação.

60912B41-7579-4B5D-B289-8856030F0A6A

StartTime

string

O início do intervalo de tempo a ser consultado.

2019-05-30T12:10:00Z

TotalRecordCount

integer

O número total de entradas retornadas.

100

Exemplos

Resposta de sucesso

JSON formato

{
  "EndTime": "2019-06-15T12:10:00Z",
  "Items": {
    "Item": [
      {
        "BackupEndTime": "2024-03-05T02:23:37Z",
        "BackupMethod": "P",
        "BackupSetScale": 0,
        "BackupSetStatus": 0,
        "BackupStartTime": "2024-03-05T02:22:45Z",
        "BackupType": "F",
        "Category": "HighAvailability",
        "ConsistentTime": "2024-03-05T02:22:54Z",
        "CrossBackupDownloadLink": "http://rdsddrbak-shanghai.oss-cn-shanghai.aliyuncs.com/****",
        "CrossBackupId": 0,
        "CrossBackupRegion": "cn-shanghai",
        "CrossBackupSetFile": "cn-hangzhou_rm-****_hins81xxx_data_20190612134426_qp.xb",
        "CrossBackupSetLocation": "oss",
        "CrossBackupSetSize": 5312836,
        "DBInstanceStorageType": "ssd",
        "Engine": "mysql",
        "EngineVersion": "5.6",
        "InstanceId": 0,
        "RestoreRegions": {
          "RestoreRegion": [
            "\"cn-hangzhou\", \"cn-shanghai\""
          ]
        }
      }
    ]
  },
  "PageNumber": 1,
  "PageRecordCount": 30,
  "RegionId": "cn-hangzhou",
  "RequestId": "60912B41-7579-4B5D-B289-8856030F0A6A",
  "StartTime": "2019-05-30T12:10:00Z",
  "TotalRecordCount": 100
}

Códigos de erro

Código de status HTTP

Código de erro

Mensagem de erro

Descrição

400 ParameterAbsence Necessary param is absence.
400 InvalidParameters.Format Specified parameter is not valid.
400 InvalidRegion.Format Specified Region is not valid. A região especificada é inválida. Verifique se o parâmetro é válido.
400 InvalidStartTime.Format Specified start time is not valid. O formato da hora de início é inválido. O formato deve estar no formato GMT padrão: AAAA-MM-DDThh:mmZ. Exemplos: DescribeDBInstancePerformance: 2012-06-11T15:00Z. DescribeErrorLogs: 2011-06-11T16:00Z.
400 InvalidEndTime.Format Specified end time is not valid. A operação falhou. O formato da hora de término é inválido. O formato deve estar no formato GMT padrão: AAAA-MM-DDThh:mmZ. Exemplo: 2012-06-11T15:00Z.
400 InvalidTime.Format Specified time is not valid. A operação falhou. O formato de hora é inválido.
400 Order.ComboInstanceNotAllowOperate A package instance is not allowed to operate independently. Operações individuais não são permitidas para instâncias de pacote.
400 Price.PricingPlanResultNotFound Pricing plan price result not found. O resultado do preço do plano de preços não foi encontrado.
400 Order.NoRealNameAuthentication You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. Você não concluiu a verificação de nome real e não está elegível para fazer uma compra. Faça login em Despesas e Custos para concluir a verificação de nome real.
400 InsufficientAvailableQuota Your account quota limit is less than 0, please recharge before trying to purchase. O crédito disponível da sua conta é menor que 0. Recarregue sua conta antes de tentar fazer uma compra.
400 CommodityServiceCalling.Exception Failed to call commodity service. A chamada para o serviço de commodity retornou uma falha.
400 RegionDissolvedEOM Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. O Alibaba Cloud planeja otimizar e ajustar a região atual. Os serviços em nuvem nesta região serão descontinuados. Para garantir a continuidade dos seus negócios e uma migração de dados tranquila, você não pode fazer novos pedidos de compra no momento. Agradecemos sua compreensão e apoio.
400 Commodity.InvalidComponent The module you purchased is not legal, please buy it again. O módulo adquirido é inválido. Adquira um módulo válido.
400 RegionEndTimeDissolvedAustralia Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. A região foi desativada.
400 Price.CommoditySys Commodity system call exception. Ocorreu uma exceção ao chamar o sistema de commodities.
400 Pay.InsufficientBalance Insufficient available balance.
400 Order.PeriodInvalid There is a problem with the period you selected, please choose again. O período de assinatura selecionado é inválido. Selecione um período de assinatura válido.
400 pay.noCreditCard Account not bound to credit card. A conta não está associada a um cartão de crédito.
400 Order.InstHasUnpaidOrder There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. Existe um pedido não pago para o serviço selecionado. Pague ou cancele o pedido antes de fazer um novo.
400 noAvailablePaymentMethod No payment method is specified for your account. We recommend that you add a payment method. Nenhum método de pagamento está especificado para a conta. Adicione um método de pagamento.
400 BasicInfoUncompleted Your information is incomplete. Complete your information before the operation. Suas informações básicas estão incompletas. Complete suas informações básicas antes de realizar esta operação.
400 Risk.RiskControlRejection Your account is abnormal, please contact customer service for details. Ocorreu uma exceção com a sua conta. Entre em contato com o atendimento ao cliente para obter detalhes.
400 Api.NotSupport Specified api is not supported. A operação de API atual não é suportada.
400 ContainForbiddenLabelError There is a label that prohibits placing orders. Please contact your distributor for assistance. Existe uma tag de bloqueio de pedido. Entre em contato com seu distribuidor para obter assistência.
400 InvalidDBInstanceId.NotFound The DBInstanceId provided does not exist in records. O DBInstanceId especificado não existe.
400 InvalidInstanceLevel.DiskType Specified instance level not support request disk type O tipo de instância atual não oferece suporte ao tipo de armazenamento especificado.
400 InvalidParam Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. O parâmetro de entrada é inválido.
400 KmsApiError User secret key invalid. A chave do usuário é inválida.
400 System.SaleValidateFailed Sales expression validation system error.
400 Abs.InvalidAccount.NotFound account is not found. Sua conta da Alibaba Cloud não existe ou sua AccessKey expirou.
400 SqlExecuteFailedOrTimeout sql command execution failed or timed out:%s. A execução do comando SQL falhou ou expirou.
400 ColdData.EngineVersionNotSupport The current instance engine version not support coldDataEnabled. A versão atual do mecanismo DPI da instância não suporta o arquivamento de dados frios.
400 ColdData.MinorVersionNotSupport The current instance minor version not support coldDataEnabled. A versão atual do kernel não suporta o arquivamento de dados frios.
400 IncorrectTargetClasscode The current instance type does not support this operation. O tipo de instância atual não oferece suporte a esta operação.
400 InvalidConnectionString.Duplicate Specified connection string already exists in the RDS. O nome do endereço de conexão está duplicado. Reconfigure a string de conexão.
400 RequiredParam.NotFound Required input param is not found. Parâmetros obrigatórios estão ausentes.
400 Parameters.Invalid Parameter error, please check the parameters. O parâmetro está incorreto. Verifique o parâmetro.
400 BackupPolicyNotSupport Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. O arquivamento de dados frios não oferece suporte a backup entre regiões ou backup de snapshot de alta frequência. Verifique a política de backup.
400 InvalideStatus.Format The instance status does not support this operation. O status da instância não suporta esta operação.
400 InvalidReleasedKeepPolicy.Format Specified Released Keep Policy is not valid. A política de retenção de dados de backup arquivados após a liberação da instância é inválida.
400 InvalidDBInstanceEngineType.Format the DB instance engine type does not support this operation. O tipo de mecanismo de banco de dados da instância não oferece suporte a esta operação.
400 Pay.NoCreditCard No credit cards.
400 VpcNetworkTypeNotSupport The vpc network type instance does not support this operation. Esta operação não é suportada para instâncias do tipo de rede VPC.
400 MirrorInsExists Specified DB instance mirror ins already existed. A imagem da instância de banco de dados atual já existe.
400 UnsupportedClassCode The specified DB instance class stops selling. O tipo de instância não está mais disponível para compra.
400 InvalidBackupSet The specified database does not exist in the backup set. O banco de dados especificado não existe no conjunto de backup.
400 OrdTCommodityQueryError Failed to query for product. Falha ao consultar o produto.
400 ProductInstanceReleased The instance has been released. Please check before placing the order. A instância foi liberada. Verifique a instância antes de fazer o pedido.
400 RegionEndTimeDissolvedIndia The region is no longer supported. A região foi desativada.
500 ExternalFailure The request processing has failed due to external service failure. A solicitação para o serviço falhou. Tente novamente mais tarde.
500 RequestMetaDataFailed The service request failed. Please try again later or contact service personnel. A solicitação de serviço falhou. Tente novamente mais tarde ou entre em contato com o suporte.
500 InvokeProxyFailure The request processing has failed due to service failure of rds api. A solicitação falhou porque o serviço da API do RDS apresentou falha.
403 CrossBackupNotSupport Specified region not support cross region backup. A região especificada não oferece suporte a backup entre regiões.
403 OrderStatus.UnPaid The specified db instance has unpaid order. Existe um pedido não pago para a instância atual. Pague o pedido e tente novamente.
403 InvalidReduceDiskSize The storage capacity after the scale-down must be larger than the used amount. A capacidade de destino para redução de escala não pode ser menor que o uso de armazenamento atual.
403 CloudSSDNotSupport Cloud ssd does not support this operation, please upgrade to essd. Os discos em nuvem SSD não suportam esta operação. Faça upgrade para ESSD.
403 InvalidUserOperatorPermission The user permission does not support this operation. As permissões do usuário não suportam esta operação.
403 InvalidVswitchId Specified conn vswitch id is not valid. O VSwitchId especificado está em um formato incorreto ou está vazio.
403 IncorrectMinorVersion Current engine minor version does not support operations. A versão secundária atual do mecanismo não suporta esta operação.
403 OperationDenied.ZoneResource There is no available zone for inventory. Não há regiões de inventário disponíveis.
403 NotInFlowController Sorry,no permission. Este recurso está disponível apenas para usuários de nuvem corporativa. Você não tem as permissões necessárias.
403 InvalidKmsKey Kms key is disabled. A chave KMS está desativada.
403 InvalidInstanceLevel.Malformed Current DB instance level does not support this operation. O nível atual da instância de banco de dados não oferece suporte a esta operação.
404 InvalidPage.notFound Page not found. O parâmetro especificado não foi encontrado. Verifique e valide o parâmetro.
404 InvalidDBInstance.NotFound Specified instance does not exist or not support. A instância especificada não foi encontrada. Verifique se a instância é válida.
404 InvalidClusterKms The current instance does not authorized to access the Key Management Service. A instância atual não está autorizada a acessar o Key Management Service (KMS).
404 Request.NotFound The requested resource is not available. O recurso solicitado não está disponível.
404 HostInfo.NotFound The specified host info is not found. As informações do host especificado não existem.

Consulte Códigos de Erro para uma lista completa.

Notas de versão

Consulte Notas de Versão para uma lista completa.