Todos os produtos
Search
Central de documentação

ApsaraDB RDS:DescribeActiveOperationTasks

Última atualização: Jul 07, 2026

Consulta os detalhes sobre as tarefas de O&M agendadas para uma instância.

Descrição da operação

Mecanismos de banco de dados compatíveis

  • MySQL

  • PostgreSQL

  • SQL Server

  • MariaDB

Experimente agora

Experimente esta API no OpenAPI Explorer, sem necessidade de assinatura manual. Chamadas bem-sucedidas geram automaticamente código SDK correspondente aos seus parâmetros. Faça o download com segurança de credenciais integrada para uso local.

Testar

Autorização RAM

A tabela abaixo descreve a autorização necessária para chamar esta API. Você pode defini-la em uma política do Resource Access Management (RAM). As colunas da tabela estão detalhadas abaixo:

  • Ação: As ações que podem ser usadas no elemento Action das instruções de política de permissão do RAM para conceder permissões para executar a operação.

  • API: A API que você pode chamar para executar a ação.

  • Nível de acesso: O nível de acesso predefinido concedido para cada API. Valores válidos: create, list, get, update e delete.

  • Tipo de recurso: O tipo de recurso que suporta autorização para executar a ação. Indica se a ação suporta permissão em nível de recurso. O recurso especificado deve ser compatível com a ação. Caso contrário, a política será ineficaz.

    • Para APIs com permissões em nível de recurso, os tipos de recursos obrigatórios são marcados com um asterisco (*). Especifique o Nome de Recurso Alibaba Cloud (ARN) correspondente no elemento Resource da política.

    • Para APIs sem permissões em nível de recurso, é exibido como Todos os Recursos. Use um asterisco (*) no elemento Resource da política.

  • Chave de condição: As chaves de condição definidas pelo serviço. A chave permite controle granular, aplicando-se somente a ações ou a ações associadas a recursos específicos. Além das chaves de condição específicas do serviço, o Alibaba Cloud fornece um conjunto de chaves de condição comuns aplicáveis a todos os serviços compatíveis com RAM.

  • Ação dependente: As ações dependentes necessárias para executar a ação. Para concluir a ação, o usuário RAM ou a função RAM deve ter permissões para executar todas as ações dependentes.

Ação

Nível de acesso

Tipo de recurso

Chave de condição

Ação dependente

rds:DescribeActiveOperationTasks

get

*全部资源

*

Nenhuma Nenhuma

Parâmetros da solicitação

Parâmetro

Tipo

Obrigatório

Descrição

Exemplo

Region

string

Não

O ID da região do evento pendente. Você pode chamar a operação DescribeRegions para consultar a lista de regiões mais recente.

Nota

O valor all indica todas as regiões.

cn-beijing

TaskType

string

Não

O tipo da tarefa. Valores válidos:

  • rds_apsaradb_ha: alternância primário/secundário

  • rds_apsaradb_transfer: migração de instância

  • rds_apsaradb_upgrade: atualização da versão secundária do mecanismo

  • rds_apsaradb_maxscale: atualização da versão secundária do proxy

  • all: todos os tipos

rds_apsaradb_upgrade

PageSize

integer

Não

O número de entradas por página. Valor padrão: 25. Valor máximo: 100.

25

PageNumber

integer

Não

O número da página. As páginas começam na página 1. Valor padrão: 1.

1

ProductId

string

Não

O nome do serviço. Valores válidos: RDS, POLARDB, MongoDB e Redis. Para instâncias RDS, defina o valor como RDS.

RDS

DbType

string

Não

O tipo do banco de dados. Valor padrão: all. Valores válidos: mysql, pgsql e mssql.

all

Status

integer

Não

O status da tarefa, que é usado como condição de filtro para retornar tarefas.

  • -1: todas as tarefas

  • 3: pendente

  • 4: em processamento

  • 5: concluída

  • 6: com falha

  • 7: cancelada

-1

InsName

string

Não

O nome da instância. Você pode deixar este parâmetro vazio. Se você configurar este parâmetro, poderá especificar o nome de apenas uma instância.

rm-bp191w771kd3****

AllowChange

integer

Não

A condição de filtro usada para retornar tarefas com base nas configurações do horário de alternância. Valor padrão: -1. Valores válidos:

  • -1: retorna todas as tarefas.

  • 0: retorna apenas tarefas para as quais o horário de alternância não pode ser alterado.

  • 1: retorna apenas tarefas para as quais o horário de alternância pode ser alterado.

-1

AllowCancel

integer

Não

A condição de filtro usada para retornar tarefas com base nas configurações de cancelamento de tarefa. Valor padrão: -1. Valores válidos:

  • -1: retorna todas as tarefas.

  • 0: retorna apenas tarefas que não podem ser canceladas.

  • 1: retorna apenas tarefas que podem ser canceladas.

-1

ChangeLevel

string

Não

A condição de filtro usada para retornar tarefas com base no nível da tarefa. Valor padrão: all. Valores válidos:

  • all: todos os tipos

  • S0: retorna as tarefas do nível de correção de exceção.

  • S1: retorna as tarefas do nível de O&M do sistema.

all

Elementos de resposta

Elemento

Tipo

Descrição

Exemplo

object

Os parâmetros de resposta.

Items

array<object>

Os detalhes sobre a tarefa de O&M.

object

AllowCancel

string

Indica se a tarefa pode ser cancelada. O valor 1 indica que a tarefa pode ser cancelada. O valor 0 indica que a tarefa não pode ser cancelada.

1

AllowChange

string

Indica se o horário de alternância pode ser alterado. O valor 1 indica que o horário de alternância pode ser alterado. O valor 0 indica que o horário de alternância não pode ser alterado.

1

ChangeLevel

string

O código do nível da tarefa. O valor S1 indica o nível de O&M do sistema. O valor S0 indica o nível de correção de exceção.

S1

ChangeLevelEn

string

O nível da tarefa em inglês.

System maintenance

ChangeLevelZh

string

O nível da tarefa em chinês.

系统运维

CreatedTime

string

A hora em que a tarefa foi criada. A hora segue o padrão ISO 8601 no formato yyyy-MM-ddThh:mm:ssZ. A hora é exibida em UTC.

2018-05-30T14:30:00Z

CurrentAVZ

string

A zona atual.

cn-beijing-h

DbType

string

O tipo do banco de dados. Valores válidos: mysql, pgsql e mssql.

mysql

DbVersion

string

A versão secundária do mecanismo.

5.7

Deadline

string

O prazo do horário de alternância para a tarefa. A hora segue o padrão ISO 8601 no formato yyyy-MM-ddThh:mm:ssZ. A hora é exibida em UTC.

2018-05-30T23:59:59Z

Id

integer

O ID da tarefa.

11111

Impact

string

O impacto da tarefa.

TransientDisconnection

ImpactEn

string

O impacto da tarefa em inglês.

Transient instance disconnection

ImpactZh

string

O impacto da tarefa em chinês.

实例闪断。

InsComment

string

O alias e a descrição da instância.

test

InsName

string

O ID da instância.

rm-wz96h8jujh512****

ModifiedTime

string

A hora da modificação. A hora segue o padrão ISO 8601 no formato yyyy-MM-ddThh:mm:ssZ. A hora é exibida em UTC.

2018-05-30T14:30:00Z

PrepareInterval

string

O período de preparação necessário entre a hora de início da tarefa e o horário de alternância. A hora é exibida no formato HH:mm:ss.

04:00:00

Region

string

O ID da região da tarefa pendente.

cn-beijing

ResultInfo

string

As informações sobre o resultado da execução.

userCancel

StartTime

string

A hora em que a tarefa foi executada. A hora segue o padrão ISO 8601 no formato yyyy-MM-ddThh:mm:ssZ. A hora é exibida em UTC.

2018-05-30T00:00:00Z

Status

integer

O status da tarefa.

  • 3: pendente

  • 4: em processamento

  • 5: concluída

  • 6: com falha

  • 7: cancelada

3

SubInsNames

array

As subtarefas da instância.

string

O nome da subtarefa.

sub1369716295573-tes2cy6****.2013052818****

SwitchTime

string

O horário de alternância da tarefa. A hora segue o padrão ISO 8601 no formato yyyy-MM-ddThh:mm:ssZ. A hora é exibida em UTC.

2018-05-30T14:30:00Z

TaskParams

string

Os parâmetros da tarefa.

{ "Action": "UpgradeDBInstance" }

TaskType

string

O tipo da tarefa de O&M. Valores válidos:

  • rds_apsaradb_ha: alternância primário/secundário

  • rds_apsaradb_transfer: migração de instância

  • rds_apsaradb_upgrade: atualização da versão secundária do mecanismo

  • rds_apsaradb_maxscale: atualização da versão secundária do proxy de banco de dados

rds_apsaradb_upgrade

TaskTypeEn

string

O motivo da tarefa em inglês.

Minor version update

TaskTypeZh

string

O motivo da tarefa em chinês.

小版本升级

PageNumber

integer

O número da página. As páginas começam na página 1. Valor padrão: 1.

1

PageSize

integer

O número de entradas por página. Valores válidos: 1 a 100. Valor padrão: 25.

25

RequestId

string

O ID da solicitação.

D4D4BE8A-DD46-440A-BFCD-EE31DA81****

TotalRecordCount

integer

O número total de entradas retornadas.

1

Exemplos

Resposta de sucesso

JSON formato

{
  "Items": [
    {
      "AllowCancel": "1",
      "AllowChange": "1",
      "ChangeLevel": "S1",
      "ChangeLevelEn": "System maintenance",
      "ChangeLevelZh": "系统运维",
      "CreatedTime": "2018-05-30T14:30:00Z",
      "CurrentAVZ": "cn-beijing-h",
      "DbType": "mysql",
      "DbVersion": "5.7",
      "Deadline": "2018-05-30T23:59:59Z",
      "Id": 11111,
      "Impact": "TransientDisconnection",
      "ImpactEn": "Transient instance disconnection",
      "ImpactZh": "实例闪断。",
      "InsComment": "test",
      "InsName": "rm-wz96h8jujh512****",
      "ModifiedTime": "2018-05-30T14:30:00Z",
      "PrepareInterval": "04:00:00",
      "Region": "cn-beijing",
      "ResultInfo": "userCancel",
      "StartTime": "2018-05-30T00:00:00Z",
      "Status": 3,
      "SubInsNames": [
        "sub1369716295573-tes2cy6****.2013052818****"
      ],
      "SwitchTime": "2018-05-30T14:30:00Z",
      "TaskParams": "{\n      \"Action\": \"UpgradeDBInstance\"\n}",
      "TaskType": "rds_apsaradb_upgrade",
      "TaskTypeEn": "Minor version update",
      "TaskTypeZh": "小版本升级"
    }
  ],
  "PageNumber": 1,
  "PageSize": 25,
  "RequestId": "D4D4BE8A-DD46-440A-BFCD-EE31DA81****",
  "TotalRecordCount": 1
}

Códigos de erro

Código de status HTTP

Código de erro

Mensagem de erro

Descrição

400 InvalidPageParam.Format Page param should be a positive integer. O parâmetro de número da página deve ser um número positivo.
400 RequiredParam.NotFound Required input param is not found. Parâmetros obrigatórios estão ausentes.
400 InvalidDBType The DB type does not support this operation. A operação falhou porque o status do banco de dados não oferece suporte a esta operação.
400 Order.ComboInstanceNotAllowOperate A package instance is not allowed to operate independently. Operações individuais não são permitidas para instâncias de pacote.
400 Price.PricingPlanResultNotFound Pricing plan price result not found. O resultado do preço do plano de preços não foi encontrado.
400 Order.NoRealNameAuthentication You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. Você não concluiu a verificação de nome real e não está elegível para fazer uma compra. Faça login em Despesas e Custos para concluir a verificação de nome real.
400 InsufficientAvailableQuota Your account quota limit is less than 0, please recharge before trying to purchase. O crédito disponível da sua conta é menor que 0. Recarregue sua conta antes de tentar fazer uma compra.
400 CommodityServiceCalling.Exception Failed to call commodity service. A chamada para o serviço de commodity retornou uma falha.
400 RegionDissolvedEOM Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. O Alibaba Cloud planeja otimizar e ajustar a região atual. Os serviços em nuvem nesta região serão descontinuados. Para garantir a continuidade dos seus negócios e uma migração de dados tranquila, você não pode fazer novos pedidos de compra no momento. Agradecemos sua compreensão e apoio.
400 Commodity.InvalidComponent The module you purchased is not legal, please buy it again. O módulo adquirido é inválido. Adquira um módulo válido.
400 RegionEndTimeDissolvedAustralia Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. A região foi desativada.
400 Price.CommoditySys Commodity system call exception. Ocorreu uma exceção ao chamar o sistema de commodities.
400 Pay.InsufficientBalance Insufficient available balance.
400 Order.PeriodInvalid There is a problem with the period you selected, please choose again. O período de assinatura selecionado é inválido. Selecione um período de assinatura válido.
400 pay.noCreditCard Account not bound to credit card. A conta não está associada a um cartão de crédito.
400 Order.InstHasUnpaidOrder There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. Existe um pedido não pago para o serviço selecionado. Pague ou cancele o pedido antes de fazer um novo.
400 noAvailablePaymentMethod No payment method is specified for your account. We recommend that you add a payment method. Nenhum método de pagamento está especificado para a conta. Adicione um método de pagamento.
400 BasicInfoUncompleted Your information is incomplete. Complete your information before the operation. Suas informações básicas estão incompletas. Complete suas informações básicas antes de realizar esta operação.
400 Risk.RiskControlRejection Your account is abnormal, please contact customer service for details. Ocorreu uma exceção com a sua conta. Entre em contato com o atendimento ao cliente para obter detalhes.
400 Api.NotSupport Specified api is not supported. A operação de API atual não é suportada.
400 ContainForbiddenLabelError There is a label that prohibits placing orders. Please contact your distributor for assistance. Existe uma tag de bloqueio de pedido. Entre em contato com seu distribuidor para obter assistência.
400 InvalidDBInstanceId.NotFound The DBInstanceId provided does not exist in records. O DBInstanceId especificado não existe.
400 InvalidInstanceLevel.DiskType Specified instance level not support request disk type O tipo de instância atual não oferece suporte ao tipo de armazenamento especificado.
400 InvalidParam Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. O parâmetro de entrada é inválido.
400 KmsApiError User secret key invalid. A chave do usuário é inválida.
400 System.SaleValidateFailed Sales expression validation system error.
400 Abs.InvalidAccount.NotFound account is not found. Sua conta da Alibaba Cloud não existe ou sua AccessKey expirou.
400 SqlExecuteFailedOrTimeout sql command execution failed or timed out:%s. A execução do comando SQL falhou ou expirou.
400 ColdData.EngineVersionNotSupport The current instance engine version not support coldDataEnabled. A versão atual do mecanismo DPI da instância não suporta o arquivamento de dados frios.
400 ColdData.MinorVersionNotSupport The current instance minor version not support coldDataEnabled. A versão atual do kernel não suporta o arquivamento de dados frios.
400 IncorrectTargetClasscode The current instance type does not support this operation. O tipo de instância atual não oferece suporte a esta operação.
400 InvalidConnectionString.Duplicate Specified connection string already exists in the RDS. O nome do endereço de conexão está duplicado. Reconfigure a string de conexão.
400 Parameters.Invalid Parameter error, please check the parameters. O parâmetro está incorreto. Verifique o parâmetro.
400 BackupPolicyNotSupport Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. O arquivamento de dados frios não oferece suporte a backup entre regiões ou backup de snapshot de alta frequência. Verifique a política de backup.
400 InvalideStatus.Format The instance status does not support this operation. O status da instância não suporta esta operação.
400 InvalidReleasedKeepPolicy.Format Specified Released Keep Policy is not valid. A política de retenção de dados de backup arquivados após a liberação da instância é inválida.
400 InvalidDBInstanceEngineType.Format the DB instance engine type does not support this operation. O tipo de mecanismo de banco de dados da instância não oferece suporte a esta operação.
400 Pay.NoCreditCard No credit cards.
400 VpcNetworkTypeNotSupport The vpc network type instance does not support this operation. Esta operação não é suportada para instâncias do tipo de rede VPC.
400 MirrorInsExists Specified DB instance mirror ins already existed. A imagem da instância de banco de dados atual já existe.
400 UnsupportedClassCode The specified DB instance class stops selling. O tipo de instância não está mais disponível para compra.
400 InvalidBackupSet The specified database does not exist in the backup set. O banco de dados especificado não existe no conjunto de backup.
400 OrdTCommodityQueryError Failed to query for product. Falha ao consultar o produto.
400 ProductInstanceReleased The instance has been released. Please check before placing the order. A instância foi liberada. Verifique a instância antes de fazer o pedido.
400 RegionEndTimeDissolvedIndia The region is no longer supported. A região foi desativada.
400 InvalidRequest Invalid Request. A solicitação é inválida.
500 ExternalFailure The request processing has failed due to external service failure. A solicitação para o serviço falhou. Tente novamente mais tarde.
500 RequestMetaDataFailed The service request failed. Please try again later or contact service personnel. A solicitação de serviço falhou. Tente novamente mais tarde ou entre em contato com o suporte.
500 InvokeProxyFailure The request processing has failed due to service failure of rds api. A solicitação falhou porque o serviço da API do RDS apresentou falha.
403 OrderStatus.UnPaid The specified db instance has unpaid order. Existe um pedido não pago para a instância atual. Pague o pedido e tente novamente.
403 InvalidReduceDiskSize The storage capacity after the scale-down must be larger than the used amount. A capacidade de destino para redução de escala não pode ser menor que o uso de armazenamento atual.
403 CloudSSDNotSupport Cloud ssd does not support this operation, please upgrade to essd. Os discos em nuvem SSD não suportam esta operação. Faça upgrade para ESSD.
403 InvalidUserOperatorPermission The user permission does not support this operation. As permissões do usuário não suportam esta operação.
403 InvalidVswitchId Specified conn vswitch id is not valid. O VSwitchId especificado está em um formato incorreto ou está vazio.
403 IncorrectMinorVersion Current engine minor version does not support operations. A versão secundária atual do mecanismo não suporta esta operação.
403 OperationDenied.ZoneResource There is no available zone for inventory. Não há regiões de inventário disponíveis.
403 NotInFlowController Sorry,no permission. Este recurso está disponível apenas para usuários de nuvem corporativa. Você não tem as permissões necessárias.
403 InvalidKmsKey Kms key is disabled. A chave KMS está desativada.
403 InvalidInstanceLevel.Malformed Current DB instance level does not support this operation. O nível atual da instância de banco de dados não oferece suporte a esta operação.
404 InvalidClusterKms The current instance does not authorized to access the Key Management Service. A instância atual não está autorizada a acessar o Key Management Service (KMS).
404 Request.NotFound The requested resource is not available. O recurso solicitado não está disponível.
404 HostInfo.NotFound The specified host info is not found. As informações do host especificado não existem.

Consulte Códigos de Erro para uma lista completa.

Notas de versão

Consulte Notas de Versão para uma lista completa.