Consulta as informações da conta de uma instância ApsaraDB RDS.
Descrição da operação
Mecanismos suportados
ApsaraDB RDS for MySQL
ApsaraDB RDS for PostgreSQL
ApsaraDB RDS for SQL Server
ApsaraDB RDS for MariaDB
Experimente agora
Testar
Autorização RAM
|
Ação |
Nível de acesso |
Tipo de recurso |
Chave de condição |
Ação dependente |
|
rds:DescribeAccounts |
get |
*DBInstance
|
|
Nenhuma |
Parâmetros da solicitação
|
Parâmetro |
Tipo |
Obrigatório |
Descrição |
Exemplo |
| DBInstanceId |
string |
Sim |
O ID da instância. Você pode chamar DescribeDBInstances para consultar o ID da instância. Nota
Instâncias do SQL Server 2017 Cluster Edition não são suportadas. |
rm-bp1v6z81ho9****** |
| AccountName |
string |
Não |
O nome da conta do banco de dados. |
zhttest |
| PageSize |
integer |
Não |
O número de entradas por página. Valores válidos: 30 a 200. Valor padrão: 30. |
30 |
| PageNumber |
integer |
Não |
O número da página. Valor padrão: 1. O valor deve ser um número inteiro positivo que não exceda o valor máximo do tipo de dados Integer. |
1 |
Elementos de resposta
|
Elemento |
Tipo |
Descrição |
Exemplo |
|
object |
Os parâmetros de resposta. |
||
| Accounts |
object |
||
| DBInstanceAccount |
array<object> |
A lista de informações da conta. |
|
|
array<object> |
Os detalhes da conta. |
||
| AccountDescription |
string |
A descrição da conta. |
Conta de banco de dados de teste |
| AccountName |
string |
O nome da conta do banco de dados. |
test1 |
| AccountStatus |
string |
O status da conta. Valores válidos:
|
Available |
| AccountType |
string |
O tipo de conta. Valores válidos:
|
Normal |
| BypassRLS |
string |
Indica se a conta tem permissão para ignorar políticas de Row-Level Security (RLS). Valores válidos:
Nota
Este parâmetro é retornado apenas para instâncias do ApsaraDB RDS for PostgreSQL. |
f |
| CheckPolicy |
boolean |
Indica se a política de senha é aplicada. |
true |
| CreateDB |
string |
Indica se a conta tem permissão para criar bancos de dados. Valores válidos:
Nota
Este parâmetro é retornado apenas para instâncias PostgreSQL. |
t |
| CreateRole |
string |
Indica se a conta tem permissão para criar roles. Valores válidos:
Nota
Este parâmetro é retornado apenas para instâncias PostgreSQL. |
t |
| DBInstanceId |
string |
O ID da instância à qual a conta pertence. |
rm-bp1v6z81ho9****** |
| DatabasePrivileges |
object |
||
| DatabasePrivilege |
array<object> |
A lista de permissões de banco de dados que a conta possui. |
|
|
object |
Os detalhes das permissões de banco de dados que a conta possui. |
||
| AccountPrivilege |
string |
O tipo de permissão da conta. Valores válidos: |
ReadWrite |
| AccountPrivilegeDetail |
string |
As permissões específicas correspondentes ao tipo de permissão da conta. Para mais informações, consulte Permissões da conta. |
SELECT,INSERT |
| DBName |
string |
O nome do banco de dados. |
test1 |
| PasswordExpireTime |
string |
O tempo de expiração da senha. |
2024-10-21 |
| PrivExceeded |
string |
Indica se o número de bancos de dados gerenciados pela conta excede o limite máximo. Valores válidos: |
0 |
| Replication |
string |
Indica se a conta possui a permissão de replicação. Valores válidos:
Nota
Este parâmetro é retornado apenas para instâncias do ApsaraDB RDS for PostgreSQL. |
t |
| ValidUntil |
string |
O horário de expiração da senha. Valores válidos:
Nota
Este parâmetro é retornado apenas para instâncias do ApsaraDB RDS for PostgreSQL. |
2022-10-01T00:00:00Z |
| PageNumber |
integer |
O número da página. |
1 |
| RequestId |
string |
O ID da solicitação. |
17F2EA6C-3CA2-528D-A263-DC29707AD652 |
| SystemAdminAccountFirstActivationTime |
string |
A hora em que a conta privilegiada foi ativada pela primeira vez. A hora segue o padrão ISO 8601 no formato aaaa-MM-ddTHH:mm:ssZ (UTC). |
2023-10-17T07:51:22Z |
| SystemAdminAccountStatus |
string |
Indica se a conta privilegiada está ativada. Valores válidos: |
True |
| TotalRecordCount |
integer |
O número total de registros. |
3 |
| ResourceGroupId |
string |
O ID do grupo de recursos. |
rg-acfmy**** |
Exemplos
Resposta de sucesso
JSON formato
{
"Accounts": {
"DBInstanceAccount": [
{
"AccountDescription": "Conta de banco de dados de teste",
"AccountName": "test1",
"AccountStatus": "Available",
"AccountType": "Normal",
"BypassRLS": "f",
"CheckPolicy": true,
"CreateDB": "t",
"CreateRole": "t",
"DBInstanceId": "rm-bp1v6z81ho9******",
"DatabasePrivileges": {
"DatabasePrivilege": [
{
"AccountPrivilege": "ReadWrite",
"AccountPrivilegeDetail": "SELECT,INSERT",
"DBName": "test1"
}
]
},
"PasswordExpireTime": "2024-10-21",
"PrivExceeded": "0",
"Replication": "t",
"ValidUntil": "2022-10-01T00:00:00Z"
}
]
},
"PageNumber": 1,
"RequestId": "17F2EA6C-3CA2-528D-A263-DC29707AD652",
"SystemAdminAccountFirstActivationTime": "2023-10-17T07:51:22Z",
"SystemAdminAccountStatus": "True",
"TotalRecordCount": 3,
"ResourceGroupId": "rg-acfmy****"
}
Códigos de erro
|
Código de status HTTP |
Código de erro |
Mensagem de erro |
Descrição |
|---|---|---|---|
| 400 | %s | DB Operation Failed:%s. | |
| 400 | IO.Exception | IO exception, retry later. | Ocorreu uma exceção de E/S. |
| 400 | Database.ConnectError | Database connect error. please check instance status and database processlist | A conexão com o banco de dados está anormal. Verifique o status da instância e o pool de conexões do banco de dados. |
| 400 | InvalidDBInstanceStatus.NotSupport | The Specified instance status is not supported to query account list. | |
| 400 | InvalidEngine.Malformed | Specified engine is not valid. | A verificação do tipo de banco de dados falhou. Valores válidos para o tipo de banco de dados: MySQL, SQL Server, PostgreSQL e PPAS. |
| 400 | Account.QueryError | Query Account failed, please check your input value. | Falha ao consultar a conta. Verifique os parâmetros da solicitação. Por exemplo, o nome da conta do ApsaraDB RDS for MySQL pode conter caracteres especiais. |
| 400 | SqlExcutionFailed | Database is already open and can only have one user at a time. | Este banco de dados não pode ser excluído. |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | A execução do comando SQL falhou ou expirou. |
| 400 | ConcurrentLimit | The request processing has been concurrent limit. | O processamento da solicitação atingiu o limite de simultaneidade. |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | Operações individuais não são permitidas para instâncias de pacote. |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | O resultado do preço do plano de precificação não foi encontrado. |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | Você não concluiu a verificação de nome real e não está elegível para realizar uma compra. Faça login em Despesas e Custos para concluir a verificação de nome real. |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | O crédito disponível da sua conta é menor que 0. Recarregue sua conta antes de tentar realizar a compra. |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | A chamada ao serviço de commodity falhou. |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | O Alibaba Cloud planeja otimizar e ajustar a região atual. Os serviços em nuvem nesta região serão descontinuados. Para garantir a continuidade dos seus negócios e uma migração de dados tranquila, você não pode fazer novos pedidos de compra no momento. Agradecemos sua compreensão e apoio. |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | O módulo adquirido é inválido. Adquira um módulo válido. |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | A região foi desativada. |
| 400 | Price.CommoditySys | Commodity system call exception. | Ocorreu uma exceção ao chamar o sistema de commodities. |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | O período de assinatura selecionado é inválido. Selecione um período válido. |
| 400 | pay.noCreditCard | Account not bound to credit card. | Nenhum cartão de crédito disponível. |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | Existe um pedido não pago para o serviço selecionado. Pague ou cancele o pedido existente antes de fazer um novo. |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | Suas informações básicas estão incompletas. Complete suas informações básicas antes de realizar esta operação. |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | Ocorreu uma exceção na sua conta. Entre em contato com o atendimento ao cliente para obter detalhes. |
| 400 | Api.NotSupport | Specified api is not supported. | A operação de API atual não é suportada. |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | Existe uma tag de bloqueio de pedido. Entre em contato com seu distribuidor para resolver este problema. |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | O DBInstanceId especificado não existe. |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | O tipo de instância atual não suporta o tipo de armazenamento especificado. |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | O parâmetro de entrada é inválido. |
| 400 | KmsApiError | User secret key invalid. | A chave do usuário é inválida. |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | Sua conta Alibaba Cloud não existe ou seu AccessKey expirou. |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | A versão atual do mecanismo DPI da instância não suporta arquivamento de dados frios. |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | A versão atual do kernel não suporta arquivamento de dados frios. |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | A especificação atual da instância não suporta esta operação. |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | O nome do endereço de conexão está duplicado. Defina a string de conexão novamente. |
| 400 | RequiredParam.NotFound | Required input param is not found. | Parâmetros obrigatórios estão ausentes. |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | O parâmetro está incorreto. Verifique o parâmetro. |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | A política de backup atual não suporta esta operação. |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | A política de retenção de dados de backup de arquivamento após a liberação da instância é inválida. |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | O tipo de mecanismo de banco de dados da instância não suporta esta operação. |
| 400 | Pay.NoCreditCard | No credit cards. | |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | Esta operação não é suportada para instâncias com o tipo de rede VPC. |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | A imagem da instância de banco de dados atual já existe. |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | O tipo de instância não está mais disponível para compra. |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | O banco de dados especificado não existe no conjunto de backup. |
| 400 | OrdTCommodityQueryError | Failed to query for product. | Falha ao consultar o produto. |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | A instância foi liberada. Verifique a instância antes de fazer o pedido. |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | A região especificada é inválida. |
| 400 | DbossGeneralError | The instance is being created. Please wait. | A instância está sendo criada. Aguarde um momento. Alternativamente, o nome da conta do ApsaraDB RDS for SQL Server pode conter caracteres especiais. |
| 400 | InvalidCharacter.DbOrAccount | The database name or account name contains invalid characters. | O nome do banco de dados ou o nome da conta contém caracteres inválidos. |
| 400 | NoAvailablePaymentMethod | No payment method is specified for account. We recommend that you add a payment method. | |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | A solicitação ao serviço falhou. Tente novamente mais tarde. |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | A solicitação de serviço falhou. Tente novamente mais tarde ou entre em contato com o suporte. |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | O processamento da solicitação falhou devido a uma falha no serviço de API do RDS. |
| 403 | IncorrectDBInstanceState | Current DB instance state does not support this operation. | O status atual da instância não suporta esta operação. |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | Existe um pedido não pago para a instância atual. Pague o pedido e tente novamente. |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | A capacidade de destino para redução de escala não pode ser menor que o uso atual de armazenamento. |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | Os discos SSD não suportam esta operação. Atualize para ESSD. |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | As permissões do usuário não oferecem suporte a esta operação. |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | O VSwitchId especificado está em um formato incorreto ou está vazio. |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | A versão secundária do mecanismo atual não suporta esta operação. |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | Não existem regiões de inventário disponíveis. |
| 403 | NotInFlowController | Sorry,no permission. | Este recurso está indisponível. Você não tem permissão porque não é um usuário de nuvem corporativa. |
| 403 | InvalidKmsKey | Kms key is disabled. | A chave KMS está desativada. |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | O nível atual da instância de banco de dados não suporta esta operação. |
| 403 | GuardDBInstanceNotSupport | Guard instance does not support this operation. | Esta operação não é suportada para instâncias de recuperação de desastres. |
| 404 | InvalidDBInstanceName.NotFound | The database instance does not exist. | A instância especificada não existe ou não é suportada. |
| 404 | IncorrectDBInstanceLockMode | Current DB instance lock mode does not support this operation. | A operação falhou. A instância está em estado bloqueado. |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | A instância atual não está autorizada a acessar o Key Management Service. |
| 404 | Request.NotFound | The requested resource is not available. | O recurso solicitado não está disponível. |
| 404 | HostInfo.NotFound | The specified host info is not found. | As informações do host especificado não existem. |
| 408 | NetworkOrSqlTimeoutError | Failed to create login due to potential SQL Server overload or other issues that may cause the login creation fail. Please retry later. | A consulta expirou devido a uma possível sobrecarga do SQL Server ou a um número excessivo de contas na instância. |
Consulte Códigos de Erro para uma lista completa.
Notas de versão
Consulte Notas de Versão para uma lista completa.