Cria uma instância temporária para uma instância do ApsaraDB RDS for SQL Server 2008 R2 com SSDs locais premium.
Descrição da operação
Mecanismo aplicável
RDS SQL Server 2008 R2 (com SSDs locais premium)
Documentação relacionada
Restaurar dados do SQL Server usando uma instância temporária
Experimente agora
Testar
Autorização RAM
|
Ação |
Nível de acesso |
Tipo de recurso |
Chave de condição |
Ação dependente |
|
rds:CreateTempDBInstance |
create |
*DBInstance
|
|
Nenhuma |
Parâmetros da solicitação
|
Parâmetro |
Tipo |
Obrigatório |
Descrição |
Exemplo |
| DBInstanceId |
string |
Sim |
O ID da instância. |
rm-bp13**** |
| BackupId |
integer |
Não |
O ID do conjunto de backups. Você pode chamar a operação DescribeBackups para consultar os IDs dos conjuntos de backups. Nota
Pelo menos um dos parâmetros BackupId e RestoreTime deve ser especificado. |
1883**** |
| RestoreTime |
string |
Não |
Qualquer ponto no tempo dentro do período de retenção de backup especificado pelo usuário. Formato: aaaa-MM-ddTHH:mm:ssZ (UTC). |
2023-06-11T16:00:00Z |
| ResourceGroupId |
string |
Não |
O ID do grupo de recursos. |
rg-acfmy**** |
Elementos de resposta
|
Elemento |
Tipo |
Descrição |
Exemplo |
|
object |
Os parâmetros de resposta. |
||
| RequestId |
string |
O ID da solicitação. |
069EB9B1-DE12-54B9-8C20-822**** |
| TempDBInstanceId |
string |
O ID da instância temporária. |
sub16****_rm-bp13**** |
Exemplos
Resposta de sucesso
JSON formato
{
"RequestId": "069EB9B1-DE12-54B9-8C20-822****",
"TempDBInstanceId": "sub16****_rm-bp13****"
}
Códigos de erro
|
Código de status HTTP |
Código de erro |
Mensagem de erro |
Descrição |
|---|---|---|---|
| 400 | OperationDenied.DBInstanceStatus | The operation is not permitted due to status of instance. | |
| 400 | IncorrectInstanceNetworkType | The specified parameter InstanceNetworkType is not valid. | O parâmetro InstanceNetworkType é inválido. |
| 400 | InvalidAvailableArea.NotFound | Specified available area does not exist in RDS. | A zona especificada não existe no ApsaraDB RDS. |
| 400 | InvalidRestoreType.Format | Specified restore type is not valid. | O tipo de restauração especificado é inválido. Defina um tipo de restauração válido. |
| 400 | ParamTypeError | The parameter type error. | O tipo do parâmetro está incorreto. |
| 400 | InvalidRetainInstance.Format | Specified retain instance is not valid. | O tempo de restauração é inválido. Verifique o parâmetro RestoreTime. |
| 400 | InvalidRestoreTime.Format | Specified restore time is not valid. | A operação falhou porque o tempo de restauração especificado é inválido. Defina um tempo de restauração válido. |
| 400 | InvalidRegion.Format | Specified Region is not valid. | A região especificada é inválida. Verifique a validade deste parâmetro. |
| 400 | InvalidInstanceLevelExtraInfo | Specified class code has error extra info. | O código de classe especificado contém informações adicionais inválidas. |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | Operações individuais não são permitidas para instâncias de pacote. |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | O resultado do preço do plano de precificação não foi encontrado. |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | Você não concluiu a verificação de nome real e não está elegível para realizar uma compra. Faça login em Despesas e Custos para concluir a verificação de nome real. |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | O crédito disponível da sua conta é menor que 0. Recarregue sua conta antes de tentar realizar a compra. |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | A chamada ao serviço de commodity falhou. |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | O Alibaba Cloud planeja otimizar e ajustar a região atual. Os serviços em nuvem nesta região serão descontinuados. Para garantir a continuidade dos seus negócios e uma migração de dados tranquila, você não pode fazer novos pedidos de compra no momento. Agradecemos sua compreensão e apoio. |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | O módulo adquirido é inválido. Adquira um módulo válido. |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | A região foi desativada. |
| 400 | Price.CommoditySys | Commodity system call exception. | Ocorreu uma exceção ao chamar o sistema de commodities. |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | O período de assinatura selecionado é inválido. Selecione um período válido. |
| 400 | pay.noCreditCard | Account not bound to credit card. | Nenhum cartão de crédito disponível. |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | Existe um pedido não pago para o serviço selecionado. Pague ou cancele o pedido existente antes de fazer um novo. |
| 400 | noAvailablePaymentMethod | No payment method is specified for your account. We recommend that you add a payment method. | Nenhum método de pagamento está especificado para a conta. Adicione um método de pagamento. |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | Suas informações básicas estão incompletas. Complete suas informações básicas antes de realizar esta operação. |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | Ocorreu uma exceção na sua conta. Entre em contato com o atendimento ao cliente para obter detalhes. |
| 400 | Api.NotSupport | Specified api is not supported. | A operação de API atual não é suportada. |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | Existe uma tag de bloqueio de pedido. Entre em contato com seu distribuidor para resolver este problema. |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | O DBInstanceId especificado não existe. |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | O tipo de instância atual não suporta o tipo de armazenamento especificado. |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | O parâmetro de entrada é inválido. |
| 400 | KmsApiError | User secret key invalid. | A chave do usuário é inválida. |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | Sua conta Alibaba Cloud não existe ou seu AccessKey expirou. |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | A execução do comando SQL falhou ou expirou. |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | A versão atual do mecanismo DPI da instância não suporta arquivamento de dados frios. |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | A versão atual do kernel não suporta arquivamento de dados frios. |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | A especificação atual da instância não suporta esta operação. |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | O nome do endereço de conexão está duplicado. Defina a string de conexão novamente. |
| 400 | RequiredParam.NotFound | Required input param is not found. | Parâmetros obrigatórios estão ausentes. |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | O parâmetro está incorreto. Verifique o parâmetro. |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | A política de backup atual não suporta esta operação. |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | O status da instância não suporta esta operação. |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | A política de retenção de dados de backup de arquivamento após a liberação da instância é inválida. |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | O tipo de mecanismo de banco de dados da instância não suporta esta operação. |
| 400 | Pay.NoCreditCard | No credit cards. | |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | Esta operação não é suportada para instâncias com o tipo de rede VPC. |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | A imagem da instância de banco de dados atual já existe. |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | O tipo de instância não está mais disponível para compra. |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | O banco de dados especificado não existe no conjunto de backup. |
| 400 | OrdTCommodityQueryError | Failed to query for product. | Falha ao consultar o produto. |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | A instância foi liberada. Verifique a instância antes de fazer o pedido. |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | A região especificada é inválida. |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | A solicitação ao serviço falhou. Tente novamente mais tarde. |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | A solicitação de serviço falhou. Tente novamente mais tarde ou entre em contato com o suporte. |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | O processamento da solicitação falhou devido a uma falha no serviço de API do RDS. |
| 403 | OperationDenied.TempDBInstanceExists | The operation is not permitted due to temp instance exist. | A operação falhou. Já existe uma instância temporária para a instância atual. |
| 403 | IncorrectDBInstanceType | Current DB instance engine and type does not support operations. | A operação falhou. Esta operação não é suportada no status atual da instância. |
| 403 | IncorrectDBInstanceState | Current DB instance state does not support this operation. | O status atual da instância não suporta esta operação. |
| 403 | IncorrectDBInstanceCharacterType | Current DB Instance character_type does not support this operation. | O tipo de caractere da instância de banco de dados atual não suporta esta operação. |
| 403 | InvalidBackupLogStatus | Current backup log enable status does not support this operation. | A operação falhou. O backup de log não está ativado. A restauração point-in-time não está disponível. |
| 403 | ChildDBInstanceExists | Current DB instance had child instance. | A operação falhou. Já existe uma instância somente leitura. |
| 403 | IncorrectDBInstance | The current DB instance does not support this operation. | A operação falhou. A instância atual não suporta esta operação. |
| 403 | IncorrectBackupSetMethod | Current backup set method does not support operations. | A operação falhou. O conjunto de backup especificado não suporta restauração de banco de dados e tabelas. |
| 403 | IncorrectBackupSetState | Current backup set state does not support operations. | A operação falhou. O status atual do conjunto de backup não suporta esta operação. |
| 403 | IncorrectDBInstanceConnType | Current DB instance conn type does not support this operation. | O tipo de conexão da instância de banco de dados atual não suporta esta operação. |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | Existe um pedido não pago para a instância atual. Pague o pedido e tente novamente. |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | A capacidade de destino para redução de escala não pode ser menor que o uso atual de armazenamento. |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | Os discos SSD não suportam esta operação. Atualize para ESSD. |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | As permissões do usuário não oferecem suporte a esta operação. |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | O VSwitchId especificado está em um formato incorreto ou está vazio. |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | A versão secundária do mecanismo atual não suporta esta operação. |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | Não existem regiões de inventário disponíveis. |
| 403 | NotInFlowController | Sorry,no permission. | Este recurso está indisponível. Você não tem permissão porque não é um usuário de nuvem corporativa. |
| 403 | InvalidKmsKey | Kms key is disabled. | A chave KMS está desativada. |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | O nível atual da instância de banco de dados não suporta esta operação. |
| 403 | GuardDBInstanceNotSupport | Guard instance does not support this operation. | Esta operação não é suportada para instâncias de recuperação de desastres. |
| 404 | InvalidDBInstanceName.NotFound | The specified db instance is not found. | A instância especificada não existe ou não é suportada. |
| 404 | IncorrectDBInstanceLockMode | Current DB instance lock mode does not support this operation. | A operação falhou. A instância está em estado bloqueado. |
| 404 | InvalidBackupSetID.NotFound | Specified backup set ID does not exist. | O conjunto de backup não existe. Visualize os conjuntos de backup existentes. |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | A instância atual não está autorizada a acessar o Key Management Service. |
| 404 | Request.NotFound | The requested resource is not available. | O recurso solicitado não está disponível. |
| 404 | HostInfo.NotFound | The specified host info is not found. | As informações do host especificado não existem. |
Consulte Códigos de Erro para uma lista completa.
Notas de versão
Consulte Notas de Versão para uma lista completa.