Cria uma instância somente leitura para uma instância do ApsaraDB RDS.
Descrição da operação
Mecanismos aplicáveis.
Experimente agora
Testar
Autorização RAM
|
Ação |
Nível de acesso |
Tipo de recurso |
Chave de condição |
Ação dependente |
|
rds:CreateReadOnlyDBInstance |
create |
*DBInstance
|
|
Nenhuma |
Parâmetros da solicitação
|
Parâmetro |
Tipo |
Obrigatório |
Descrição |
Exemplo |
| ClientToken |
string |
Não |
O token de cliente usado para garantir a idempotência da solicitação. Você pode usar o cliente para gerar o token, mas deve garantir que o token seja exclusivo entre diferentes solicitações. O token pode conter apenas caracteres ASCII e não pode exceder 64 caracteres de comprimento. |
ETnLKlblzczshOTUbOC**** |
| RegionId |
string |
Sim |
O ID da região. A região da instância somente leitura deve ser a mesma da instância primária. Você pode chamar DescribeRegions para consultar o ID da região. |
cn-hangzhou |
| ZoneId |
string |
Sim |
O ID da zona. Você pode chamar DescribeRegions para consultar as zonas disponíveis.
|
cn-hangzhou-b |
| DBInstanceId |
string |
Sim |
O ID da instância primária. Você pode chamar DescribeDBInstances para consultar o ID da instância. |
rm-uf6wjk5**** |
| DBInstanceClass |
string |
Sim |
O tipo da instância. Para mais informações, consulte Tipos de instância somente leitura. Recomendamos que as especificações da instância somente leitura sejam iguais ou superiores às da instância primária. Caso contrário, a instância somente leitura pode apresentar alta latência e carga elevada. |
mysqlro.n2.small.1c |
| DBInstanceStorage |
integer |
Sim |
Capacidade de armazenamento da instância. A capacidade de armazenamento da instância somente leitura deve ser maior ou igual à da instância primária. Para mais informações, consulte a coluna Capacidade de armazenamento em Tipos de instância somente leitura. O valor é incrementado em unidades de 5 GB. Unidade: GB. |
20 |
| EngineVersion |
string |
Sim |
A versão do mecanismo de banco de dados. A versão deve ser a mesma da instância primária. |
5.6 |
| PayType |
string |
Sim |
O método de cobrança. Valores válidos:
|
Postpaid |
| DBInstanceDescription |
string |
Não |
A descrição da instância. A descrição deve ter de 2 a 256 caracteres de comprimento e pode conter letras, dígitos, sublinhados (_) e hifens (-). Deve começar com uma letra ou um caractere chinês. |
testReadOnly |
| InstanceNetworkType |
string |
Não |
O tipo de rede da instância somente leitura. Valores válidos: |
Classic |
| VPCId |
string |
Não |
O ID da VPC da instância somente leitura. Este parâmetro é obrigatório quando InstanceNetworkType está definido como vazio ou VPC. |
vpc-uf6f7l4fg90**** |
| VSwitchId |
string |
Não |
O ID do vSwitch da instância somente leitura. Este parâmetro é obrigatório quando InstanceNetworkType está definido como vazio ou VPC. |
vsw-uf6adz52c2p**** |
| PrivateIpAddress |
string |
Não |
Configurações para o endereço IP de rede interna da instância somente leitura. O endereço IP deve estar dentro do intervalo de endereços do vSwitch especificado. O sistema aloca automaticamente um endereço IP de rede interna com base nos valores de VPCId e VSwitchId por padrão. |
172.16.XX.XX |
| ResourceGroupId |
string |
Não |
O ID do grupo de recursos. |
rg-acfmy**** |
| Category |
string |
Não |
A edição da instância. Valores válidos: |
HighAvailability |
| DBInstanceStorageType |
string |
Não |
O tipo de armazenamento da instância. Valores válidos:
Nota
|
local_ssd |
| DedicatedHostGroupId |
string |
Não |
O ID do cluster dedicado. Este parâmetro é obrigatório quando você cria uma instância somente leitura em um cluster dedicado. |
dhg-4n**** |
| TargetDedicatedHostIdForMaster |
string |
Não |
O ID do host da instância primária. Este parâmetro é obrigatório quando você cria uma instância somente leitura em um cluster dedicado. |
i-bp**** |
| GdnInstanceName |
string |
Não |
Um parâmetro reservado. Você não precisa configurar este parâmetro. |
test |
| TddlBizType |
string |
Não |
Um parâmetro reservado. Você não precisa configurar este parâmetro. |
test |
| TddlRegionConfig |
string |
Não |
Um parâmetro reservado. Você não precisa configurar este parâmetro. |
test |
| InstructionSetArch |
string |
Não |
Um parâmetro reservado. Você não precisa configurar este parâmetro. |
test |
| UsedTime |
string |
Não |
A duração da assinatura. Valores válidos:
Nota
Este parâmetro é obrigatório se PayType estiver definido como Prepaid. |
1 |
| Period |
string |
Não |
Especifica se a instância de assinatura é cobrada anualmente ou mensalmente. Valores válidos: |
Month |
| AutoRenew |
string |
Não |
Especifica se a renovação automática deve ser ativada para a instância. Este parâmetro entra em vigor apenas quando você cria uma instância por assinatura. Valores válidos:
Nota
|
true |
| DeletionProtection |
boolean |
Não |
Especifica se o recurso de proteção contra liberação deve ser ativado para a instância. Valores válidos: |
true |
| Port |
string |
Não |
A porta que é inicializada quando você cria uma instância somente leitura para uma instância primária do ApsaraDB RDS for MySQL. |
3306 |
| BurstingEnabled |
boolean |
Não |
Um parâmetro obsoleto. Você não precisa configurar este parâmetro. |
0 |
| IsAnalyticReadOnlyIns |
boolean |
Não |
Especifica se o recurso de burst de E/S deve ser ativado para um disco em nuvem do tipo disco de desempenho premium. Valores válidos: |
false |
| AutoPay |
boolean |
Não |
Especifica se deve ser criada uma instância analítica baseada em DuckDB. Valores válidos:
Nota
Atualmente, apenas o ApsaraDB RDS for MySQL e o ApsaraDB RDS for PostgreSQL suportam a criação de instâncias analíticas baseadas em DuckDB. |
false |
| AutoCreateProxy |
boolean |
Não |
Especifica se o pagamento automático deve ser ativado. Valores válidos:
Nota
Valor padrão: true. Se o seu método de pagamento tiver saldo insuficiente, você pode definir AutoPay como false. Nesse caso, um pedido não pago será gerado. Você pode fazer login no console do ApsaraDB RDS para concluir o pagamento. |
false |
| IoAccelerationEnabled |
string |
Não |
Indica se a criação automática de um proxy de banco de dados está ativada. Valores válidos: |
false |
| AutoUseCoupon |
boolean |
Não |
Especifica se o recurso Buffer Pool Extension (BPE) deve ser ativado para um disco em nuvem de desempenho premium. Valores válidos: |
0 |
| PromotionCode |
string |
Não |
Especifica se cupons devem ser usados. Valores válidos: |
true |
| CustomExtraInfo |
string |
Não |
O código do cupom. |
71744626**** |
|
Não |
Um parâmetro reservado. Você não precisa configurar este parâmetro. |
None |
Elementos de resposta
|
Elemento |
Tipo |
Descrição |
Exemplo |
|
object |
Os parâmetros de resposta. |
||
| ConnectionString |
string |
O endereço de conexão interna do banco de dados da instância somente leitura criada. |
rr-****.mysql.rds.aliyuncs.com |
| DBInstanceId |
string |
O ID da instância da instância somente leitura criada. |
rr-uf6wjk5**** |
| OrderId |
string |
O ID do pedido. |
10078937**** |
| Port |
string |
A porta de conexão interna do banco de dados da instância somente leitura criada. |
3306 |
| RequestId |
string |
O ID da solicitação. |
1E43AAE0-BEE8-43DA-860D-EAF2AA0724DC |
Exemplos
Resposta de sucesso
JSON formato
{
"ConnectionString": "rr-****.mysql.rds.aliyuncs.com",
"DBInstanceId": "rr-uf6wjk5****",
"OrderId": "10078937****",
"Port": "3306",
"RequestId": "1E43AAE0-BEE8-43DA-860D-EAF2AA0724DC"
}
Códigos de erro
|
Código de status HTTP |
Código de erro |
Mensagem de erro |
Descrição |
|---|---|---|---|
| 400 | InvalidEngineVersion.Malformed | The specified parameter EngineVersion is not valid. | |
| 400 | InvalidNetworkTypeClassicWhenCloudStorage | The Specified InstanceNetworkType value Classic is not valid when choose cloud storage type. | Definir InstanceNetworkType como Classic é inválido quando o tipo de armazenamento em nuvem é selecionado. |
| 400 | InvalidSecurityIPList.Malformed | The specified parameter SecurityIPList is not valid. | |
| 400 | InvalidSecurityIPList.Duplicate | The Security IP address is not in the available range or occupied. | A lista de IPs de segurança especificada é inválida. Ela contém valores duplicados. |
| 400 | InvalidParameter | The specified parameter dbInstanceId is not valid. | |
| 400 | OperationDenied | VPC IP is in use, please check. | O tipo de instância não suporta esta operação. |
| 400 | InvalidZoneId.NotSupported | The Specified vpc Zone not supported. | A zona atual não suporta a criação de instâncias que usam o tipo de rede VPC. Crie uma VPC em uma zona diferente ou selecione uma zona que suporte este tipo de rede. |
| 400 | InvalidAvZone.NotSupport | Specified availableArea multiZone does not support in RDS. | O multiZone availableArea especificado não é suportado no ApsaraDB RDS. |
| 400 | CDDC.AvailableHostsNotEnoughInZone | Not enough available hosts are in the target zone. | A zona de destino não possui recursos de host suficientes. Crie um host na zona. |
| 400 | InvalidReadEngineVersionPattern | The engine versions of the primary instance and the read-only instance do not match. | O engineVersion da instância primária e da instância somente leitura não correspondem. |
| 400 | InvalidDBInstanceClass.Offline | The specified instance type is no longer provided. Please specify another instance type. | O tipo de instância selecionado foi aposentado. Selecione um tipo de instância diferente. |
| 400 | SYSTEM.CONCURRENT_OPERATE | Concurrent operation is detected. | Existe uma operação simultânea no sistema. |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | O resultado do preço do plano de precificação não foi encontrado. |
| 400 | InvalidDBInstanceName.Duplicate | Specified DB instance name already exists in the Aliyun RDS. | A operação falhou porque o nome da instância já existe. Modifique o nome da instância e tente novamente. |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | O tipo de instância atual não suporta o tipo de armazenamento especificado. |
| 400 | InvalidRequestId | The request is copy, check your token. | A solicitação é duplicada. Verifique o token. |
| 400 | InvalidParam.InstanceNetworkType | Creation of classic network instances is not supported. | A rede clássica foi descontinuada. A criação de instâncias de rede clássica não é suportada. |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | Operações individuais não são permitidas para instâncias de pacote. |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | Você não concluiu a verificação de nome real e não está elegível para realizar uma compra. Faça login em Despesas e Custos para concluir a verificação de nome real. |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | O crédito disponível da sua conta é menor que 0. Recarregue sua conta antes de tentar realizar a compra. |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | A chamada ao serviço de commodity falhou. |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | O Alibaba Cloud planeja otimizar e ajustar a região atual. Os serviços em nuvem nesta região serão descontinuados. Para garantir a continuidade dos seus negócios e uma migração de dados tranquila, você não pode fazer novos pedidos de compra no momento. Agradecemos sua compreensão e apoio. |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | O módulo adquirido é inválido. Adquira um módulo válido. |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | A região foi desativada. |
| 400 | Price.CommoditySys | Commodity system call exception. | Ocorreu uma exceção ao chamar o sistema de commodities. |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | O período de assinatura selecionado é inválido. Selecione um período válido. |
| 400 | pay.noCreditCard | Account not bound to credit card. | Nenhum cartão de crédito disponível. |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | Existe um pedido não pago para o serviço selecionado. Pague ou cancele o pedido existente antes de fazer um novo. |
| 400 | noAvailablePaymentMethod | No payment method is specified for your account. We recommend that you add a payment method. | Nenhum método de pagamento está especificado para a conta. Adicione um método de pagamento. |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | Suas informações básicas estão incompletas. Complete suas informações básicas antes de realizar esta operação. |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | Ocorreu uma exceção na sua conta. Entre em contato com o atendimento ao cliente para obter detalhes. |
| 400 | Api.NotSupport | Specified api is not supported. | A operação de API atual não é suportada. |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | Existe uma tag de bloqueio de pedido. Entre em contato com seu distribuidor para resolver este problema. |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | O DBInstanceId especificado não existe. |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | O parâmetro de entrada é inválido. |
| 400 | KmsApiError | User secret key invalid. | A chave do usuário é inválida. |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | Sua conta Alibaba Cloud não existe ou seu AccessKey expirou. |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | A execução do comando SQL falhou ou expirou. |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | A versão atual do mecanismo DPI da instância não suporta arquivamento de dados frios. |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | A versão atual do kernel não suporta arquivamento de dados frios. |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | A especificação atual da instância não suporta esta operação. |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | O nome do endereço de conexão está duplicado. Defina a string de conexão novamente. |
| 400 | RequiredParam.NotFound | Required input param is not found. | Parâmetros obrigatórios estão ausentes. |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | O parâmetro está incorreto. Verifique o parâmetro. |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | A política de backup atual não suporta esta operação. |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | O status da instância não suporta esta operação. |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | A política de retenção de dados de backup de arquivamento após a liberação da instância é inválida. |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | O tipo de mecanismo de banco de dados da instância não suporta esta operação. |
| 400 | Pay.NoCreditCard | No credit cards. | |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | Esta operação não é suportada para instâncias com o tipo de rede VPC. |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | A imagem da instância de banco de dados atual já existe. |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | O tipo de instância não está mais disponível para compra. |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | O banco de dados especificado não existe no conjunto de backup. |
| 400 | OrdTCommodityQueryError | Failed to query for product. | Falha ao consultar o produto. |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | A instância foi liberada. Verifique a instância antes de fazer o pedido. |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | A região especificada é inválida. |
| 400 | InvalidVSwitchId.Format | The specified vswitch Id format is incorrect. | O ID do vSwitch especificado está em um formato incorreto. |
| 400 | InvalidParameterValue.NotStandard | Invalid parameter format. | O formato do parâmetro especificado é inválido. |
| 400 | AtLeastThreeVSwitchAvailableIp | The primary vswitch requires at least three available IP addresses. | O vSwitch primário deve ter pelo menos 3 endereços IP disponíveis. |
| 400 | AtLeastTwoVSwitchAvailableIp | The primary vswitch requires at least two available IP addresses. | O vSwitch primário deve ter pelo menos 2 endereços IP disponíveis. |
| 400 | DuckDBOperationConflictBetweenPrimaryAndReadOnlyInstance | Current instance is already attached to another duckdb instance, operation is conflict. | A instância atual já está associada a outra instância DuckDB, o que entra em conflito com a operação DuckDB atual. |
| 500 | CannotDecreaseEssdPerfLevel | cannot decrease cloud essd performance level. | |
| 500 | InvalidEssdStorageSize | invalid cloud essd storage size. | |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | A solicitação ao serviço falhou. Tente novamente mais tarde. |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | A solicitação de serviço falhou. Tente novamente mais tarde ou entre em contato com o suporte. |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | O processamento da solicitação falhou devido a uma falha no serviço de API do RDS. |
| 403 | OperationDenied.PrimaryDBInstanceStatus | The operation is not permitted due to status of primary instance. | A operação falhou. Uma instância do ApsaraDB RDS que não esteja no estado Running em um cluster dedicado não pode ser migrada. |
| 403 | InvalidReadStorageTypePattern | The storage type of the primary instance and the read-only instance do not match. | |
| 403 | IncorrectCharacterType | Current DB instance character type does not support this operation. | O tipo de caractere da instância atual não suporta esta operação. |
| 403 | InvalidMultiparamZoneInfoList | Zoneinfo list is invaild. | A zona primária atual não está alinhada. A instância primária não pode ser migrada. |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | Existe um pedido não pago para a instância atual. Pague o pedido e tente novamente. |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | A capacidade de destino para redução de escala não pode ser menor que o uso atual de armazenamento. |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | Os discos SSD não suportam esta operação. Atualize para ESSD. |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | As permissões do usuário não oferecem suporte a esta operação. |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | O VSwitchId especificado está em um formato incorreto ou está vazio. |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | A versão secundária do mecanismo atual não suporta esta operação. |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | Não existem regiões de inventário disponíveis. |
| 403 | NotInFlowController | Sorry,no permission. | Este recurso está indisponível. Você não tem permissão porque não é um usuário de nuvem corporativa. |
| 403 | InvalidKmsKey | Kms key is disabled. | A chave KMS está desativada. |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | O nível atual da instância de banco de dados não suporta esta operação. |
| 403 | BasicCategoryNotSupport | The Basic category is not supported. | A Basic Edition não é suportada. |
| 403 | GuardDBInstanceNotSupport | Guard instance does not support this operation. | Esta operação não é suportada para instâncias de recuperação de desastres. |
| 404 | IncorrectDBInstanceConnType | Current DB instance conn type does not support this operation. | |
| 404 | InvalidDBInstance.NotFound | The specified instance does not exist or is not supported. | A instância especificada não foi encontrada. Verifique se a instância é válida. |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | A instância atual não está autorizada a acessar o Key Management Service. |
| 404 | Request.NotFound | The requested resource is not available. | O recurso solicitado não está disponível. |
| 404 | HostInfo.NotFound | The specified host info is not found. | As informações do host especificado não existem. |
Consulte Códigos de Erro para uma lista completa.
Notas de versão
Consulte Notas de Versão para uma lista completa.