Reconstrói uma instância a partir da lixeira.
Descrição da operação
Mecanismos de banco de dados compatíveis
RDS MySQL
RDS PostgreSQL
RDS SQL Server
RDS MariaDB
Referências
: Taxas serão geradas se a chamada for bem-sucedida. Antes de chamar esta operação, leia atentamente a seguinte documentação:
Experimente agora
Testar
Autorização RAM
|
Ação |
Nível de acesso |
Tipo de recurso |
Chave de condição |
Ação dependente |
|
rds:CreateDBInstanceForRebuild |
create |
*DBInstance
|
Nenhuma | Nenhuma |
Parâmetros da solicitação
|
Parâmetro |
Tipo |
Obrigatório |
Descrição |
Exemplo |
| RegionId |
string |
Sim |
O ID da região. Você pode chamar a operação DescribeRegions para consultar a lista de regiões mais recente. |
cn-hangzhou |
| DBInstanceId |
string |
Sim |
O ID da instância. Você pode chamar a operação DescribeDBInstances para consultar o ID da instância. |
rm-uf6wjk5**** |
| PayType |
string |
Sim |
O método de cobrança da instância de destino. Valores válidos:
|
Postpaid |
| SecurityIPList |
string |
Não |
A lista de permissões de endereços IP da instância serverless. Para mais informações, consulte Usar um cliente de banco de dados ou a CLI para conectar-se a uma instância ApsaraDB RDS for PostgreSQL. Se a lista de permissões de endereços IP contiver mais de uma entrada, separe as entradas com vírgulas (,). Cada entrada deve ser única. Você pode especificar até 1.000 entradas. As entradas na lista de permissões de endereços IP devem estar em um dos seguintes formatos:
Se este parâmetro não for especificado, a lista de permissões de endereços IP padrão será usada. |
127.0.0.1 |
| DBInstanceDescription |
string |
Não |
O nome da instância. O nome deve ter de 2 a 256 caracteres de comprimento. O nome pode conter letras, dígitos, underscores (_) e hifens (-). O nome deve começar com uma letra. Nota
: O nome não pode começar com http:// ou https://. |
testdb |
| ZoneId |
string |
Não |
O ID da zona da instância primária. Você pode chamar a operação DescribeRegions para consultar a lista de zonas mais recente. Nota
Se você especificar uma virtual private cloud (VPC) e um vSwitch, deverá especificar este parâmetro para identificar a zona do vSwitch. |
cn-hangzhou-e |
| ZoneIdSlave1 |
string |
Não |
O ID da zona da instância secundária. Nota
Se a instância não executar o RDS Basic Edition, você deverá especificar este parâmetro. |
cn-hangzhou-c |
| ZoneIdSlave2 |
string |
Não |
O ID da zona da instância de logger. Nota
Este parâmetro está disponível apenas quando a instância executa o RDS Enterprise Edition. |
cn-hangzhou-d |
| VPCId |
string |
Não |
O ID da VPC da instância. Se você definir InstanceNetworkType como VPC, deverá especificar este parâmetro. Nota
: Se você especificar este parâmetro, também deverá especificar ZoneId. |
vpc-uf6f7l4fg90**** |
| VSwitchId |
string |
Não |
O ID do vSwitch. O vSwitch deve pertencer à zona especificada por ZoneId. Nota
|
vsw-uf6adz52c2p**** |
| Period |
string |
Não |
A unidade da duração da assinatura. Valores válidos:
Nota
Se você definir o parâmetro PayType como Prepaid, também deverá especificar este parâmetro. |
Month |
| UsedTime |
string |
Não |
A duração da assinatura da instância. Valores válidos:
Nota
Se você definir PayType como Prepaid, deverá especificar este parâmetro. |
1 |
| ClientToken |
string |
Não |
O token do cliente usado para garantir a idempotência da solicitação. Você pode usar o cliente para gerar o token, mas deve garantir que o token seja único entre diferentes solicitações. O token pode conter apenas caracteres ASCII e não pode exceder 64 caracteres de comprimento. |
ETnLKlblzczshOTUbOC**** |
| DBInstanceNetType |
string |
Não |
O tipo de conexão de rede com a instância. Valores válidos:
|
Internet |
| InstanceNetworkType |
string |
Não |
O tipo de rede da instância. Valores válidos:
Valor padrão: Classic. Nota
Se a instância usar discos em nuvem, este parâmetro é obrigatório. Defina o valor como VPC. Os parâmetros VpcId e VSwitchId devem ser especificados quando este parâmetro for definido como VPC. |
VPC |
| ResourceGroupId |
string |
Não |
O ID do grupo de recursos. O valor deste parâmetro pode ser NULL. |
rg-acfmy**** |
Elementos de resposta
|
Elemento |
Tipo |
Descrição |
Exemplo |
|
object |
Os parâmetros de resposta. |
||
| DBInstanceId |
string |
O ID da instância. |
rm-uf6wjk5**** |
| Message |
string |
Os parâmetros de resposta. |
success |
| OrderId |
string |
O ID do pedido. |
20793850608**** |
| RequestId |
string |
O ID da solicitação. |
1AD222E9-E606-4A42-BF6D-8A4442913CEF |
| TaskId |
string |
O ID da tarefa. |
417450000 |
Exemplos
Resposta de sucesso
JSON formato
{
"DBInstanceId": "rm-uf6wjk5****",
"Message": "success",
"OrderId": "20793850608****",
"RequestId": "1AD222E9-E606-4A42-BF6D-8A4442913CEF",
"TaskId": "417450000"
}
Códigos de erro
|
Código de status HTTP |
Código de erro |
Mensagem de erro |
Descrição |
|---|---|---|---|
| 400 | RR309 | We have detected a security risk with your payment method. Please proceed with verification via the link in your email or console message and re-submit your order after verification. | Um risco de segurança foi detectado no método de pagamento padrão. Verifique seu método de pagamento antes de fazer um pedido. Um link de verificação será enviado a você por e-mail e mensagem interna. |
| 400 | GeneralIns.Creating | The general instance is creating. | Uma instância está sendo provisionada. Tente novamente mais tarde. |
| 400 | InvalidZone.NotSupportedForStorageType | The specified zone is closed or invalid for Specified DBInstanceStorageType. | A região especificada está fechada ou é inválida para o DBInstanceStorageType especificado. |
| 400 | GeneralIns.Maintaining | The general instance is maintaining. | Uma instância está sendo migrada ou passando por manutenção. Tente novamente mais tarde. |
| 400 | GeneralIns.Switching | The general instance is Switching. | Uma alternância de alta disponibilidade (HA) está em andamento. Tente novamente mais tarde. |
| 400 | InvalidEngine.VauleNotSupported | The specified parameter "Engine" is not valid. | O tipo de banco de dados é inválido. Valores válidos: MySQL, SQLServer, PostgreSQL e PPAS. |
| 400 | InvalidEngineVersion.ValueNotSupported | The specified parameter "EngineVersion" is not valid. | A verificação da versão do banco de dados falhou. Valores válidos: MySQL: 5.5, 5.6 ou 5.7. SQLServer: 2008r2 ou 2012. PostgreSQL: 9.4. PPAS: 9.3. |
| 400 | InvalidDBinstanceClass.ValueNotSupported | The specified parameter DBinstanceClass is invalid. | |
| 400 | InvalidDBInstanceStorage.ValueNotSupported | The specified parameter "DBInstanceStorage" is not valid. | A configuração de armazenamento da instância é inválida. Defina o armazenamento novamente. Os intervalos de armazenamento suportados para cada mecanismo são os seguintes: o MySQL suporta de 5 a 1000 GB. O SQL Server suporta de 10 a 1000 GB. O PostgreSQL e o PPAS suportam de 5 a 2000 GB. |
| 400 | InvalidDBInstanceDescription.Malformed | The specified parameter "DBInstanceDescription" is not valid. | A validação da descrição da instância falhou. Requisitos de formato: A descrição da instância não pode exceder 256 bytes, não pode começar com http:// ou https:// e deve começar com um caractere chinês ou letra. Pode conter caracteres chineses, letras, sublinhados (_), hifens (-) e dígitos. O comprimento deve ser de 2 a 256 caracteres. |
| 400 | InvalidSecurityIPList.Duplicate | Specified security IP list is not valid: Duplicate IP address in the list | A lista de IPs de segurança especificada é inválida. Ela contém valores duplicados. |
| 400 | InvalidSecurityIPListLength.Malformed | The quota of security ip exceeds. | O número de endereços IP de segurança atingiu o limite superior. |
| 400 | DefaultVpc.NotSupport | The default vpc create is not support. | A operação falhou. Sua conta Alibaba Cloud não suporta a rede VPC padrão. Crie uma VPC e um vSwitch primeiro. |
| 400 | Forbidden.RegionNotFound | The provided RegionId does not exist in our record. | A operação falhou. Esta operação não é permitida na região da instância atual. |
| 400 | InvalidVpcIdOrVswitchId.NotSupported | The specified vpcId or vSwitchId is not supported. | A operação falhou. As informações da VPC são inválidas. Verifique a correção deste parâmetro. |
| 400 | InvalidVpcId.NotSupported | The specified vpcId or vSwitchId is not supported. | A operação falhou. A VPC ou o vSwitch está incorreto. Verifique se a VPC ou o vSwitch estão na mesma zona da instância do ApsaraDB RDS. |
| 400 | InvalidZoneId.NotSupported | The Specified vpc Zone not supported. | A zona atual não oferece suporte à criação de uma instância do tipo de rede VPC. Selecione outra zona. |
| 400 | VswitchIpExhausted | No available ip in the specified vswitch. | Não existem endereços IP disponíveis no vSwitch especificado. |
| 400 | InvalidGeneralGroupName.Malformed | The specified parameter GeneralGroupName is not valid. | O parâmetro GeneralGroupName é inválido. |
| 400 | AccountBasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | Suas informações estão incompletas. Complete suas informações antes de continuar. |
| 400 | IncorrecttVpcId | The specified parameter VPCId is not valid. | O VPCId é inválido. Selecione a VPC correta. |
| 400 | OperationDenied.DBInstanceStatus | Operation is denied by the current database instance status. | A operação falhou. O status atual da instância não oferece suporte a esta operação. |
| 400 | InvalidDBInstanceClass.Offline | The specified instance type is no longer provided. Please specify another instance type. | O tipo de instância selecionado foi descontinuado. Selecione um tipo de instância diferente. |
| 400 | ZoneId.NotMatchWithCategory | The number of available zones does not match the database engine or instance edition. Please reset it. | O número de zonas não corresponde ao tipo de banco de dados ou à edição da instância. Reconfigure as definições. |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | Operações individuais não são permitidas para instâncias de pacote. |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | O resultado do preço do plano de preços não foi encontrado. |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | Você não concluiu a verificação de nome real e não está elegível para fazer uma compra. Faça login em Despesas e Custos para concluir a verificação de nome real. |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | O crédito disponível da sua conta é menor que 0. Recarregue sua conta antes de tentar fazer uma compra. |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | A chamada para o serviço de commodity retornou uma falha. |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | O Alibaba Cloud planeja otimizar e ajustar a região atual. Os serviços em nuvem nesta região serão descontinuados. Para garantir a continuidade dos seus negócios e uma migração de dados tranquila, você não pode fazer novos pedidos de compra no momento. Agradecemos sua compreensão e apoio. |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | O módulo adquirido é inválido. Adquira um módulo válido. |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | A região foi desativada. |
| 400 | Price.CommoditySys | Commodity system call exception. | Ocorreu uma exceção ao chamar o sistema de commodities. |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | O período de assinatura selecionado é inválido. Selecione um período de assinatura válido. |
| 400 | pay.noCreditCard | Account not bound to credit card. | A conta não está associada a um cartão de crédito. |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | Existe um pedido não pago para o serviço selecionado. Pague ou cancele o pedido antes de fazer um novo. |
| 400 | noAvailablePaymentMethod | No payment method is specified for your account. We recommend that you add a payment method. | Nenhum método de pagamento está especificado para a conta. Adicione um método de pagamento. |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | Suas informações básicas estão incompletas. Complete suas informações básicas antes de realizar esta operação. |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | Ocorreu uma exceção com a sua conta. Entre em contato com o atendimento ao cliente para obter detalhes. |
| 400 | Api.NotSupport | Specified api is not supported. | A operação de API atual não é suportada. |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | Existe uma tag de bloqueio de pedido. Entre em contato com seu distribuidor para obter assistência. |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | O DBInstanceId especificado não existe. |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | O tipo de instância atual não oferece suporte ao tipo de armazenamento especificado. |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | O parâmetro de entrada é inválido. |
| 400 | KmsApiError | User secret key invalid. | A chave do usuário é inválida. |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | Sua conta da Alibaba Cloud não existe ou sua AccessKey expirou. |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | A execução do comando SQL falhou ou expirou. |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | A versão atual do mecanismo DPI da instância não suporta o arquivamento de dados frios. |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | A versão atual do kernel não suporta o arquivamento de dados frios. |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | O tipo de instância atual não oferece suporte a esta operação. |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | O nome do endereço de conexão está duplicado. Reconfigure a string de conexão. |
| 400 | RequiredParam.NotFound | Required input param is not found. | Parâmetros obrigatórios estão ausentes. |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | O parâmetro está incorreto. Verifique o parâmetro. |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | O arquivamento de dados frios não oferece suporte a backup entre regiões ou backup de snapshot de alta frequência. Verifique a política de backup. |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | O status da instância não suporta esta operação. |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | A política de retenção de dados de backup arquivados após a liberação da instância é inválida. |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | O tipo de mecanismo de banco de dados da instância não oferece suporte a esta operação. |
| 400 | Pay.NoCreditCard | No credit cards. | |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | Esta operação não é suportada para instâncias do tipo de rede VPC. |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | A imagem da instância de banco de dados atual já existe. |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | O tipo de instância não está mais disponível para compra. |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | O banco de dados especificado não existe no conjunto de backup. |
| 400 | OrdTCommodityQueryError | Failed to query for product. | Falha ao consultar o produto. |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | A instância foi liberada. Verifique a instância antes de fazer o pedido. |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | A região foi desativada. |
| 400 | InvalidParam.InstanceNetworkType | Creation of classic network instances is not supported. | A rede clássica foi descontinuada. A criação de instâncias de rede clássica não é suportada. |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | A solicitação para o serviço falhou. Tente novamente mais tarde. |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | A solicitação de serviço falhou. Tente novamente mais tarde ou entre em contato com o suporte. |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | A solicitação falhou porque o serviço da API do RDS apresentou falha. |
| 403 | ClassicNetworkType.NotSupport | The Classic instance network create is not support. | A operação falhou. A instância atual não suporta o tipo de rede clássica. Crie uma instância de outro tipo de rede. |
| 403 | InvalidEngineVersionInRegion.NotAvailable | The EngineVersion in the Region is not available. | A operação falhou. A região atual não suporta a versão do mecanismo DPI especificada. |
| 403 | OperationDenied | The specified request is out of resources. | O tipo de instância não oferece suporte a esta operação. |
| 403 | QuotaExceeded.CreateInstance | The quota of create instance exceeds. | O número máximo de instâncias foi excedido. Libere as instâncias que não são mais necessárias. |
| 403 | Forbidden.Authentication | The operation is forbidden by Aliyun Realname Authentication System. | A operação falhou. A operação é proibida pelo sistema de verificação de nome real do Alibaba Cloud. |
| 403 | INST_HAS_UNPAID_ORDER | The instanceId has unpaid order. | A operação falhou. A instância atual possui pedidos não pagos. Conclua o pagamento antes de prosseguir. |
| 403 | COMMODITY.FAILED | The commodity is error. | Ocorreu uma exceção no servidor. Envie um ticket para o suporte técnico. |
| 403 | MoneyLessThan100 | The Account Monet less Than 100. | O saldo da sua conta Alibaba Cloud é inferior a 100. Recarregue sua conta. |
| 403 | OperationDenied.ClassicNetworkType | The operation is not permitted due to status of instance. | A operação falhou. O tipo de rede clássica não suporta esta operação. |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | Existe um pedido não pago para a instância atual. Pague o pedido e tente novamente. |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | A capacidade de destino para redução de escala não pode ser menor que o uso de armazenamento atual. |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | Os discos em nuvem SSD não suportam esta operação. Faça upgrade para ESSD. |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | As permissões do usuário não suportam esta operação. |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | O VSwitchId especificado está em um formato incorreto ou está vazio. |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | A versão secundária atual do mecanismo não suporta esta operação. |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | Não há regiões de inventário disponíveis. |
| 403 | NotInFlowController | Sorry,no permission. | Este recurso está disponível apenas para usuários de nuvem corporativa. Você não tem as permissões necessárias. |
| 403 | InvalidKmsKey | Kms key is disabled. | A chave KMS está desativada. |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | O nível atual da instância de banco de dados não oferece suporte a esta operação. |
| 404 | InvalidDBInstanceId.NotFound | Invalid DBInstanceId NotFound. | O DBInstanceId especificado não existe. |
| 404 | CreateOrder.Failed | Create Order Failed. | O pedido falhou. |
| 404 | InvalidRegionId.NotFound | The provided RegionId does not exist in our records. | As informações da região são inválidas. |
| 404 | QueryPrice.Failed | QueryPrice Failed. | A consulta de preços falhou. Entre em contato com o atendimento ao cliente. |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | A instância atual não está autorizada a acessar o Key Management Service (KMS). |
| 404 | Request.NotFound | The requested resource is not available. | O recurso solicitado não está disponível. |
| 404 | HostInfo.NotFound | The specified host info is not found. | As informações do host especificado não existem. |
Consulte Códigos de Erro para uma lista completa.
Notas de versão
Consulte Notas de Versão para uma lista completa.