Cria um endpoint público para uma instância que executa o RDS Cluster Edition.
Descrição da operação
Motor de banco de dados compatível
MySQL
Precauções
Você pode criar um endpoint público de um tipo de endpoint somente quando nenhum endpoint público foi criado para esse tipo de endpoint.
Os pesos dos nós e outras configurações são os mesmos do endpoint interno desse tipo de endpoint. Cada tipo de endpoint pode conter um endpoint interno e um endpoint público.
Experimente agora
Testar
Autorização RAM
|
Ação |
Nível de acesso |
Tipo de recurso |
Chave de condição |
Ação dependente |
|
rds:CreateDBInstanceEndpointAddress |
create |
*DBInstance
|
|
Nenhuma |
Parâmetros da solicitação
|
Parâmetro |
Tipo |
Obrigatório |
Descrição |
Exemplo |
| ClientToken |
string |
Não |
O token do cliente usado para garantir a idempotência da solicitação. Você pode usar o cliente para gerar o token, mas deve garantir que o token seja único entre diferentes solicitações. O token pode conter apenas caracteres ASCII e não pode exceder 64 caracteres. |
6000170000591aed949d0f**** |
| DBInstanceId |
string |
Sim |
O ID da instância. Você pode chamar a operação DescribeDBInstances para consultar o ID da instância. |
rm-**** |
| DBInstanceEndpointId |
string |
Sim |
O ID do endpoint da instância. Você pode chamar a operação DescribeDBInstanceEndpoints para consultar o ID do endpoint. |
ep-**** |
| ConnectionStringPrefix |
string |
Sim |
O prefixo do endpoint público. |
rm-**** |
| Port |
string |
Sim |
O número da porta do endpoint público. |
3306 |
| IpType |
string |
Sim |
O tipo de rede do endpoint. Apenas Internet é compatível. Defina o valor como Public. Valores válidos:
|
Public |
| ResourceGroupId |
string |
Não |
O ID do grupo de recursos. Você pode chamar a operação DescribeDBInstanceAttribute para obter o ID do grupo de recursos. |
rg-acfmy**** |
Elementos de resposta
|
Elemento |
Tipo |
Descrição |
Exemplo |
|
object |
Os parâmetros de resposta. |
||
| Data |
object |
Os dados retornados. |
|
| ConnectionString |
string |
O endpoint público. |
rm-****.mysql.rds.aliyuncs.com |
| DBInstanceEndpointId |
string |
O ID do endpoint da instância. |
ep-**** |
| DBInstanceName |
string |
O ID da instância. |
rm-**** |
| RequestId |
string |
O ID da solicitação. |
08A3B71B-FE08-4B03-974F-CC7EA6DB1828 |
Exemplos
Resposta de sucesso
JSON formato
{
"Data": {
"ConnectionString": "rm-****.mysql.rds.aliyuncs.com",
"DBInstanceEndpointId": "ep-****",
"DBInstanceName": "rm-****"
},
"RequestId": "08A3B71B-FE08-4B03-974F-CC7EA6DB1828"
}
Códigos de erro
|
Código de status HTTP |
Código de erro |
Mensagem de erro |
Descrição |
|---|---|---|---|
| 400 | InvalidSourceCategory | specified source category is invalid. | |
| 400 | InvalidDBInstanceConnType.Format | Specified DB instance conn type is not valid. | |
| 400 | IncorrectDBInstanceNetType | Current DB instance net type does not support this operation. | |
| 400 | EndpointType.NotSupport | Current db type is not support specified endpoint type. | |
| 400 | APICallingFailed | Meta db calling failed. | |
| 400 | EngineNotSupported | The engine does not support the operation. | |
| 400 | InvalidEngineVersion.NotSupport | The specified parameter "EngineVersion" is not valid. | |
| 400 | InvalidBizType.Format | Specified biz type is not valid. | |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | |
| 400 | Price.CommoditySys | Commodity system call exception. | |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | |
| 400 | pay.noCreditCard | Account not bound to credit card. | |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | |
| 400 | noAvailablePaymentMethod | No payment method is specified for your account. We recommend that you add a payment method. | |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | |
| 400 | Api.NotSupport | Specified api is not supported. | |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | |
| 400 | KmsApiError | User secret key invalid. | |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | |
| 400 | RequiredParam.NotFound | Required input param is not found. | |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | |
| 400 | Pay.NoCreditCard | No credit cards. | |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | |
| 400 | OrdTCommodityQueryError | Failed to query for product. | |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | |
| 403 | IncorrectDBInstanceState | Current DB instance state does not support this operation. | |
| 403 | NetTypeExists | Specified net type already existed. | |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | |
| 403 | NotInFlowController | Sorry,no permission. | |
| 403 | InvalidKmsKey | Kms key is disabled. | |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | |
| 404 | InvalidDBInstanceName.NotFound | Invalid DBInstanceId NotFound. | |
| 404 | IncorrectDBInstanceLockMode | Current DB instance lock mode does not support this operation. | |
| 404 | InvalidConnectionString.Duplicate | Specified connection string already exists in the Aliyun RDS. | |
| 404 | Endpoint.NotFound | Specified endpoint is not existed. | |
| 404 | InvalidDBInstance.NotFound | Specified instance does not exist or not support. | |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | |
| 404 | Request.NotFound | The requested resource is not available. | |
| 404 | HostInfo.NotFound | The specified host info is not found. |
Consulte Códigos de Erro para uma lista completa.
Notas de versão
Consulte Notas de Versão para uma lista completa.