Todos os produtos
Search
Central de documentação

ApsaraDB RDS:CreateDatabase

Última atualização: Aug 17, 2026

Cria um banco de dados em uma instância do ApsaraDB RDS.

Descrição da operação

Mecanismos aplicáveis.

Experimente agora

Experimente esta API no OpenAPI Explorer, sem necessidade de assinatura manual. Chamadas bem-sucedidas geram automaticamente código SDK correspondente aos seus parâmetros. Faça o download com segurança de credenciais integrada para uso local.

Testar

Autorização RAM

A tabela abaixo descreve a autorização necessária para chamar esta API. Você pode defini-la em uma política do Resource Access Management (RAM). As colunas da tabela estão detalhadas abaixo:

  • Ação: As ações que podem ser usadas no elemento Action das instruções de política de permissão do RAM para conceder permissões para executar a operação.

  • API: A API que você pode chamar para executar a ação.

  • Nível de acesso: O nível de acesso predefinido concedido para cada API. Valores válidos: create, list, get, update e delete.

  • Tipo de recurso: O tipo de recurso que suporta autorização para executar a ação. Indica se a ação suporta permissão em nível de recurso. O recurso especificado deve ser compatível com a ação. Caso contrário, a política será ineficaz.

    • Para APIs com permissões em nível de recurso, os tipos de recursos obrigatórios são marcados com um asterisco (*). Especifique o Nome de Recurso Alibaba Cloud (ARN) correspondente no elemento Resource da política.

    • Para APIs sem permissões em nível de recurso, é exibido como Todos os Recursos. Use um asterisco (*) no elemento Resource da política.

  • Chave de condição: As chaves de condição definidas pelo serviço. A chave permite controle granular, aplicando-se somente a ações ou a ações associadas a recursos específicos. Além das chaves de condição específicas do serviço, o Alibaba Cloud fornece um conjunto de chaves de condição comuns aplicáveis a todos os serviços compatíveis com RAM.

  • Ação dependente: As ações dependentes necessárias para executar a ação. Para concluir a ação, o usuário RAM ou a função RAM deve ter permissões para executar todas as ações dependentes.

Ação

Nível de acesso

Tipo de recurso

Chave de condição

Ação dependente

rds:CreateDatabase

create

*DBInstance

acs:rds:{#regionId}:{#accountId}:dbinstance/{#dbinstanceId}

  • rds:ResourceTag
  • rds:ResourceTag
  • rds:ResourceTag
Nenhuma

Parâmetros da solicitação

Parâmetro

Tipo

Obrigatório

Descrição

Exemplo

DBInstanceId

string

Sim

O ID da instância. Você pode chamar DescribeDBInstances para obter o ID da instância.

rm-uf6wjk5****

DBName

string

Sim

O nome do banco de dados.

Nota
  • O nome deve ter de 2 a 64 caracteres.

  • O nome deve começar com uma letra e terminar com uma letra ou dígito.

  • O nome pode conter letras minúsculas, dígitos, sublinhados (_) ou hifens (-).

  • O nome deve ser único dentro da instância.

  • Para obter mais informações sobre caracteres inválidos, consulte Palavras-chave proibidas.

rds_mysql

CharacterSetName

string

Sim

O conjunto de caracteres. Valores válidos:

  • MySQL/MariaDB: utf8, gbk, latin1, utf8mb4

  • SQL Server: Chinese_PRC_CI_AS, Chinese_PRC_CS_AS, SQL_Latin1_General_CP1_CI_AS, SQL_Latin1_General_CP1_CS_AS, Chinese_PRC_BIN

  • PostgreSQL: Você deve configurar o conjunto de caracteres, Collate e Ctype no formato Conjunto de caracteres,<Collate>,<Ctype>. Exemplo: UTF8,C,en_US.utf8.
    • Valores válidos para conjunto de caracteres: KOI8U, UTF8, WIN866, WIN874, WIN1250, WIN1251, WIN1252, WIN1253, WIN1254, WIN1255, WIN1256, WIN1257, WIN1258, EUC_CN, EUC_KR, EUC_TW, EUC_JP, EUC_JIS_2004, KOI8R, MULE_INTERNAL, LATIN1, LATIN2, LATIN3, LATIN4, LATIN5, LATIN6, LATIN7, LATIN8, LATIN9, LATIN10, ISO_8859_5, ISO_8859_6, ISO_8859_7, ISO_8859_8, SQL_ASCII.

    • Valores válidos para Collate: Você pode executar o comando SELECT DISTINCT collname FROM pg_collation; para consultar os valores disponíveis. Valor padrão: C.

    • Valores válidos para Ctype: Você pode executar o comando SELECT DISTINCT collctype FROM pg_collation; para consultar os valores disponíveis. Valor padrão: en_US.utf8.

gbk

CollationName

string

Não

A collation. Este parâmetro é suportado apenas para instâncias MySQL. Especifique uma collation que corresponda ao conjunto de caracteres. Por exemplo, se o conjunto de caracteres for utf8mb4, a collation deve ser utf8mb4_bin ou utf8mb4_general_ci.

gbk_chinese_ci

DBDescription

string

Não

A descrição do banco de dados. A descrição deve ter de 2 a 256 caracteres e deve começar com uma letra ou um caractere chinês. Pode conter dígitos, caracteres chineses, letras, sublinhados (_) e hifens (-).

testdb

AccountName

string

Não

AccountPrivilege

string

Não

Elementos de resposta

Elemento

Tipo

Descrição

Exemplo

object

Os parâmetros de resposta.

RequestId

string

O ID da solicitação.

5A77D650-27A1-4E08-AD9E-59008EDB6927

Exemplos

Resposta de sucesso

JSON formato

{
  "RequestId": "5A77D650-27A1-4E08-AD9E-59008EDB6927"
}

Códigos de erro

Código de status HTTP

Código de erro

Mensagem de erro

Descrição

400 %s DB Operation Failed:%s.
400 EngineMigration.ActionDisabled Specified action is disabled while custins is in engine migration. A operação especificada está desativada enquanto a instância está passando por migração de mecanismo.
400 Database.ConnectError Database connect error. please check instance status and database processlist A conexão com o banco de dados está anormal. Verifique o status da instância e o pool de conexões do banco de dados.
400 InvalidDescription.Format Specified description is not valid. O conteúdo da descrição é inválido.
400 InvalidDBName.Forbid Specified DB name is a keyword in RDS. Falha ao definir o nome do banco de dados. Palavras-chave não podem ser usadas para nomenclatura de parâmetros. DBName é uma palavra-chave. Modifique o nome do parâmetro.
400 InvalidAccountName.Forbid Specified account name is a keyword in RDS. O nome da conta é inválido porque contém uma palavra-chave reservada. Modifique o nome da conta.
400 InvalidAccountPrivilege.Malformed Specified account privilege is not valid. A conta não tem permissões suficientes.
400 IncorrectDBInstanceServiceType Current DB instance top type does not support this operation. A operação falhou. O tipo top da instância de banco de dados atual não suporta esta operação.
400 Database.AddError Create Db failed, please check input value and instance status. Falha ao criar o banco de dados. Verifique os parâmetros de entrada e o status da instância.
400 Database.QueryError invalid value, may include special character. O valor é inválido e pode conter caracteres especiais.
400 SqlExcutionFailed Due to the limit number you can't create a database. Este banco de dados não pode ser excluído.
400 SqlExecuteFailedOrTimeout sql command execution failed or timed out:%s. A execução do comando SQL falhou ou expirou.
400 InvalidDBInstanceIdOrDBInstanceName The specified params DBInstanceId or DBInstanceName should not be empty. O parâmetro especificado DBInstanceId ou DBInstanceName não pode estar vazio.
400 Order.ComboInstanceNotAllowOperate A package instance is not allowed to operate independently. Operações individuais não são permitidas para instâncias de pacote.
400 Price.PricingPlanResultNotFound Pricing plan price result not found. O resultado do preço do plano de precificação não foi encontrado.
400 Order.NoRealNameAuthentication You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. Você não concluiu a verificação de nome real e não está elegível para realizar uma compra. Faça login em Despesas e Custos para concluir a verificação de nome real.
400 InsufficientAvailableQuota Your account quota limit is less than 0, please recharge before trying to purchase. O crédito disponível da sua conta é menor que 0. Recarregue sua conta antes de tentar realizar a compra.
400 CommodityServiceCalling.Exception Failed to call commodity service. A chamada ao serviço de commodity falhou.
400 RegionDissolvedEOM Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. O Alibaba Cloud planeja otimizar e ajustar a região atual. Os serviços em nuvem nesta região serão descontinuados. Para garantir a continuidade dos seus negócios e uma migração de dados tranquila, você não pode fazer novos pedidos de compra no momento. Agradecemos sua compreensão e apoio.
400 Commodity.InvalidComponent The module you purchased is not legal, please buy it again. O módulo adquirido é inválido. Adquira um módulo válido.
400 RegionEndTimeDissolvedAustralia Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. A região foi desativada.
400 Price.CommoditySys Commodity system call exception. Ocorreu uma exceção ao chamar o sistema de commodities.
400 Pay.InsufficientBalance Insufficient available balance.
400 Order.PeriodInvalid There is a problem with the period you selected, please choose again. O período de assinatura selecionado é inválido. Selecione um período válido.
400 pay.noCreditCard Account not bound to credit card. Nenhum cartão de crédito disponível.
400 Order.InstHasUnpaidOrder There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. Existe um pedido não pago para o serviço selecionado. Pague ou cancele o pedido existente antes de fazer um novo.
400 noAvailablePaymentMethod No payment method is specified for your account. We recommend that you add a payment method. Nenhum método de pagamento está especificado para a conta. Adicione um método de pagamento.
400 BasicInfoUncompleted Your information is incomplete. Complete your information before the operation. Suas informações básicas estão incompletas. Complete suas informações básicas antes de realizar esta operação.
400 Risk.RiskControlRejection Your account is abnormal, please contact customer service for details. Ocorreu uma exceção na sua conta. Entre em contato com o atendimento ao cliente para obter detalhes.
400 Api.NotSupport Specified api is not supported. A operação de API atual não é suportada.
400 ContainForbiddenLabelError There is a label that prohibits placing orders. Please contact your distributor for assistance. Existe uma tag de bloqueio de pedido. Entre em contato com seu distribuidor para resolver este problema.
400 InvalidDBInstanceId.NotFound The DBInstanceId provided does not exist in records. O DBInstanceId especificado não existe.
400 InvalidInstanceLevel.DiskType Specified instance level not support request disk type O tipo de instância atual não suporta o tipo de armazenamento especificado.
400 InvalidParam Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. O parâmetro de entrada é inválido.
400 KmsApiError User secret key invalid. A chave do usuário é inválida.
400 System.SaleValidateFailed Sales expression validation system error.
400 Abs.InvalidAccount.NotFound account is not found. Sua conta Alibaba Cloud não existe ou seu AccessKey expirou.
400 ColdData.EngineVersionNotSupport The current instance engine version not support coldDataEnabled. A versão atual do mecanismo DPI da instância não suporta arquivamento de dados frios.
400 ColdData.MinorVersionNotSupport The current instance minor version not support coldDataEnabled. A versão atual do kernel não suporta arquivamento de dados frios.
400 IncorrectTargetClasscode The current instance type does not support this operation. A especificação atual da instância não suporta esta operação.
400 InvalidConnectionString.Duplicate Specified connection string already exists in the RDS. O nome do endereço de conexão está duplicado. Defina a string de conexão novamente.
400 RequiredParam.NotFound Required input param is not found. Parâmetros obrigatórios estão ausentes.
400 Parameters.Invalid Parameter error, please check the parameters. O parâmetro está incorreto. Verifique o parâmetro.
400 BackupPolicyNotSupport Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. A política de backup atual não suporta esta operação.
400 InvalideStatus.Format The instance status does not support this operation. O status da instância não suporta esta operação.
400 InvalidReleasedKeepPolicy.Format Specified Released Keep Policy is not valid. A política de retenção de dados de backup de arquivamento após a liberação da instância é inválida.
400 InvalidDBInstanceEngineType.Format the DB instance engine type does not support this operation. O tipo de mecanismo de banco de dados da instância não suporta esta operação.
400 Pay.NoCreditCard No credit cards.
400 VpcNetworkTypeNotSupport The vpc network type instance does not support this operation. Esta operação não é suportada para instâncias com o tipo de rede VPC.
400 MirrorInsExists Specified DB instance mirror ins already existed. A imagem da instância de banco de dados atual já existe.
400 UnsupportedClassCode The specified DB instance class stops selling. O tipo de instância não está mais disponível para compra.
400 InvalidBackupSet The specified database does not exist in the backup set. O banco de dados especificado não existe no conjunto de backup.
400 OrdTCommodityQueryError Failed to query for product. Falha ao consultar o produto.
400 ProductInstanceReleased The instance has been released. Please check before placing the order. A instância foi liberada. Verifique a instância antes de fazer o pedido.
400 RegionEndTimeDissolvedIndia The region is no longer supported. A região especificada é inválida.
400 InvalidCharacter.DbOrAccount The database name or account name contains invalid characters. O nome do banco de dados ou o nome da conta contém caracteres inválidos.
400 InvalidDBName.Duplicate Specified DB name already exists in the This instance. O nome do banco de dados atual é inválido. Redefina o nome do banco de dados.
400 InvalidCollationName.Format Specified collation name is not valid. O formato de collation está incorreto. Este parâmetro tem efeito apenas para instâncias MySQL e deve corresponder ao conjunto de caracteres.
500 ExternalFailure The request processing has failed due to external service failure. A solicitação ao serviço falhou. Tente novamente mais tarde.
500 RequestMetaDataFailed The service request failed. Please try again later or contact service personnel. A solicitação de serviço falhou. Tente novamente mais tarde ou entre em contato com o suporte.
500 InvokeProxyFailure The request processing has failed due to service failure of rds api. O processamento da solicitação falhou devido a uma falha no serviço de API do RDS.
403 OrderStatus.UnPaid The specified db instance has unpaid order. Existe um pedido não pago para a instância atual. Pague o pedido e tente novamente.
403 InvalidReduceDiskSize The storage capacity after the scale-down must be larger than the used amount. A capacidade de destino para redução de escala não pode ser menor que o uso atual de armazenamento.
403 CloudSSDNotSupport Cloud ssd does not support this operation, please upgrade to essd. Os discos SSD não suportam esta operação. Atualize para ESSD.
403 InvalidUserOperatorPermission The user permission does not support this operation. As permissões do usuário não oferecem suporte a esta operação.
403 InvalidVswitchId Specified conn vswitch id is not valid. O VSwitchId especificado está em um formato incorreto ou está vazio.
403 IncorrectMinorVersion Current engine minor version does not support operations. A versão secundária do mecanismo atual não suporta esta operação.
403 OperationDenied.ZoneResource There is no available zone for inventory. Não existem regiões de inventário disponíveis.
403 NotInFlowController Sorry,no permission. Este recurso está indisponível. Você não tem permissão porque não é um usuário de nuvem corporativa.
403 InvalidKmsKey Kms key is disabled. A chave KMS está desativada.
403 InvalidInstanceLevel.Malformed Current DB instance level does not support this operation. O nível atual da instância de banco de dados não suporta esta operação.
403 UnsupportedByBlueGreenDeployment Operation prohibited due to blue green deployment. Esta operação não é permitida porque existe uma implantação blue-green.
403 IncorrectDBInstanceType Current DB instance type does not support this operation. A operação falhou. Esta operação não é suportada no status atual da instância.
404 InvalidDBInstanceName.NotFound The database instance does not exist. A instância especificada não existe ou não é suportada.
404 InvalidClusterKms The current instance does not authorized to access the Key Management Service. A instância atual não está autorizada a acessar o Key Management Service.
404 Request.NotFound The requested resource is not available. O recurso solicitado não está disponível.
404 HostInfo.NotFound The specified host info is not found. As informações do host especificado não existem.

Consulte Códigos de Erro para uma lista completa.

Notas de versão

Consulte Notas de Versão para uma lista completa.